14:00:34 <amoralej> #startmeeting RDO meeting - 2020-04-15
14:00:34 <zodbot> Meeting started Wed Apr 15 14:00:34 2020 UTC.
14:00:34 <zodbot> This meeting is logged and archived in a public location.
14:00:34 <zodbot> The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:34 <zodbot> The meeting name has been set to 'rdo_meeting_-_2020-04-15'
14:00:35 <openstack> Meeting started Wed Apr 15 14:00:34 2020 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:38 <openstack> The meeting name has been set to 'rdo_meeting___2020_04_15'
14:00:40 <amoralej> #topic roll call
14:00:42 <rdogerrit> Joel Capitao created openstack/debtcollector-distgit rpm-master: Remove python2/python3 compatibility in specs  https://review.rdoproject.org/r/26498
14:01:00 <baha> o/
14:01:03 <rdogerrit> Joel Capitao created openstack/automaton-distgit rpm-master: Remove python2/python3 compatibility in specs  https://review.rdoproject.org/r/26499
14:01:19 <jcapitao> o/
14:02:14 <amoralej> #chair baha jcapitao
14:02:14 <zodbot> Current chairs: amoralej baha jcapitao
14:02:16 <openstack> Current chairs: amoralej baha jcapitao
14:02:31 <rh-jelabarre> o/
14:02:31 <rdogerrit> Merged openstack/oslo-utils-distgit rpm-master: Remove python2/python3 compatibility in specs  https://review.rdoproject.org/r/26486
14:02:58 <amoralej> #chair rh-jelabarre
14:02:58 <zodbot> Current chairs: amoralej baha jcapitao rh-jelabarre
14:02:59 <openstack> Current chairs: amoralej baha jcapitao rh-jelabarre
14:03:48 <ykarel> o/
14:04:31 <amoralej> #chair ykarel
14:04:31 <zodbot> Current chairs: amoralej baha jcapitao rh-jelabarre ykarel
14:04:32 <openstack> Current chairs: amoralej baha jcapitao rh-jelabarre ykarel
14:06:01 <amoralej> let' start
14:06:09 <amoralej> you can still add your topics to https://etherpad.opendev.org/p/RDO-Meeting
14:06:45 <amoralej> #topic ppc64le package versions in delorean repos
14:07:09 <amoralej> baha, mjturek ^
14:07:18 <baha> Sure!
14:07:32 <baha> Effectively, it looks like the delorean repos are in many cases either providing significantly older package versions, or not providing packages, to ppc64le in centos 8
14:08:32 <baha> For example, the libvirt-daemon-driver-nodedev package is version 5.6.0-6 on x86 but 4.5.0-2 on ppc64le. The latter matches centos's version for both architectures, so it's unclear if delorean just isn't offering it to ppc or if it's an older version
14:09:57 <amoralej> #info list of problematic packages http://paste.openstack.org/show/792163/
14:10:05 <amoralej> baha, i see several cases there
14:10:18 <baha> A lot of those are similar versioning issues, some run a little deeper
14:10:23 <amoralej> updated libvirt is provided by advanced virtualization
14:10:33 <amoralej> which is provided by virtualization sig
14:10:38 <amoralej> i need to check status in ppc64
14:10:54 <baha> Do you know the official mechanism to add that repo on centos 8? The release packages don't seem to be around anymore
14:11:00 <amoralej> python-boto3 comes from HighAvailability iirc
14:11:47 <amoralej> baha, http://mirror.centos.org/centos/8/virt/ppc64le/advanced-virtualization/
14:11:59 <amoralej> that will provided the updated virtualization packages
14:12:06 <amoralej> i see them there
14:12:10 <amoralej> so that should be fine
14:12:39 <baha> That solves a very significant chunk of them! Thank you
14:13:13 <amoralej> about rabbitmq
14:13:17 <amoralej> should be fine
14:13:22 <amoralej> what repo are you using?
14:13:53 <amoralej> http://mirror.centos.org/centos/8/messaging/ppc64le/rabbitmq-38/
14:14:04 <amoralej> that should be the good one
14:14:40 <mjturek> hmmm - should we need to manually install these repos? Wondering if enabling them should be a patch to tripleo-ci
14:14:48 <baha> We're using the default centos 8 repos combined with what the tripleo playbooks install for delorean repos, which is sufficient on x86 but seemingly not power
14:15:17 <amoralej> mjturek, for messaging we are preparing a release rpm
14:15:23 <amoralej> should be published probably today
14:15:37 <mjturek> cool
14:15:51 <amoralej> we also created rdo-release for centos8
14:16:02 <amoralej> that should install official repos for train on centos8
14:16:11 <amoralej> but those are not pupulated yet
14:16:31 <amoralej> about collectd-sensubility issue
14:16:35 <amoralej> i need to check the issue
14:16:45 <amoralej> and same for golang-github-vbatts-tar-split
14:17:05 <amoralej> mjturek, i'd like to see what dependencies repos do you configure
14:18:00 <amoralej> https://cbs.centos.org/koji/buildinfo?buildID=28443
14:18:02 <amoralej> ups
14:18:10 <amoralej> there is no ppc
14:18:27 <amoralej> dunno why
14:18:46 <baha> http://paste.openstack.org/show/792165/ current list of repos that get automatically configured for ppc, I can get contents of them if needed but the delorean one is pretty long =)
14:18:47 <amoralej> #info golang-github-vbatts-tar-split-0.11.1-1.el8 cbs build missed ppc64 build
14:19:32 <ykarel> baha, can u get content of delorean-master-testing.repo
14:19:41 <ykarel> may be they have x86_64 hardcoded
14:19:49 <amoralej> ykarel, i think repo is fine
14:19:58 <amoralej> note the issue with ge tar-split one
14:20:01 <amoralej> that explains it
14:20:16 <amoralej> and delorean-deps in master is still pointing to trunk.r.o
14:20:22 <amoralej> we need to move that to mirror
14:20:28 <ykarel> amoralej, hmm tar split looks valid issue
14:21:13 <baha> http://paste.openstack.org/show/792166/ here's a proper dnf repolist and http://paste.openstack.org/show/792167/ is the master-testing repo
14:21:42 <amoralej> baha, what do you get if you run dnf whatprovides "libpthread.so.0(GLIBC_2.2.5)(64bit)" in a ppc64le server?
14:22:27 <baha> I get a no matches found
14:22:45 <amoralej> mmm
14:22:59 <amoralej> i see glibc-2.28-72.el8.x86_64
14:23:07 <amoralej> in x86_64
14:23:38 <amoralej> baha, may i get access to a ppc64le server with repos enabled?
14:23:42 <amoralej> after the mtg
14:24:37 <baha> amoralej: The only ppc server I have access to is behind company firewall, unfortunately. I think there's a way to hold cico power nodes from a jump box but I'm not familiar with it
14:24:57 <baha> Also, we do have the advanced virt repo installed, I'm not sure why we're still getting the older virt packages
14:25:02 <amoralej> i'll check if i can get access to a cico node
14:25:11 <amoralej> you need to enable module_hotfixes
14:25:26 <amoralej> look at https://trunk.rdoproject.org/centos8-master/delorean-deps.repo
14:25:34 <amoralej> forget the baseurl
14:25:39 <amoralej> use the one i pasted before
14:26:15 <baha> module_hotfixes is already set to 1
14:27:05 <amoralej> mmm
14:27:11 <amoralej> and still don't pull it?
14:27:33 <baha> No, it still only sees version 4, not 5
14:27:55 <baha> (of the example package above of libvirt-daemon-driver-nodedev)
14:28:00 <amoralej> baha, let's continue after the mtg
14:28:06 <baha> amoralej: Sounds good
14:28:18 <amoralej> let's move on
14:28:22 <amoralej> to next topic
14:28:26 <amoralej> if it's fine for you baha
14:28:34 <baha> Go for it! And thank you
14:29:27 <amoralej> #topic Ussuri preparation update
14:30:09 <amoralej> #info reqcheck and python2/3 compatibility cleanup is on progress for libraries and clients
14:30:16 <amoralej> jcapitao is working on it
14:30:34 <amoralej> #info topic for ussuri preparation is https://review.rdoproject.org/r/#/q/topic:ussuri-branching+(status:open+OR+status:merged)
14:30:49 <amoralej> jcapitao, something you'd like to add?
14:31:30 <jcapitao> mmh nope
14:32:15 <amoralej> ok, i think that's it then wrt ussuri preparation
14:32:27 <amoralej> reviews are going fast so i think we are good
14:33:00 <amoralej> #info RDO Trunk centos8-ussuri is being bootstrapped https://trunk.rdoproject.org/centos8-ussuri-bootstrap/report.html
14:33:04 <amoralej> also that
14:33:15 <ykarel> nice
14:33:26 <amoralej> once that's finished we'll move it to centos8-ussuri
14:33:44 <amoralej> chandankumar, ^ note we are preparing new RDO Trunk repo following stable/ussuri
14:33:56 <amoralej> at some point a new promotion pipeline will be needed
14:34:21 <chandankumar> amoralej, yes, it is planned for next sprint, rfolco is going to be the contact person for the same
14:35:16 <amoralej> #info rfolco will work in promotion pipeline for centos8-ussuri repo on next sprint
14:35:18 <amoralej> thanks chandankumar
14:35:26 <rfolco> amoralej, please keep me posted about ussuri dlrn updates
14:35:38 <amoralej> ok
14:35:47 <amoralej> i think boostrap will be finished by end of the week
14:35:58 <rfolco> nice
14:35:59 <amoralej> i'll let you know when we move to final url
14:37:03 <rdogerrit> Merged rdo-infra/ci-config master: Fixes for CentOS8 phase 1  https://review.rdoproject.org/r/26478
14:37:13 <amoralej> i think that's it about ussuri
14:37:19 <ykarel> so centos7 master dlrn builder is stopped, right?
14:37:25 <amoralej> yes
14:37:30 <ykarel> okk cool
14:37:33 <amoralej> did we publish that last meeting?
14:37:36 <amoralej> i think so
14:38:03 <jcapitao> j
14:38:31 <amoralej> #info CentOS7-master DLRN builder has been stopped
14:38:42 <amoralej> ykarel, we don't have topic about cento8 today
14:38:51 <rdogerrit> Merged openstack/debtcollector-distgit rpm-master: Remove python2/python3 compatibility in specs  https://review.rdoproject.org/r/26498
14:38:54 <amoralej> somehting you want to add?
14:38:55 <ykarel> hmm in last meeting we said in next week centos7 will go
14:39:06 <ykarel> amoralej, just RDO phase 1 is being setup
14:39:08 <amoralej> yes, that's why i added an info
14:39:17 <amoralej> #topic Update about CentOS8
14:39:32 <amoralej> #info RDO Phase 1 for CentOS8 master is being setup
14:40:17 <amoralej> ok
14:40:20 <ykarel> #info puppet is upgraded to puppet 6 in CentOS8 Ussuri
14:40:39 <amoralej> ah, good one
14:41:13 <amoralej> can we move to open floor?
14:41:41 <rdogerrit> Merged openstack/stevedore-distgit rpm-master: Remove python2/python3 compatibility in specs  https://review.rdoproject.org/r/26494
14:42:01 <pojadhav> #rdo : hey all, I need some pointers to resolve this : https://9f9aacbdfdeb1863718c-b57e3215d80dcf0e9eb86eff2f5ca36a.ssl.cf5.rackcdn.com/706288/10/check/tripleo-ci-centos-8-standalone-on-multinode-ipa/79ba5c1/job-output.txt
14:42:06 <rdogerrit> Merged openstack/oslo-middleware-distgit rpm-master: Remove python2/python3 compatibility in specs  https://review.rdoproject.org/r/26484
14:42:39 <ykarel> yes for me
14:42:48 <jcapitao> ok for me as well
14:42:58 <amoralej> #topic open floor
14:43:00 <amoralej> first
14:43:09 <amoralej> any volunteer to chair next week?
14:43:17 <amoralej> #undo
14:43:17 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7fdff8fb5a50>
14:43:18 <openstack> Removing item from minutes: #topic open floor
14:43:34 <jcapitao> i can take it
14:44:02 <amoralej> #action jcapitao to chair next RDO meeting
14:44:35 <amoralej> #topic roll call
14:44:47 <amoralej> pojadhav, we'll check at the issue after the mtg
14:44:52 <amoralej> #undo
14:44:52 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7fe00afa1110>
14:44:53 <openstack> Removing item from minutes: #topic roll call
14:44:57 <amoralej> #topic open floor
14:45:01 <pojadhav> amoralej, sure. thanks
14:45:16 <amoralej> any other topic that someone wants to bring?
14:49:42 <amoralej> ok, i'll give you 10 minutes back
14:49:48 <amoralej> thanks all for joining
14:49:57 <amoralej> have a good week and stay safe
14:50:08 <amoralej> #endmeeting