14:01:43 <leanderthal> #startmeeting RDO meeting - 2020-05-13
14:01:43 <zodbot> Meeting started Wed May 13 14:01:43 2020 UTC.
14:01:43 <zodbot> This meeting is logged and archived in a public location.
14:01:43 <zodbot> The chair is leanderthal. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:43 <zodbot> The meeting name has been set to 'rdo_meeting_-_2020-05-13'
14:01:44 <iurygregory> ack
14:01:44 <openstack> Meeting started Wed May 13 14:01:43 2020 UTC and is due to finish in 60 minutes.  The chair is leanderthal. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:48 <openstack> The meeting name has been set to 'rdo_meeting___2020_05_13'
14:01:49 <leanderthal> #topic rollcall
14:01:53 <leanderthal> come on put your hands UP!
14:01:58 <iurygregory> o/
14:02:01 <leanderthal> #chair iurygregory spotz amoralej
14:02:01 <zodbot> Current chairs: amoralej iurygregory leanderthal spotz
14:02:02 <openstack> Current chairs: amoralej iurygregory leanderthal spotz
14:02:44 <jcapitao> o/
14:02:49 <leanderthal> #chair jcapitao
14:02:49 <zodbot> Current chairs: amoralej iurygregory jcapitao leanderthal spotz
14:02:49 <openstack> Current chairs: amoralej iurygregory jcapitao leanderthal spotz
14:03:03 <leanderthal> ykarel, jpena - you two in the hizzouse?
14:03:11 <ykarel> o/
14:03:17 <leanderthal> #chair ykarel
14:03:17 <zodbot> Current chairs: amoralej iurygregory jcapitao leanderthal spotz ykarel
14:03:18 <openstack> Current chairs: amoralej iurygregory jcapitao leanderthal spotz ykarel
14:03:38 <jpena> o/ (but multi-booked)
14:03:43 <leanderthal> #chair jpena
14:03:43 <zodbot> Current chairs: amoralej iurygregory jcapitao jpena leanderthal spotz ykarel
14:03:44 <openstack> Current chairs: amoralej iurygregory jcapitao jpena leanderthal spotz ykarel
14:03:47 <leanderthal> jpena, no worries
14:04:00 <spotz> That's my life:)
14:04:08 <leanderthal> yar.
14:05:43 <leanderthal> #topic [amoralej] RDO Ussuri GA - definition of done
14:05:52 <leanderthal> amoralej, how're we doing?
14:05:58 <amoralej> ok
14:06:00 <amoralej> let's start
14:06:33 <amoralej> so, as you can see by previous logs in this channel, upstream has merged Ussuri GA releases
14:06:40 <leanderthal> WHEEEEEEEEEEEEEEEEEEEEEEEEE
14:06:47 <leanderthal> (ahem)
14:06:51 <amoralej> #info Ussuri GA is released https://review.opendev.org/#/c/726484/
14:07:19 <amoralej> we are in the process of building packages in CBS for those and promote to -testing and -release
14:07:21 <iurygregory> \o/
14:07:26 <leanderthal> \o/
14:07:37 <leanderthal> so. awesome.
14:07:40 <amoralej> but, there is not tripleo releases in ussuri yet
14:07:55 <leanderthal> right; which is normal
14:07:56 <amoralej> tripleo and kolla are trailing cycle projects and take some more time
14:08:01 <amoralej> yes, it's expected
14:08:04 <leanderthal> yar.
14:08:13 <amoralej> but brings the question of when to announce RDO GA
14:08:20 <leanderthal> we *can* announce later.
14:08:24 <amoralej> tripleo folks told me they plan to branch next week
14:08:30 <amoralej> so i'm in favor or waiting
14:08:35 <leanderthal> i've finished the release announcement
14:08:36 <amoralej> i think there is no rush
14:08:49 <leanderthal> AND spotz and iurygregory are ready to handle the actual announcement
14:08:52 <ykarel> +1 on waiting for announcement
14:08:54 <leanderthal> this is my last week
14:08:57 <amoralej> so we can keep pushing builds
14:08:58 <leanderthal> i'm okay with waiting
14:09:07 <leanderthal> +1 on waiting
14:09:16 <leanderthal> i like the idea of waiting for tripleo and kolla
14:09:16 <iurygregory> makes sense to me =)
14:09:18 <amoralej> but for announcement wait for "release criteria" or definition of done
14:09:26 <amoralej> for me release criteria is
14:09:34 <amoralej> - all packstack jobs passing
14:09:39 <amoralej> - all p-o-i jobs passing
14:09:50 <amoralej> - we can build tripleo images with clousig repo
14:10:03 <amoralej> - we can do a standalone deployment with cloudsig builds
14:10:30 <amoralej> we have a published definition of done in https://blogs.rdoproject.org/2016/05/technical-definition-of-done/
14:10:41 <amoralej> but that's now out-of-date
14:10:52 <amoralej> so i'd propose to update it
14:10:59 <spotz> Yeah makes sense to wait, especially if the trailing projects are still out there
14:11:02 <iurygregory> ++
14:11:14 <leanderthal> awww, trown++
14:11:14 <zodbot> leanderthal: Karma for trown changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:11:14 <amoralej> and publish it somewhere in rdoproject.org
14:11:26 <amoralej> yeah, trown did it 4 years ago :)
14:11:46 <spotz> definitely out of date if 4 years old:)
14:11:52 <leanderthal> amoralej, would you do an updated definition of done, please? on blogs.rdoproject.org
14:11:56 <leanderthal> do you need an account?
14:12:00 <amoralej> ykarel, how far are we of being able to add a oooq job which builds images and deploy standalone in rdoinfo check pipeline?
14:12:03 <leanderthal> i would normally volunteer, but.....
14:12:14 <leanderthal> here's the thing.
14:12:22 <leanderthal> i mean, waiting for ykarel 's answer.
14:12:39 <amoralej> leanderthal, you think it's better to do it in that blog or in https://www.rdoproject.org/ ?
14:12:53 <ykarel> amoralej, u mean build without tripleo and kolla CBS builds?
14:12:55 <spotz> Or both?
14:13:00 <ykarel> using tripleo from trunk
14:13:11 <leanderthal> amoralej, in the blogs because it varies from release to release - every six months, we should agree on done.
14:13:13 <amoralej> ykarel, i mean using only clousig packages
14:13:25 <amoralej> in the job
14:13:31 <amoralej> we had it for centos7
14:13:42 <amoralej> but iirc we have some issues in centos8 with the local registry?
14:13:51 <leanderthal> spotz, the only reason i wouldn't put it on the website directly is that the website is pure chaos. it'll get lost.
14:13:59 <ykarel> amoralej, shouldn't take much effort as we enabled it for centos8 trunk builds
14:14:02 <leanderthal> actually....
14:14:03 <ykarel> it's not merged yet though
14:14:07 <spotz> heheh
14:14:33 <rdogerrit> Yatin Karel proposed rdo-jobs master: Enable container build in CentOS8 001 job  https://review.rdoproject.org/r/26087
14:14:38 <ykarel> amoralej, ^^
14:14:39 <leanderthal> maybe it'd go nicely on https://www.rdoproject.org/rdo/release-checklist/
14:14:41 <amoralej> ykarel, ok, let's see if we can get that job for the time hen tripleo create their tags
14:15:15 <amoralej> leanderthal, i think that's the perfect place
14:15:18 <ykarel> amoralej, ack
14:15:27 <amoralej> a new section
14:15:38 <leanderthal> amoralej, do you have time to add it towards the beginning?
14:15:44 <amoralej> "Technical definition of done"
14:15:48 <leanderthal> Yeah
14:15:54 <spotz> +1
14:16:04 <leanderthal> but also, the announcement needs to happen before the next major event after the release.
14:16:16 <amoralej> i'd say at the beginning
14:16:23 <amoralej> i can send a PR and discuss there
14:16:29 <leanderthal> this is why, even though multi arch was still broken for train, we published before open infra shanghai
14:16:49 <spotz> So we need to announce before PTG then?
14:16:56 <leanderthal> so the timing needs to be 'ideally' once the technical definition is completed, but, yes, before PTG
14:17:03 <leanderthal> that's a hard stop.
14:17:16 <spotz> So gives us about 2 weeks
14:17:23 <leanderthal> and not on a friday or the weekend
14:17:26 <amoralej> should be enough
14:17:30 <leanderthal> so the deadline is 28 may
14:17:52 <amoralej> ETA for tripleo release is 21st
14:17:55 <amoralej> weshay|ruck, ^
14:17:59 <leanderthal> that'd be awesome.
14:18:36 <amoralej> #action amoralej to update Definition of Done in https://www.rdoproject.org/rdo/release-checklist/
14:19:07 <amoralej> #agreed to wait for TripleO Ussuri release before announcing RDO Ussuri release
14:19:08 <iurygregory> If tripleO does next week we should be fine I would say =)
14:19:14 <leanderthal> exactly
14:19:54 <leanderthal> any questions on definition of done before we move on to the next topic?
14:20:24 <amoralej> #agreed to announce RDO Ussuri release before PTG
14:20:52 <spotz> sent out a calendar reminder to iurygregory, Jason and myself for that date
14:20:57 <leanderthal> perfect
14:21:01 <iurygregory> spotz, tks!
14:21:04 <leanderthal> jbrooks, ^^
14:21:12 <leanderthal> jbrooks is in here, by the way
14:21:15 <leanderthal> that's jason
14:21:19 <jbrooks> o/
14:21:22 <spotz> hi jbrooks:)
14:21:24 <leanderthal> he's just now waking up
14:21:28 <leanderthal> #chair jbrooks
14:21:28 <zodbot> Current chairs: amoralej iurygregory jbrooks jcapitao jpena leanderthal spotz ykarel
14:21:28 <openstack> Current chairs: amoralej iurygregory jbrooks jcapitao jpena leanderthal spotz ykarel
14:21:29 <jbrooks> hey spotz
14:21:31 <iurygregory> hey =)
14:21:33 <leanderthal> #topic [amoralej] Removal of RDO Trunk Pike and Ocata
14:21:41 <leanderthal> amoralej, this is also you
14:22:56 <amoralej> #info pike and ocata are in Extended Maintenance phase upstream and with a very small number of new commits
14:23:34 <amoralej> #info RDO made CloudSIG repos for pike and ocata EOL but maintains RDO Trunk repos for them
14:23:56 <amoralej> i doubt it provides any value, so i'm proposing to alse remove RDO Trunk repos for pike and ocata
14:23:59 <amoralej> from trunk server
14:24:21 <iurygregory> makes sense to me
14:24:35 <ykarel> let's advertise as still some jobs are running for tripleo in upstream
14:24:44 <ykarel> upgrade from pike to queens
14:24:54 <jpena> ^ that's my only concern, if some of them are being used for FFU
14:25:05 <leanderthal> please send an email to the lists - including centos-devel - to let people know that they're going away in, say, a month? and then remove them then?
14:25:18 <leanderthal> oh, valid.
14:25:21 <amoralej> #info cron jobs to build new commits has been stopped https://softwarefactory-project.io/r/#/c/18347/
14:25:50 <leanderthal> jpena, ykarel how can we find out?
14:26:01 <jpena> we need to ask the tripleo team
14:26:06 <amoralej> yep
14:26:21 <amoralej> i doubt we have some upgrade job for those releases, but let's ask
14:26:22 <leanderthal> jpena, or ykarel will one of you take the action item to confirm?
14:27:03 <amoralej> #undo
14:27:03 <zodbot> Removing item from minutes: INFO by amoralej at 14:25:21 : cron jobs to build new commits has been stopped https://softwarefactory-project.io/r/#/c/18347/
14:27:04 <openstack> Removing item from minutes: #info cron jobs to build new commits has been stopped https://softwarefactory-project.io/r/#/c/18347/
14:27:08 <ykarel> https://bugs.launchpad.net/tripleo/+bug/1877031 highlighted the issue with upgrade jobs from pike to queens
14:27:10 <openstack> Launchpad bug 1877031 in tripleo "queens tripleo-ci-centos-7-undercloud-upgrades broken for ansible version" [High,Triaged] - Assigned to Rafael Folco (rafaelfolco)
14:27:17 <ykarel> so jobs are running currently
14:27:23 <amoralej> #info cron jobs to build new commits from ocata and pike have been stopped https://softwarefactory-project.io/r/#/c/18347/
14:27:37 <ykarel> there is a proposal to drop that job
14:28:01 <ykarel> so we need to followup with TripleO wrt there usage of trunk repos before cleanup
14:28:35 <amoralej> https://review.opendev.org/#/c/727696/
14:28:42 <amoralej> yep
14:28:47 <amoralej> let's confirm with them
14:29:33 <ykarel> leanderthal, ok i can drop a mail on openstack and rdo list to remove the repos
14:29:44 <leanderthal> and centos-devel please, ykarel ?
14:29:52 <ykarel> leanderthal, sure will include that as well
14:29:56 <leanderthal> perfect
14:29:59 <leanderthal> thx ykarel
14:30:46 <ykarel> #action ykarel to send mail wrt pike and ocata trunk repos removal
14:31:03 <leanderthal> who is going to follow up with TripleO specifically?
14:31:13 <ykarel> #link https://bugs.launchpad.net/tripleo/+bug/1877031
14:31:14 <openstack> Launchpad bug 1877031 in tripleo "queens tripleo-ci-centos-7-undercloud-upgrades broken for ansible version" [High,Triaged] - Assigned to Rafael Folco (rafaelfolco)
14:31:41 <leanderthal> I highly recommend saying something along the lines of, 'we're doing this thing on 01 July. speak now or forever hold your peace'
14:32:06 <iurygregory> ^ ++
14:32:42 <spotz> Scream test for the win
14:32:45 <EmilienM> ++ to remove pike & ocata repos. Maybe openstack-discuss is the right channel. I'm sure we have operators using tripleo (outside of OSP context)
14:34:52 <leanderthal> EmilienM, cool!
14:35:17 <leanderthal> any other questions / comments re: pike / ocata before we move on to RDO Ussuri Release Announcement
14:38:11 <leanderthal> #topic [leanderthal] RDO Ussuri Release Announcement
14:38:26 <leanderthal> #link https://review.rdoproject.org/etherpad/p/ussuri-release-announcement
14:38:31 <leanderthal> #link https://review.rdoproject.org/etherpad/p/ussuri-release-announcement
14:38:44 <leanderthal> #action spotz to coordinate with iurygregory regarding release checklist / announcements
14:38:58 <leanderthal> #link https://www.rdoproject.org/rdo/release-checklist/
14:39:05 <iurygregory> ack
14:39:38 <leanderthal> as we already discussed, we're going to officially announce once the criteria of 'done' is completed; however, it needs to be by thursday, 28 may at the latest.
14:39:53 <iurygregory> yeah
14:39:58 <leanderthal> thx for setting up the calendar reminder for you, jbrooks and iurygregory, spotz
14:40:13 <spotz> My pleasure:)
14:40:14 <leanderthal> any questions on that?
14:40:16 <jbrooks> +1
14:40:22 <iurygregory> nope =)
14:41:30 <spotz> not I
14:41:57 <leanderthal> #topic Next Week's Chair?
14:42:03 <leanderthal> anyone keen?
14:42:20 <ykarel> i can take it
14:42:27 <leanderthal> thx so much ykarel
14:42:38 <leanderthal> #topic Open Floor
14:43:05 <spotz> Will miss you Rain!
14:43:20 <leanderthal> I'm leaving Red Hat and I'll miss the RDO COMMUNITY SO MUCH!
14:43:28 <leanderthal> spotz typed faster than me
14:43:34 <amoralej> we'll miss you too :)
14:43:36 <leanderthal> spotz++
14:43:36 <zodbot> leanderthal: Karma for spotz changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:43:38 <leanderthal> amoralej++
14:43:38 <zodbot> leanderthal: Karma for amoralej changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:43:44 <leanderthal> iurygregory++
14:43:57 <leanderthal> i wonder if there's a limit to how many plus pluses i can give out in one go
14:44:03 <ykarel> you will be missed leanderthal , but i hope u will be around :)
14:44:05 <leanderthal> jcapitao++
14:44:05 <zodbot> leanderthal: Karma for jcapitao changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:44:10 <iurygregory> there isn't =)
14:44:13 <leanderthal> ykarel++
14:44:13 <zodbot> leanderthal: Karma for ykarel changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:44:26 <leanderthal> jpena++
14:44:26 <zodbot> leanderthal: Karma for jpena changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:44:27 <iurygregory> leanderthal, good luck =)
14:44:29 <leanderthal> jbrooks++
14:44:31 <leanderthal> <3
14:44:32 <zodbot> leanderthal: Karma for jasonbrooks changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:44:32 <iurygregory> leanderthal++
14:44:40 <jpena> we'll miss you leanderthal :o)
14:44:51 <leanderthal> thx so much!! !
14:44:55 <mjturek> best of luck leanderthal!
14:45:03 <leanderthal> mjturek++
14:45:06 <leanderthal> #chair mjturek
14:45:06 <zodbot> Current chairs: amoralej iurygregory jbrooks jcapitao jpena leanderthal mjturek spotz ykarel
14:45:07 <openstack> Current chairs: amoralej iurygregory jbrooks jcapitao jpena leanderthal mjturek spotz ykarel
14:45:14 <jcapitao> leanderthal++ good luck :)
14:45:14 <zodbot> jcapitao: Karma for leanderthal changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:45:27 <leanderthal> do you all wanna hear where i'm going?
14:45:31 <leanderthal> just between us?
14:45:32 <leanderthal> ;-)
14:45:41 <spotz> hehe
14:47:19 <jcapitao> ... wait for it ...
14:47:37 <rdogerrit> Merged openstack/nova-distgit ussuri-rdo: openstack-nova-21.0.0-1  https://review.rdoproject.org/r/27516
14:48:17 <leanderthal> I mean, I'm not pausing for dramatic effect; if no one says yes, then I'm not telling.
14:48:35 <jpena> I'm curious :D
14:48:55 <leanderthal> I'm headed over to Packet / Equinix to be a Developer Advocate
14:49:10 <leanderthal> Which is why I can definitely do CloudSIG but not sure if I'm also allowed to do RDO.
14:49:20 <iurygregory> cool =)
14:49:26 * jpena googles
14:49:50 <rdogerrit> Yatin Karel created rdoinfo master: Promote GA builds to ussuri-testing  https://review.rdoproject.org/r/27524
14:49:54 <ykarel> all GA bits are built, promoting to ussuri-testing with ^^
14:50:10 <leanderthal> ykarel, SQUEEEEE!! !
14:51:07 <leanderthal> anything else for open floor today?
14:51:47 <leanderthal> jpena, https://www.packet.com/
14:52:26 <ykarel> upstream GA announced http://lists.openstack.org/pipermail/openstack-announce/2020-May/002035.html
14:52:36 <leanderthal> NICE!! !
14:52:45 <leanderthal> #link http://lists.openstack.org/pipermail/openstack-announce/2020-May/002035.html
14:54:03 * iurygregory discovered that there is an openstack-announce list...
14:55:47 <leanderthal> nice
14:55:59 <leanderthal> i'll give ya back five minutes of your day! have a great one, everyone!
14:56:00 <leanderthal> #endmeeting