14:00:56 <amoralej> #startmeeting RDO meeting - 2020-07-15
14:00:56 <zodbot> Meeting started Wed Jul 15 14:00:56 2020 UTC.
14:00:56 <zodbot> This meeting is logged and archived in a public location.
14:00:56 <zodbot> The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:56 <zodbot> The meeting name has been set to 'rdo_meeting_-_2020-07-15'
14:00:57 <openstack> Meeting started Wed Jul 15 14:00:56 2020 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:01 <openstack> The meeting name has been set to 'rdo_meeting___2020_07_15'
14:01:02 <amoralej> #topic rall call
14:01:16 <spotz> Warning I'm at the car dealership as I had a bad tire. So if I dissapear suddenly that's why
14:01:22 <spotz> o/
14:01:45 <amoralej> ok
14:01:49 <amoralej> #chair spotz
14:01:49 <zodbot> Current chairs: amoralej spotz
14:01:50 <openstack> Current chairs: amoralej spotz
14:04:32 <ykarel> o/
14:05:16 <jcapitao> o/
14:05:19 <amoralej> #chair ykarel jcapitao
14:05:19 <zodbot> Current chairs: amoralej jcapitao spotz ykarel
14:05:20 <openstack> Current chairs: amoralej jcapitao spotz ykarel
14:05:27 <amoralej> ok, let's start with first topic
14:05:59 <amoralej> #topic Upcoming events - https://review.rdoproject.org/etherpad/p/rdo-events
14:06:24 <amoralej> spotz, are you available?
14:06:32 <spotz> So I ran this past jbrooks and we're a go from his end
14:07:02 <amoralej> oh, sounds good
14:07:04 <spotz> We are looking at getting t-shirts for workers and participants from the same vendor that CEPH is using
14:07:21 <amoralej> i need to review the etherpad
14:07:31 <jcapitao> \o/
14:07:37 <spotz> And I estimated for all events plus helpers being about 50 but said I'd check with everyone
14:07:42 <ykarel> \o/
14:08:44 <amoralej> sounds great spotz !
14:08:46 <spotz> I waited to this week to send the goc days email out as I didn't want it to get lost over the weekend and we have 1 response. I've linked the etherpad I'm gathering responses on to the events etherpad
14:10:00 <spotz> We had one response this morning, I'm not sure how realistic getting every config option in TripleO is but who knows:) He also said the Ironic instructions while he figured it out weren't clear. So that's 2 things for a doc days so far
14:10:47 <spotz> Does anyone think even with helpers we'd be over 50 people for hackfest, install RDO, install packstack, and doc days?
14:10:48 <amoralej> yes, valid feedback, although that should go to TripleO upstream doc more that RDO
14:11:18 <amoralej> but still good to collect and contribute
14:11:30 <ykarel> i think 50 is more than enough considering last test days
14:11:32 <amoralej> spotz, i don't expect more that 50 people
14:11:33 <amoralej> yes
14:11:36 <spotz> amoralej: Yeah my thoughts as well for that one, but I did include upstream as if we're missing like how to install Octavia on RHEL/CentOS that might be something we can cover
14:11:37 <amoralej> +1
14:12:34 <spotz> Ok so 50 total for all the events including the workers and hopefully next time we'll say 100+ for the events
14:13:21 <spotz> And yes I'm including all volunteers for shirts as well with the hope maybe we could get ours to wear should we be doing video for an event
14:14:04 <spotz> So any other comments/thoughts on this besides the fact we need to narrow down dates and platform(s)?
14:14:43 <amoralej> spotz, also we need to detail a bit on the installating workshop
14:14:47 <amoralej> if we do that with tripleo
14:14:54 <amoralej> we probably need some more infra
14:15:00 <amoralej> undercloud/overcloud
14:15:03 <amoralej> etc
14:15:06 <spotz> Ok that might be a third install workshop:)
14:15:18 <amoralej> so, for the installation workshop
14:15:33 <amoralej> what were you thinking for deployment tooling?
14:15:45 <spotz> I figured the devstack might be good for onboading. then a use the RPMs workshop. FOrgot about tripleO
14:16:01 <spotz> !devstack but packstack
14:16:03 <openstack> spotz: Error: "devstack" is not a valid command.
14:16:09 <amoralej> good :)
14:16:12 <ykarel> :)
14:16:36 <spotz> :)
14:16:43 <ykarel> sorry for undercloud/overcloud we targetting baremetals?
14:16:50 <ykarel> or just libvirt based deployments
14:17:01 <ykarel> using quickstart
14:17:07 <amoralej> i'd avoid quickstart
14:17:15 <amoralej> as quickstart is not intended for users, but for CI
14:17:16 <amoralej> right?
14:17:17 <ykarel> then manual install?
14:17:34 <ykarel> no it's for users as well
14:17:37 <amoralej> how are users supposed to install
14:17:42 <spotz> I was thinking libvirt only because it's easier for people to have one piece of hardware and if they messup recreate the VM
14:17:43 <ykarel> for ci there is rapper on quickstart
14:18:04 <spotz> Yeah the one time I tried quickstart.sh it was no bueno
14:18:27 <ykarel> quickstart https://www.rdoproject.org/tripleo/
14:18:41 <amoralej> that still works?
14:18:43 <ykarel> it needs mainly few steps to deploy
14:18:43 <amoralej> :)
14:18:44 <ykarel> yes
14:18:56 <ykarel> might need some adjustment for tripleo, but it works
14:18:56 <apevec> ykarel, there's now https://opendev.org/openstack/tripleo-operator-ansible which was supposed to be usable for both CI and users
14:19:01 <ykarel> s/tripleo/centos8
14:19:02 <amoralej> my personal opinion is that using that
14:19:23 <spotz> Ok I'll go through that quickstart page once I get an OS on my NUC
14:19:24 <amoralej> hides too much the actual process and it's too opinionated
14:19:29 <ykarel> apevec, yup that's also an option, quickstart too started adopting it
14:19:45 <amoralej> oh
14:19:47 <amoralej> good point
14:19:52 <amoralej> let's engage tripleo
14:19:54 <amoralej> guys
14:19:59 <spotz> Yeah if we're doing this we want folks to learn something
14:20:11 <spotz> And add more t-shirts to the count:)
14:20:12 <amoralej> could also be a good oportunity to show   tripleo-operator-ansible
14:20:30 <ykarel> for quickstart, there is also phases doc https://docs.openstack.org/tripleo-quickstart/latest/getting-started.html
14:20:40 <spotz> Think tripleo-operator-ansible could be a twitch stream?
14:20:40 <amoralej> mwhahaha may be interested
14:20:41 <ykarel> but yes inside it's all ansible tasks
14:21:10 <spotz> ykarel: That's the one I think I tried a year or two with no luck but might have been my network setup
14:21:37 <spotz> Oh and we got bumped from 7/27 for commons, will let you know new possible date
14:21:46 <ykarel> spotz, hmm possible, but it works fine, me also not tried recently though
14:22:15 <ykarel> but runs in CI fine so saying it works
14:22:29 <spotz> ykarel: It might have been how I had networking configured. It took me a bit to figure it out thanks to one of ktenzer's blogs
14:22:55 <spotz> And I mean the networking but at that point I just installed like in the blog
14:23:39 <spotz> And I've added the tripleo install to the etherpad
14:23:42 <mwhahaha> tripleo-operator-ansible simplifies the execution, it doesn't unfortuantely do anything for environmental setup and configuration generation
14:23:57 <rdogerrit> Sergii Golovatiuk created rdo-infra/ansible-role-tripleo-ci-reproducer master: Remove screen from package list  https://review.rdoproject.org/r/28544
14:24:13 <mwhahaha> Tengu's tripleo-lab is an alternative to quickstart if you want to give that a go
14:24:22 <mwhahaha> it uses tripleo-operator-ansible to do the exeuction
14:24:35 <mwhahaha> https://github.com/cjeanner/tripleo-lab
14:24:38 <mwhahaha> fwiw
14:24:47 <spotz> added to the etherpad thanks
14:25:07 <amoralej> mwhahaha, we are thinking in doing creating some virtual workshops about installation methods
14:25:17 <amoralej> wrt tripleo, what do you think may be the best way for users?
14:25:18 <mwhahaha> for virtual workships tripleo-lab would be good
14:25:31 <mwhahaha> requires libvirt tho i think
14:25:37 <EmilienM> yes it does
14:26:03 <ykarel> spotz, ack, let's see how it works now, it doesn't need much on networking side
14:27:02 <spotz> Yeah so a beefy enough server which we should probably provide specs for ahead of time
14:27:10 <mwhahaha> for a virtual thing, if you provided the ovb instances, then you could just use tripleo-operator-ansible
14:27:12 <Tengu> it does yep
14:27:25 <Tengu> libvirt, and a computer with enough power to run VMs.
14:27:58 <mwhahaha> the environment creation/config is really a seperate thing from the actual tripleo usage
14:28:04 <Tengu> spotz: minimal specs are provided in the readme - but since you can set whatever resources you want per VM...
14:28:23 <sshnaidm> do we have fedora32 images in rdo?
14:28:55 <Tengu> (also note, tripleo-labs has been tested with centos7, centos8, rhel7 and rhel8 - not with any fedora atm)
14:28:55 <ykarel> yes as per https://review.rdoproject.org/zuul/labels
14:29:00 <ykarel> sshnaidm, ^
14:29:02 <spotz> We were thinking we'd do guided config/install workshops with checkins for longer workshops
14:29:29 <spotz> Whether it's someone being around the entire time or office hour checkins not sure yet
14:31:05 <amoralej> spotz, so it would one workshop to deploy with tripleo
14:31:13 <amoralej> one for PoC with packstack
14:31:24 <amoralej> and first one is not clear to me, manually following upstream doc?
14:31:37 <spotz> So tripleo team would you be willing to help if we do a tripleo install workshop? Also not sure if you have it but someone asked for tripleo config option
14:31:43 <amoralej> dnf install, schema creating, manual config and so on?
14:31:44 <spotz> amoralej: Yeah using the RPMs
14:31:52 <amoralej> uh, the hard way :)
14:32:01 <spotz> That's actually easier for me:)
14:32:29 <rdogerrit> Sagi Shnaidman created rdo-jobs master: Create nodesets for fedora 32 and rawhide  https://review.rdoproject.org/r/28545
14:32:35 <sshnaidm> amoralej, ykarel please review ^
14:32:39 <spotz> But the advantage is that people learn more when they make mistakes.
14:33:00 <amoralej> yes, it's useful for learning purposes
14:33:16 <amoralej> i'd say not practical to deploy production environments
14:33:46 <amoralej> but yes, you learn a lot, it used to be the firs task to learn openstack
14:33:50 <spotz> Hehehe it's how I did my first prod environment but there were no other options for Grizzly
14:34:17 <spotz> So anyways 3 install workshops, hackfest and doc days
14:34:23 <amoralej> ok
14:34:26 <amoralej> sounds great
14:34:28 <ykarel> +1
14:34:57 <rdogerrit> Sagi Shnaidman created rdo-infra/ansible-role-tripleo-ci-reproducer master: Add new podman fedora jobs  https://review.rdoproject.org/r/28546
14:35:02 <spotz> I'll work on details such as platform and possible dates and get back to the team but will keep that document updated
14:35:16 <Tengu> might be better to push the tripleo-operator-ansible instead of calling "openstack" commands though.... ansible, that kind of things.
14:35:56 <Tengu> especially since the operators are here in order to help converging the tools/way things are being deployed
14:35:56 <spotz> tengu was kinda thinking a twitch stream for that if anyone was interested:)
14:38:38 <spotz> I think that's it for this round of RDO events discussions
14:38:40 <amoralej> thanks for all that work spotz
14:38:44 <amoralej> yep
14:38:49 <spotz> amoralej: My pleasure
14:38:52 <amoralej> i think we can move to next topic
14:39:27 <spotz> +1
14:39:35 <amoralej> #topic restarting NFV SIG for more official OVS/OVN builds
14:39:50 <amoralej> #link https://lists.centos.org/pipermail/centos-devel/2020-July/055933.html
14:40:21 <amoralej> as announce in previous meetings we'll start building OSP/OVN from Fast DataPath in CentOS NFV Sig
14:40:36 <amoralej> I've proposed a meeting to relaunch the SIG next week
14:41:04 <ykarel> amoralej, how many volunteers/members are already there with new SIG?
14:41:04 <amoralej> #action everyone interested in NFV SIG please join us!
14:41:19 <amoralej> not many :)
14:41:22 <amoralej> i expect 3-4
14:41:33 <ykarel> ok i can join then :)
14:41:35 <amoralej> i got confirmation from oVirt guys
14:41:53 <amoralej> i'm trying to engage NFV team too
14:42:01 <amoralej> sure ykarel, you are welcome!
14:42:14 <ykarel> yes that would be much better to engage folks with background
14:42:24 <amoralej> also i'll check if former NFV members are interested inparticipate
14:43:25 <ykarel> that's good
14:43:39 <apevec> for us (RDO/CLoud SIG) prio is to get OVS/OVN rebuilds from FDP srpms going
14:43:51 <amoralej> yes
14:43:59 <apevec> I did scratch build and it just worked(tm)
14:44:23 <spotz> Don't foget to make a SiG page:)
14:44:24 <amoralej> in fact 2.13 seems to not be affected by the issue affecting previous versions
14:44:34 <amoralej> i saw unit tests are passing
14:44:44 <apevec> #link  scratch OVS FDP build https://cbs.centos.org/koji/taskinfo?taskID=1386673
14:44:46 <amoralej> yes spotz it's part of the next steps
14:45:03 <spotz> Maybe make a Sig section on https://www.rdoproject.org/contribute/?
14:45:21 <ykarel> amoralej, so for us it would be just an external repo, right?
14:45:30 <apevec> yes
14:45:30 <ykarel> how we planning to test the builds
14:45:35 <amoralej> ykarel, yes
14:45:47 <apevec> that's the open topic to discuss, gating
14:45:50 <amoralej> i want to create some CI jobs to test it from -testing
14:45:52 <ykarel> hmm okk
14:45:57 <apevec> I guess oVirt would like to contribute their use-cases
14:46:03 <apevec> too
14:46:11 <amoralej> spotz, i don't want to mix nfv sig in RDO
14:46:22 <amoralej> i'll use CentOS doc pages, i think
14:46:34 <spotz> Ok
14:47:37 <amoralej> yes, i expect ovirt to also test builds
14:47:47 <amoralej> we'll discuss in the meeting
14:48:51 <amoralej> i think that's it about this topic
14:49:10 <amoralej> #topic next week chair
14:49:13 <amoralej> any volunteer?
14:49:42 <spotz> I can do it I think
14:49:57 <amoralej> #action spotz to chair next week
14:49:59 <amoralej> thanks
14:50:08 <amoralej> #topic open floor
14:50:53 <spotz> One thing:)
14:51:17 <spotz> Do we do triage or review list meetings or anything like that?
14:51:37 <amoralej> no, we don't
14:52:06 <amoralej> you'd like to have?
14:52:53 <spotz> We had them for a bit with OSA but no longer have them. I'm just trying to think of ways we can get folks involved and keep them involved
14:53:29 <spotz> Time from commit to merge on a first patch could be important for maintaining a new contributor
14:53:41 <spotz> commit=git review
14:55:34 <amoralej> some time ago we had easyfix initiative https://github.com/redhat-openstack/easyfix
14:56:15 <amoralej> and mainly chandankumar took care of office hours for it
14:56:28 <spotz> Ok I'll take a look and check in with him
14:56:44 <amoralej> it was a way to attract new contributors
14:57:28 <amoralej> chandankumar is now focused in tripleo-ci, but we can discuss if it'd be good to retake
14:57:36 <rdogerrit> Merged rdo-jobs master: Create nodesets for fedora 32 and rawhide  https://review.rdoproject.org/r/28545
14:57:54 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Promoter: switch to qcow python promotion  https://review.rdoproject.org/r/27626
14:58:21 <spotz> Yeah some of the mentors are doing other things or gone from RH
14:58:42 <amoralej> yep
14:59:01 <amoralej> anything else, we are almost out of time
14:59:17 <spotz> Ok I'll put updating that and making it available from the website as wishlit to do items:)
14:59:30 <apevec> ah yes I'll  update https://github.com/redhat-openstack/easyfix#mentors list
15:00:15 <ykarel> include me ^ :)
15:00:16 <apevec> removals done
15:00:21 <apevec> ykarel, send PR :)
15:00:29 <ykarel> sure will send
15:01:06 <rdogerrit> Sorin Sbarnea (zbr) created rdo-infra/ci-config master: Add mol-promoter periodic  https://review.rdoproject.org/r/28547
15:01:49 <spotz> Once I get more of a handle on RDO processes and stuff I'll mentor but not while I'm still pestering folks with questions:)
15:02:19 <amoralej> sure :)
15:02:28 <amoralej> I'm closing the meeting unless there is any last minute topic
15:02:59 <amoralej> #endmeeting