14:01:04 <ykarel> #startmeeting RDO meeting - 2020-08-19
14:01:04 <zodbot> Meeting started Wed Aug 19 14:01:04 2020 UTC.
14:01:04 <zodbot> This meeting is logged and archived in a public location.
14:01:04 <zodbot> The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:04 <zodbot> The meeting name has been set to 'rdo_meeting_-_2020-08-19'
14:01:06 <openstack> Meeting started Wed Aug 19 14:01:04 2020 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:09 <openstack> The meeting name has been set to 'rdo_meeting___2020_08_19'
14:01:19 <spotz> o/
14:01:25 <ykarel> #topic roll call
14:01:31 <ykarel> #chair spotz
14:01:31 <zodbot> Current chairs: spotz ykarel
14:01:31 <openstack> Current chairs: spotz ykarel
14:01:38 <spotz> Also manning the kubecon chats so if I should answer and don't ping please:)
14:01:55 <ykarel> Please add last minute topic to agenda https://etherpad.opendev.org/p/RDO-Meeting
14:03:11 <spotz> Haven't heard back from Wes this week so no updates on the tripleo workshop
14:05:57 <ykarel> Ok let's start with the topic we have
14:06:11 <ykarel> #topic haproxy 2.2
14:06:24 <ykarel> #link https://lists.rdoproject.org/pipermail/dev/2020-August/009435.html
14:06:29 <ykarel> cgoncalves, ^^
14:06:51 <cgoncalves> thank you
14:07:24 <cgoncalves> as written in the email, the OpenStack Octavia will soon require HAProxy 2.x. CentOS provides 1.8 so we need to make 2.x available somehow
14:07:56 <cgoncalves> I rebuilt 2.2 from Fedora rawhide and it passed our scenario tests on CentOS 8
14:08:23 <cgoncalves> I would like to know if RDO could help make 2.2 available either in RDO repos or elsewhere (NFV?)
14:08:40 <spotz> Is that an option we can do? I know I've been grabbing stuff from centos on my rhel machine
14:09:00 <spotz> I mean pulling from Fedora
14:09:34 <cgoncalves> I know RDO rebuilds many packages from Fedora
14:09:57 <ykarel> yes we rebuild dependencies from Fedora into CBS
14:10:13 <rdogerrit> Merged rdo-jobs master: Replace promoter periodic jobs  https://review.rdoproject.org/r/29004
14:10:50 <ykarel> cgoncalves, is that haproxy needed only for amphora driver, just curious
14:10:55 <spotz> So sounds like something we could work with the CentOS folks for
14:11:03 <ykarel> in past i heard there is ovn driver which replacing amphora
14:11:12 <ykarel> but me not know much about the plans
14:12:23 <ykarel> and wrt to shipping haproxy in RDO deps, we consume it from CentOS8 base, and we avoid overriding these deps in RDO
14:12:43 <ykarel> cgoncalves, you checked if there is plan to update in some next rhel8 version
14:12:52 <ykarel> like 8.3, 8.4 etc
14:13:02 <ykarel> so it can come to c8 stream and you can consume from there
14:13:31 <cgoncalves> ykarel, only for amphora that I know of but 2.x provides performance improvements, etc that would also help other projects like tripleo, kolla, etc
14:14:02 <cgoncalves> I checked with RHEL, no plans to provide 2.x in RHEL 8.x
14:14:10 <ykarel> :(
14:14:41 <cgoncalves> Octavia can't wait for RHEL 9 to develop new features, other distros provide 2.x today
14:14:43 <spotz> Probably as RHEL will add in 9 when RHOSP17 is released
14:15:18 <ykarel> cgoncalves, other distros, you mean fedora?
14:15:24 <ykarel> ubuntu etc
14:15:24 <cgoncalves> fedora, ubuntu, ...
14:15:39 <spotz> If RDO isn't the right place for this has anyone asked centos if they're willing?
14:16:13 <spotz> They still have EPEL, I pulled screen from there:)
14:16:33 <ykarel> spotz, centos too will likely not build in base, as base is picked from rhel
14:16:46 <ykarel> some SIG has to adopt it
14:16:49 <spotz> ykarel: But could it go in EPEL?
14:17:10 <ykarel> i think in EPEL it could go
14:17:58 <spotz> So maybe we could ask cloud SIG to champion it going there?
14:18:05 <ykarel> but epel and rdo repos don't play well
14:18:06 <cgoncalves> apevec was more of the opinion of NFV. I'm okay with that
14:18:39 <ykarel> yes since it's more related to networking, NFV seems more ideal for it
14:18:59 <ykarel> currently NFV sig only building openvswitch/ovn
14:19:10 <ykarel> and is recently bootstrapped
14:19:36 <ykarel> it's weekly meeting happens every 2 week, next meeting is next week
14:20:12 <spotz> Worth asking them
14:20:30 <ykarel> cgoncalves, so when developing feature it will be still be backward compatible, right?
14:21:14 <ykarel> i mean you can develop/test new features on fedora/ubuntu and other distros can go with older haproxy until it's get available
14:21:23 <cgoncalves> ykarel, backward compatible? new features like HTTP/2 won't run some older HAProxy versions
14:22:05 <cgoncalves> ykarel, not really. for fedora, we would need to add support of it, we've been there and it's difficult because it's a moving target
14:22:33 <ykarel> cgoncalves, i mean octavia once added new features, will continue working with haproxy < 2
14:22:34 <cgoncalves> as for ubuntu, we could but I hear a different hat, a red one
14:22:39 <ykarel> i guess it will be made configurable
14:22:57 <ykarel> because atleast Downstream OSP will not update haproxy
14:23:09 <cgoncalves> ykarel, we would have to exclude tests in tempest for the centos job. that is just... not ideal
14:23:29 <rdogerrit> Rafael Folco proposed rdo-infra/ci-config master: Remove legacy molecule scenarios/playbooks  https://review.rdoproject.org/r/28901
14:23:48 <cgoncalves> ykarel, we won't be backporting new features to OSP 16.x or older
14:24:06 <cgoncalves> ^ ones that need haproxy 2.x at least
14:24:49 <ykarel> cgoncalves, ohkk got it
14:25:04 <ykarel> and understand your points on fedora and ubuntu
14:25:35 <ykarel> so we can bring this to NFV sig and see what other guys think
14:25:43 <cgoncalves> sure
14:25:49 <cgoncalves> I can join next week's NFV meeting
14:25:50 <ykarel> this is PTO month, so people are out as well
14:26:03 <ykarel> next week we will have more people, more opinion
14:26:29 <spotz> Also Kubecon this week so less people
14:26:53 <ykarel> me agrees on upgrading part, just we need to find right home for it
14:28:01 <spotz> +1
14:28:29 <ykarel> Ok let's move to next topic
14:28:46 <ykarel> #topic Testing NFV builds(ovs/ovn2.13)
14:28:58 <ykarel> #link https://review.rdoproject.org/r/#/c/29009/
14:29:23 <ykarel> So in an effort to consume builds from NFV SIG, started testing with https://review.rdoproject.org/r/#/c/29009/
14:30:15 <ykarel> till now results looks good
14:30:25 <ykarel> jobs are still running
14:30:59 <ykarel> By next week we will see how to move forwards with it once Alfredo is back
14:31:22 <ykarel> that's it from me on this topic
14:32:49 <ykarel> If nothing to discuss, let's move to next topic
14:33:03 <ykarel> #topic Chair for next Meeting
14:34:08 <ykarel> any volunteer?
14:38:49 <ykarel> Ok i can re take it
14:38:56 <ykarel> #action ykarel to chair next week
14:39:02 <spotz> I've got 1 conflict at the time but can if you can't
14:39:10 <ykarel> #topic open floor
14:39:13 <spotz> Today I have 3:)
14:39:19 <ykarel> Feel free to bring any topic now
14:40:14 <spotz> I need to follow up with weshay|ruck about the tripleo stuff. I'm on the fence on the manual install. And so far only the one person with docs suggestions and that was tripleo docs
14:41:55 <spotz> I think we could probably free some time back. ykarel if something happens and you need me to run next week just ping
14:43:56 <ykarel> spotz, ok Thanks
14:44:13 <ykarel> so if nothing to discuss, let's close early and everyone get's back 15 minutes
14:45:03 <ykarel> Thanks all for joining
14:45:06 <ykarel> #endmeeting