14:01:16 <jcapitao> #startmeeting RDO meeting - 2020-09-09
14:01:16 <zodbot> Meeting started Wed Sep  9 14:01:16 2020 UTC.
14:01:16 <zodbot> This meeting is logged and archived in a public location.
14:01:16 <zodbot> The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:16 <zodbot> The meeting name has been set to 'rdo_meeting_-_2020-09-09'
14:01:18 <openstack> Meeting started Wed Sep  9 14:01:16 2020 UTC and is due to finish in 60 minutes.  The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:21 <openstack> The meeting name has been set to 'rdo_meeting___2020_09_09'
14:01:31 <jcapitao> #topic roll call
14:01:40 <jcapitao> #chair spotz
14:01:40 <zodbot> Current chairs: jcapitao spotz
14:01:41 <openstack> Current chairs: jcapitao spotz
14:02:08 <amoralej> o/
14:02:43 <jcapitao> #chair amoralej
14:02:43 <zodbot> Current chairs: amoralej jcapitao spotz
14:02:44 <openstack> Current chairs: amoralej jcapitao spotz
14:03:18 <spotz> hey all
14:04:42 <ykarel> o/
14:05:10 <jcapitao> #chair ykarel
14:05:10 <zodbot> Current chairs: amoralej jcapitao spotz ykarel
14:05:11 <openstack> Current chairs: amoralej jcapitao spotz ykarel
14:05:28 <jcapitao> let's start
14:05:35 <jcapitao> #topic site pull requests
14:05:59 <jcapitao> spotz: ^ all yours
14:06:21 <spotz> Yeah so if anyone has permissions to merge the website - https://github.com/redhat-openstack/website/pulls
14:06:51 <spotz> One adds out test days and the other points to the correct location for things for 2020
14:07:18 <spotz> We're already merged for the calendar so once those are in we can start advertising
14:07:33 * jcapitao reading the markdown files
14:07:38 <amoralej> i do
14:07:51 <amoralej> sorry spotz, those got out of my radar
14:08:02 <spotz> Now because of UTC times FYI we show  on the calendar as 4-6 which I think is still valid
14:08:28 <spotz> amoralej: Oh tht's ok, when I saw the calendar merge I actually thought it was those so didn't follow up sooner
14:08:50 <spotz> And well I suck at PRs so the first one is 2 commits
14:09:37 <amoralej> spotz, the new links are broken
14:09:55 <amoralej> i mean https://github.com/OSAS/rh-events/edit/master/2020/RDO-Community.yml and https://github.com/OSAS/rh-events/edit/master/2020/RDO-Meetups.yml
14:10:06 <amoralej> from https://github.com/redhat-openstack/website/pull/1395/files
14:10:53 <spotz> Looking
14:12:01 <spotz> Ok I see the issue I'll get that fixed
14:12:44 <spotz> And it's a page in 2018 that points to a 2017 event:(
14:13:49 <amoralej> spotz, let me know when ready to get it merged
14:14:34 <spotz> amoralej: WIll do, I'm basically just making a new file with the test days with the thought we can add other events on there as well as overall community stuff
14:15:04 <spotz> Real quick mascot is waiting for resources, the person who will help us is busy with a website
14:16:41 <jcapitao> who is he ?
14:17:06 <spotz> Tuomas I always spell it wrong:(
14:18:40 <spotz> Oh I actually got it right!
14:19:18 <jcapitao> yeah i found him ;)
14:19:29 <jcapitao> that's all for this topic ?
14:19:41 <spotz> I actually looked at some free logos but didn't like anything. Yep that's all from me
14:21:04 <jcapitao> let's wait for him then
14:21:10 <jcapitao> let's move on
14:21:14 <jcapitao> #topic Expected switch to NFV SIG for OVS and OVN on next week for Victoria
14:22:02 <amoralej> #info RDO is moving to use OpenvSwitch and OVN packages from NFV SIG on next week
14:22:17 <amoralej> #info this will move from current 2.12 version to 2.13
14:22:46 <amoralej> we will do two steps, 1st to add new repo, 2nd add the wrapper
14:22:58 <amoralej> we are currently testing (1) in https://review.opendev.org/#/q/topic:nfvsig+(status:open+OR+status:merged)
14:23:36 <amoralej> #info this switch will start in Victoria repos, backport to Ussuri and Train are being considered
14:23:40 <amoralej> i think that's it
14:23:49 <amoralej> ykarel, am i forgetting something?
14:23:56 <ykarel> amoralej, no that's it
14:23:58 <jcapitao> what's the wrapper ?
14:24:19 <amoralej> https://cbs.centos.org/koji/buildinfo?buildID=30524
14:24:45 <amoralej> it's a package rdo-openvswitch which is used to select which version of ovs/ovn will be installed from the ones available in nfv
14:24:46 <jcapitao> ok i see
14:25:02 <amoralej> nfv sig uses openvswitch2.13 and ovn2.13 names
14:25:24 <amoralej> the wrapper provides unversioned package names, as openvswitch and ovn and requires the desired version
14:25:31 <amoralej> it's a bit of magic
14:26:00 <amoralej> https://media.tenor.com/images/5bcb5056e6dfe7f757018ecaa8a4b868/tenor.gif
14:26:31 <amoralej> the wrapper itself will be included in the dependencies repo
14:26:45 <spotz> On the backports will version need to be specified or still magic?
14:26:54 <ykarel> :D gif
14:27:18 <amoralej> spotz, for the backports we'd use the same wrapper
14:27:27 <amoralej> for ussuri i don't see much problem
14:27:37 <amoralej> other that doing that kind of change in a stable release
14:27:47 <rdogerrit> Merged rdoinfo master: Bump rdoinfo victoria-uc tags to latest upper-constraints  https://review.rdoproject.org/r/29158
14:27:47 <amoralej> in train, the problem is that we have both centos7 and centos8
14:28:03 <amoralej> and nfv only have centos8 builds
14:28:17 <amoralej> and i'd like to keep train as consistent as possible for c7 and c8
14:28:26 <amoralej> so i need to check if there is the need
14:29:13 <spotz> And do we have to backport to train?
14:29:27 <amoralej> i received a request for it
14:29:34 <amoralej> but i need to double check with the networking guys
14:29:46 <spotz> Ok
14:30:20 <spotz> And PR is up, not sure I like the semi empty page but once we decide to do something with summit I'll update it:)
14:30:46 <spotz> But back to the backport:)
14:31:31 <amoralej> spotz, which PR?
14:31:50 <rdogerrit> Merged rdoinfo master: Rebuild packages from Fedora to match u-c  https://review.rdoproject.org/r/29212
14:31:56 <spotz> helps if I hit create
14:32:04 <amoralej> :D
14:32:16 <spotz> Have I mentioned I suck at PRs?:)
14:32:30 <amoralej> gerrit++
14:32:30 <zodbot> amoralej: Karma for gerrit changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:32:37 <spotz> ++++++++
14:33:12 <amoralej> i still have discussions with colleages about gerrit vs github
14:33:14 <spotz> I do find it interesting someone wants a backport on Train which is now or will be in a month extended life
14:33:36 <jcapitao> indeed i parsed the rdo-openvswitch.spec, looks like black magic
14:34:00 <amoralej> :)
14:34:13 <spotz> Not sure how decisions ultimately get made on something like this but definitely ROI with lack of folks:(
14:34:52 <amoralej> well, notes some organizations keeps maintaining releases during extended maintenance
14:35:29 <amoralej> so, yes, it's a matter of evaluating value vs effort
14:35:31 <amoralej> and risk
14:35:51 <spotz> And with C7 and C8 in that release might be riskier then normal
14:36:25 <amoralej> riskier or more effort
14:36:29 <amoralej> yes
14:36:46 <amoralej> that's why i want to avoid having differences between c7 and c8
14:37:42 <jcapitao> yeah, better to put effort on the future
14:38:05 <jcapitao> let's move
14:38:06 <amoralej> depends on the expected value :) that's what i need to get from networking team
14:38:18 <amoralej> yes, we can move to next topic
14:39:07 <jcapitao> #topic Preparation for Victoria release
14:40:12 <amoralej> #info dependencies updates ongoing in https://review.rdoproject.org/r/#/q/topic:match-uc+(status:open+OR+status:merged)
14:40:20 <amoralej> we've done good progress on deps updates
14:40:50 <amoralej> we still have some work to rebuild and promote some but overall, we did well
14:41:13 <spotz> Woot!
14:41:22 <amoralej> #info upstream is doing final releases for libs and clients for victoria
14:41:29 <amoralej> now we can start doing reqchecks
14:42:47 <amoralej> let's start by adding the list of packages to https://review.rdoproject.org/etherpad/p/victoria-release-preparation
14:43:02 <amoralej> and with usual reqcheck and branching
14:43:15 <amoralej> we can coordinate efforts in the etherpad
14:43:50 <amoralej> I'll add the list after the meeting
14:43:55 <jcapitao> +1 i'll start in parallel of updating deps
14:43:58 <jcapitao> i have a question about updating deps
14:44:11 <jcapitao> why don't we update deps continuously and not in one shot as we're doing ?
14:44:16 <amoralej> :)
14:44:28 <amoralej> we should :)
14:44:32 <spotz> +1
14:44:37 <amoralej> it's a matter of resources and effort
14:44:44 <amoralej> also of lack of automation
14:44:58 <amoralej> we've done some attempts of automating it but it's pretty hard
14:45:05 <amoralej> now we are probably at a better position
14:45:13 <jcapitao> ok i thought it related to a technical reason
14:45:19 <amoralej> actually not
14:45:44 <amoralej> if a dep is updated 4 times in a cycle
14:45:54 <amoralej> if we do it continuously, we do 4 updates
14:46:02 <amoralej> if we do it at the end, we do it once
14:46:13 <amoralej> if effort is low with automation
14:46:20 <amoralej> it's better to do 4 times
14:46:21 <spotz> WHat's the percentage of forgotten updates?
14:46:30 <amoralej> and be up to date always
14:46:39 <jcapitao> when you say "it's pretty hard" it's because the divergence between fedora and CentOS ?
14:46:45 <amoralej> yes
14:46:47 <amoralej> mostly
14:46:48 <rdogerrit> Yatin Karel created rdoinfo master: Rebuild packages from Fedora to match u-c  https://review.rdoproject.org/r/29213
14:47:04 <amoralej> and the number of corner cases
14:47:15 <amoralej> not impossible
14:47:38 <amoralej> in fact, now should be easier
14:47:40 <amoralej> with c8
14:47:52 <amoralej> although divergence is already growing
14:47:56 <amoralej> i.e. %pytest
14:48:04 <ykarel> %python3 too
14:48:07 <amoralej> yep
14:48:12 <jcapitao> yep..
14:48:25 <amoralej> spotz, i can't give you a number
14:48:42 <jcapitao> and CentOS Stream can't help us here ?
14:48:47 <spotz> I kinda was typing when you said if automated 4 updates is better:)
14:49:01 <amoralej> the good point is that, actual issues created by old deps are catch by CI
14:49:07 <spotz> So I think we're actually on the same thought if it's easy enough do them more often
14:49:15 <amoralej> so I'd say we don't forget important updates
14:49:25 <ykarel> actually issue is with deps that are not in CentOS base, so CentOS stream will not help
14:49:26 <amoralej> spotz, absolutely
14:49:35 <ykarel> jcapitao, ^
14:49:54 <amoralej> jcapitao, no centos stream will not help on this, as ykarel mentioned
14:50:19 <amoralej> these are packages not coming from CentOS base repos
14:50:39 <jcapitao> indeed
14:50:51 <amoralej> #action amoralej to add the list of packages for Victoria in preparation etherpad
14:52:11 <amoralej> i think that's it from victoria preparation PoV
14:52:16 <amoralej> anything else?
14:52:40 <ykarel> nothing from me
14:52:54 <spotz> For the release note we'll need new contributors?
14:53:02 <spotz> note=email
14:53:40 <amoralej> spotz, you mean to get the list of new contributors?
14:53:51 <spotz> yeah
14:54:05 <amoralej> i'd say so
14:54:13 <amoralej> i think jpena has some script
14:54:24 <amoralej> for metrics of contributors
14:54:52 <spotz> amoralej: Ok I'll ask when it gets closer
14:54:58 <jpena> yes, I can get them from a repoxplorer instance (if it's still alive)
14:55:05 <amoralej> yes, i think we still have some time
14:55:46 <jcapitao> ok we're out of time, let's move
14:55:55 <jcapitao> #topic next week's chair
14:56:11 <jcapitao> any volunteers ?
14:56:15 <spotz> I can take it
14:56:22 <spotz> no conflicts for once:)
14:56:26 <rdogerrit> Javier Peña created openstack/cinder-distgit rpm-master: Add python3-packaging dependency  https://review.rdoproject.org/r/29214
14:57:07 <jcapitao> #action spotz to chair next week
14:57:14 <jcapitao> thank you spotz
14:57:30 <jcapitao> #topic open floor
14:59:06 <jcapitao> anything else you'd like to share?
14:59:32 <spotz> I'm good
15:01:15 <rdogerrit> Merged rdo-infra/ansible-role-dlrn master: Add rdoinfo_driver options  https://review.rdoproject.org/r/29186
15:01:25 <spotz> SUmmit schedule just went live
15:01:33 <jcapitao> i'm closing the meeting
15:01:43 <jcapitao> thanks all for joining
15:01:50 <jcapitao> #endmeeting