00:44:33 <mchua> #startmeeting
00:44:33 <zodbot> Meeting started Fri Nov 13 00:44:33 2009 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:44:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:44:46 <mchua> thanks for the transbot reminder, ianweller - thanks for transbot, ctyler!
00:45:01 <ianweller> i had a suggestion for a change :)
00:45:15 <mchua> #chair mchua_afk harish tira xinyi YeLong yipch
00:45:15 <zodbot> Current chairs: YeLong harish mchua mchua_afk tira xinyi yipch
00:47:57 <mchua> Hey, we're on Planet!
00:47:58 <mchua> #link http://teachingopensource.org/index.php/Planet
00:48:21 <mchua> kinchew's blog was the first with a post to hit Planet TOS, yay!
00:48:22 <mchua> #link http://eunisim.blogspot.com/2009/11/reflections-on-posse-workshop-in.html
00:48:34 <mchua> And it looks like jadudm has been reading. :)
00:48:35 <mchua> #link http://www.sububi.org/2009/11/12/new-posse-bloggers/
00:48:46 <transbot0> hers has disconnected
00:49:09 <mchua> for those of you who haven't met him yet, jadudm is Matt Jadud, one of the lecturers (in the US we call lecturers 'professors') from our first POSSE in Raleigh this July.
00:52:05 <transbot0> jaricsng has disconnected
00:55:23 <kinchew> Good morning everybody!
01:00:06 <mchua> #chair pohyee-cheong kinchew
01:00:06 <zodbot> Current chairs: YeLong harish kinchew mchua mchua_afk pohyee-cheong tira xinyi yipch
01:01:01 <transbot0> rchiun has joined: #teachingopensource-posse-zh
01:01:22 <transbot0> kinchew has disconnected
01:05:08 <transbot0> YeLong has disconnected
01:05:30 <rchiun> Just learn a  open source software. Brasero. Cool!
01:07:22 <rchiun> Last day of POSSE and Mel is giving a briefing POSSE blog.
01:07:35 <mchua> #topic Examples of what other professors have done
01:07:36 <mchua> #link http://www.sububi.org/2009/07/27/the-busy-students-guide-to-project-blogging/
01:09:15 <harish2> go to http://172.20.132.147/ to pick up some goodies :-)
01:09:46 <rchiun> Thank Harish. Sure we have lot of goodies. ;-}
01:11:10 <kinchew> Hi Everybody, I am back.
01:11:45 <kinchew> Mel is just reviewing the blog at "the student's guide to project blogging".
01:12:07 <kinchew> #link http://www.sububi.org/2009/07/27/the-busy-students-guide-to-project-blogging/
01:12:32 <rchiun> Kin Chew: Thanks for the blog. Yes, certainly we learn a lot.
01:13:59 <kinchew> #link http://en.wikipedia.org/wiki/Allegheny_College
01:14:23 <kinchew> Now it is rockalypse.org
01:14:24 <mchua> #link http://www.rockalypse.org/
01:14:36 <kinchew> #link http://rockalypse.org
01:15:10 <kinchew> CMPSC112F09: Data Structures
01:15:33 <kinchew> If you are teaching Data Structures, you can grab the contents from this website.
01:16:32 <kinchew> We are now talking about the screencasts on the Data Structures website.
01:16:33 <mchua> It is creative commons licensed. yay jadudm!
01:17:23 <kinchew> British Comedy in Translation
01:18:09 <kinchew> Can use some of the tools and techniques from this British Comedy website.
01:20:18 <mchua> #link http://www.rockalypse.org/courses/cmpsc112f09/blog/
01:20:25 <mchua> #link http://www.rockalypse.org/courses/fs101f09/blog/
01:21:41 <kinchew> #link http://blog.chris.tylers.info/index.php?/categories/11-CDOT
01:21:54 <kinchew> We are now looking at Chris Tyler's Blog.
01:22:03 <mchua> #link http://zenit.senecac.on.ca/wiki/index.php/Main_Page
01:22:04 <kinchew> Chris Tyler lives in Canada.
01:23:26 <kinchew> #link http://zenit.senecac.on.ca/wiki/index.php/DPS909
01:23:35 <rchiun> A good way to publish your materials.
01:24:00 <kinchew> Topics in Open Source Development.
01:24:40 <kinchew> We are now doing OOP344
01:25:05 <kinchew> Object Oriented Programming II using C++
01:25:24 <rchiun> Subject matters are different but the tools are the same.
01:25:30 * ctyler listens
01:25:32 <kinchew> Get into the habit of blogging!
01:26:46 <kinchew> Make use of the Resources on the OOP344 page.
01:27:34 <kinchew> Get everybody to check in their codes into git!
01:28:01 <kinchew> Learn how to use version control.
01:28:49 <kinchew> Look at examples and the notes.
01:29:47 <kinchew> How to engage students in open source coding.
01:30:56 <mchua> #link http://zenit.senecac.on.ca/wiki/index.php/DPS909
01:31:00 <mchua> #link http://vocamus.net/dave
01:31:18 <mchua> #link http://vocamus.net/dave/?p=26
01:32:00 <kinchew> Mel is now talking about Chris Tyler's blog on Fedora Bugzilla.
01:32:32 <mchua> #link http://blog.chris.tylers.info/
01:32:37 <mchua> #link http://blog.chris.tylers.info/index.php?/archives/217-StudentProject-keyword-in-Fedora-Bugzilla.html
01:33:13 <kinchew> Fedoar 12 Toronto Release Party Alternative
01:34:16 <kinchew> #link http://blog.chris.tylers.info/index.php?/archives/214-Fedora-12-Toronto-Release-Party-Alternative.html
01:34:26 <mchua> #link http://teachingopensource.org/index.php/POSSE_Blogs
01:36:04 <mchua> #topic: first round - what are you thinking about doing?
01:36:29 <mchua> #chair martz927
01:36:29 <zodbot> Current chairs: YeLong harish kinchew martz927 mchua mchua_afk pohyee-cheong tira xinyi yipch
01:37:08 <kinchew> Hi martz927, welcome!
01:37:13 <mchua> New module for the coming semester - before looking at these materials, I was thinking about what the end objective was for the module.
01:37:41 <kinchew> We are now getting the participants to talk about what they plan to do after going through this workshop.
01:37:48 <mchua> Original objective: Students can do programming from the front end to the back end.
01:38:37 <kinchew> 1st speaker:  3rd year programming course on open source
01:38:45 <mchua> But after looking at this, maybe the objective would be to have students be productive when they start in industry.
01:38:50 <mchua> kinchew, thanks for taking notes also :)
01:39:06 <kinchew> LAMPP, Google toolkit
01:39:16 <kinchew> Mel, you are most welcome!
01:39:20 <mchua> Can choose any open source project I want
01:39:27 <kinchew> Everything is very new in the 3rd year course.
01:39:48 <mchua> harish talking about the idea of having two tracks: one group of students trying to learn how to do front-end-to-back-end
01:39:58 <kinchew> Harish is now giving his ideas on introducing open source.
01:40:01 <mchua> second group whose goal is to participate in an open source project.
01:40:23 <mchua> harish asking: Which one was the desired outcome?
01:40:29 <kinchew> Harish:  what is the desired outcome.
01:40:33 <transbot0> yipch_ has disconnected
01:41:10 <kinchew> Speaker:  Contribution to open source may not be easy to assess.
01:41:28 <mchua> Poh yee commenting: open source software development is very related to programming. Instead of using .ASP, you're using open source tools.
01:41:38 <mchua> We should also introduce concepts like legal implications.
01:41:48 <mchua> That was my original idea.
01:41:54 <mchua> Harish: Now that you've gone through POSSE, what are you thinking?
01:41:58 <kinchew> Cheong Poh Yee:  Issue now is we have only 60 hours.
01:41:59 <mchua> Poh Yee: We only have 60 hours.
01:42:18 <mchua> So we need to think about what students in industry need to know - how to collaborate.
01:42:24 <kinchew> Students need to know Java, PHP,  before they join the industry.
01:42:42 <mchua> Harish: Maybe a longer-term objective is to do this open source thing across many things.
01:42:48 <kinchew> Harish:  Immediate objective is to get the 60-hour course going.
01:43:01 <mchua> But in the short term, maybe you focus on one thing - say, year 1 students, get them started.
01:43:16 <kinchew> Harish:  need to build up some credibility.
01:43:25 <ctyler> if posse-apac wanted to hit bugzilla and add StudentProject to any applicable bugs on, say, the New Bugs page ... :-)
01:43:34 <mchua> ctyler, we were just talking about you!
01:43:41 <kinchew> Poh Yee:  Too many tools in Open Source.
01:43:42 <ctyler> I saw :-)
01:43:50 <mchua> ctyler, want to add anything about what Seneca does?
01:43:57 <mchua> we've seen your wiki pages and your course websites.
01:44:12 <ctyler> I hope you got a pretty good idea from that, but if there are any questions I'd be glad to answer them.
01:44:20 <kinchew> Roger Chium is now talking.
01:44:42 <kinchew> He wants to go back to Singapore Polytechnic to share what he has learnt here.
01:44:54 <kinchew> Harish:  Start with a student group?
01:45:06 <kinchew> Harish:  Outside curriculum stuff?
01:45:08 <mchua> Roger teaches part-time (I think?) so it's hard to figure out where to start, which is why Harish is suggesting starting with a club.
01:45:18 <kinchew> Harish:  Want to build something for the club.
01:45:40 <mchua> ctyler, what was the most surprising thing you learned when you started to teach open source?
01:45:49 <mchua> ctyler, and the hardest thing you had to overcome (and how did you do it)?
01:45:53 <kinchew> Harish:  Send me an e-mail if you need help.
01:46:29 <kinchew> Roger:  Most systems are very structured.
01:46:52 <mchua> ctyler, and the big outstanding problems in teaching open source - the things that are still *really* hard to do, so we can expect them to be hard?
01:46:56 <kinchew> Roger:  The most important thing for academicians is to assess the students.
01:47:13 <mchua> ctyler: OH! Question from the lecturers (rather than from me): how do you grade this stuff?
01:47:23 <kinchew> Harish:  Look at student body, societies, etc.  Can start something with them.
01:47:33 <ctyler> mchua: let me start with the hardest thing: Overcoming the things we had already taught the students, such as: work must be entirely your own (no cheating), you should be able to completely understand the program you're working on, and you're "just a student".
01:47:58 <kinchew> Harish:  Can start with an IRC channel in Freenode.net.
01:48:13 <ctyler> In open source, on the other hand, they need to collaborate and build on existing work; the code is usually too big to completely understand; and instead of being "just a student" they are valued contributors.
01:48:29 <kinchew> Jaric:  Can Red Hat sponsor a server?
01:48:50 <kinchew> Harish:  Fedorahosted?
01:48:55 <ctyler> As far as grading, it is far easier than it would appear, because the community will help mark.
01:49:33 <ctyler> For example, if a student has submitted a patch, there's a review process for that patch.
01:49:42 <rchiun> Kin Chew: I am full time staff. Hee! Hee!
01:50:01 <kinchew> Jaric:  Hardware may not be there.
01:50:12 <ctyler> The community will be far more demanding and precise that I will be in terms of their expectations! I can use the review comments to guide the marking.
01:50:36 <kinchew> Roger:  I think it was Mel who mentioned that you might be a part-time staff.  Not me.
01:51:10 <kinchew> Chris, good to know that the community can help to grade the student's work.
01:52:45 <kinchew> Hosting of the TeachingOpenSource POSSE website is with the Seneca?
01:53:01 <rchiun> Sorry. Kin Chew.
01:53:05 <mchua> rchiun - sorry, I misheard then :)
01:53:07 <ctyler> kinchew: Hosting of TeachingOpenSource.org is on my system.
01:53:14 <kinchew> Roger:  no problem.
01:53:36 <kinchew> Harish:  Need to figure out our own requirements, e.g. hardware, hosting, etc.
01:53:39 <mchua> ctyler: but when you grade, is it more subjective than if it were, say, a problem set?
01:53:46 <mchua> ctyler: where there is an expected right/wrong answer?
01:54:06 <mchua> #action look into ways of providing infrastructure to schools in the TOS community
01:54:23 <kinchew> Harish:  As a follow-up, determine the institutional support amongst ourselves.
01:54:52 <kinchew> Jaric:  Students' feedback is very important.
01:55:02 <mchua> Jaric: Our school values student comments, so if we get good student feedback, it will help us as lecturers a lot.
01:55:22 <ctyler> mchua: you're really grading process. whether the answer is right or not really depends on whether it does what the project (community) needs.
01:55:31 <kinchew> Another speaker:  Students doing certification courses.
01:55:55 <kinchew> Harish:  Certification e.g. for system administration.
01:56:12 <mchua> Harish is mentioning the various Red Hat certifications - Red Hat Academy program for training for the RHCT, RHCE (system administration) certifications.
01:56:34 <mchua> ctyler: thanks - we're threading multiple conversations in parallel but I'll call everyone's attention to your messages in just a moment, this is really helpful.
01:56:43 <kinchew> Harish:  JBOSS certification as well.
01:56:54 <mchua> ctyler: does it take you more or less time grading open source vs conventional problem sets? (Is it more fun to grade open source stuff?)
01:56:56 <kinchew> Harish:  2 buckets of certification from Red Hat.
01:57:01 <mchua> ctyler: how do your colleagues feel about those grades?
01:57:07 <mchua> ctyler: employers, too?
01:57:44 <kinchew> Roger:  Materials for RHCT and RHCE may not be enough?
01:57:53 <ctyler> mchua: In terms of hard things to do: students that don't engage the community -- lone-wolf types, or the very shy -- find it difficult to excel at open source.
01:58:19 <kinchew> Jaric:  Need an ecosystem for Open Source.
01:58:37 <kinchew> Jaric:  Industrial attachment
01:58:47 <mchua> ctyler, actually, as one of those (formerly, I suppose) really shy students, open source was a lifesaver for me.
01:59:09 <kinchew> Jaric:  Red Hat and its business partners for industrial attachment.
01:59:21 <mchua> ctyler: I was afraid of talking with other people in person, and speaking up in my actual classes - but I could read a lot and listen, and eventually I became ok with writing, and then... well, now I talk to people :)
01:59:44 <kinchew> Jaric:  Students are paid about S$440 per month during their industrial attachment.
02:00:01 <mchua> The word I know for what Jaric is talking about is "co-op."
02:00:24 <ctyler> mchua: Grading OS requires flexibility but is more enjoyable than marking traditional coursework. Our colleagues are generally very accepting of the marks, because they are grounded in reality. When a student has written a new feature that's shipped to millions of people around the world, how can you say they were not successful?
02:00:42 <kinchew> Jaric:  12-week industrial attachment.
02:01:56 <kinchew> Roger:  Ongoing projects.  Want to apply POSSE concepts and ideas in these projects.  IRC, webchat.
02:02:37 <kinchew> Mel:  We are going to blog to publicise our work on Open Source.
02:03:38 <kinchew> Harish:  Any political issue when different polytechnics collaborate on OSS Projects?
02:03:39 * mchua is looking forward to people introducing themselves, their schools, and their first TOS projects/classes (which we're defining now) to the TOS community
02:04:06 <kinchew> Jaric:  We need a higher level commitment.
02:04:21 <mchua> *really* lively discussion going on in the classroom right now
02:05:08 <ctyler> Harish: If there are political issues with collaborating with other institutions, you can avoid this by collaborating with the OS community instead (which may, incidentally, contain collaborators from the other institution).
02:05:27 <mchua> ctyler + 1 insightful!
02:05:35 <mchua> Tirath also brings up the problem of IP (and tech transfer)
02:06:19 <kinchew> Harish:  Need some clarity.
02:07:42 <ctyler> Obviously, to work with open source, you are receiving a lot of IP from outside, and transferring your IP to the community. It's a completely different IP regime than proprietary work.
02:08:04 <ctyler> And remarkably close to traditional science.
02:08:30 <mchua> Tirath: As a researcher, are you allowed to contribute the same code you write for your university research to the open source community under an open license too?
02:08:47 * mchua has seen exactly that happen - it's not uncommon, in my perception - but I don't know what problems might be out there.
02:09:11 <jaricsng> ctyler, in every class we will have lone-wolf types, or the very shy student, what do we do with them?
02:09:52 <kinchew> Mel:  Students can also contribute by taking notes and posting them.
02:11:15 <kinchew> Harish:  Don't deride students.  "You are just students and you are not able to contribute!".  Such statements are not helpful.
02:11:45 <kinchew> Mel:  Someone files a bug in Bugzilla.  This is a good contribution.
02:12:18 <ctyler> jaricsng: often, it's a matter of having the students find an area within the community that is aligned with their passion. Once they find the type of contribution that matches their skills, interests, and personal style, they can blossom.
02:12:46 <ctyler> A shy person might be a great tester, for example, or a wiki gardener.
02:12:52 <kinchew> Mel:  In OSS work:  does it serve the needs of people?
02:13:53 <kinchew> Harish:  Jaric, use the backchannel!  Use the second projector.
02:14:21 <kinchew> Mel:  We were using Twitter as a backchannel!
02:14:48 <ctyler> kinchew: what hashtag?
02:14:58 <kinchew> Harish:  I used Twitter as a backchannel when I was teaching OSS in NTU.
02:15:14 <mchua> I think an important concept is the teacher as guide rather than sole information source - how do you help your students learn something that you yourself don't know? (This is kinda scary to do at first.)
02:15:22 <mchua> ctyler: we were at #iif
02:15:27 <mchua> (this was last spring semester)
02:15:35 * mchua points out that there is an open source alternative to twitter
02:15:37 <kinchew> Chris:  I am not sure what hashtag is all about?  Mel?
02:15:38 <mchua> #link http://identi.ca
02:15:48 <mchua> kinchew, I'll find you a link.
02:16:07 <mchua> kinchew, http://www.searchenginejournal.com/twitter-hashtags/9419/
02:16:23 <kinchew> Thanks, Mel, for the link.
02:16:51 <kinchew> Harish:  140 characters for Twitter.  Limitation forces you to be precise!
02:17:07 <kinchew> Mel:  Sage on the stage.
02:17:59 <kinchew> Mel:  How to teach our students the stuff that you are not familiar with?
02:18:35 <kinchew> Mel:  Student projects - can find many advisers in the community.
02:19:34 <ctyler> Therefore you need to know the community :-)
02:20:10 <kinchew> Tirath:  I work with people with religious focus.  I have to sell OSS to them.  Centre in Malacca, Penang.  How to create open source stuff to teach them.
02:20:38 <kinchew> Mel:  POSSE Malaysia.
02:20:52 <kinchew> Harish:  We all will be alumni!
02:21:36 <kinchew> Mel:  Have lecturers to teach POSSE to our students.
02:24:39 <kinchew> #link http://teachingopensource.org/index.php/RIT
02:25:06 <kinchew> RIT:  Rochester Institute of Technology - blog in TOS
02:26:04 * mchua showing RIT's co-op program
02:26:09 <mchua> Steve Jacobs == awesome
02:26:42 <kinchew_> Harish:  Since all the work done is online, we can always check it online.
02:27:49 <kinchew_> Mel is now talking about the Sugar Summer Program
02:28:38 <kinchew_> I want to focus on interesting projects using OSS.
02:30:19 <pohyee-cheong> kinchew: using ruby on rails, mysql, Redhat enterprise linux for projects
02:30:25 <mchua> thanks, pohyee-cheong!
02:30:42 <mchua> I think Kin Chew is talking about writing a document sharing system for his school, because they needed the infrastructure?
02:31:29 <mchua> Kin Chew was able to teach someone how to take on maintenance of his code with only one week of training!
02:31:33 <mchua> (Wow, that must be some *really* nice code.)
02:31:56 <pohyee-cheong> kinchew: Using projects as showcase as means of evangelise open source software
02:32:28 <pohyee-cheong> kinchew: Currently, developing course on physiology using open source software
02:32:56 <pohyee-cheong> Kinchew: Do be launched on 27 Jan.  Intending to create a blog on it
02:33:08 <mchua> also using (luke macken's) liveusb to deliver content for the physiology class
02:33:49 <mchua> "Learning doesn't mean the instructor has to prepare everything down to the last slide."
02:34:12 <mchua> Did a blog post last night - "why is it I had difficulty this week? It's because I'm used to a structured environment."
02:34:27 <mchua> kinchew has learned the magic of the backchannel :)
02:34:33 <mchua> active participation instead of passive absorbing of material
02:34:50 <mchua> "also social learning - I've learned a lot from other participants"
02:35:29 <pohyee-cheong> kinchew:  Intends to pass on what is learnt last one week to his students
02:38:00 <pohyee-cheong> mchua: reminds us initially unstructed learning  will face resistance from students
02:38:15 <kinchew_> I think we should encourage our students to blog about their experiences with OSS.
02:38:58 <mchua> Tirath: "Prepare them for the pain."
02:39:01 <mchua> (set expectations)
02:39:29 <mchua> ctyler: by gosh, I think they've got it :) I'm really looking forward to the new class of POSSE graduates joining the main TOS mailing list
02:41:05 <ctyler> :-)
02:42:03 <mchua> Tirath: what if we did POSSE on weekends - 6 Sundays?
02:42:12 <mchua> Harish: The challenge is that real life catches up with you.
02:42:17 <mchua> (This week was a deliberate immersion.)
02:43:10 <mchua> Harish: Could we do it in fewer days? Probably not.
02:43:25 <mchua> Mel: Oh - question for everyone... on Tuesday, you probably hated us... when did it start making sense?
02:43:28 <kinchew_> We only became productive probably after the middle of the 2nd day.
02:43:45 <mchua> Jaric: Actually what I was thinking was "IRC? I use MSN! I use Blackboard, I can already share files with my students..."
02:43:47 <kinchew_> Jaric:  Why IRC when we could be using MSN?
02:43:59 <kinchew_> Harish:  DIMDIM
02:44:49 <kinchew_> #link http://www.dimdim.com
02:45:37 <kinchew_> Jaric:  Students blog and say bad things about companies and supervisors and then they got into trouble.
02:45:41 <mchua> Jaric: One challenge I have is teaching students how to blog appropriately - some of them blog in ways that, if a future employer were to see their blog, it would look very unprofessional.
02:45:55 <kinchew_> Jaric:  We should channel them into positive things.
02:45:56 * mchua will sit back and let kinchew take notes because he's doing a much better job :)
02:46:30 <kinchew_> Tirath:  Teach them about blog etiquette.
02:47:34 <kinchew_> Harish:  Have a repository of best practices.
02:47:45 <kinchew_> Harish:  No SMS lingo!
02:48:08 <kinchew_> Mel:  How do we expect students to do good coding if they never read good codes before?
02:48:29 <tira> mchua: Can we have some links for demo good and bad code?
02:48:29 <mchua> #link http://www.spinellis.gr/codereading/
02:48:53 <kinchew_> Harish has just given a link on code reading.
02:49:30 <kinchew_> Mel:  Example:  You put up a graph.  Now put up its label.
02:49:59 <kinchew_> Code Reading:  The Open Source Perspective
02:50:24 <kinchew_> Harish:  A working device drive - read the real code.
02:52:59 <kinchew_> Mel:  Capture as much of our discussions today and share it with the POSSE community.
02:53:11 <kinchew_> Mel:  POSSE pledge!
02:53:13 <mchua> tira, see link for the ookl is a good one
02:53:23 <kinchew_> Let us go for a break!
02:53:51 <mchua> #topic list of projects
02:54:25 <transbot0> rchiun has disconnected
02:58:39 <mchua> #endmeeting