19:04:20 <mchua> #startmeeting
19:04:20 <zodbot> Meeting started Fri Nov 20 19:04:20 2009 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:04:28 <mchua> #chair quaid ctyler alolita biertie
19:04:28 <zodbot> Current chairs: alolita biertie ctyler mchua quaid
19:04:43 <mchua> Anyone have any particular agenda they want to get through today?
19:04:49 <mchua> or list of questions, etc?
19:04:51 <quaid> ctyler: mel got nirik to get zodbot here
19:05:06 <alolita> mchua: i have some questions re: posse in the bay area
19:05:17 <quaid> I'm curious which schools and/or instructors are interested?
19:05:37 * biertie wants to announce something
19:06:14 * quaid re:
19:06:18 * quaid re: Bay Area, fwiw
19:06:18 <mchua> I have some questions about what people planning to do POSSEs need, so we can build resources and a process that supports it
19:06:46 <mchua> what else is on people's minds? then we can start cranking through the list and see where the discussion goes.
19:07:16 <alolita> quaid, mchua: here are my agenda items: 1. initiating conversation with profs / schools in bay area 2. who can help 3. timeframes 4. infrastr reqd 5. successful implementation issues 6. execution
19:07:39 <quaid> alolita: are you comfie with what a POSSE is for?  And that there are people who want or will want that?
19:07:54 <quaid> but I'm intrigued by biertie's announcement ...
19:08:08 <mchua> biertie: was there anything about that announcement you wanted to discuss? if so, let's put it down
19:08:27 <biertie> ach sorry, /me and mr Jan Wildeboer will organise a posse in emea this summer :)
19:08:35 <quaid> yay!
19:09:01 <biertie> but it's still in very early draft ;-)
19:09:03 <alolita> quaid: i have been following mel's excellent posts to tos about posse and have a good amount of experience working with profs in india, sri lanka, nepal
19:09:16 <alolita> biertie: cool :-)
19:10:11 <alolita> quaid: ive had some good initial conversations with profs in the local area (bay area) also whom i've known for a long time and they're interested in posse
19:10:42 <biertie> we have some interested parties in UK / belgium / netherlands :)
19:10:46 <mchua> ok, I see 5 topics on our agenda right now
19:10:49 <quaid> alolita: cool; yeah, this seems like an area that should be ripe
19:10:52 <quaid> mchua: rock it
19:11:09 <mchua> 1) which schools/projects are interested (exhaustive braindump of all that we know, so we see where the possibilities lie)
19:11:38 <mchua> 2) quick status updates, if any, on any of those POSSEs (other than the ones in agenda items (3) and (4))
19:11:50 <mchua> 3) Bay Area POSSE - alolita's 6 questions
19:11:56 <mchua> 4) EMEA POSSE - biertie update
19:12:02 <mchua> 5) what people planning to do POSSEs need, so we can build resources and a process that supports it
19:12:12 <mchua> (though I suspect #5 will be practically done by the time we get through (3) and (4))
19:12:26 <mchua> that's what I have so far, anything else we want to make sure that we hit?
19:12:35 <mchua> (and does anyone have to leave at any particular time?)
19:13:04 * mchua is under the impression that this is a one-time meeting, but we can always continue convo on list, schedule another one, etc. if we think we need to
19:13:23 * quaid too
19:13:32 <biertie> ³
19:13:37 <mchua> okay
19:13:38 <alolita> yes that works for me too
19:13:41 <mchua> #topic which schools/projects are interested
19:13:44 <mchua> BRAINDUMP GO!
19:14:17 <mchua> plone folks were keen on doing possibly 2 this summer - one in england, one on the left coast of the US (somewhere in Washington state, iirc)
19:14:24 * mchua has to followup
19:14:33 <mchua> #action mchua followup on plone POSSE interest
19:14:46 <alolita> the schools we can tap into in the bay area are stanford, ucsf, usf
19:14:55 <biertie> wouldn't it be stupid to have 2 posses in emea then?
19:15:05 <mchua> biertie: no, EMEA is a big place
19:15:18 <alolita> biertie: agree with mchua
19:15:20 <mchua> biertie: list yours :)
19:15:26 <quaid> alolita: is there a way to reach "all" schools?  I mean, not just the big 3 or 5
19:15:29 <mchua> alolita: any particular project(s) in mind?
19:15:57 <mchua> quaid: i think we're looking at host schools now - the events have been open to profs from any institution who's willing to travel to the posse location
19:16:17 <alolita> quaid: yes - the community colleges are more interesting - de anza and foothill in south bay are interested also
19:16:37 <mchua> quaid: being "big" is not a prereq for a host school, but someone from within that school has to be willing to do planning/logistics legwork and help organize
19:16:46 <quaid> I don't know anyone at UCSC yet for this, but I can ask; there is also SJ and Monterey CSU
19:17:05 <alolita> mchua: the topics covered in the apac posse were of interest to the folks i talked with
19:17:11 <quaid> and Cabrillo community college here might also, we do know folks there
19:17:27 <alolita> quaid: sjsu is definitely also a good candidate
19:17:30 <mchua> a Sugar Labs related POSSE around Rochester seems pretty likely with Steve Jacobs and his class totally kicking butt up there
19:17:56 <mchua> Mo Duffy and I have been talking about doing a Design POSSE in the Boston area - so that'd likely be either in Fedora or GNOME - but no host schools yet
19:18:35 <mchua> Tirath (one of the POSSE APAC profs) wants to do one in Malaysia with the PECM network
19:18:50 <alolita> mchua: a couple of host schools interested here are usf and ucsf
19:19:10 <mchua> humph: would Mozilla be interested in another (all-Mozilla) POSSE this summer?
19:19:33 <alolita> mchua: that would be pretty cool especially since their hq are here in mtn view
19:19:52 <humph> mchua: not sure.
19:20:42 <alolita> mchua: there is a lot of interest in doing firefox add-ons so that could be quite a live topic in the bay area
19:20:57 <quaid> hmm, did Blizzard move to SF?
19:20:57 <humph> note: we're doing something like this now, called JetPack for Learning
19:21:00 <humph> yes
19:21:10 <quaid> he would _rock_ to help teach a Moz POSSE here
19:21:21 <humph> he's unlikely to do it
19:21:25 <quaid> :(
19:21:36 <alolita> quaid: definitely - blizzard would be a great resource
19:21:45 * mchua notes that every POSSE needs a project - a largish project that can handle the influx of new contributors - for participants to get immersed into
19:21:54 <humph> he faces toward web developers now, that's his focus
19:22:08 <alolita> humph: ok
19:22:26 <mchua> #info every POSSE needs a large OSS project that profs can get immersed into (and have community members willing to on-board them)
19:22:38 <mchua> #info every POSSE needs a host location (usually/ideally a host university)
19:22:49 <quaid> humph: well, not sure if that knocks him out unless he doesn't want to :)
19:23:18 <biertie> mchua: is fedora a big project? ;-)
19:23:22 * humph finds that blizzard is hard to pull into education stuff--he's too busy
19:23:30 <quaid> ok
19:23:37 <mchua> biertie: just a bit. ;)
19:23:51 <alolita> mchua: yes - agreed - having a project for projects to immerse into (well at least one project) is key for continuing interest
19:24:26 <mchua> alolita: I'd like to stick with a One Project Per POSSE assumption at least for this summer
19:24:32 <alolita> we can ask blizzard to be an advisor - doesn't have to do the actual work
19:24:48 <mchua> this was ctyler's suggestion for POSSE APAC after the first one in July where we tried to do 2 projects (Moz, Fedora) simultaneously
19:24:56 <alolita> mchua: i think that's a good strategy
19:25:12 <alolita> mchua: its more focused and would like have more results
19:25:16 <mchua> that having been said, one could do multiple POSSEs in CA. ;)
19:25:24 <mchua> ...which actually would not be a bad idea
19:25:34 <alolita> sure... if we had a good team here :-)
19:26:15 <mchua> one of the reqs for POSSE instructors we discussed was that they be prior POSSE attendees (nothing set, though)
19:26:25 <mchua> (but I think it's a good idea - you need to know what the experience you're teaching is)
19:26:35 <alolita> mchua: i think fedora would be a good project to start with
19:26:49 <mchua> so if we flew someone (probably me) to CA to do the first one, then that gives you a good team in CA who can teach POSSEs there forevermore
19:27:14 <mchua> (me + alolita + Karsten + other Fedora folks in the area)
19:27:20 <mchua> but I'm sidetracking a bit
19:27:27 <alolita> definitely - that would greatly help in building and sustaining local energy :-)
19:27:33 * quaid notes that you all weren't POSSE instructors before you started :)
19:27:59 <mchua> any other POSSEs anyone knows of? because otherwise I think we've covered #1 and #2 and should skip to #3 and go through alolita's questions since we're kinda doing that already ;)
19:28:07 <alolita> ***alolita agrees with quaid - especially as we go into new locations
19:28:49 <quaid> yeah, I'm in favor of picking a school that is interested and going with it - UCSF or USF - isn't the latter where the OLPC user group is from?
19:29:10 <alolita> the olpc group is from ucsf
19:29:21 <alolita> sorry - its from sfsu
19:29:23 <mchua> quaid: ctyler and humph have taught the class before (it's based on one of their semesterlong courses at Seneca, iirc), and I was at the first one and helped get it together, so I went to APAC
19:29:52 <alolita> great so we have three possibilities already to teach
19:29:58 <quaid> mchua: ah, ok
19:30:04 <mchua> quaid, alolita: I think it's important that POSSE instructors have prior POSSE experience because it's not really a syllabus that can be taught, it's more like an experience that... needs to be lived.
19:30:26 <biertie> mchua: +1
19:30:44 * quaid must be naive in his confidence :D
19:30:54 <alolita> mchua: true  especially to get a project perspective
19:30:58 <mchua> quaid, alolita: it's *really* hard to describe unless you've been to one
19:31:12 <mchua> (which is why, until we figure out how to do that, the way you learn to run one is to go to one. ;)
19:31:32 <alolita> mchua: did you teach at the first posse in nc
19:31:42 <mchua> quaid, alolita: the same way it's sometimes hard to describe what being an open source contributor is like to someone who's new to it - there's only so much you can sit down and tell them, it's not something you can write in a textbook.
19:32:07 <mchua> alolita: ctyler and humph taught the first POSSE; I was one of the organizers and was there helping out for the week, but they ran the classroom
19:32:33 <mchua> alolita: I taught in Singapore
19:32:39 <mchua> (and didn't document it very well)
19:32:42 <alolita> mchua: did you find a difference between the first and second posse due to geography, as well as level of understanding and interest of participants - as an organizer
19:33:25 <quaid> #idea Each POSSE needs an 'organizer' who is not also instructing, so they can be documenting and backchanneling.
19:33:36 <mchua> alolita: yes, but it's hard to tell what was due to language and what was due to other things
19:33:43 <mchua> quaid: +1
19:33:49 <alolita> quaid: good suggestion +1
19:33:53 <biertie> quaid: true
19:34:12 <biertie> but every summit / conf / ... should have that :)
19:34:22 * quaid . o O {a grad student would make a good organizer victim}
19:34:42 <biertie> >:(
19:34:49 * biertie is still a grad student
19:34:59 <alolita> i would think that for the first 6 posses there should be some overlap in organizers and instructors so that there is a team
19:36:41 <biertie> I think we should be able to fall back on some people, but I don't think it's necessary to have people from other posse's on the team..
19:37:39 <alolita> biertie: the consistency in quality of teaching can only come from having a trained team - at least one person is required (in my experience) :-)
19:38:22 <mchua> That was the intent with the "POSSE instructors should be prior POSSE attendees" thing
19:39:57 <alolita> in one sense it is easier to teach the class than ensure participation from attendees in the long run - so there is a short term part - where we organize to implement posse and then the long term part - where we help ensure that there are successful results from at least some of the participants (attendees)
19:40:41 <alolita> mchua: +1
19:41:53 <alolita> the bay area posse could occur at the earliest during spring break or in early summer (May)
19:42:04 <alolita> due to availability and faculty commitments
19:42:20 <quaid> sounds reasonable
19:42:41 <biertie> the S in POSSE is for summer, right? ;-)
19:43:00 <quaid> sort-of
19:43:00 <alolita> :-)
19:44:43 <mchua> It was originally, but since there's interest in running it year-round (and that makes sense) we may change that.
19:45:10 <biertie> :D
19:45:58 <alolita> mchua: well POSSE will become our acronym so we can do it any time all year :-)
19:46:58 <biertie> but I guess it will be the earliest in early summer for emea
19:47:58 <alolita> so what I'm working on as the first step for the Bay Area Fedora POSSE - is to get as many teachers involved from the various schools to understand what POSSE is all about and get their feedback as well as their participation
19:48:31 <alolita> i already have a venue interest (as I had mentioned) from USF and possibly SFSU
19:49:35 <quaid> +1 for picking one and going with it; we can add "more" POSSE occurences later of the interest grows
19:49:50 <quaid> s/of the interest/as the interest/
19:50:30 <alolita> what I'm hoping is that we can nail down the dates for the session to be held
19:50:45 <alolita> quaid: i agree we start with one venue and finalize it asap
19:51:42 <alolita> mchua: what kind of infrastr is reqd ? would a school lab with PCs and wi-fi or wired connectivity do? Or do we just get folks to bring their laptops?
19:51:50 <quaid> lab is best
19:51:52 <alolita> tell me more about the classroom infrastr
19:52:00 <quaid> then we can have the lab running the POSSE remix of Fedora
19:52:30 <alolita> quaid: yes i agree - is this remix somewhere i can download it from
19:52:48 <quaid> alolita: I think mchua and ctyler did one for the RDU event, but it's an ongoing need to maintain one
19:53:03 <quaid> not a big need, and I _think_ sdziallas expressed interest in helping.
19:53:16 <alolita> Lab Setup  Any POSSE must be run in a lab that provides, for each student:   Desktops or laptops running either the latest version of Fedora, or the latest POSSE remix  Ports 80, 6667, and 443 open to the world - This is what the posse page states.
19:53:22 * sdziallas looks up...
19:53:44 <sdziallas> quaid: you betcha!
19:53:47 <quaid> :D
19:54:19 <alolita> quaid: cool - i agree that we need to maintain a posse remix long-term
19:54:30 <quaid> hmm, that should include port 22
19:54:48 * quaid also thinks the VPN ports would be good, too :)
19:54:56 <alolita> quaid: agreed
19:55:13 <quaid> alolita: we won't have any problem having one ready for the event; we can work out on-list what it should feature
19:55:29 * quaid . o O { POSSE desktop background! }
19:55:30 <alolita> quaid: cool :-)
19:55:38 <alolita> good idea!
19:56:24 <sdziallas> quaid: I can only server with a boot screen atm, but... yay! :)
19:56:32 <alolita> mchua, quaid: were the posse sessions videotaped - how do you analyze what could've been done better?
19:57:54 <quaid> I don't think there was video ...
20:00:38 <mchua> No video.
20:00:47 <alolita> quaid: ok - so is there some material which i can go through to understand what were blocking factors or successful from the teachers point of view in Posse 1 and Posse 2 (APAC)
20:00:47 <mchua> Not from the APAC one, anyway.
20:01:31 <mchua> The first one was taped, and the gigs and gigs of raw files are... on a hard drive if you'd like them.
20:01:58 <alolita> mchua: sorry if I'm asking too many questions - just trying to sync up with all the knowledge you guys already have :-) about posse
20:02:05 <quaid> we did get some feedback filtered from the students in APAC -- has that been included somewhere?
20:03:07 <alolita> quaid: it would be great to at least see the high level feedback from participants
20:03:52 <alolita> so i'm on #6 (execution) in my list
20:04:40 <alolita> i think we just finished #5 (successful implementation issues)
20:06:03 <alolita> how are costs for travel covered?
20:06:17 <alolita> for the participants and teachers?
20:06:31 <alolita> the participants - im assuming are local so we don't have to fly anyone in
20:07:04 <alolita> what about the teachers?
20:07:19 <alolita> can we get other sponsors? for meals etc?
20:07:42 <quaid> mchua and I should bring that back to Max Spevack, to think about budgeting for next year.
20:07:55 <mchua> alolita: sorry I'm being so slow to respond - will speed up in a moment
20:07:56 <quaid> for the past ones, Raleigh for example, I think Red Hat covered everything
20:08:07 <biertie> alolita: I'm going to companies that use linux / give linux support etc etc
20:08:14 <quaid> and that's the general idea, I think
20:08:17 <biertie> and I ask if they want to sponsor such an event
20:08:44 <biertie> because investing in teachers > investing in students > investing in people that are ready for a linux job
20:08:50 <quaid> the problem is, this isn't like a normal conference or something
20:09:01 <quaid> I think there may be something valuable lost if we have "Coffee sponsored by Google"
20:09:07 <alolita> biertie: that's a good idea - they can certainly sponsor in kind to cover certain costs like food or books
20:09:14 * quaid notes, when at certain venues, at $1000/day for coffee, you can't avoid that
20:09:29 <quaid> so, holding it at schools lets us save on a ton of the normal conference/event costs.
20:09:45 <alolita> quaid: would a university venue be able to provide free coffee - it would the organizers who bring the coffee in then :-)
20:09:58 <biertie> quaid: if I want it at my school, I would have to lobby *allot* to get some rooms for free -_-
20:10:08 <quaid> alolita: what I mean is, where we can provide our own coffee, that's a nice thing that e.g. Red Hat can budget for
20:10:43 <alolita> quaid: yes agreed
20:10:52 <quaid> we held an event at the San Jose Convention Center, and such venues have e.g. union rules that prevent you providing your own coffee, doing your own A/V, etc.
20:11:18 <quaid> I think I'd like an on-list discussion about sponsorship
20:11:33 <quaid> it feels to me like Red Hat + $school should be enough
20:12:15 <alolita> quaid: yes agreed - because we can be innovative about sponsorship - unless RHT can cover all incidental costs
20:12:29 <biertie> don't know, I think it's a good thing to have more than one sponsor
20:12:45 <alolita> sponsorship is also another way to engage more groups to help grow the POSSE brand - gets us more buzz
20:13:00 <biertie> my point exactly ;)
20:13:31 <quaid> it could also be a distraction ... for example, we need sponsoring organizations who provide people to help bring our professors on to the project
20:13:53 <quaid> this is one reason I think Google eschews sponsors for Summer of Code
20:13:58 <alolita> so for example if intel sponsors coffee and bagels that's good - intel has a large education program
20:14:17 <quaid> maybe brand dilution, but also it lets them focus "want to help? get your open source project involved"
20:14:18 <alolita> well it depends on POSSE's objectives
20:14:56 <quaid> how about we put this topic to the list for discussion?
20:15:07 * quaid knows we aren't solving it here right now anyway :)
20:15:16 <alolita> well - if we're looking at supporting one project at a time - it may make complete sense for one organization to support all costs :-)
20:16:08 <alolita> quaid: its an important item to discuss since if we do go after other organizations to get involved - it takes time and planning and we all multi-task :-)
20:16:29 <alolita> we can certainly discuss it on the list
20:16:44 <biertie> alolita: true, but supporting some important projects can convince more people to come?
20:16:58 <quaid> hmm, industry isn't the focus, though
20:17:17 <alolita> biertie: i agree with you completely :-)
20:18:07 <alolita> quaid: but industry is paying for this interface with educators - its industry's interest to get open source taught in the universities in the long run :-)
20:18:52 <biertie> alolita: +1
20:19:32 <quaid> ok, what other questions do we have?
20:19:42 <quaid> specifically about getting ready for Bay Area
20:19:50 * quaid acts all selfish :D
20:22:14 <alolita> quaid: i think we need to create some documentation for planning to include potential schools and faculty members to cover for participation, venue lock-in and assuming the first posse in the bay area is focusing on fedora - create a proposal to provide to each university to get more profs involved or interested in participating at POSSE
20:23:54 <alolita> quaid: can you help in meeting up with some of the schools after we have the proposal - like ucsc and community colleges you mentioned?
20:24:08 <quaid> alolita: definitely
20:24:23 <alolita> quaid: what kind of availability do you have
20:24:27 <quaid> ideally I can come in person up to SF as needed
20:24:47 <quaid> (or wherever)
20:25:08 <alolita> ok very cool - i'm located in south bay - san jose area
20:25:10 <quaid> I will note the next few weeks aren't so hot, but we have enough to do at remote during that time ...
20:25:44 <alolita> yes - i agree december will be mostly online - i think january onwards things will be more face-to-face
20:25:50 <quaid> OK, I live in downtown Santa Cruz; I've lately been taking the Hwy17 bus to downton SJ, then Caltrain + BART, but I can also rent a car and drive us both around :)
20:26:07 * quaid will make sure he has budget for that :D
20:26:43 <alolita> that's cool - if we can schedule meetings with various profs - then we can plan to rent a car and have mtg days :-)
20:26:54 <quaid> aye
20:27:20 * mchua reads up
20:27:45 * mchua will try to answer floods of questions really quick - sorry about the unannounced random afkness, thanks for your patience...
20:27:55 <mchua> (there are sometimes disadvantages to working in the house your parents live in)
20:28:05 <quaid> alolita: we also have Fedora's regional coordinator for the West Coast, Larry Cafiero (lcafiero), here in the SC mountains; I'm going to ping him to see if he wants to be involved (likely answer, YES)
20:28:07 <biertie> mchua: +1 ;-)
20:28:22 <alolita> quaid: excellent !
20:28:40 <alolita> mchua: +1
20:28:48 <mchua> OK. I think I can try answering them all in one fell swoop here...
20:28:48 <quaid> in fact, he is going to SFSU this Sat. for the OLPC meeting ...
20:29:05 * quaid may have his date wrong ... maybe that just happened
20:29:31 <mchua> POSSE is a TOS project - and as such is *super* infrastructurally-lightweight
20:29:49 <mchua> i.e. one of the reasons each POSSE has a host project is that the point is to put that participation in the host project
20:30:09 <mchua> with TOS as a metacommunity where professors in multiple projects can get together and talk about their shared experience of teaching open source
20:30:27 <mchua> and POSSE is sort of an on-ramp for that (it's one way to get rapidly involved in TOS-stuff)
20:31:00 <alolita> quaid: yes - i think they may have already had the olpc mtg - i know sameer verma (the prof who does the olpc stuff at sfsu) well so i can definitely coordinate - he's a ubuntu fan btw :-)
20:31:09 <mchua> RH funded the first 2 POSSEs; they weren't particularly expensive, most of the costs were because participants weren't local and we paid for housing
20:31:26 <mchua> but we want to move towards local POSSEs anyway, so that should take away the housing costs
20:31:41 <mchua> people get themselves there
20:31:45 <mchua> people get themselves housed
20:31:52 <mchua> people get themselves fed for most of the dinners
20:32:18 <mchua> (though we usually have a Sunday "get to know you" dinner and a Thursday "invite all the open source folks in the area to join us for a feast" dinner)
20:32:32 <mchua> so the budget is usually for those two meals + lunches + swag
20:32:42 <mchua> which should be <$1000
20:32:44 <mchua> (USD)
20:33:29 <mchua> and then there's whatever it takes to do travel/hotel/transit/food for the instructors
20:33:35 <biertie> I was just thinking, in europe we have the erasmus program, and I heard that a foreign prof that was at my last school was paid by that program. I should contact erasmus program about possibilities
20:33:46 <mchua> biertie: not familiar with erasmus program, can you explain more?
20:34:02 <alolita> mchua: cool - though i think doing lunches would be useful to keeping the folks at the venue - and to interact with each other
20:34:26 <mchua> alolita: though quaid and I can probably ask for budget from our team to cover our expenses for the first CA POSSE if I'm flying in to teach the first one
20:34:41 <biertie> erasmus is a program in europe that would give me some money (+- 1000euro) if I wanted to do my internship in a foreign country
20:34:42 <mchua> alolita: yep, the $1k would be for those 2 dinners + lunches M-F
20:34:48 <biertie> as long if it's in the EU
20:34:56 <alolita> mchua: cool
20:35:02 <mchua> alolita: this assumes the location costs $0 to rent
20:35:23 <alolita> mchua: yes agreed
20:35:30 <mchua> (donuts + coffee in the morning == very nice, but probably optional)
20:35:33 <biertie> but last week someone told me they sponsor lectors too, if they go for a session in a foreign country
20:35:51 <mchua> alolita: which is another reason it's important to get prof buy-in from the host location ;)
20:36:15 <mchua> alolita: infrastructure-wise, we need a room that we can use consistently - and leave our stuff in all week - with wifi
20:36:22 <alolita> mchua: yes - at least one prof has to be involved from the host location
20:36:32 <mchua> alolita: and everybody needs a computer (bring their own laptop, or have desktops set up there)
20:37:21 <mchua> alolita: for a Fedora POSSE, we'd ask everyone to install the latest release of Fedora before they arrive, and do some pre-POSSE exercises (like getting a Fedora account, etc)
20:37:28 <mchua> other projects may vary
20:38:01 <mchua> alolita: the host location needs to have networking with ssh and irc ports unblocked, too. (We, uh, forgot that for POSSE APAC, and it was a pain)
20:38:32 <mchua> alolita: as far as professor pre-event pre;
20:38:34 <mchua> prep:
20:38:36 <mchua> http://teachingopensource.org/index.php/POSSE_Pre-event_Survey
20:38:44 <mchua> is the info that's good to have
20:38:51 <alolita> mchua: cool thanks! for the link
20:39:11 <mchua> we've had people basically write app essays in the past, but should have an application form page that standardizes that more
20:39:15 <mchua> #action mchua make POSSE application form
20:39:28 * mchua is getting too much into detail here, will pull back
20:39:29 <alolita> mchua: excellent idea
20:40:00 <quaid> mchua: I added ssh port to the how-to page
20:40:05 <mchua> I would say that for POSSE planning, you want to start at least 3mo in advance, preferably a semester in advance
20:40:08 <mchua> quaid: thanks!
20:40:21 * quaid is also working on getting ALL the POSSE pages in categories
20:40:26 <mchua> alolita: so you're well on target for a late spring early summer POSSE
20:40:50 <mchua> (the POSSE planning process is fuzzy, but each time we work through it it gets less fuzzy, so... thanks for hanging in there!)
20:40:53 <mchua> quaid: you rock.
20:41:05 <mchua> alolita: the big dates to hit - counting backwards...
20:41:33 <alolita> mchua: i think it takes 4-6 months to do any open source class well :-)
20:41:44 <mchua> alolita: 2 weeks before POSSE, the final prof list should be locked down so we can start prep.
20:41:47 <mchua> (Ideally, 1 month.)
20:41:59 <alolita> so summer may work better - May is looking good
20:42:07 <mchua> alolita: :) I think it depends on the definition of "open source class," but yeah, good classes take a lot of time to prep for
20:42:29 <mchua> alolita: Yeah, I think it will depend on the academic calendars more than anything else.
20:42:40 <mchua> alolita: if we schedule it during finals week, we'll probably get 2 profs.
20:42:54 <mchua> alolita: oh! here we go
20:42:56 <mchua> http://teachingopensource.org/index.php/HOWTO_plan_a_POSSE#timeline
20:42:56 <alolita> mchua: academic calendars are what are driving the dates for sure -
20:43:18 <mchua> alolita: those are minimum lead times imo. for ideal, multiply by 2.
20:43:42 <alolita> mchua: thanks !
20:44:17 <mchua> alolita: did you want to try shooting for multiple POSSEs in CA (maybe 2 is a good number, or 3?) this summer
20:44:34 <mchua> with the idea that the first one will be where the instructors for #2 and #3 get trained?
20:44:58 <mchua> because if that's the case, then I think quaid and I have a pretty strong argument for throwing *lots* of resources into the first one
20:45:25 <quaid> I _think_ we can do multiple, say 2
20:45:28 <alolita> agreed - 2 or 3 is a good number - i definitely think fedora is the first project ; maybe mozilla would like to do the second iteration?
20:45:37 <mchua> (well, comparatively lots - or asking "hey, can we handle food/swag/instructor-expenses for this one?")
20:45:40 <alolita> quaid: 2 is a good number
20:45:43 <quaid> e.g. once we get the right person at Berkeley, I'm sure they'll be good, etc.
20:45:57 <quaid> I'm going to try HARD for UCSC because I'm lazy
20:46:10 <mchua> ok, so tentative target 2
20:46:17 <quaid> yes, first = training
20:46:28 <quaid> so anyone who leads any following must be in that first, that's a good rhythm
20:46:30 * mchua nods
20:46:32 <alolita> quaid: UCSC has a great faculty :-) so good to try there definitely
20:46:39 <mchua> my goal then is to not be involved in any way shape or form in the second :)
20:47:10 <mchua> (I mean, I'll be around for questions online and such, but I shouldn't have to actually be there, or figuring out details, etc)
20:47:18 <alolita> mchua: gosh! we were thinking we'd get you in california twice ! :-)
20:47:22 * mchua grins
20:47:26 <mchua> I wouldn't mind that, mind you ;)
20:47:41 <mchua> I /could/ be the documentation ninja for the 2nd
20:47:44 <alolita> especially in may and june - its fantastic weather :-))
20:47:56 <quaid> I'll have to substituve; what I don't know about academia I make up for in FLOSS savvy :D
20:48:07 <mchua> esp. if they're close enough together that I can lump them into the same CA trip
20:48:11 <quaid> s/I'll/If I/
20:48:27 <alolita> mchua: good thinking!
20:48:48 <mchua> (if the planets align, I can fly to CA for POSSE #1, go from there to WA for a Plone POSSE, then back down to CA to doc-ninja POSSE #2, then head back east)
20:49:08 <biertie> it would be cool to have you over in europe too ;-)
20:49:14 <alolita> let's do some comparative analysis on school exam schedules and set up the dates
20:49:24 * mchua nods
20:49:32 <mchua> oh - should have posted these before
20:49:37 <mchua> but my big 4 POSSE goals this summer:
20:49:38 <mchua> * a POSSE I don't run at all
20:49:38 <mchua> * a POSSE outside North America
20:49:38 <mchua> * a POSSE on not-Fedora
20:49:39 <mchua> * a POSSE on not-computer-science
20:49:54 <mchua> biertie: you folks are the 2nd ;)
20:50:09 <quaid> ooh, yeah, SF design institute .. what's that called?
20:50:15 <alolita> i like a POSSE on not computer-science - sounds like a great idea
20:50:17 <quaid> I think I know an instructor there
20:50:30 <biertie> alolita: like: design?
20:50:48 <alolita> biertie: yes - that works :-)
20:50:51 <biertie> maybe we can have one big posse with a programmer track, design track, and cooking track? :D
20:51:12 <biertie> (the 3rd example is stupid, ok)
20:51:19 <alolita> biertie: cool idea :-D
20:51:29 <alolita> but would require lot more funding
20:51:38 <biertie> but I don't see allot of small posse's happen in europe, that's my point
20:51:46 <alolita> one instructor is not enough - would need at least 3-4 profs
20:51:52 <biertie> certainly when we just start with it, I would focus on one good one
20:51:58 <alolita> biertie: you have a good point
20:52:18 <alolita> at least a couple of projects brings in diversity
20:52:19 <mchua> biertie: I think that's a good idea for a location and a group of folks who have already run their first POSSE ;)
20:52:47 <mchua> biertie: for instance, if humph and ctyler were to run another POSSE, I'd be all for going "experiment with things!" cause they have the general notion of POSSE stuff down
20:53:59 <alolita> mchua: in apac posse - did harish also do some classes
20:54:20 <mchua> alolita: he taught some sessions
20:54:28 <mchua> well, topics
20:54:31 <quaid> we had guests, too :)
20:54:36 <mchua> alolita: they're not really carved up into "classes"
20:54:38 <mchua> quaid: yep
20:54:53 <mchua> alolita: quaid popped in on IRC mid-week and did a "let us do Docs!" session
20:54:59 <mchua> pretty much spontaneously
20:55:12 <mchua> (i.e. it wasn't on the curriculum beforehand, I had no idea he was going to do that, but it worked out really well)
20:55:15 <alolita> mchua: cool - so we could have some guest teachers for special topics?
20:55:17 <mchua> and that's what a POSSE is like
20:55:30 <mchua> alolita: absolutely, did you have anyone in particular in mind?
20:55:49 <alolita> mchua, quaid: good idea! to do a lets do a docs session
20:56:17 <mchua> So, one of the really key things, imo, is that the schedule is *extremely flexible*
20:56:36 <alolita> mchua: well there are quite a few linux gurus here in the valley - esp we could tap into the linux foundation for providing one or two luminaries
20:56:55 <mchua> a docs session is a great idea - and maybe we should put that on the list - but exactly when it'll fall and what it'll cover might be something we don't know until literally right before it starts
20:57:15 <alolita> mchua: agreed
20:57:29 <mchua> hard-scheduling 2-4 things during the course of the week is probably good too, since it gives us solid things to improvise around
20:57:42 <mchua> alolita: and I'd likely schedule the Linux Foundation Gurus for that
20:58:03 <mchua> but we want the profs to spend most of their time swimming in the ocean - and if the LFGs can do that, *awesome*
20:58:35 <mchua> (for instance, if one of them is familiar with... I dunno, kernel wizardry, and can guide people through that in Fedora, sweetness, etc.)
20:58:36 <alolita> mchua: cool - i'll talk to jim zemlin and see what we can do :-)
20:58:41 <mchua> alolita: w00t
20:59:14 <mchua> or if someone's superfamiliar with the history of open source licensing, and can look at fedora-legal for some recent examples...
20:59:18 <alolita> mchua: we also talked about sponsorship models
20:59:37 <mchua> basically, sessions should pull people into the project, not temporarily take them out of it to listen to a Disembodied Lecture
20:59:40 <mchua> alolita: ayup
20:59:41 <alolita> yes - we can pull in OSI's general counsel for doing a session :-)
20:59:47 <mchua> alolita: oh that would be AWESOME.
21:00:19 <mchua> alolita: one thing I'd love to see is a session on how to explain "open source" to people - since these profs are basically going to be ambassadors back to the ivory tower
21:00:35 <mchua> alolita: I figure that's something you folks will be extremely good at ;)
21:00:45 <mchua> alolita: but, ah, sponsorship
21:00:48 <alolita> mchua: agreed - that's very important
21:01:22 <mchua> I think sponsorship is a Very Good Thing.
21:01:23 <alolita> mchua: what has been the posse strategy on sponsorships - since rht has provided such an excellent start
21:01:58 <mchua> my thinking: "The less RHT has to pay for POSSEs, the better"
21:02:20 <mchua> obviously if a RHT person is going to be teaching, we can probably cover at least some of their expenses, at least for this summer
21:02:47 <mchua> (for instance, I don't think it's unreasonable to ask for my expenses and Karsten's to be covered for at least the first CA POSSE)
21:02:54 <alolita> mchua: yes - RHT is the initial bootstrap for POSSE - couldn't have been done otherwise
21:03:12 <alolita> it also depends on the project focus -
21:03:31 <mchua> but I don't really care who sponsors what for a POSSE - I think sometimes it'll be the school, sometimes it'll be the project, sometimes it'll be a group or company that wants to help the school or project
21:03:35 <mchua> alolita: yep
21:03:42 <alolita> if mozilla participates then we could ask the moz folks to contribute in various ways
21:04:38 * mchua nods
21:05:14 <mchua> I think asking the school to cover the location/networking, asking the project to cover swag and possible some infrastructure (if VMs need to be made, etc)
21:05:17 <alolita> we can do in-kind sponsorships - i.e just as RHT supports the instructors, get Intel to do lunch, LF to support etc
21:05:35 <mchua> alolita: +1 - I think that's a good idea
21:05:59 <biertie> alolita: yep, we're doing that for barcampGhent too :)
21:06:10 <alolita> we should itemize what areas we can seek sponsorship for in our Bay-POSSE planning document - and then see who can support what
21:06:17 * mchua nods
21:06:17 <alolita> biertie: cool!
21:06:30 <mchua> alolita: I think it's time to start a POSSE $some_cool_name page
21:06:35 * quaid is back
21:06:36 <mchua> strawmen:
21:06:53 <alolita> mchua: cool idea!
21:06:57 <mchua> POSSE California #1: sometime-in-may, CS focus, Mel teaching, Alolita, Karsten, $some_professor(s) learning how to teach
21:07:00 <mchua> POSSE California #2: sometime-after-may, Design focus, Alolita, Karsten, $some_professor(s) teaching, possibly Mo Duffy too - Mel documenting like a maniac
21:07:20 <mchua> (if Mo comes out to the 2nd CA POSSE, she and I will probably have done one up in Boston before then)
21:07:29 <mchua> as per the "go to a POSSE before you teach one" thing
21:09:01 <biertie> maybe stupid question, but wouldn't it be smart to combine those 2 posse's?
21:09:05 <mchua> alolita: how well does that match up with what you have in mind?
21:09:12 <mchua> biertie: there are no stupid questions ;)
21:09:33 <mchua> biertie: I think that since there's going to be a lot of "learn how to teach a POSSE!" "wow, lots of people new to open source contrib!" stuff going on
21:09:34 <biertie> there are!
21:09:43 <mchua> biertie: it's probably a good idea to keep it as simple as possible
21:09:52 <mchua> biertie: i.e. one project per POSSE, one topic per POSSE
21:10:16 <mchua> biertie: also, part of the reason behind having 2 separate POSSEs is so there will be a POSSE run *without me*
21:10:17 <alolita> mchua: i think biertie has a good point for international POSSEs since it is hard to gather everyone together for multiple sessions
21:10:20 <biertie> mchua: how do you fill x days about 'how to teach open source'
21:10:47 <mchua> biertie: for the lots-of-detail part, see http://teachingopensource.org/index.php/POSSE_Blogs#Inaugural_POSSE.2C_July_2009
21:11:05 <alolita> i.e if we can do this is Europe this summer and in India - it is practical to do one POSSE - may be hard to do two or three
21:11:11 <mchua> biertie: for the shorter version, see http://teachingopensource.org/index.php/POSSE_2009#Topic_Schedule
21:11:22 <biertie> mchua: details are better ;-) thx
21:11:33 <mchua> alolita: nonono, it *shouldn't* have to be an international event
21:11:52 <mchua> the fact that we had so many non-local participants in the first two is, in part, a FAIL rather than a plus
21:11:53 <alolita> mchua: for California - your suggestion of CA 1 and CA 2 works !
21:12:24 <biertie> RPM Packaging Basics  > if you are a hardcore designer, you don't care about this (I think)
21:12:28 <quaid> yes, we want POSSE to be very local, I think; maybe even something run regularly.
21:12:35 <alolita> mchua: sorry for not being clear - by "international" i meant in countries other than North America
21:13:16 <mchua> biertie: right, but I'm pretty sure we'll have things not on that curriculum that the design faculty will have to learn
21:13:32 <mchua> biertie: how to use a lot of the open source software stuff, for example - if they're used to photoshop, learn gimp, etc
21:13:56 <mchua> biertie: how to look at code - not to write it, but how to look at it and not be 100% lost
21:14:05 <mchua> (not that they will be, but... making sure)
21:14:20 <alolita> mchua: i would think that there would be some common sessions and some for each track? (development, design etc)
21:14:24 <biertie> hehe ok :)
21:14:40 <biertie> alolita: that's my suggestion too
21:15:04 <quaid> regarding sponsorship ...
21:15:20 <quaid> I'd like to i) talk with Max about RHT's intention here, and ii) take that to the list after we have that resolved.
21:16:01 <quaid> with my Big Red Fedora on, I'm thinking, "There is value to tightly controlling the POSSE brand through one sponsorship, etc." -- being the steward, so to speak.
21:16:04 <alolita> quaid: yes - agreed - clarification about RHT's focus points is important
21:16:13 <mchua> alolita: I think that all POSSEs will include some common topics - no matter what you do in whatever project, you're *probably* going to have to learn to use a wiki, mailing lists, IRC, some bug tracker or other
21:16:33 <alolita> mchua: yes
21:17:17 <mchua> quaid: +1
21:17:29 <quaid> right
21:17:34 <biertie> mchua: but I was thinking about maybe 2 day's general stuff everybody should hear, and then 2 days more specific tracks...
21:17:37 <quaid> POSSE teaches how we do open source _right_now_
21:18:08 <mchua> alolita: re international POSSEs - do you think we'll have our hands full with 2 CA POSSEs this summer and should look at India in March or April when the CA POSSEs are more planned out?
21:18:25 <mchua> or try to fit a 3rd in (not sure what your bandwidth is looking like this summer)?
21:18:38 <alolita> mchua: sorry for not being clear in that sentence - India would be in the fall 2010
21:18:45 <alolita> needs more planning
21:19:38 <mchua> alolita: oh, okay, cool, good to know :)
21:20:09 <mchua> as long as people keep on talking about POSSE planning on the TOS list, we'll see everything that's going on.
21:20:36 <alolita> venue would be indian institute of technology (iit) bombay :-)
21:20:41 <mchua> alolita: so if we're starting with the 2 Cali POSSEs for the summmer... what do you need in terms of resources/howto in order to get started?
21:20:44 <mchua> Ooh. That would be very cool.
21:21:10 <alolita> Yup :-)
21:23:55 <alolita> As quaid and I were discussing earlier - we need to work on a planning document to add details about what we need to do - we also need to create a proposal document - as an invitation to each college / dept of computer science or MIS to get profs to participate in the program. We need a sponsorship document - with our guidelines and what we can do
21:24:08 <mchua> alolita: from my side, I think the first thing on your end is to figure out dates and locations, so we can figure out scheduling - and from our side working out the RHT-sponsorship-question-mark? stuff quaid mentioned, and seeing what kind of resources we can put towards that so we know what else we need to fill in.
21:24:13 * mchua nods
21:24:20 <mchua> okay, so http://teachingopensource.org/index.php/HOWTO_plan_a_POSSE
21:24:23 <mchua> needs a lot more work.
21:25:09 * mchua throws logs into http://teachingopensource.org/index.php/Talk:HOWTO_plan_a_POSSE temporarily
21:25:25 <alolita> yes - agreed - i think the dates are driven by exam schedules as well as the venue - so that should be resolved as soon as possible
21:26:29 <alolita> mchua: question: should we just create another page on tos for the planning doc?
21:26:35 <mchua> alolita: ok - do you want to touch base in a week (or possibly 2, because of Thanksgiving) and come back with those answers, or as close as we can get?
21:26:51 <mchua> alolita: is there an outline different from http://teachingopensource.org/index.php/HOWTO_plan_a_POSSE you'd like filled in?
21:27:33 <mchua> alolita: if you have a rough idea of what you'd like in that doc, and what questions you need answered (at least now) I can take that on as a task before we get together again, sprinting on it early next week before the holidays hit.
21:27:38 * quaid looks out the window at http://www.wunderground.com/radar/radblast.asp?ID=MUX&region=c1&lat=37.04412079&lon=-122.09850311&label=Santa%20Cruz%2c%20CA
21:27:54 <mchua> quaid: SO JEALOUS
21:28:06 <quaid> hmm, that's pretty wet
21:28:15 <alolita> mchua: cool - i would recommend that another page be created for planning details for CA POSSE
21:29:04 <alolita> since much of the info would be specific to the CA POSSEs
21:29:38 <quaid> [[Category:POSSE CA 2010 planning]]
21:29:40 <quaid> pls
21:29:50 <mchua> alolita: any particular name you'd like?
21:29:53 <alolita> and let's definitely touch base in two weeks - would Dec 3 (thursday) would for you and quaid?
21:30:03 <mchua> alolita: works for me.
21:30:14 <mchua> biertie: (thanks for being so patient! we'll get to emea in a moment)
21:30:16 <quaid> hmm, when is the IDEA 2009?
21:30:38 <alolita> mchua: POSSE California 1 and POSSE California 2 work for me
21:31:06 <quaid> just make sure the page names are unique, include spaces, and such
21:31:33 <alolita> CA could be Canada too :-)
21:32:00 <alolita> quaid: does dec 3 work for you?
21:32:01 <quaid> yep, good point
21:32:12 <quaid> one sec, let me look at something
21:32:53 <quaid> ah, OK, Big Ideas Fest is the following week
21:32:56 <quaid> yeah, 3 Dec is OK with me
21:33:08 <mchua> POSSE California {CS, Design}?
21:33:18 * mchua noting that wiki page names can be moved if needed
21:33:27 <alolita> mchua: that works!
21:33:39 <mchua> http://teachingopensource.org/index.php/POSSE#Events
21:33:41 <quaid> put [[Category:POSSE planning]] in them
21:34:36 <alolita> quaid: that's great - Dec 3 for our next irc then!
21:35:12 <mchua> alolita: same time? you work on dates/locations, we'll work on sponsorship?
21:35:25 <alolita> mchua: i will start adding info/details to the POSSE California CS page then.
21:35:37 <mchua> alolita: also, if there's a particular outline/list-of-questions you'd like filled in for the planning doc, let me know
21:35:43 * quaid has to bail now to go pick up folks caught in the rain
21:35:46 <alolita> mchua: yes - 11am PST works for me -
21:35:55 <quaid> I'll catch up on list; I should be fairly wide open on that Thu (now that soccer season is done)
21:36:11 <alolita> mchua: yes - will do :-)
21:36:28 <mchua> alolita, quaid: I think we've got plenty of room to run, and are flexible/comfortable enough to push back on each other when we need to
21:36:40 <alolita> quaid: ok - thanks so much for being on the call - this is exciting :-)
21:36:49 <mchua> alolita: I'll take another shot at it early next week, but the things I do may or may not be the things you need, and I want to make sure they are
21:37:06 <mchua> alolita: quaid: thanks for staying through a marathon meeting :)
21:37:11 <mchua> the next one should be shorter
21:37:15 <alolita> mchua: yes i agree - we should be able to do some cool stuff!
21:37:16 <mchua> biertie: still around?
21:37:42 <alolita> mchua: it was a very useful meeting !
21:37:47 <biertie> mchua: yes
21:38:05 <biertie> mchua: I've just been setting up a wiki page :)
21:38:42 <alolita> thanks again - and i'll phase into other work now - but stay tuned to chip in when I can
21:39:08 * mchua nods
21:39:11 <mchua> biertie: rockin'
21:39:13 <mchua> biertie: EMEA time?
21:39:16 <alolita> biertie: nice to meet you !
21:39:36 <biertie> mchua: it's now 10:38pm :)
21:39:48 <biertie> alolita: hi! ;-)
21:40:06 <mchua> biertie, alolita, quaid: I'll send (and summarize, for sanity) these minutes to the list, btw, so no worries
21:40:17 <mchua> biertie: :P
21:40:29 <mchua> biertie: ok, so... POSSE EMEA - what are you thinking?
21:40:33 <alolita> mchua: many thanks again ! Bye!
21:40:38 <biertie> big ;-)
21:40:39 <mchua> #topic POSSE EMEA
21:40:55 <mchua> biertie: Project? Location? Focus?
21:40:56 <biertie> so, Jan told me he had 2 cities were he wanted to hold it
21:41:12 <biertie> munchen <germany>
21:41:22 <biertie> or amman <Jordan>
21:41:40 <biertie> I think Munchen would be better, (price to get professors over?)
21:41:57 <biertie> but Jan told me something about amman wanted to be the center hub for open source in middle east
21:42:31 <mchua> biertie: so think about this in terms of a, say... 2-year POSSE in EMEA plan
21:43:00 <biertie> mchua: so, one posse in 2 years? .check
21:43:04 <biertie> and realistic
21:43:24 <biertie> but I think we should start off with a bigger posse
21:43:33 <mchua> biertie: I think it's a reasonable goal to say "let's find all the professors who are interested, right now, in POSSEs in their home institutions"
21:43:48 <biertie> and then the next step would be getting smaller, and more posses
21:43:51 <mchua> biertie: and target that 2 years from now, all those professors (if they so still choose) will be able to run them
21:43:54 <mchua> biertie: why start with big?
21:44:01 <mchua> biertie: I'd actually think the opposite
21:44:34 <mchua> biertie: also, language - would everyone (at least for the first EMEA POSSE) be speaking English?
21:44:38 <biertie> well, if allot of people can see how things go, they can help people start a posse in their own region?
21:44:46 <biertie> where emea is not a region anymore
21:44:56 <biertie> yes, english isn't a problem
21:45:05 <biertie> you don't get a professor by being stupid ;-)
21:45:07 <mchua> biertie: the two biggest problems we had at POSSE APAC were (1) too many people in the beginning, and (2) language barriers
21:45:29 <mchua> biertie: people are smart in non-English languages too, so I don't want to assume :)
21:45:49 <biertie> I mean, my native language is dutch
21:45:51 <mchua> biertie: POSSE is one of those things that needs a pretty high instructor/student ratio
21:45:55 <biertie> and half of my courses are in english
21:45:57 <biertie> ;-)
21:45:59 <mchua> 1 instructor to 5 students is about right
21:46:20 <mchua> biertie: (see, I wish America had that attitude towards languages more, but no...)
21:46:25 <biertie> ach, so there should be students at the event too?
21:46:34 <mchua> biertie: students = the professors who are learning
21:46:40 <mchua> biertie: sorry I wasn't being clear on that
21:46:52 <mchua> biertie: instructor == what Harish and I did in Singapore
21:47:02 <mchua> biertie: (and what Chris and Dave did in Raleigh)
21:47:20 <biertie> I am a traditional student, so I thought about one contributor (can be student) that talks to 50 professors or so about how to do things
21:47:26 <biertie> but it's more hands on then?
21:47:52 <mchua> biertie: yes. have you ever taken a studio art course?
21:47:55 <ojwb> wow, a lot of activity here suddenly!
21:48:00 <mchua> ojwb: :)
21:48:02 <mchua> ojwb: POSSE plannin'
21:48:28 * ojwb decides it's time to go and find out what a POSSE is...
21:48:38 <mchua> ojwb: http://teachingopensource.org/index.php/POSSE
21:48:56 <mchua> ojwb: it's a bootcamp for professors who want to get their classes involved in open source contribution
21:49:07 <biertie> mchua: nope
21:49:15 <mchua> ojwb: a one-week immersion in an open source project so the profs get themselves into an open source community and grok what the experience is like
21:49:34 <biertie> but ok, I get the concept now
21:49:48 <biertie> and I start to think that there won't be any students at my school :P
21:49:50 <mchua> ojwb: because we got a lot of professors saying "oh, I'd love to teach my students open source development... uh, how do I do that?"
21:50:07 <ojwb> I'd got a rough idea - just looking at the details
21:50:34 <mchua> biertie: We really need to get a film crew in to shoot a nice 5-15m "this is a POSSE" vid
21:50:41 <mchua> at some point
21:50:59 <biertie> indeed! ;-)
21:51:48 <biertie> but ok, now I know what you mean
21:51:55 <biertie> and also, what you mean with start small
21:52:08 <biertie> getting students on one line can be hard :(
21:52:09 <mchua> biertie: out of curiosity, what were you thinking before?
21:52:24 <mchua> biertie: yeah, the hard part about the week is that it's really a paradigm shift
21:52:32 <mchua> and there's no way to rote-learn that, or put it in a syllabus
21:52:48 <biertie> well, I was more thinking about
21:52:53 <mchua> and the professors tend to come not looking for that paradigm shift, but expecting to go through nice structured lectures
21:52:58 <biertie> ok, I'll show you how to use bugzilla (or something)
21:53:14 <biertie> and I have my projector, and show some things
21:53:36 <biertie> and then 20 or 30 professors in front me, where I'm saying: ok, so now I want you to do x and y
21:53:37 <mchua> (it's as if someone showed up in #fedora-something and said "hey, I would like to participate. Where is the textbook and the 2-semester course on how to Do Fedora Stuff?")
21:53:43 <biertie> if you have any questions, you can ask me
21:53:48 <mchua> biertie: ahhhhhh
21:53:53 <biertie> like a real lab at my school :)
21:53:56 <mchua> biertie: So... (okay, and this might get confusing)
21:53:59 <mchua> biertie: ...so there's some of that
21:54:09 <mchua> biertie: but it's... backwards
21:54:18 <mchua> biertie: like... hrm. *example!*
21:54:32 <mchua> biertie: quaid walked people through an example of how to do some Docs stuff
21:54:38 <mchua> but the way that came about wasn't that we had it on our syllabus
21:54:45 <mchua> the profs were poking around the wiki
21:54:54 <mchua> and some of them happened to comment on documentation
21:54:58 <mchua> and I went "oh, docs?"
21:55:02 <mchua> and they went "oh yeah docs"
21:55:05 <mchua> and started asking questions
21:55:11 <mchua> and I went "uh, uh... wiki page is here"
21:55:23 <mchua> and went on IRC and pinged Karsten
21:55:43 <mchua> and said (to the class) "let's figure out what we want to do today, did you want to do docs today?"
21:55:46 <mchua> "yeah"
21:55:50 <mchua> and Karsten said he'd come and do docs
21:55:57 <mchua> and *that's* how we had the docs lesson
21:56:12 <mchua> (and I'm pretty sure he figured out "the lesson" all of 5 minutes in advance)
21:56:37 <mchua> (and interspersed with his teaching of the docs stuff were comments on how he was playing a board game with his kids, or reading them a bedtime story, or something)
21:56:39 <biertie> hmm, ok
21:56:52 <mchua> biertie: so when I say "highly improvisational," I mean it :)
21:57:00 <mchua> because that's how things happen in open source
21:57:02 <biertie> I don't like anarchy :(
21:57:04 <mchua> (a lot of times, anyway)
21:57:16 <mchua> it's not anarchy
21:57:20 <mchua> it's...
21:57:35 <mchua> biertie: another analogy - were you ever a boy scout?
21:57:41 <biertie> no
21:57:46 <biertie> I am utterly boring!
21:57:47 <mchua> or on a wilderness expedition with a guide
21:57:49 <mchua> biertie: :)
21:58:15 <biertie> I'm in a youth group now
21:58:26 <biertie> and we drink beer ;-)
21:58:30 <biertie> in an organised way!
21:58:35 <mchua> biertie: so imagine a group of scouts going out into the forest with their troop leader - the point is not that the troop leader teaches the boys how to get through those exact woods
21:58:46 <mchua> but that the troop leader knows how to get through a forest - any forest
21:58:47 <biertie> if I have a project, I set up a road map, and we stick +- to it :P
21:58:57 <mchua> and by going through the forest, the boys will learn to get themselves through any other forest
21:59:28 <mchua> it's not anarchy; the troop leader leads, but he leads the improvisation, and the response to the unknown.
21:59:59 <biertie> but doesn't normal lessons do that to? -if you're smart enough to see the concepts anyway-
22:00:11 <biertie> while that isn't spontanious
22:00:24 <mchua> there are certain skills (how to start a fire, how to pitch a tent) he knows the boys will have to learn, and so he teaches them, but in context (ok, we need to set up camp now. here, I'll show you how to pitch a tent)
22:01:42 <mchua> biertie: There's a balance - I'm talking on the far end of the improv spectrum right now because in my experience, professors (and students, too) tend to think way over on the other side of being very planned.
22:02:22 <biertie> true
22:02:33 <biertie> but a flexibel planning is just handy :)
22:02:36 <mchua> biertie: and the first day or two is usually *really* uncomfortable
22:02:49 <mchua> biertie: I think "flexible planning" is a good term for it.
22:02:49 <biertie> I can imagine
22:02:59 <mchua> biertie: (as both sides adjust)
22:03:03 <biertie> but when I have to organise it, I better get how things are going ;)
22:03:17 <mchua> biertie: I usually use the phrase "plan to improvise" - you need a lot of preparation to be able to move freely.
22:04:17 <biertie> hehe
22:04:40 <biertie> so, if I want to have the fedora project (and maybe another big project)
22:04:49 <mchua> biertie: so, POSSE organizers and POSSE instuctors can be (and really, should be) different people
22:05:06 <mchua> I'd say that during the first POSSE, Greg and I were the organizers, and Chris and Dave were the instructors
22:05:09 <biertie> we have to get *allot* of contributors over too
22:05:25 <mchua> we did stuff like "is there food? let's book hotel rooms! when are people flying in? do we have wifi?"
22:05:30 <mchua> and they taught
22:06:01 <mchua> for the POSSE in Singapore, Alan and Jasmine organized ("when will the reporters come?" "let us make dinner reservations") and Harish and I taught
22:07:12 <biertie> uhu
22:07:28 <mchua> biertie: POSSE *organizers* can be first-time POSSE attendees
22:07:28 <biertie> so, what do you think about different tracks?
22:07:36 <mchua> biertie: POSSE *instructors* need to have been to one before
22:07:59 <biertie> so, you have to come over ;-)
22:08:00 <mchua> biertie: not for the first one in EMEA - not this summer
22:08:05 <mchua> biertie: good target for the 2nd or 3rd
22:08:19 <mchua> biertie: (possibly - I'm curious whether you'll still think it's a good idea after the first ;)
22:08:40 <biertie> maybe I just want to kill myself then ;-)
22:09:08 <biertie> but why wouldn't that be a good idea?
22:09:12 <mchua> biertie: I need to see how much I can travel where, but I'm hoping to be in EMEA for a Plone POSSE anyway.
22:09:42 <mchua> biertie: if you were teaching a foreign language class, would you try to teach two classes two different languages at the same time?
22:10:03 <mchua> biertie: even if they were pretty similar languages - say Spanish and Italian, which share a lot of grammar (as I understand it)
22:10:12 <mchua> and could therefore hypothetically have some shared lectures?
22:10:22 <biertie> well, point me one professor that doesn't speak english?
22:10:28 <biertie> (in europe)
22:10:43 <mchua> biertie: I'm not talking about English fluency; I don't doubt that at all.
22:10:57 <biertie> why not a Fedora track, and a Plone track?
22:11:14 <biertie> hey, I don't speak perfecht english either
22:11:21 <biertie> and still I manage to survive ;-)
22:12:03 <biertie> yesterday I was at a showcase organized by a company that supports rhel and open source en blah blah blah
22:12:09 <biertie> everybody there speaks dutch
22:12:11 <mchua> biertie: There is value in POSSE classes being small.
22:12:19 <mchua> biertie: imo.
22:12:25 <biertie> guess, the presentation was in english ;-)
22:12:39 <mchua> biertie: again, language is not the issue.
22:13:06 <biertie> but allot of small things will cost more than one bigger one, I think?
22:13:29 <mchua> biertie: teaching Spanish and Italian was just an example - I might as well have said "auto mechnaics" and "horseback riding" instead
22:13:39 <mchua> biertie: nope
22:14:08 <biertie> how?
22:14:09 <mchua> biertie: hypothetical case: 2 POSSEs of 15 people each, or 1 with 30
22:14:15 <mchua> biertie: food costs: identical
22:14:21 <biertie> if I have to pay one guy twice
22:14:33 <biertie> to get to both posse's
22:14:37 <mchua> biertie: travel costs: much less, because each prof can pick the POSSE closer to them (the point is to make it possible to do local stuff)
22:14:51 <mchua> biertie: again, think of a 2-year plan, not a 1-summer plan
22:15:00 <mchua> biertie: this summer should be the pilot, to prove that this is possible in EMEA
22:15:01 <biertie> yes, but I am professor X, and I don't care about plone, but I love fedora
22:15:06 <biertie> plone is in the city where I live
22:15:16 <biertie> fedora is in a city 1000km's away
22:15:32 <mchua> biertie: then you either (1) go to the plone one, learn how to teach open source, then get involved in Fedora and run a Fedora POSSE in your town the following summer
22:15:42 <mchua> or you (2) pony up your own travel money and go to the Fedora one
22:16:00 <mchua> note that travel costs for professors should be paid by the professors
22:16:06 <mchua> unless some kind external sponsor steps in
22:16:09 <mchua> generally speaking
22:16:15 <biertie> that's why I was thinking about erasmus
22:16:30 <mchua> (in other words, "professors travel costs are not your problem")
22:16:54 <biertie> http://en.wikipedia.org/wiki/Erasmus_programme
22:17:52 <mchua> biertie: POSSE is only for 1 week - does the professors variant of Erasmus cover terms that short?
22:18:02 <biertie> yes,
22:18:15 <mchua> biertie: also, POSSE is not a formal academic program or institution, it's just hosted by one
22:18:17 <biertie> but I don't know if they pay if they don't give a session at a school
22:18:30 <biertie> so, that's something I have to find out
22:18:35 <mchua> (just as if a BarCamp were to be held at your uni - would you get Erasmus grants for that?)
22:18:55 <biertie> barcampGhent is only for people from the region
22:19:00 <mchua> biertie: EXACTLY
22:19:01 <biertie> you wouldn't be allowed! ;-)
22:19:13 <biertie> but, we had a limit on 100people
22:19:14 <mchua> biertie: but if I flew myself to Ghent and walked in the door, would I be turned away?
22:19:25 <biertie> and we have 150requests
22:19:31 <biertie> yes, you would be turned away ;-)
22:19:51 <mchua> biertie: ok, if I'd pre-registered and been on the list of 100 and flew myself in?
22:20:03 <biertie> just like I'm organising stugent-geek-dinner
22:20:12 <mchua> biertie: (my point is that the burden is on *me* rather than on the organizers to make it accessible to non-local Mel)
22:20:12 <biertie> only for students in ghent and geeks :P
22:20:58 <biertie> mchua: probably yes, because we say you have to give a session to get in, and you're session has to be dutch ;-)
22:21:29 <mchua> biertie: and if I happened to be reasonably conversational in dutch, and had prepared a session?
22:21:43 <biertie> then you're crazy ;-)
22:21:53 <biertie> but yeah, you would get in then I guess
22:21:54 <mchua> biertie: the point is that it is not unreasonable to list requirements, even difficult ones, and expect people to meet them, *especially for a pilot*
22:22:03 <biertie> it's not like we check were you live :P
22:22:10 <mchua> if I don't get in, then I know oh, okay, 100 people limit, don't speak dutch, etc
22:22:30 <mchua> and if I really, *really* want to go to barcampGhent - and I know there will probably be another one
22:22:42 <mchua> then I'll start studying Dutch, make sure I register in time for the 2nd, etc
22:22:49 <biertie> haha
22:22:53 <biertie> ok, I'll see you there then ;-)à
22:23:05 <biertie> but you can't apply for stugent-geek-dinner :D
22:23:56 <biertie> but ok, I get your point
22:24:05 <biertie> I'll search sponsors anyway
22:24:18 <mchua> biertie: here's what I'm thinking, and why I think we need to start it small.
22:24:23 <mchua> Summer 2009: 1 POSSE, CS focus, 10-15 lecturers (objective: prove this works in EMEA; attendees here will ideally be interested in teaching POSSEs themselves)
22:24:28 <mchua> School year 2009-2010: 1-2 POSSEs, any topic focus, 10-15 lecturers each (objective: try different topics in EMEA, build EMEA capacity to teach POSSEs)
22:24:34 <mchua> Summer 2010: 5+ POSSEs, any topic focus - now we can get larger and think about experimenting with multiple tracks, etc. (but only with POSSEs run by experienced instructors who have run at least 1 POSSE before)
22:24:54 <mchua> biertie: we'll get to where you want to be; we'll just not going to get there *right now*
22:25:03 <biertie> I think we're late for 2009 ;-)
22:25:09 <mchua> uh
22:25:15 <mchua> d'oh
22:25:19 <biertie> but ok, what is CS btw? :$
22:25:19 <mchua> year = year+1
22:25:31 <mchua> biertie: computer science, more development-type stuff
22:25:40 <mchua> (making patches, packaging, etc...)
22:25:41 <biertie> ach right :')
22:25:57 <biertie> ok, we have 15professors that want to come
22:26:01 <biertie> what now?
22:26:22 <biertie> we should invite how many students than that support the professors?
22:27:15 <mchua> biertie: (we *might* be able to creep to 20 lecturers, but I'd rather play it safe, and if we have a 16th and 17th applicant that look *amazing*, squeeze them in, perhaps)
22:27:44 <mchua> biertie: are we assuming this is a Fedora POSSE, and in Germany?
22:28:01 <biertie> I hope so, because I don't like amman ;-)
22:28:16 <mchua> Okay. Let us run with that assumption then.
22:28:30 <mchua> Students to support the professors: how many students like you (already involved in Fedora) would be already in the area?
22:28:46 <biertie> real students? I don't know
22:28:52 <biertie> there are allot of fedora people in germany
22:29:01 <biertie> but most them already work I think
22:29:31 <mchua> biertie: okay, so those are community members, and we should invite them to participate as much as possible (and to join us for Thursday's dinner) but we don't need to pre-schedule any of them to come
22:30:32 <mchua> biertie: the roles we need to fill are Logistics, Marketing/Docs, Instructing
22:30:58 <biertie> instructing is the hardest, I think?
22:31:14 <mchua> biertie: from the Logistics side, either someone from the host institution has to be helping with that, or someone on the Logistics team (1-3 people) has to be a liason to the host school
22:31:32 <biertie> liason?
22:31:46 <mchua> biertie: someone who is in charge of communicating with
22:31:55 <biertie> a good point about munich is; Jan lives there
22:32:02 <biertie> and there is quite a big red hat office there
22:32:32 <mchua> biertie: for instance, if we need to make sure that a door is unlocked at a certain time, or that the networking is set up, etc. someone has to be able to interface with the school's IT dept, security dept, etc
22:32:40 <mchua> biertie: yay red hat offices :)
22:33:01 <mchua> biertie: and it's easy if that person is already on the school's staff or faculty
22:33:07 <mchua> (well... easier)
22:33:16 <biertie> that can't be that hard
22:33:25 <mchua> Oh, Logistics is hard.
22:33:28 <mchua> hard hard hard.
22:33:39 <mchua> Greg and I - and Alan - can tell you war stories.
22:33:48 <biertie> :(
22:33:54 <mchua> It's a lot of little things, but the complexity of lots of little things adds up.
22:34:03 <mchua> biertie: don't get me wrong, I personally find it to be hard in the fun sort of way. :)
22:34:07 <mchua> it's a challenge.
22:34:22 <mchua> you learn a lot about event organizing and managing complex projects that way and all.
22:34:27 <biertie> logistics = hotel, food, drinks, T shirts, swag, getting people over, ...?
22:34:47 <mchua> yep, making sure they all know where to go, and have cell phone numbers, and know what time to show up in the morning
22:35:04 <mchua> and that the instructors have hotels, and that nobody's allergic to peanuts
22:35:09 <mchua> and that there's vegan food for the one vegan guy
22:36:13 <mchua> and that the network is setup, and that when someone's laptop breaks there's a spare somewhere, and that the local community members climb on IRC to pitch in, and...
22:36:16 <mchua> etc
22:36:18 <biertie> I'll kick his ass then :P
22:36:38 <biertie> ok, sounds cool to me :)
22:36:40 <mchua> (and that people have visas, and that... well, there's a lot.)
22:36:49 <mchua> (and much of it crops up at the last moment)
22:36:50 <biertie> the cool thing about europe is
22:37:06 <biertie> if you don't come from a monkey country, you don't need a visum
22:37:08 <mchua> :D
22:37:16 <mchua> yeah, I'm glad for that
22:37:34 <biertie> :D
22:37:44 <mchua> oh, also under Logistics: opening registration, making sure applications are processed, repling to applicants, etc
22:37:57 <biertie> repling?
22:38:01 <mchua> er, erplying
22:38:02 <mchua> replying
22:38:04 * mchua can't type
22:38:08 <biertie> ach :D
22:38:25 <biertie> join the club ;-)
22:38:47 <biertie> but that are standard things, most of the things I have to to for fosdem too
22:38:58 <mchua> Marketing: spreading the word about registration, encouraging professors to apply, local community members to come, press releases, getting local journalists to come, talking with the school newspapers of the professors who are attending and getting them to cover the professors' experiences when they get back
22:39:00 <biertie> except the registration and such
22:39:04 <mchua> biertie: you're used to it then, good.
22:39:30 <biertie> 'used' is a big word
22:39:37 <mchua> biertie: Marketing team also Docs team - present throughout entire session (welcome press, orient journalists, etc) and making sure that IRC logs are kept, notes taken, every day is blogged
22:39:50 <biertie> this would be the first international event that I (help) organize
22:40:07 <mchua> (we want the level of detail to be more like http://teachingopensource.org/index.php/POSSE_Blogs#Inaugural_POSSE.2C_July_2009 than the lack of blogs that came out of POSSE APAC)
22:40:30 <mchua> Docs also needs to nag the profs and instructors to log things on IRC, to blog themselves, etc
22:40:49 <mchua> collates the "what happened?" stuff (press, articles, blogs, logs, notes, feedback, reflections) afterwards
22:40:52 <mchua> maintains the wiki page
22:41:17 <mchua> Instructing: getting the students to Teach Open Source
22:41:43 <mchua> (which involves a lot in and of itself - including tons of prep)
22:42:00 <biertie> but when I look to my own school
22:42:09 <biertie> 140 students in my year
22:42:14 <biertie> 3 that use linux?
22:42:43 <biertie> /what do I hate my school.. the best of belgium they say... :')
22:43:33 <biertie> so, getting real students to posse, will be harder than you think - I think -
22:44:12 <mchua> biertie: I'll just say "professors" whenever I mean "POSSE students" then
22:44:13 <biertie> but the students are sponsored, right?
22:44:22 <mchua> biertie: I meant the professors who will be attending POSSE as students
22:44:27 <mchua> not the students of the professors themselves
22:44:38 <biertie> :')
22:44:42 <mchua> biertie: no, no sponsored students
22:44:44 <mchua> biertie: no students
22:44:45 <biertie> it's to late
22:44:46 <biertie> to
22:44:53 <biertie> make sense of this :P
22:45:02 <biertie> you confused me some hour ago
22:45:08 <biertie> when you were talking about students :')
22:45:17 <biertie> now things are back to normal =)
22:45:35 <mchua> biertie: ok, look - here's what you and Jan need to do
22:46:38 <biertie> yez?
22:46:41 <mchua> biertie: read the http://teachingopensource.org/index.php/POSSE page
22:46:46 <mchua> biertie: do this: http://teachingopensource.org/index.php/POSSE#Organize_your_own_POSSE
22:46:58 <mchua> (or rather, the instructions there)
22:47:14 <mchua> biertie: write your proposal on what you want to do and why, and how you propose to do it, and send that to the list
22:47:27 <mchua> biertie: to start the conversation more concretely
22:47:40 <mchua> biertie: there *will* be pushback, I can practically guarantee you - we'll workshop it on-list
22:48:13 <biertie> pushback a la: don't do that?
22:48:24 <mchua> biertie: yeah, and that pushback is a *good thing*
22:48:35 <mchua> biertie: or "you really need to also do X"
22:48:48 <mchua> biertie: release early, release often
22:49:03 <biertie> ok
22:50:30 <mchua> biertie: and we'll go from there. I want you and Jan to write that email together, so the two of you are on the same page
22:51:01 <mchua> biertie: and keep on being patient; I know the process is vague and frustrating right now - POSSE is still in Beta.
22:51:09 <biertie> hehe :D
22:51:15 <biertie> but we have to keep up in europe
22:51:19 <mchua> biertie: it's *much* easier to do this after you do it once.
22:51:22 <biertie> I'll beet my teachers if they don't come
22:51:38 <biertie> especialy mr vanderlinden with all this .net shizzle *brr*
22:51:44 <quaid> POSSE is Alpha :)
22:51:56 <biertie> s/beet/beat
22:51:58 <biertie> but ok :P
22:52:06 <mchua> quaid: POSSE EMEA is alpha, yeah :)
22:52:15 <biertie> mchua: that's the case with all things ;-)
22:52:46 <mchua> biertie: right. so trust me here; taking it slow the first time is good.
22:53:23 <mchua> I tend to run fast, so when I'm consciously reining in, there's typically a Good Reason.
22:53:46 <biertie> mchua: what do you think about me? ;-)
22:53:55 <biertie> I'm always running fast :(
22:53:55 <mchua> biertie: when do you think you can talk with Jan and get that draft proposal to the TOS list by?
22:54:01 <biertie> and somethimes I hit walls :P
22:54:12 <biertie> he's at a linux conventien now
22:54:20 <biertie> with only his blackberry :P
22:54:31 <biertie> so I don't know when he will have acces to a decent notebook
22:54:51 <mchua> biertie: it's a good way to learn. I learn that way myself. Balance is also good.
22:55:04 <biertie> =)
22:55:23 <mchua> biertie: I was thinking along the "at some point in the next month" timeline for that draft proposal, really.
22:55:34 <mchua> doesn't have to be tomorrow.
22:56:13 <mchua> However much time the two of you need to get together and get on the same page and get a draft plan out - I'd say it should be between 1-2 pages long, about that level of detail.
22:56:42 <mchua> Ask all the questions you can think of about this event you're trying to plan, then try to fill in answers to them, noting where you're unsure/making them up.
22:56:42 <biertie> ok
22:57:12 <biertie> next step this evening is sleep ;-)
22:57:17 <biertie> but I know what you mean
22:57:22 <mchua> biertie: any other questions before you're set to do that with Jan? I know it's getting pretty late for you.
22:58:18 <mchua> (If not, let's call it a night.)
22:59:26 <biertie> euhm
22:59:35 <biertie> no, atm the moment not really
22:59:48 <biertie> I just have to think about things now, and discuss things with Jan :)
22:59:59 <mchua> Ok. Thanks, biertie.
23:00:05 <mchua> Ending meeting now - go get some rest!
23:00:08 <mchua> #endmeeting