14:06:14 <quaid> #startmeeting
14:06:14 <zodbot> Meeting started Fri Mar 26 14:06:14 2010 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:06:35 <quaid> #topic Getting organized ...
14:07:15 <quaid> so I had a bit of a late night and am just now on keyboard, so I'm taking the first bit here to get organized
14:07:37 <quaid> #link http://teachingopensource.org/index.php/Textbook_wiki2xml_conversion_sprint_20100326
14:21:36 <quaid> #link http://teachingopensource.org/index.php/Textbook_wiki2xml_conversion_sprint_20100326#Requirements
14:21:44 <quaid> for anyone participating, that's the stuff we need to do the work
14:26:09 * quaid hopes he didn't just set up a recursive time lookp
14:59:39 <sumanah> Open Source Bridge extended their CfP for a few more days
15:25:05 * quaid finally settles down to do just one (set of) thing(s)
15:30:57 <quaid> anyone able to touch teachingopensource.org?
15:31:10 * quaid tries .com too
15:41:50 <quaid> gregdek: tos.org responding for you?
15:42:16 <gregdek> Dunno yet, checking.
15:42:33 <gregdek> Seems like no, though.  humph?
15:43:03 <gregdek> Might be just moving really slow, though.
15:43:10 <gregdek> Maybe we're slashdotted or something, lol
15:44:08 <quaid> nope
15:44:12 <quaid> host www.teachingopensource.org
15:44:12 <quaid> ;; connection timed out; no servers could be reached
15:44:38 <quaid> domain registration still open 'til 05-May-2010 so that's not it
15:44:41 <gregdek> humph, if you can ping ctyler, please, that would be great.
15:45:06 <humph> gregdek: he's dropped from moznet
15:45:19 <humph> I'll try to get him
15:45:54 * quaid checks his cellie but finds no magic ctyler button
15:46:46 <quaid> gregdek: sometime after Monday let's find a way to bolster ctyler on the sysadmin side
15:47:26 <humph> he needs moar power, yes
15:47:36 * quaid wishes money would get him Fedora Hosted + FQDN + SSL
15:48:31 <humph> hey guys, congrats on your amazing textbook work
15:48:38 <humph> it's awesome to see
15:53:39 <gregdek> (a) Thank you.
15:53:51 <gregdek> (b) Your flattery does not get you out of your promise to write us a chapter.  ;)
15:54:48 <gregdek> Hm.  It seems that alpine doesn't even send mail now if it can't find the domain of one of its recipients.
15:54:55 <gregdek> Interesting.
15:58:30 <quaid> d'oh
16:10:35 <humph> gregdek: it's on the TODO pile
16:11:03 <gregdek> :)
16:11:08 <gregdek> I know that pile.
16:11:20 <humph> my emails to you seem to go into that pile!
16:11:51 <quaid> humph: do you have a magic ctyler button?  SMS or cell phone?
16:12:02 <humph> I've tried 3 buttons, I'll try one more
16:12:20 <quaid> gregdek: sorry, I was literally sitting down to do the snarf-to-XML, so I'm stuck until we get site back up
16:12:31 <gregdek> Yep.
16:12:44 * quaid hangs tight
16:15:06 <humph> I don't have a phone that can send SMS, but I have his cell if someone wants to do it
16:15:14 <humph> let me know and I'll msg you the #
16:15:28 <gregdek> humph, yes pls
16:17:58 <gregdek> ctyler has ack'd, will respond soon.
16:22:45 <gregdek> ctyler suspects power issues again, checking.
16:35:50 <gregdek> Hey ctyler :)
16:36:32 <ctyler> hi, trying to figure out what's going on with the power on tos.o, sending someone to check
16:36:42 <ctyler> sorry for the downtime!
16:45:01 <quaid> word, thanks
16:45:07 <quaid> I'll run a quick errand
18:36:54 <quaid> 'pears we have .org
18:48:34 <quaid> #link http://www.teachingopensource.org/index.php/Textbook_wiki2xml_conversion_sprint_20100326#Process
18:48:42 <quaid> I'm working that process now, starting with snarfing the XML
18:54:27 <ctyler_> and... tos.o is back. Looks like the hydro company moved the mains supply *back* to the previous location; the mind boggles.
18:55:33 <quaid> aye, thanks
18:55:39 <quaid> it is a strange world, truly
19:00:38 * ctyler starts complaining to PowerStream
19:01:45 <quaid> see, that's what happens
19:01:55 <quaid> start complaining to powerstream and the cut your IRC connection
19:02:19 <quaid> ctyler: thought They had gotten you for a moment!
19:11:02 <ctyler> just switching from a local session to a persistent remote session on the same server as tos.o
19:11:49 <ctyler> sorry for the lost time today, quaid
19:17:20 <quaid> ctyler: no worries, I wasn't going to get the time devoted I wanted to anyway (kids have a talent show tonight) so I'm going in to the weekend anyway
19:17:27 <quaid> might get more help then, too
19:17:42 <quaid> esp if I can tackle jsmith or stickster or some of the other Fedora Docs folks
19:19:30 <quaid> ctyler: btw, are you familiar with the mediawiki configuration details around $wgScriptPath ?
19:19:59 <quaid> typically it uses /w and their default "pretty URL" stuff has you do a symlink with /wiki and mod_rewrite rules
19:20:17 <quaid> maybe what I mean is ... what is the $wgScriptPath?  /?
19:40:02 <quaid> #action quaid to file bug about F11 mw-render needing python-dateutil >= 1.4
19:42:38 <quaid> #action quaid to file bug about F11 mw-render requiring odfpy==0.7.0 and current version is 0.8-3
19:42:47 <quaid> ok, moving to f12 instead
20:12:34 <quaid> ctyler: I think I'm getting anonymous svn checkout
20:12:40 <quaid> when I run this command:
20:12:54 <quaid> svn co --username quaid --password PASS http://teachingopensource.org/repos/textbook
20:13:04 <quaid> it doesn't seem to be capturing my username
20:13:13 <quaid> so when I go to do a commit, I'm getting throwback
20:13:19 * quaid pulls up an error for fpaste
20:14:24 <quaid> http://fpaste.org/WLsv/
20:14:31 <quaid> anyone else with ideas feel free to help
20:15:38 * ianweller waves
20:15:45 <quaid> :D
20:15:49 <quaid> howdy ianweller
20:16:31 <nb_> .channel capability add #teachingopensource quaid op
20:16:31 <zodbot> nb_: The operation succeeded.
20:16:35 <quaid> ianweller: mw-render did not treat the <pre> well, and threw lots of errors ... we'll probably be repasting all the <pre> sections from the wiki, a brute force 1+ hour instead of trying to solve it first ..
20:16:45 <ianweller> lol
20:16:49 <nb_> quaid: it should let you lobotomize zodbot now, as long as you /msg zodbot identify username password first
20:16:51 <ianweller> *sigh*
20:16:53 <quaid> but otherwise it made good stuff
20:17:00 <ianweller> well good!
20:17:00 <quaid> nb_: thanks!
20:17:04 <nb_> quaid: you're welcome
20:17:08 * ianweller praises stickster's work for getting mwlib working again
20:18:04 <ianweller> the fun part is going to be getting it up to date with upstream -- it requires python-timelib which is not in fedora because it's almost impossible to package under current guidelines
20:19:15 <quaid> ctyler: trying svn:// seems to just hang
21:42:38 <sumanah> bleah, my talk got rejected from OSCON
21:42:41 <sumanah> mchua_afk: ^
21:52:27 <ctyler> quaid: svn against http://teachingopensource.org/repos/textbook   ?
21:54:01 <ctyler> that server uses WebDAV (http://) instead of SVN (svn://)
21:56:57 <ctyler> checkout is anonymous, commit uses the pw
21:57:07 * ctyler checks in README.txt to test
21:58:52 <ctyler> shoot, permission issue. fixed.
22:00:24 <sumanah> http://www.oscon.com/oscon2010/public/schedule/detail/13174 sounds cool: "Ingex is an open source product, built on FFmpeg and Linux and running on commodity hardware, which can replace tens of thousands of dollars worth of broadcast equipment in TV studios, developed by BBC R&D. We discuss the change management, commercial and ecosystem issues we have faced in getting Ingex used by the broadcasting industry, generally unawar
22:00:24 <sumanah> the benefits of open source."
22:00:33 <quaid> yay!
22:00:51 * quaid has been using local 'cp source source-003' version control for the last little bit :)
22:03:39 <quaid> success!
22:20:39 <quaid> ok, raw XML is committed
22:20:46 * quaid been holding local commts
22:37:30 <quaid> note to channel - if I get eaten by a raptor tonight, tell gregdek to look at the wiki sprint page + svn to get up to speed.
22:37:52 <ianweller> noted.
22:38:43 <quaid> my next goal is a commit that I'll tag "RAPTOR_BUILDS" to indicate that it builds in case I get bumped off by a clever troupe
22:39:29 * ianweller is appropriately wearing his one velociraptor per child shirt
22:39:49 <quaid> yay!
22:40:17 <ianweller> and i'm trying to see if i just got into BU but so is everyone else and their server load is through the roof
22:42:02 <quaid> heh
22:42:51 <ianweller> what the worst thing in the world would be is if i get into BU with that full ride scholarship
22:43:12 <ianweller> i'm pretty much set on KU and that knowledge would totally screw with me for the rest of my life
23:08:57 <quaid> ok, time for me to go off for the evening and I want to send status to the list ...
23:09:46 <quaid> #endmeeting