17:48:20 <mchua> #startmeeting
17:48:20 <zodbot> Meeting started Wed Jul 14 17:48:20 2010 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:48:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:48:26 <mchua> #chair ianweller ctyler quaid
17:48:26 <zodbot> Current chairs: ctyler ianweller mchua quaid
17:48:29 <ctyler> actually I'm writing some stuff for the list, so this fits in well.
17:48:32 <mchua> nice.
17:48:38 <mchua> ctyler: so, we'd like to make the following offer
17:48:48 <mchua> (1) RH pays for tummy.com hosting
17:49:04 <mchua> (2) RH pays for teachingopensource.org domain (and owns it on behalf of TOS, similar to Fedora)
17:49:41 <mchua> (3) RH takes accountability for making sure the services TOS needs stays up, and lets others come in and share responsibility (as in, "others can help us do the sysadmin work, but if things go down, it's our ass on the line")
17:49:45 <mchua> ianweller: (is that accurate?)
17:50:11 <mchua> ctyler: and in exchange, (4) RH gets to put a "this website hosted by RH" mark somewhere on the bottom
17:50:24 <mchua> quaid, ianweller: plz correct me if I'm getting this wrong
17:50:29 <ctyler> ok, this has many good points
17:50:30 <ianweller> that's what we discussed, yeah
17:50:41 <mchua> ctyler: the $$ would come out of the $8k TOS budget we've got to throw at TOS in general; it's one of the first things I would like to spend it on.
17:50:44 <ctyler> and one less positive one
17:50:48 <ctyler> and some undefined ones
17:51:16 <ctyler> the good part is that TOS.o ends up on a better vhost
17:51:27 <ctyler> and has a solid sponsor
17:51:45 <ctyler> however, I'd like to see the sponsorship diversified a bit
17:51:49 * mchua sits back and listens (that's about all we had)
17:52:19 <ctyler> we don't have a lot of participation by other .com players
17:52:22 <quaid> ctyler: sounds great, or goal is to "get stuff done" but we aren't ever going to do it in a way that closes other people out
17:52:36 <ctyler> right, and I know that's not the intention
17:52:46 <ctyler> because otherwise you'd just have edu.rh.com
17:52:52 <ctyler> or something
17:53:02 <quaid> for example, we're paving the way for people who do want to sponsor to know what it looks like when they do ... and that sponsorship should be as much about doing as paying.
17:53:13 <ctyler> right
17:53:20 <ctyler> so a few questions
17:53:52 <ctyler> I can see the services offered growing/changing over time, and the sysadmin group changing over time too
17:54:07 <ctyler> how do we decide direction, and players?
17:54:58 <mchua> Do we need to do that now, or do we need to make sure the possibility of doing that when it comes up remains open?
17:55:29 <ctyler> e.g., there was an offer some time back to either change every occurrence of "Open Source" changed to include "Free Software", and/or a parallel site.
17:56:16 <ctyler> mchua: we need a framework, or an idea of how we might set up the framework
17:56:30 <mchua> ctyler: what would you propose? :)
17:56:43 * mchua is glad, btw, that ctyler is looking out for the neutrality of TOS - I'm *really* thankful that you're taking that role
17:56:50 <ctyler> I don't know, hence the question rather than proposal :-)
17:56:54 * quaid thinks "Use the Fedora Infrastructure CSI book"
17:56:56 <mchua> we need it - we need that dynamic :)
17:57:05 <mchua> ctyler: ok, er... hm. any requirements for it you can think of?
17:57:06 <quaid> just remix it for tos.org
17:57:10 <ctyler> CSI?
17:57:24 <quaid> one sec
17:57:26 <ianweller> http://infrastructure.fedoraproject.org/csi/
17:57:32 <quaid> https://fedorahosted.org/csi/
17:57:35 <mchua> yeah, fedora infrastructure csi + "if you'd like to help with infrastructure, email TOS list saying so and we'll have those convos on-list" == how's that, ctyler?
17:58:47 <Jeff_S> hmmm
17:58:53 <mchua> Jeff_S: feedback welcome :)
18:00:01 <spevack> i think that infrastructure-related conversations and projects that TOS is expending energy on conversations are somewhat different.
18:00:06 <spevack> And are approached differently.
18:01:18 <ctyler> spevack: Don't they overlap heavily? e.g., we want to do a book, we need certain infra to do that
18:01:22 <Jeff_S> I'll re-iterate my offer to have OSL host (and do sys admin if desired) for TOS website and any other infrastructure needed for the project.  For free, or for pay if RH does have money
18:01:43 <Jeff_S> Also, I think that the website, but even more so, the resources used should be hosted on an I2 connected link
18:01:58 <Jeff_S> this will make the experience much better for the end-users
18:02:10 <ianweller> +1
18:02:12 <spevack> Jeff_S: +1
18:02:16 <quaid> Jeff_S: yes, and here's why we didn't come back to that
18:02:24 <spevack> ctyler: yes.  I am not expressing myself clearly.  :)
18:02:25 <mchua> Jeff_S: I'd actually love that - basically replace the "RH pays $ to tummy" part with "OSL provides the box" part
18:02:33 <quaid> Jeff_S: we keep thinking about our flexibility needs, and how other people need that flexiblity
18:02:46 <quaid> and I keep not remembering to comeback to you for that conversation
18:02:52 <spevack> and RH is happy to provide some $$$ when it's needed :)  We're happy to make more contributions to OSL
18:02:54 <mchua> Jeff_S: and have both parties chip in sysadmin-fu (or we can just say "hey ianweller, make sure MW doesn't go down" and make him accountable for that, etc.) (as an example)
18:02:57 <ctyler> I2 makes a ton of difference to some, and none to others
18:03:10 <Jeff_S> ctyler: yes
18:03:13 <quaid> so we were going from "how to take now to more scalable and flexible in one step at a time' but if we can do that + move it to OSL in one move, that's AWESOME
18:03:23 <mchua> ctyler: would that help? if OSL stepped up with the hosting from the start?
18:03:50 <Jeff_S> and I'm not saying that it needs to be OSL (but the offer's on the table).  But I think having it at *some* university will give a much better perception to potential educators
18:03:56 <mchua> Jeff_S: +1 to that
18:04:15 <quaid> Jeff_S: actually, it makes perfect sense for it to be OSL over anyone else, imnsho
18:04:17 <Jeff_S> s/potential educators/potential teachingopensource professors/
18:04:24 <mchua> I think the thing is that "in the absence of someone else stepping up with a solution to move us to a better host, RH is happy to chip in some cash for tummy hosting" was more of what we were trying to say
18:04:34 <mchua> and OSL is *clearly* a better solution than "RH pays for tummy hosting"
18:04:37 <quaid> Jeff_S: and thanks for keeping on gently reminding us of the offer
18:04:40 <Jeff_S> also nothing against tummy who I quite like :)
18:05:27 <ctyler> OSL, Seneca, RIT -- I think there are a number of .edu-based hosting options
18:05:27 <Jeff_S> the other thing I can see is, for something as small as teachingopensource, I'm not sure that going through all the overhead of having a "public" sys admin team would really be necesary
18:06:07 <ctyler> otoh, the advantage of tummy is that it's not under a .edu's umbrella
18:06:09 <Jeff_S> but whatever makes people happy
18:06:50 <Jeff_S> we also have some central resources such as mailman so that would be one less thing to maintain specifically for TOS
18:06:55 <quaid> well, we're not stuck with anything forever :)
18:07:52 <Jeff_S> heh
18:07:58 <ctyler> quaid: good point, perhaps we should have a renewable timeframe on the hosting
18:08:14 <mchua> ctyler: so, the way I see this... this isn't irreversible, you can always set up the same arrangement you have now for hosting again if we completely screw it up :)
18:08:45 <ctyler> that VMs already migrated around plenty :-)
18:09:15 <ctyler> ok, to work through a couple of things
18:09:43 <ctyler> I really like the idea of community-run admin, I think this has value.
18:10:00 <ctyler> Do we have agreement on that?
18:10:13 <mchua> +1
18:10:45 <mchua> ctyler: ianweller and spevack and quaid agree (we're in the same room now)
18:10:52 <mchua> Jeff_S: ?
18:11:18 <Jeff_S> I'm indifferent about it.  depends on who/how many step up really.  vs. what your host is willing to do for you
18:11:30 <Jeff_S> it's not a bad idea :)
18:11:39 <Jeff_S> just a "devil in the details" type thing
18:11:58 <quaid> Jeff_S: do you have anything like that?  student training or community-run admin work?
18:12:00 <Jeff_S> and like quaid(?) said, Fedora has done this nicely
18:12:04 <quaid> or interested in adding that
18:12:16 * mchua doesn't want to get into the details atm
18:12:35 <mchua> (us RH folks are going to have to hop out pretty soon for meeting-fu, ctyler)
18:12:38 <ctyler> So maybe we start by putting together the initial admin team, and let them review hosting options, and go from there.
18:12:42 <Jeff_S> quaid: we have students who we employ, but we don't give anyone external access (unless they have such through their project)
18:13:01 <mchua> ctyler: we'd have to move pretty fast if we want this up and tested by the time school starts again at end of ug
18:13:05 <mchua> er, August
18:13:34 <ctyler> mchua: shouldn't be horrendous, it's a mediawiki instance, svn, and mailman atm
18:14:01 <mchua> but if that means "Jeff, Karsten, Ian, and Chris write TOS an email tonight with hosting options, and say 'if there are no objections we'd like to go with OSL hosting and RH paying for the domain and people can help us with the admin if they want, talk to us'" I'm ok with that
18:14:15 * mchua nods, that really isn't bad.
18:14:38 <mchua> ctyler: does that sound okay, or am I rushing things too much?
18:15:00 <mchua> mostly I'm cognizant that everyone on that list has very little time, and that free time tends to not overlap predictably
18:15:04 <ctyler> I think the list may have more to say about this than we think, but we'll know soon :-)
18:15:09 <mchua> so while we're all here I'd like to move forward while we can
18:15:10 * mchua nods
18:15:20 <paulproteus> mchua: Holy Jesus I'm on crack the talk is next week.
18:15:38 <mchua> ctyler: and if the list objects, then we can adjust... but if, say, nobody objects within a week, we do it?
18:15:48 <paulproteus> I mean, hi, nice to see you online.
18:15:51 <mchua> paulproteus: yeah, hence the higher volume of pings from me recently :)
18:15:59 <paulproteus> I didn't really put two and two together.
18:16:01 <ctyler> I'm going to propose that quaid take lead on the team to start, and that we very undemocratically give him rights to pick the initial team, and go from there.
18:16:07 <mchua> paulproteus: I was trying to get that convo in before I started manic travel (in the middle of that now) - apologies for not being clearer on that.
18:16:18 <mchua> ctyler: I'm cool with that. :)
18:16:21 <ctyler> quaid: You good with that?
18:16:21 <paulproteus> mchua: That's okay, stump (from #openhatch) reminded me (-:
18:16:36 <paulproteus> mchua: Let me review my today todo and get back to you shortly-ish.
18:16:37 <mchua> paulproteus: can we have this convo later? how early/late are you up these days?
18:16:57 <mchua> paulproteus: I'm in meetings all day but I'll be hunting for you any time I'm online, and we should braindump to each other asynchronously as much as possible.
18:17:08 <paulproteus> mchua: Yeah, sounds good.
18:17:31 <ctyler> Pending reply from quaid, I'll send this to the list and see what they say.
18:17:56 * quaid has to read, one moment
18:18:06 <ianweller> we were distracted :)
18:18:14 <Jeff_S> stop passing notes back there!
18:18:18 <ianweller> :(
18:18:22 <Jeff_S> :)
18:18:33 <ctyler> quaid: proposing that you take the helm of v0.1 of the admin team to bootstrap it
18:18:38 <mchua> Jeff_S: s/passing notes/nagging Karsten to look at this window :)
18:19:17 <quaid> ctyler: +1 .... I'm square with that
18:19:42 <ctyler> ok, let me send this to the list and we'll act on it ... start of next week?
18:19:51 <ianweller> <nod>
18:19:59 <mchua> ctyler: one week after the email's sent == "if no objections, proposal goes into effect" time?
18:20:13 <mchua> that's right after OSCON so (presumably) quaid and ianweller will have bandwidth again.
18:20:17 <mchua> ...I think.
18:20:21 <ianweller> i always have bandwidth
18:20:25 <ianweller> ;)
18:20:38 <mchua> ianweller: but is it free? ;)
18:20:41 <ctyler> I was thinking a bit less binary than objection/no objection, list feedback may shape the proposal
18:20:47 <ianweller> mchua: it actually functions on an infinite auction system
18:20:51 <ctyler> but yes
18:20:59 <ctyler> so we're talking next Wed or Fri?
18:21:00 <ianweller> highest bidder gets the ianweller-bandwidth
18:21:06 * ctyler can't remember when OSCON ends
18:21:06 <mchua> ctyler: nod, that makes sense
18:21:26 <mchua> ctyler: Next week, Friday.
18:21:29 <mchua> it's all next week M-F.
18:21:33 <ctyler> sounds reasonable
18:21:52 <ianweller> i nominate mchua to write the mail to the list
18:21:58 <mchua> I... sometimes phrase things too binarily. "feedback yay plz!" but the strawman we propose is a reasonable executable if we get radio silence
18:21:58 <Jeff_S> 2ndeded
18:22:09 <mchua> ctyler: I thought you wanted to write that email?
18:22:16 <quaid> yeah, ctyler said he'd write
18:22:20 <ctyler> ianweller: I'd like to do that, being the original infra-starter
18:22:31 <Jeff_S> I can reply w/ more details about what OSL can provide
18:22:31 <mchua> ctyler: I'd rather that, tbh
18:22:40 * Jeff_S gonna run off here in a min. too
18:22:45 <ctyler> ok, watch for mail later today
18:22:50 * mchua actually wants no responsibility for the sysadmin-fu of TOS whatsoever, just wants to make sure this shift to a community admin team + better hosting happens
18:22:54 <mchua> ctyler: yay! thank you, chris!
18:23:01 * mchua notes this down
18:23:02 <ctyler> thank you all
18:23:06 <ianweller> ctyler: ah! ok
18:23:07 <mchua> #action ctyler to kick off discussion with list email
18:23:23 * ianweller was just attempting to jab mchua  :)
18:23:56 <mchua> #agreed proposal: OSL hosts, RH pays for domain name, quaid appointed interim head of community sysadmin group for TOS
18:24:10 <mchua> #agreed proposal is a strawman we'll throw to the list for feedback & shaping, but if we get radio silence we're happy to just go for this
18:24:40 <mchua> #agreed admin team will take feedback into account and jump into action after 7/23
18:24:51 <mchua> ctyler, spevack, quaid, Jeff_S, ianweller: does that summarize?
18:25:22 <ianweller> +1
18:25:37 <spevack> +1
18:26:01 <ctyler> mchua: I'd say that the admin group should select hosting, but otherwise +1
18:27:05 <mchua> #agreed admin group will select hosting (OSL is one proposal to consider)
18:27:11 <mchua> ok, I think we are a wrap then
18:27:18 <mchua> ctyler: you'll have shiny meeting logs in a moment
18:27:22 <mchua> ending in 3...
18:27:23 <mchua> 2...
18:27:26 <mchua> 1...
18:27:40 <mchua> #endmeeting