07:39:56 <mchua> #startmeeting
07:39:56 <zodbot> Meeting started Mon Oct  4 07:39:56 2010 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:39:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
07:40:14 <mchua> #chair jwildeboer_WEB jwildeboer liknus micadeyeye gruntus boniface
07:40:14 <zodbot> Current chairs: boniface gruntus jwildeboer jwildeboer_WEB liknus mchua micadeyeye
07:41:31 <mchua> Shout if you're in POSSE SA and I haven't chaired you yet.
07:42:59 <mchua> #topic Reading discussion
07:43:03 <liknus> #info people care about : getting people to contribute, open standards, open source for everyday life and the 3 Os
07:43:09 <mchua> #link http://teachingopensource.org/index.php/POSSE_South_Africa#Monday_readings
07:43:18 <mchua> #link http://piratepad.net/possesa
07:44:51 <mchua> #chair mfladischer
07:44:51 <zodbot> Current chairs: boniface gruntus jwildeboer jwildeboer_WEB liknus mchua mfladischer micadeyeye
07:46:01 <mchua> #action mchua get copy of jwildeboer's slide deck
07:48:14 <mchua> liknus: are you liveblogging today? if so, I can wrangle transcription/note-taking, or vice versa - your pick.
07:49:00 <liknus> mchua, I am :) do you want me to take notes on IRC?
07:49:03 <mchua> So, for those of you in the classroom watching on IRC - one of the nice things about backchannel is that it lets us have conversations about the content without interrupting the speaker. :)
07:49:15 <mchua> liknus: We can both do that, I'll focus on the channel more since I know you're blogging now. :)
07:49:30 <liknus> ok thats nice :) thanks mchua
07:49:32 <mchua> #link http://en.wikipedia.org/wiki/Richard_stallman
07:49:44 <mchua> That's the fellow whose picture is on the slide Jan is showing right now, and the founder of the Free Software movement.
07:49:46 <liknus> microblogging as a matter of fact
07:49:49 <mchua> In case you're interested in more details.
07:49:52 <mchua> liknus: excellent!
07:49:56 <liknus> #link http://identi.ca/tag/possesa
07:50:16 <mchua> (And for those of you who are professors - it lets you keep track of the backchannel conversation your students are going to have about the class anyhow. ;)
07:52:16 * mchua notes that Mozilla is a group that cares greatly about the open web, and that micadeyeye works within that community - we can also ping him for questions. ;)
07:53:43 <mchua> (feel free to speak up here, btw)
07:53:49 <mchua> (whether you're at POSSE or not)
07:53:52 <gruntus> ok thanks mchua
07:54:13 <mchua> hey gruntus! welcome to the channel. :)
07:54:35 <mchua> #link http://en.wikipedia.org/wiki/Open_Web_Foundation
07:54:49 <liknus> I can also fill in for Mozilla open standards (I am on Drumbeat also)
07:55:42 <mchua> Nice!
07:55:51 <mchua> liknus: You're everywhere!
07:56:18 <liknus> mchua, I am trying :P
07:56:28 <gruntus> kinda like chicken man
07:57:38 * mchua notes that not everybody here is running Fedora, which is totally ok - as long as you can ssh, use git, etc. and basic FOSS dev tools, it doesn't matter what you're running.
07:57:46 <liknus> Is everyone ok with the flow of info at http://identi.ca/tag/possesa ? shall i go for more or less?
07:58:07 <mchua> Linux of some sort is probably easiest - some folks here have Ubuntu, some Fedora, both are ok.
07:58:19 <mchua> Windows users will have a hard time with git tomorrow, so you may want to get a livecd from liknus.
07:58:38 <mchua> liknus: looks good to me :)
07:58:46 <liknus> mchua, ok nice
07:59:22 <liknus> Anyone interested can give me a USB stick and make it a LiveUSB Fedora 13
07:59:40 * mchua has usb sticks people can borrow for the week too
08:01:26 <liknus> mchua, give me one now to start making :)
08:03:07 <gruntus> perhaps an os commonwealth
08:05:20 <mchua> Some people will get up in arms about the difference between "free software" and "open source."
08:05:57 <mchua> Most folks who work on it tend not to consider them to be more or less the same thing, from my experience.
08:06:12 <mchua> But some people, for instance, will go "you can't just call it open source, you need to call it free and open source."
08:06:22 <mchua> They tend to be the vocal ones. :)
08:06:35 <gruntus> i guess there is a difference but it probabl philosophical onl
08:06:36 <mchua> So it may be easy to think that all FOSS proponents are the same way - that's not necessarily true.
08:06:40 * mchua nods
08:07:05 <mchua> gruntus: Well, the open source definition (osd) is different from the 4 F's.
08:07:08 <mchua> http://www.opensource.org/osd.html
08:07:11 <mchua> #link http://www.opensource.org/osd.html
08:07:30 <mchua> For instance, the osd contains anti-discrimination clauses.
08:08:17 <mchua> #link http://www.gnu.org/philosophy/free-sw.html
08:09:05 <mchua> “Free software” is a matter of liberty, not price. To understand the concept, you should think of “free” as in “free speech,” not as in “free beer.”
08:09:12 <mchua> (...says that link above)
08:09:22 <mchua> Regarding open source, the same page says:
08:09:25 <mchua> Another group has started using the term “open source” to mean something close (but not identical) to “free software.” We prefer the term “free software” because, once you have heard that it refers to freedom rather than price, it calls to mind freedom. The word “open” never refers to freedom.
08:10:02 <micadeyeye> mchua: I agree with you.
08:10:15 <mchua> For an exhaustive list of free software licenses, see:
08:10:17 <mchua> #link http://en.wikipedia.org/wiki/Comparison_of_free_software_licenses
08:10:27 <mchua> The GPL is probably the most well-known.
08:10:27 <micadeyeye> Free Software != Open Software
08:10:40 <mchua> Apache, BSD, and MIT are also pretty common.
08:10:54 <micadeyeye> And vice versa.
08:11:19 <mchua> micadeyeye: Yep. Some people say you can call something "open source" if you can see the code - but not modify or redistribute it - which is clearly not Free by the FSF's definition of free software.
08:11:41 <mchua> I'll point out that http://www.opensource.org/osd.html does specify free distribution.
08:11:57 <mchua> And also that "The license must allow modifications and derived works, and must allow them to be distributed under the same terms as the license of the original software."
08:12:40 <mchua> However, if you see the "Integrity of The Author's Source Code" section, you'll start seeing subtle differences between the FSF's freedoms and the osdd.
08:12:43 <mchua> er, osd.
08:15:22 <mchua> jwildeboer: We need to start wrapping the lecture component so we can introduce the projects and the teaching model, then take a break, then do a tools session.
08:15:38 <mchua> (schedule's a little funny b/c of our late start today, I know)
08:15:42 <mchua> how much longer do you need?
08:16:07 <liknus> fedora has an excellent matrix of licenses at:
08:16:09 <liknus> #link https://fedoraproject.org/wiki/Licensing
08:17:28 * mchua is curious how much context jwildeboer's presentation assumes - it's usually given to new Red Hat employees, who oftentimes have participation context in free software communities already.
08:17:47 <mchua> are things making sense? are we rehashing things people already know? is this assuming too much background and being confusing?
08:18:19 <gruntus> somehwere in the middle mchua
08:18:30 <mchua> boniface: how about you?
08:18:35 <mchua> questions, thoughts? :) you've been quiet so far.
08:18:54 <liknus> One LiveUSB is ready :) Fedora 13 if anyone needs it
08:19:36 <liknus> Is it too "Red Hat orientation" oriented? :P
08:19:41 * mchua has the Sugar on a Stick and XFCE spins for Fedora 13 ("F13") .isos on her laptop if people want that
08:20:00 <liknus> SOAS ftw :)
08:20:04 <mchua> \o/
08:20:12 <mchua> liknus: ooh, and you have the design spin, too.
08:20:21 <mchua> we can mention spins at some point this week. probably not today, but... sometime.
08:20:51 <liknus> mchua, yeap and some experimental spins with me also.. i can also introduce to Spins Creations
08:20:59 <mchua> (http://spins.fedoraproject.org for the curious)
08:21:14 <liknus> #link http://spins.fedoraproject.org
08:21:21 <mchua> whoops, thanks
08:21:32 <liknus> #info We have LiveUSBs with us
08:32:43 <liknus> Dress up your Firefox for POSSE SA
08:32:46 <liknus> #link Dress up your Firefox for #possesa :) https://www.getpersonas.com/en-US/persona/307490
08:32:57 <liknus> #link https://www.getpersonas.com/en-US/persona/307490
08:40:01 <jwildeboer_WEB> I thought the slides were general enough to kickstart drilling deeper.
08:40:23 <jwildeboer_WEB> Touching a lot of fields, society, company, university, politics
08:48:00 <jwildeboer_WEB> wrt Red Hat and SWPAT (Software Patents) http://press.redhat.com/2010/09/28/red-hat-responds-to-u-s-patent-and-trademark-office-request-for-guidance-on-bilski/
08:57:57 <mchua> #topic opening session
09:03:40 <liknus> reviewing our schedule
09:09:14 <mchua> #link http://teachingopensource.org/index.php/POSSE_South_Africa#Monday_resources
09:09:21 <micadeyeye> I enjoyed Jan's talk.
09:09:34 <micadeyeye> jwildeboer_WEB: thanks for the great talk.
09:10:03 <jwildeboer_WEB> micadeyeye: I enjoyed it too ;-)
09:12:46 <liknus> hi posse_projector :P
09:12:50 <mchua> #link http://blog.melchua.com/2010/09/07/fedora-classroom-tuesday-sep-14-at-1600-utc-working-with-people-who-arent-there-basic-distributed-collaboration-tools/
09:15:58 <liknus> hi all :)
09:16:00 <mchua> Hello!
09:16:02 <micadeyeye> hi guys!
09:16:02 <boniface> Am in hello
09:16:03 <gruntus> hi posse projector
09:16:06 <jwildeboer> Morning
09:16:47 <michaelgraaf> morning everyone
09:20:23 <liknus> This is a chatroom essentially :)
09:20:32 <posse_projector> message!
09:20:37 <posse_projector> michaelgraaf: message!
09:20:42 <liknus> nice message posse_projector :P
09:20:50 <jwildeboer> I will upload my slides sometime today, they are free tpo re-use, ofcourse. Will add licensing info.
09:20:59 <liknus> nice message posse_projector :P
09:21:11 <liknus> I am repeating my self :P
09:21:31 <liknus> boniface, this is a message to you :P
09:21:36 <posse_projector> gruntus: hello!
09:21:38 <liknus> Wait... that was a song... ?
09:21:46 <jwildeboer> liknus: I am talking to sou :-)
09:21:50 <micadeyeye> jwildeboer_WEB: could send me the links to the projects you mentioned yesterday?
09:21:53 <posse_projector> michaelgraaf: got it?
09:21:57 <michaelgraaf> jwildeboer: hi
09:21:58 <jwildeboer> liknus: s/sou/you/g
09:22:01 <liknus> jwildeboer_yeap you lit up on my screen
09:22:03 <boniface> michaelgraaf: hello
09:22:14 <gruntus> projector: thanks
09:22:32 * jwildeboer taking of his hat
09:22:49 <liknus> jwildeboer, possibly "off" ?
09:23:00 * jwildeboer needs more coffee ;-)
09:31:16 <boniface> join #tp3group
09:37:04 <posse_projector> zodbot: swedish
09:37:13 <mchua> zodbot: swedish
09:39:32 <zodbot> posse_projector: kwack kwack
09:39:36 <zodbot> posse_projector: bork bork bork
09:39:40 <zodbot> posse_projector: (supybot-fedora version 0.2.8)
09:39:44 <zodbot> mchua: kwack kwack
09:39:48 <zodbot> mchua: bork bork bork
09:39:52 <zodbot> mchua: (supybot-fedora version 0.2.8)
09:39:56 <zodbot> posse_projector: Error: Can't start another meeting, one is in progress.
09:42:56 <mchua> #endmeeting