23:48:39 <mchua> #startmeeting
23:48:39 <zodbot> Meeting started Mon Feb  7 23:48:39 2011 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:48:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:48:41 <mchua> #chair rrix
23:48:41 <zodbot> Current chairs: mchua rrix
23:48:47 <rrix> poof!
23:48:54 <rrix> I haz le chair
23:48:55 <mchua> rrix: okay, so for context I wanted to pick your brain in a way similar to Ian's
23:49:05 <rrix> Hokay
23:49:07 <mchua> I can do this in 5m or less if you're tight on time, or a more extended discussion if you'd like, your call
23:49:26 <mchua> but: at the FUDCon retreat we talked about "TOS public-facing web presence" being your area of responsibility
23:49:29 <mchua> ja?
23:49:52 <rrix> I'm totally free right now
23:49:54 <mchua> so, I'm a customer of this public-facing web presence (going to SIGCSE in a month) and have some requests and am curious about your plan for working on it ;)
23:50:03 <rrix> Okay :)
23:50:16 <rrix> Do you want to start with your requests? :)
23:50:30 <mchua> rrix: well, I'm curious if you were already planning on doing stuff I wanted
23:50:36 <mchua> ...or rather, I was going to listen first :)
23:50:42 <rrix> Okiedoke
23:50:52 <mchua> so, o TOS-Public-Facing-Web-Presence-Master (TPFWPM), sup?
23:51:04 * mchua listens at the feet of the TPFWPM
23:51:04 <rrix> Well, for starters, I'm thinking of just an inventory on what we have, basically what content is there...
23:51:09 <rrix> Then what can be killedd off
23:51:10 <rrix> brb, door
23:51:13 <mchua> k
23:51:29 <mchua> An inventory sounds good for starters.
23:51:34 <mchua> Are you mostly talking "wiki" here?
23:51:37 <rrix> sorry
23:51:42 <rrix> Yes, wiki for now
23:51:42 <mchua> No worries, life happens. :)
23:52:00 <rrix> Because, you know, we have a bunch of stuff that we aren't working on anymore
23:52:01 <mchua> Okay, so non-wiki public-facing web-presences are not so much on the radar atm. Gotcha.
23:52:07 <mchua> Aye-aye.
23:52:13 <rrix> After there's a BigList, define what can be culled out
23:52:25 <rrix> with your and other TOS oldtimers' help :P
23:52:38 <rrix> stuff like TOS Summit doesn't need to be in the menus any more for example
23:52:56 <rrix> that list will also have "stuff that needs to be updated"
23:53:16 <rrix> Which I'll probably through at the TOS list "hey, you should update this!"-style
23:54:03 <rrix> besides that, I don't really remember what fell under my responisibiltyies
23:54:09 <rrix> wow, responsibilities
23:54:30 <mchua> Well, there's spam.
23:54:41 <mchua> How does that fit into the big TOS-wiki spring-cleaning?
23:54:55 <rrix> right, that was in the BigList of stuff that can be culled out
23:54:58 <rrix> most of it is users
23:55:04 <mchua> Ahh - okay, and spam-prevention plans? Any of those?
23:55:06 <rrix> Not sure what to do with them, though..
23:55:16 <mchua> Keeping in mind that ianweller is your infrastructure back-up should you need that for spam prevention.
23:55:23 <rrix> mchua: there really isn't much, besides captcha we can do... already have anon editing turned off
23:55:31 <mchua> rrix: Well... what are you thinking, re: dealing with spam & cleanup?
23:55:33 <rrix> ianweller knows a lot more about wikispam than I do, though
23:55:40 <ianweller> rrix: you get to delete it by hand :)
23:55:45 <rrix> Right
23:55:55 <mchua> rrix: think of yourself as ianweller's infra customer wrt wikispam here
23:56:01 <rrix> mchua: cleaning up spam pages by hand, locking the accounts that created them
23:56:12 <ianweller> rrix: there are some extensions to help with that, btw. i just don't know which ones they are. tell me what they are and we'll get 'em ni.
23:56:13 <rrix> install some captchas on the registration and post page, prolly
23:56:20 <rrix> ianweller: I will look in to that
23:56:22 <mchua> rrix: Okay, that sounds like a good one-week project to me.
23:56:28 <rrix> #action rrix to look in to spam plugins for MW
23:56:32 <mchua> rrix: "tackle the spam week"
23:56:41 <rrix> mchua: righto
23:56:53 <mchua> rrix: you'll have to do a lot of heavy lifting to get others to help you, but you know how to set up the conditions for a snowball of momentum to take shape.
23:56:58 <mchua> blogging, scheduling sprints, etc.
23:57:02 <rrix> Yup, I'm good at that :)
23:57:05 <mchua> rrix: ok, when is "tackle the spam" week?
23:57:17 <mchua> rrix: you *are* incredibly good at that, and you should capitalize on that talent more often. ;)
23:57:41 <mchua> rrix: it sounds like this is also separate from "remove the deadwood" week
23:57:48 <rrix> mchua: tackle the spam week is "ryan doesn't have any homework this week"
23:57:55 <rrix> Yes, it is
23:57:56 <mchua> rrix: whoa, when's that?
23:57:56 <harish> mchua, the team meeting is at 10pm EST?
23:58:03 <mchua> harish: 11pm, iirc.
23:58:04 * mchua looks
23:58:10 <harish> mchua, ok.
23:58:28 <mchua> harish: how much time do you want for brainstorming help on the tosw-culture questions?
23:58:44 <mchua> harish: (they might be kinda fun for TOS to see also, since these are the folks trying to teach tosw)
23:59:02 <harish> mchua, not sure. was that on the agenda?
23:59:08 <mchua> harish: 10 minutes, 15...? I was just going to hand the meeting to you for that chunk if you'd like time for it
23:59:20 <mchua> harish: it will be if you want it to be :) otherwise there's other stuff I'll have us do
23:59:37 <mchua> rrix: also, any plans wrt looking into reskinning, etc?
23:59:48 <harish> yes some of it. let's review the agenda.
00:00:19 <rrix> mchua: I was planning on tackling that after all the branding stuffs
00:00:39 <mchua> rrix: "branding stuff" meaning "what's up with the POSSE trademark"?
00:00:47 <rrix> mchua: that, the logo, etc
00:00:56 <rrix> all yours and ianweller's stuff, iirc
00:01:16 <rrix> I'd like the wiki theme to tie in the logo kinda like it does now
00:02:32 <mchua> rrix: Okay, where do you want to keep track of all these projects?
00:02:38 <mchua> So, there are at least 3 subprojects I've heard you name here.
00:02:46 <mchua> spam, deadwood, and branding.
00:02:47 <rrix> mchua: Was thinking either internalwiki or my TOS user page
00:02:55 <mchua> rrix: public plz, says the customer ;)
00:03:01 <rrix> Okay, user page :)
00:04:05 <mchua> rrix: actually, mainspace.
00:04:13 <mchua> rrix: No reason why it should be under User:Rrix
00:04:17 <rrix> Oh, ok
00:04:18 <ianweller> +1 mchua
00:04:20 <mchua> just make a page that's outright... [[Spam protection]]
00:04:22 <rrix> [[TOS Cleanup]]
00:04:27 <mchua> ...or, yeah!
00:04:30 <mchua> worksforme.
00:04:38 <mchua> rrix: So, customer request time?
00:04:43 <rrix> Go for it :)
00:04:56 <mchua> I'll tell you what I want, you tell me if I'm crazy and/or what you're going to need to make this happen.
00:05:07 <rrix> Okay
00:05:08 <mchua> Right, so, SIGCSE, biggest CS edu conference in the world, week of March 7th.
00:05:23 <mchua> So all this is *before* March 7th... I want to be able to walk into Texas with a wiki that is...
00:05:41 <mchua> 1) awesometacular and call-to-actionesque on the front page
00:06:14 <mchua> metric for that is that I would like people to look at the front page and go "holy shit this is exciting!" and overwhelmingly, overwhelmingly subscribe to the TOS mailing list and do a good intro post
00:06:42 * rrix nods
00:06:45 <mchua> so think about the design and the writing (advertising, basically) and the links, etc. you need to put on that front page to make as many people as possible join the list and intro themselves.
00:06:50 <mchua> 2) free o' spam
00:06:51 <rrix> Yes
00:07:11 <mchua> 3) has a few clear, well-structured, call-to-action project pages
00:07:12 <rrix> define spam
00:07:19 <rrix> user visiable spam, users that create spam...?
00:07:24 <mchua> rrix: user-visible spam.
00:07:35 <mchua> for #3, I don't care what they are nor how many.
00:07:46 <mchua> but that I know the list of good ones before I walk into Texas so I can make sure I show those off.
00:07:48 <rrix> Ok
00:07:58 <mchua> rrix: my suggestion is to figure out which projects have strong activity and get *those* projects to clean their pages up
00:08:03 <rrix> Righto
00:08:05 <mchua> but you may have to define standards to help them do that
00:08:16 <mchua> for instance, 2 projects you have people for right here... me on POSSE and ianweller on infra
00:08:21 <mchua> may also want to holla at sdz re: events
00:08:27 <mchua> that's 3 pages right there
00:08:27 <rrix> hollaaaa
00:08:43 <rrix> Yeah, those are all good ones, too
00:08:54 <mchua> but you're going to need to tell us what it means to make that page shiny and actionable, or we won't know what to do ;)
00:09:01 <rrix> Okay :)
00:09:11 <mchua> (you could help one of us work on ours and then show it to the other two as an example, etc... however you want to do it)
00:09:17 <mchua> rrix: that... is all
00:09:18 <rrix> Yeah, I was thinkgin that
00:09:25 <rrix> mchua: all that sounds really do-able
00:09:30 <ianweller> hollllaaaaaa
00:09:55 <mchua> rrix: so to summary, (1) frontpage makes people subscribe and intro themselves to TOS ml, (2) no spam! and (3) a known list of clear call-to-action project pages
00:10:01 <mchua> those are my "customer requests"
00:10:04 <mchua> by March 7
00:10:12 <mchua> which means, counting this week, you've got 4 weeks to finish 'em all.
00:10:15 <mchua> so.
00:10:15 <rrix> yesh :)
00:10:21 <mchua> reasonable? gameplan? what do you need from me or anyone else to make it happen?
00:10:58 <rrix> hang on lol
00:11:01 <rrix> broke keyboard ke
00:11:02 <mchua> rrix: keeping in mind that I'm not your boss, spevack is, I'm just a "customer" so you can tell me no and stuff ;)
00:11:08 * mchua chuckles
00:11:23 <rrix> yeah i did creap
00:12:08 <mchua> er...
00:12:10 <mchua> confused.
00:12:37 <rrix> okay
00:12:43 <rrix> I semi fixed it
00:12:46 <mchua> rrix: (I'd like to leave for dinner in the next 15m for the record... getting kinda hungry for le noms)
00:12:48 <rrix> my M key is broken no
00:12:59 <mchua> oy vey. What did you do, spill coke on it? :P
00:13:04 <rrix> Yes, what you asked for is reasonable :)
00:13:22 <mchua> rrix: ok, timeline o' deliverables and/or "I'm going to need $foobar to make this happen"?
00:13:40 <rrix> mchua: I would need to think about that and weigh it with schoolwork
00:13:46 <rrix> can I get back to you on timeline?
00:14:04 <mchua> rrix: Sure, just wanted to make sure we're going as far with this as possible.
00:14:09 <rrix> Yeah
00:14:15 <mchua> rrix: When do you reckon I can get a timeline for the rest?
00:14:16 <rrix> I'm kinda getting in to midterm season ;(
00:14:21 <rrix> mchua: 24h
00:14:23 <mchua> rrix: ouch, my sympathies...
00:14:28 <mchua> rrix: That worksforme. Thanks. :)
00:14:31 <mchua> Anything else I can do for ya?
00:15:00 <mchua> #info Mel's customer requests of Ryan by March 7 are: (1) frontpage makes people subscribe and intro themselves to TOS ml, (2) no spam! and (3) a known list of clear call-to-action project pages
00:15:11 <rrix> I think I am set right now :)
00:15:16 <mchua> #action Ryan to create a timeline for fulfilling these customer needs within the next 24h
00:15:25 <mchua> #agreed project tracking for this will happen in TOS wiki mainspace
00:15:31 <mchua> rrix: ok, if you think we're done, #endmeeting ;)
00:15:40 <mchua> thanks! this helped clear a lot of stuff up for me.
00:15:42 <rrix> #endmeeting :)