18:02:21 <mchua> #startmeeting
18:02:21 <zodbot> Meeting started Tue Apr 12 18:02:21 2011 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:02:23 <mchua> #chair heidi
18:02:23 <zodbot> Current chairs: heidi mchua
18:02:25 <heidi> WE were hoping that you and Sebastion, in some combination would generally take over/oversee the morning
18:02:28 <mchua> Let's see if we can hash it out here, I reckon. :)
18:02:38 <heidi> Right, Thats what I thought.
18:02:51 * mchua nods - that was the impression I got also... how long do you have now?
18:02:58 <mchua> (so I know how much to panic about time)
18:03:01 <heidi> The problem is that the Friday morning folks will be 50% from Thursday and 50% new arrivals.
18:03:12 <heidi> Right now I should leave at 2:30.
18:03:15 <heidi> Is that OK?
18:03:23 <mchua> So nothing can depend on Thursday's material, which is ok since we can't be there Thursday during the day anyway. :)
18:03:26 <mchua> Yeah, totally fine!
18:03:42 <heidi> And the idea is that you'd do an activity that you do regularly with POSSE.
18:03:44 <mchua> (we'll be staying in Springfield so we'll be around that evening and can talk at dinner, after dinner, etc. if we need to sync with you and Greg for any reason, for the record.)
18:03:49 * mchua nods
18:03:50 <heidi> Or like what you did with my students when you visited.
18:03:57 <heidi> Yes, right, that sounds good.
18:04:18 <mchua> I can think of a few possibilities - I'll start spewing them out in a moment, but were there any particular takeaways or skills or followups you wanted people to have?
18:04:22 <heidi> Thursday will cover the background on OSS stuff and the more "academic" side of the house.
18:04:45 <heidi> THe ability to make that first step towards getting involved in an OSS project? ;-)
18:04:46 <mchua> There's no way we can get folks ready to lead their classes into a FOSS project in half a day... also, will people have laptops and internet access?
18:05:03 <mchua> Are these folks we'd expect to come to a POSSE for followup, or is this pretty much it for a while for most of them?
18:05:03 <heidi> Yes to internet, but not all folks may bring laptops.
18:05:07 <mchua> Also, background?
18:05:07 * mchua nods
18:05:09 * mchua considers
18:05:10 <heidi> WE will have overhead projection.
18:05:28 <mchua> Awesome. :) I may bring my portable along so we may have two - dual screens are sometimes useful esp. when showing the collaboration side of things.
18:05:35 <heidi> I think that the workshop is a great lead-in to POSSE, but no guarantee that folks would come.
18:05:38 <heidi> Yes, thats good.
18:05:39 <mchua> Right.
18:05:57 <mchua> Okay, so we need to give them the ability to... not necessarily *participate* in a FOSS project right then, but watch and understand what's going on, and ask questions.
18:06:14 <heidi> Yes!
18:06:19 <mchua> Basically, intelligent bystanders who'll be able to spot (and follow-up on) good resources and invitations to start dipping their toes into the water... later.
18:06:29 <heidi> Thats good.
18:06:35 <mchua> It may be another school year before they do - I guess - hm...
18:06:40 <heidi> Yes, right.
18:06:49 <mchua> ...maybe "be able to watch and understand what this year's POSSE cohort is doing" is a good goal.
18:06:52 <mchua> Okay.
18:06:59 <heidi> Yes, but they may get excited and spend the time during the summer getting up to speed.
18:07:02 <heidi> Yes, right.
18:07:07 <mchua> Not everyone will have laptops, but there should be enough to get them into, maybe, 2-4 people per laptop at most?
18:07:12 <mchua> (How many professors are coming?)
18:07:13 <heidi> And some folks will come in with FOSS background.
18:07:20 <mchua> oh, good!
18:07:20 * heidi checking...
18:07:48 <mchua> We've only got 3 hours, from 9-noon, so that's going to be *tight*
18:07:52 <heidi> Yes
18:08:02 <mchua> although we could do a followup dinner on Saturday night if there are interested people, perhaps.
18:08:14 <heidi> And Greg will want some 15 minutes to walk them through the SoftHum site.
18:08:15 * mchua not sure what sort of response that would draw, but would be willing to offer it anyway.
18:08:18 * mchua nods
18:08:22 <mchua> Okay, so I'll think "we have 2 hours for an activity."
18:08:29 <mchua> maybe 90 minutes and then a 30min wrapup
18:08:31 <heidi> Ah, interesting. Might get some takers from the local folks.
18:08:36 <heidi> Yes, thats goodl
18:08:37 <mchua> to give you and Greg time at the start and end to do bigger Workshop Things.
18:09:03 <mchua> #info Workshop is 9-noon on Saturday
18:09:11 <mchua> #info We have 2 hours for an activity and wrapup
18:09:26 <heidi> Yes, and if it bleeds into the remaining hour, thats fine too.
18:09:27 <mchua> #info goal is to give professors the ability to "intelligently watch" and understand what POSSE alumni are doing with thier classes
18:09:31 <mchua> Okay.
18:09:43 <heidi> Yes
18:09:49 <heidi> Oh, and 20 people including ourselves.
18:09:55 <heidi> GIve or take 2
18:10:09 <heidi> And at least a couple of the Friday morning folks are students.
18:10:15 <mchua> #info somewhere around 20 professors, half from Thursday and half new, with varying levels of FOSS experience, and some students.
18:10:22 <mchua> undergrad, grad, FOSS experience, no?
18:10:55 * heidi Ah, the light goes on in Heidi's head about how to use MeetBot
18:11:04 * mchua grins
18:11:14 <heidi> undergrad and I have no idea about FOSS experience.
18:11:14 <mchua> I'm thinking of a rapid-fire live tour of some of these tools and terms...
18:11:18 <mchua> okay, that's cool.
18:11:28 <heidi> Ah, yes, that sounds quite good.
18:11:44 <mchua> heidi: how does http://blog.melchua.com/2010/10/08/possesa-fri-5-minutes-of-improvisation/ look to you?
18:11:52 <mchua> we did that at the end of South Africa's POSSE
18:11:59 * heidi looking
18:12:13 <mchua> so the difference here is that in SA, they had already seen all the tools, learned the basics of them, etc. and this was a "how it all fits together" demo
18:12:31 <heidi> Yes, good!
18:12:33 <mchua> but here, what we could do is do the demo first - set a timer, have a live open source project the audience is interested in...
18:12:40 <heidi> Sure.
18:12:44 <mchua> ...and then go through and dissect each of the things we happened to hit in the first 5 minutes.
18:12:48 <heidi> Another aspect is convincing faculty that they can do this.
18:12:50 * mchua nods
18:12:52 <heidi> Right.
18:13:03 <mchua> are you and Greg going to be talking more about the academic side - grading, assessment, etc - Thursday?
18:13:25 <mchua> Because if so, then Sebastian and I can concentrate purely on "so this is how *any* new contribution would get started in *any* project" aspect
18:13:28 <heidi> I think that one key piece is for faculty to walk away with the idea that even if they don't get an in-depth experience with the tools, that they can pick them up on their own.
18:13:35 <mchua> (which is, arguably, where we're more credible - I mean, neither of us have PhDs)
18:13:38 * mchua nods
18:13:49 <heidi> #info Greg and Heidi will be talking about the academic side on Thursday
18:13:57 <mchua> Okay, so we should have resources and handouts pre-loaded with references and tutorials to tools we think we may be using/hitting along the way.
18:14:03 <heidi> Yes.
18:14:08 <mchua> heidi: You got meetbot. :) awesomeness.
18:14:18 <heidi> :-) I'm learning!
18:14:35 <mchua> heidi: okay, so a handout like... perhaps... http://mchua.fedorapeople.org/talks/2011-posscon/ but expanded and modified.
18:14:54 <mchua> heidi: we got a *great* response to the "study away" metaphor at POSSCON (and actually, anywhere else I've used it)
18:15:02 <mchua> so we'll probably draw on that one again.
18:15:06 * heidi looking
18:15:47 <heidi> Yes, yes, yes!
18:15:50 * mchua beginning to coalesce a picture here
18:15:54 <heidi> The POSSCON handout looks really good.
18:16:06 <mchua> Ok, so let me spin this by you as a first run... I think I can see a 2-hour activity here.
18:16:13 <heidi> And being last minute as we are, we don't have materials yet.
18:16:16 * mchua chuckles
18:16:32 <heidi> And I can make copies before Friday.
18:16:36 <mchua> Yeah, I'm starting to get into the habit of producing artifacts at every event so we can use them later, since I know I'm uber-improvisational :)
18:16:54 <mchua> heidi: oh, that reminds me - POSSE advertising for NCC... we need to make a call on that soon but I'm guessing you're all hosed with the upcoming conf.
18:17:03 * mchua also happy to stop by Kinko's on her way to Springfield!
18:17:10 <mchua> but, er.
18:17:11 <heidi> OK, I'll let you konw.
18:17:18 <mchua> #topic 2 hours, first story pitch
18:17:29 <heidi> mchua: Yes, I'm really hosed getting ready for this conference.
18:17:32 <mchua> we come in, give a brief framing of "open source as study abroad"
18:17:39 <mchua> heidi: I imagine - please tell me you'll sleep afterwards...
18:17:45 <heidi> But I'm hoping to get this figured out when we meet for the CE21 meeting, perhaps Friday afternoon?
18:17:51 <mchua> maybe 5 minutes, it shouldn't take long for people to get the analogy
18:18:07 <mchua> heidi: Erp. Friday afternoon Sebastian's got to be back in class, but I could theoretically drive back after I drop him off at Olin
18:18:09 <heidi> mchua: Yes, sleep is definitely in the schedule!
18:18:15 <mchua> we're heading back early Saturday morning.
18:18:18 <heidi> Oh, right, forgot that!
18:18:29 <heidi> Does he have his license yet?
18:18:32 <mchua> I mean, I could easily grab him after class for Skype.
18:18:35 <mchua> heidi: a German one, yeah :)
18:18:42 <heidi> :-)
18:18:44 <heidi> Right.
18:18:46 <mchua> that's the problem... also, rental car companies in the suburbs won't rent to folks under 21
18:19:15 <mchua> ...nor will Zipcar, unless there's an on-campus program, and a 300-student campus in the burbs isn't really on the top list of sites for a zipcar.
18:19:18 <mchua> anyhoo.
18:19:24 <mchua> so, intro to the "abroad" analogy
18:19:28 <heidi> Well, if he can drive a stick one thought would be to send him back with my car as he'll be back on Saturday.
18:19:36 <mchua> heidi: he *can* drive manual.
18:19:37 <mchua> I believe.
18:19:59 <heidi> I'm ignorant on driving laws. Does his German license allow him to drive in the US?
18:20:13 <mchua> heidi: it might be worth texting/calling him about as an option - I've mostly resigned myself to a chaffeur role until he's got a SSN this summer and can apply for a conversion to a MA license.
18:20:33 <mchua> heidi: that's the fuzzy part - there's DMV bidirectionality between the 2 countries
18:20:47 <heidi> Ah, OK.
18:20:49 <mchua> so German tourists can drive in the US, and German residents can get their German license converted to a MA one without needing to take a road test...
18:21:10 <mchua> ...but after poring through the docs there's no provision for international students unless you get a SSN and then go for the license shift.
18:21:14 <heidi> Hmmm, but that might take more time than we have.
18:21:17 <mchua> so it's more of a playing-it-safe thing.
18:21:17 <mchua> yeah.
18:21:21 <heidi> Ah, OK.
18:21:25 <heidi> So no fuss.
18:21:28 <mchua> yeah.
18:21:52 <heidi> Would it work for you to Skype from Olin on Friday afternoon?
18:21:54 <mchua> Basically, I think it's safer if I do the driving for this round... but you could talk with him about it.
18:21:58 <mchua> It would work for me.
18:22:01 <mchua> I can ask Sebastian.
18:22:12 <mchua> #action mchua see if sdziallas can skype re CE21 Friday afternoon
18:22:18 <heidi> OK, lets tentatively plan that.
18:22:20 <heidi> :-)
18:22:21 <mchua> coolness.
18:22:37 <mchua> so, for the activity... frame it as study abroad, hand out the sheet of terms and tools "we might enconter in the wild"
18:22:42 <heidi> Is there a quick way to see what the meetbot has while it is still going on?
18:22:49 <heidi> Yes, I like that.
18:22:56 <mchua> (it will only make sense to experienced folks, which is okay - so they won't be bored when we start diving in)
18:23:08 <mchua> and then have the audience shout out a FOSS project
18:23:24 <mchua> and one of us dives in and thinks-out-loud while the other annotates on the board, etc
18:23:31 <heidi> Yes, and the general approach fits in with the "FOSS Fieldtrip for Faculty" which is the name of the workshop :-)
18:23:32 <mchua> possibly switch, to see 2 different approaches if there's time
18:23:33 * mchua nods
18:23:34 <mchua> oh, awesome!
18:23:43 <heidi> Yes, right! I think this is going to be awesom!
18:23:51 <mchua> and then afterwards, just rewind and review everything we went through in those 5-10 minutes, chronologically, unwinding that experience.
18:24:13 <heidi> Yes, I think so.
18:24:20 * mchua not sure how to follow-up with calls-to-action on that, but talking about POSSE and where-you-can-follow-the-cohort would probably be an easy one, that and "join the TOS list"
18:24:24 <mchua> EOF
18:24:27 <mchua> (I know you need to go to class soon)
18:24:28 <heidi> Yes, right.
18:24:43 <mchua> does that sound ok, anything you'd like more fleshed-out, resources other than an updated handout you'd like us to make/prepare?
18:24:53 <heidi> I'm actually heading home to pick Connor up so that he can get soccer socks before his 5:00 practice :-)
18:25:05 <mchua> or tools, etc. you definitely want us to hit along the way? basically, we'll improvise otherwise :D
18:25:09 * mchua grins
18:25:14 <mchua> well, socks are important!
18:25:23 <heidi> I think it sounds fine. Lets shoot what we have to Greg so that he is in the know.
18:25:29 <mchua> I'll send this log to the crew.
18:25:33 <heidi> OK, great.
18:25:48 <heidi> And you got the directions to the restaurant for Thursday evening?
18:25:51 <mchua> Yep yep.
18:25:59 <mchua> They're somewhere in my inbox, which is being shoveled out with a bulldozer.
18:26:02 <heidi> OK, good.
18:26:07 * heidi laughing!!!
18:26:18 <mchua> It reminds me of the Herculean stable-cleaning task every time.
18:26:30 <heidi> I thought that pesky email 'whack-a-mole' problem was only me!!
18:26:32 <heidi> Right!
18:26:36 <mchua> Thanks for having us this weekend, Heidi - and for trusting us with Friday morning! We're psyched. :)
18:27:03 <heidi> Me too! And I'm sure Greg is too. Or will be once he gets done with his taxes :-)
18:27:12 <mchua> no, really, I'm amazed - and grateful - to you and Greg for taking us under your wing and helping us learn the ropes of this crazy new academic world.
18:27:15 * mchua nods
18:27:15 <mchua> eeeeee, those. Yeah.
18:27:19 <mchua> I think I'm done, need to check...
18:27:25 <heidi> OK, thanks so much. Let me know if you need anything further and we can touch base on Thursday.
18:27:26 <mchua> Good luck to Greg. :)
18:27:30 <mchua> I'm good - you?
18:27:32 <heidi> I'll pass that along.
18:27:42 <heidi> Yup, I'm very good, now that I've talked with you.
18:27:48 <mchua> woo!
18:27:53 <heidi> A pleasure, as always. :-)
18:27:57 <mchua> Likewise. :)
18:28:04 <heidi> OK, wish me luck on my sock hunt. And safe travels.
18:28:07 <mchua> *Japanese-style bow*
18:28:11 <heidi> :-)
18:28:12 <mchua> Good luck on the sock hunt!
18:28:18 <mchua> See you on Thursday. :)
18:28:23 * mchua --> office
18:28:25 <mchua> #endmeeting