01:16:37 <mchua> #startmeeting
01:16:37 <zodbot> Meeting started Wed May  4 01:16:37 2011 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:16:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
01:16:39 <mchua> #chair ctyler
01:16:39 <zodbot> Current chairs: ctyler mchua
01:16:46 <mchua> #meetingname POSSE RIT planning
01:16:46 <zodbot> The meeting name has been set to 'posse_rit_planning'
01:17:05 <mchua> #topic agenda
01:17:24 <mchua> #info 1) make sure ctyler's travel logistics will be taken care of
01:17:47 <mchua> #info 2) make sure ctyler and dshein know how they'll work together to prepare for teaching
01:18:11 <mchua> #info 3) make sure we know what curriculum/material development, setup, etc. needs to happen to give ctyler and dshein the informational resources they need for teaching
01:18:25 <mchua> #info 4) make sure we know what *people* resources need to be where, remotely, for POSSE RIT
01:18:32 <mchua> ctyler: anything else? that's what I had.
01:18:44 <ctyler> sounds good
01:18:54 <mchua> #topic ctyler's travel logistics
01:18:58 <mchua> ctyler: okay, so. fill me in here. :)
01:19:40 <mchua> if this is "I know how I want to get where, when - I'll send you an email, Mel" that's totally cool - I just wanted to make sure we were booking what we need to book for you both transit and hotelwise.
01:19:48 <mchua> also, do you need a car, etc. etc.
01:20:43 <ctyler> I'll be there! That's about as far as I've thought through logistics. I'm at Linux Symposium the week before, then I think catching up with jonmasters after Andrew's wedding, then a crazy weekend, then down to POSSE RIT
01:21:08 <ctyler> Think I might rent a car and drive.
01:21:28 <mchua> ctyler: okay - you know how to find me for the magic credit card fu when the time comes.
01:21:40 <mchua> ctyler: and we'll figure out your hotel then as well, if that works out for ya.
01:22:03 <mchua> just wanted to make sure I wasn't inadvertently blocking you or anything - and immigrations wise it's canada-US so there's no special stuff to do.
01:22:07 <mchua> (afaik)
01:22:13 <mchua> ctyler: worksforyou?
01:22:42 <ctyler> On the expenses front, I'd be glad to have the stipend paid up front, I'll cover things from that and settle up after.
01:22:58 <mchua> ctyler: understood - I'll see if I can make that happen.
01:23:07 <mchua> #action mchua see if we can get instructor stipends paid up-front
01:23:41 <mchua> #info ctyler can book his own travel and settle up financials afterwards if stipend is paid up-front
01:23:49 <mchua> ctyler: anything else? I'm EOF on this
01:24:03 <ctyler> No, that's it.
01:24:07 <mchua> okeydokey.
01:24:17 <mchua> #topic ctyler and dshein syncing up re: teaching beforehand
01:24:35 <mchua> ctyler: have you and dave gotten to talk at all? I think it's just about time to start regular meetings, although I know you two are also in the throes of finals.
01:24:51 * mchua mostly doesn't want to leave everything to the last minute, and wants to get you in the same chatroom or phone call Real Soon Now
01:25:00 <mchua> (preferably IRC channel, because I think the transcript would be really useful to have.)
01:25:09 <ctyler> I'll catch up with dshein this week and we'll plot our course. I don't anticipate any challenges there.
01:25:12 * mchua nods
01:25:17 <mchua> sounds good to me :)
01:25:36 <mchua> ctyler: I'm going to basically step back and let you two do your thing, but if there's something you'd like or need me for, I'm at your service.
01:25:37 <ctyler> Large group this time
01:25:40 <mchua> Oh yes.
01:25:43 <mchua> Large and diverse.
01:25:44 <ctyler> We'll adjust for that.
01:25:47 <ctyler> :-)
01:26:00 <ctyler> Good opportunity to demonstrate that there are many ways to get involved in OS.
01:26:15 <mchua> ctyler: Yeah, I would suggest that at your first meeting that you and Dave go through the applications together and figure out how you'd like to adjust and where you might see people fitting in.
01:26:27 <mchua> and what sort of support you'd like for that - i.e. do we need design, docs, etc. people on call on a certain day, and so forth.
01:26:28 <ctyler> Will do.
01:26:33 <mchua> think of me as your remotee minion.
01:27:24 <mchua> ctyler: I'd also suggest if you have a chance emailing profs or asking Dave to find and talk with them in person pre-POSSE to set some expectations about what they individually might be focusing on
01:27:35 <ctyler> Actually, I think we can cover things, we have good connections in the community.
01:27:48 <mchua> +1 - even better!
01:27:50 <ctyler> Yes, we'll probably pingmail them.
01:28:16 <mchua> #idea first Dave-Chris meeting should involve going through applications and pinging individual attendees
01:28:37 <mchua> #note Chris and Dave have excellent Fedora connections and should be able to pull whoever they need in
01:29:19 <mchua> ctyler: anything I can do to help you folks, data you need hunted down, things you need written up, etc... let me know.
01:29:30 <ctyler> Definitely! :-)
01:29:30 <mchua> ctyler: any other thoughts, ideas, questions?
01:29:52 <ctyler> I think I'm good to get rolling on this.
01:29:58 <mchua> My base assumption is that the two of you have totally got this covered and will do an even more kickass job of teaching than I will ;)
01:30:08 <mchua> #topic things to prep
01:30:09 <ctyler> Semester's over and I'm completely switching gears, btw.
01:30:13 <mchua> ctyler: nice!
01:30:22 <mchua> ctyler: okay, anything you know you're gonna need?
01:30:33 <mchua> (I'd expect this list to grow considerably once you and Dave get together and go through apps, but...)
01:30:51 <mchua> for instance, one thought is that it might be good to have people set up FAS accounts in advance this year
01:30:51 <ctyler> Not that I know of at this point, but Dave and I will definitely keep you in the loop.
01:31:05 <mchua> do you need to check with Steve that Fedora-booted laptops will still be available? are you assuming that?
01:31:23 <mchua> do we need to make a custom kickstart so you'll have $favorite_tools there?
01:31:24 <ctyler> I forgot about that actually!
01:31:46 <mchua> #info need to ensure building has wifi with ssh, irc ports open
01:32:00 <mchua> #info need to ensure non RIT attendees have parking passes and access permits
01:32:07 <mchua> ctyler: so yes for laptops pre-prepped?
01:32:12 <mchua> ctyler: and if yes, what with?
01:32:13 <ctyler> All of this depends on what projects focus we decide upon. Custom kickstarts are straightforward.
01:32:28 <mchua> right, so you know you'll need one but you don't know what exactly with yet 'till you and Dave sit down and talk.
01:32:34 <ctyler> mchua: We'll take care of that with Steve. Basically, I think we're good to run with this from this end.
01:33:02 <mchua> #info need to ensure laptops are available and prepared with Fedora; kickstart needs to be determined
01:33:12 <mchua> ctyler: ok, so all that stuff is on your plate, or is there anything you'd like me to take?
01:33:29 <ctyler> I'm good with it.
01:33:46 <mchua> #action ctyler take lead on making sure infrastructure requirements are taken care of by RIT
01:34:01 <mchua> ctyler: ok - teaching materials? exercises, assignments, slides, etc?
01:34:23 <mchua> ctyler: we've got that little pow-wow in massachusetts to work on a bunch of student materials in 2 weeks exactly
01:34:25 <ctyler> We're good, will remix what's out there.
01:34:48 <ctyler> Looking forward to seeing the results of that.
01:34:52 <mchua> so if you want something done, we can take particular requests
01:34:55 <mchua> Yeah, me too. :)
01:35:29 <mchua> ctyler: you're also under no obligation to use the stuff, although... I mean, hopefully they'll be helpful! because if they're not useful to you, then we're doing something wrong!
01:35:43 <mchua> ctyler: which syllabus/outline are you going to follow, do you know?
01:36:06 <mchua> ctyler: we've got http://teachingopensource.org/index.php/POSSE_curriculum right now
01:36:24 <mchua> #link http://teachingopensource.org/index.php/POSSE_curriculum
01:36:49 <mchua> #info several TOS professors will be getting together to hack on student learning materials 2 weeks from now, will try to make as useful as possible for POSSE RIT
01:37:08 <ctyler> Between that, TOSW, the Seneca wiki, and some other resources, I think we're well-set.
01:38:08 <mchua> ctyler: Me too. I'd love to hear your thinking-out-loud about the pulling together of these resources whenever possible, because I'd like to learn from 'em for the July POSSE, but that may be better done in one or two "let me pick your brain" braindumps with you and Dave in June
01:38:14 <mchua> (one before the POSSE, one after)
01:38:23 <mchua> nothing that should interrupt your flow of actually doing it
01:39:00 <mchua> and it also sounded like you were all set for people since you know everyone in Fedora already :)
01:39:08 * mchua is EOF for tonight
01:39:12 * ctyler doesn't know *everyone* :-)
01:39:23 <mchua> okay, okay, "a lot of people" :)
01:39:30 <ctyler> so off-topic for a minute, catch up on a couple things?
01:39:35 <mchua> Sure.
01:39:39 <mchua> ctyler: should we wrap logs first?
01:39:44 <ctyler> #topic off-topic catchup
01:39:49 <mchua> oh, ok :)
01:39:50 <ctyler> nah, this can log
01:39:57 <mchua> go for it
01:40:27 <ctyler> So a quick update on the last semester: had a great group through SBR600.
01:40:34 <mchua> woo!
01:40:38 <ctyler> Started with 32, turned away applicants.
01:41:04 <ctyler> As usual, had a number that got overwhelmed and didn't complete, but we got some great stuff done.
01:41:40 <ctyler> Some packages in Fedora, some still in the works; new infrastructure for the Fedora-ARM project; documentation of stuff that was poorly or un-documented.
01:42:24 <mchua> That's awesome! btw, every time I talk with professors I show them planet cdot as a great example of a cross-class campus foss ecosystem.
01:42:27 <mchua> (and a planet, too)
01:42:44 <ctyler> Monday this week we welcomed the new CDOT research staff starting for the summer; total of 20 students/co-ops/graduates plus 6 faculty working in CDOT now.
01:43:17 <ctyler> Five (four+me) working on Fedora-ARM, I'm pretty pumped about it.
01:43:35 <mchua> Whoa!
01:43:52 <ctyler> The place is hopping, we're packed out all the cubicles and started using some on the other side of the building.
01:44:46 * mchua wishes there were a "day in the life of cdot" vid from this coming summer
01:45:11 <ctyler> But I was thinking recently, we should get you to observe/follow a SBR group through a semester, hang out in the channel, etc.
01:45:47 <mchua> Hrm... that would be pretty sweet, actually. I wonder if I could use some of the observations for my Purdue coursework too.
01:45:59 <ctyler> Doubleplusgood.
01:46:10 * mchua doesn't know at least half the material, if not more, in SBR though, and would have to scramble to keep up with understanding - not a bad thing though.
01:46:23 <mchua> there's the in-person component of the class, though, and that would be harder to catch/capture
01:46:38 <mchua> unless the intent is to try and get an outside impetus to capture and explain more of that for the distributed community as well?
01:47:38 <mchua> ctyler: but... basically, yeah, I'd love to! did you have any particular timeframe in mind?
01:47:44 <ctyler> When I posted the Lab URL the other day it seemed that you hadn't seen that, and I haven't seen you in channel, I think it would be useful for you to see (more closely) how we do things and for us to get an outside perspective on it.
01:47:56 <ctyler> September is the next SBR group.
01:47:57 * mchua is attempting not to overcommit for fall b/c she doesn't know what the load will be like then with work & school
01:48:04 <mchua> (but I'd be really, really happy to at least start lurking)
01:48:12 <mchua> September works nicely, I start school end of August.
01:48:17 <ctyler> I think it's a scalable thing, basically lurking, yes.
01:48:50 <mchua> I'd love that.
01:48:51 <ctyler> You're welcome to lurk this summer too, via #seneca and #seneca-cdot on Freenode and #seneca on moznet.
01:49:10 <mchua> ctyler: noted :)
01:49:30 <ctyler> Anyways, we're having wayyyy too much fun up here.
01:49:49 * mchua grins. so ctyler should I just ping you in August and say "hey, where should I lurk?"
01:50:01 <ctyler> Certainly!
01:50:04 <mchua> (I'm joining channels now, but guessing there's a list and etc as well in addition to the wiki)
01:50:15 <mchua> okeydokey. putting that in a future-email queue right now.
01:50:30 <mchua> many thanks!
01:50:46 <ctyler> Thank you :-)
01:51:17 * ctyler thinks about the "Day in the Life of CDOT" video idea
01:51:40 <mchua> #idea day in the life of cdot video
01:51:41 <ctyler> Serve that up with some Popcorn.js
01:51:56 <mchua> #note mchua should lurk SBR at CDOT next school year
01:52:02 * mchua chuckles
01:52:19 <mchua> ctyler: anything else for the night? I've just about run my brain out of stuff.
01:52:34 <ctyler> No, that's a wrap!
01:52:37 <ctyler> Thanks Mel.
01:53:03 <mchua> ctyler: thank *you*, Chris - I'll shoot the notes to list and ask about finance things tomorrow at the office.
01:53:18 * mchua learning that Finance Takes Forever, so... >1mo in advance == goodness
01:53:31 <mchua> rock on.
01:53:33 <mchua> #endmeeting