02:47:41 <mchua> #startmeeting
02:47:41 <zodbot> Meeting started Tue Jul 19 02:47:41 2011 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:47:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
02:47:43 <mchua> #chair ianweller
02:47:43 <zodbot> Current chairs: ianweller mchua
02:48:08 <ianweller> #link http://tickets.teachingopensource.org/projects/infrastructure/issues
02:48:43 <ianweller> so the big news of today was etherpad
02:48:48 <mchua> are the current tix up to date?
02:48:58 <mchua> yeah, I need to test it out but AWESOMENESS and many thanks to you and sdziallas_afk for that!
02:48:59 <ianweller> afaik, yes
02:49:10 <ianweller> up to you on whether or not you want to close the etherpad ticket
02:49:27 <ianweller> we can still shoot for getting etherpad installed (or perhaps, even moved?) to TOS
02:49:29 <mchua> make it "pending feedback" or whatever that status is
02:49:31 <ianweller> allegheny07
02:49:31 <ianweller> 01*
02:49:43 <ianweller> it would not  be difficult to move the databases and set up some 301 redirects
02:49:48 <mchua> ianweller: ah, no, I know why etherpad tix shouldn't be closed quite yet
02:49:51 <mchua> ianweller: backups
02:49:55 <ianweller> hah
02:50:01 <mchua> automated
02:50:04 <mchua> daily at minimum
02:50:06 <ianweller> okay.
02:50:14 <ianweller> i assume everything is done in mysql. i can ask sdziallas_afk about that
02:50:18 <mchua> verify that saving the mysql db = backing up
02:50:21 <ianweller> so backups would be easy
02:50:30 <mchua> and then write a cron job
02:50:31 <mchua> yeah
02:50:44 <mchua> ianweller: I asked him earlier; he doesn't know, but assumes that's likely the case.
02:50:47 <mchua> it would be good to test that
02:51:02 <ianweller> create a test install somewhere, import the old db, and see if it works
02:51:06 * mchua nods
02:51:15 <ianweller> mchua: will you note that on the ticket?
02:51:22 <mchua> ahead of ya :)
02:51:27 <ianweller> woo
02:52:24 <ianweller> mchua: aside from that, i'm still poking at 26
02:52:27 <ianweller> it's going slowly
02:52:32 <ianweller> as mediawiki themes do
02:52:48 <ianweller> mchua: i should also note that i couldn't actually find the posse logo in the zip file that you forwarded to me.
02:53:16 <mchua> er.
02:53:32 <ianweller> i really do like the rest of hte logos that you did send (pictograms inside the owl shape)
02:53:36 <ianweller> those rock
02:54:27 <ianweller> mchua: i think i'm going to make a shirt with the "BEING LAZILY PRODUCTIVE" pictogram on it
02:54:32 * mchua grins
02:54:38 <mchua> I was hoping for the ninja owl
02:54:42 <mchua> I would do the ninja owl.
02:54:44 <mchua> anyhow.
02:54:56 <ianweller> (we could make these things happen.)
02:54:58 <ianweller> (carry on)
02:55:05 <mchua> does 26 really need to be a mw theme? I mean, it seems... easier... to... just hand-code a static frontpage
02:55:13 <mchua> but that's me not being a web design ninja, likely
02:55:26 <ianweller> mchua: it's not normally that hard, i just keep getting distracted for the most part
02:55:38 <ianweller> mchua: i'd rather we have it in mediawiki, and make mediawiki our front page, than have a static front pgae
02:56:29 <ianweller> mchua: but honestly, i could get it done tomorrow, especially if allegheny01 doesn't come up and nothing catches on fire
02:57:12 <mchua> Okay. I'm curious about why mw over static frontpage, but maybe I don't see advantages so much to user-editability of that
02:57:28 <mchua> and think that not having to do the overhead of mw will make it much cleaner & simpler
02:57:36 <ianweller> we can discuss it on the list
02:57:36 <mchua> I mean, fedoraproject.org is a static frontpage
02:57:46 <mchua> so the thing is, you're the one doing the work
02:57:57 <mchua> so however is actually the fastest and simplest way for you to get it done
02:58:00 <mchua> is how it ought to be done
02:58:16 <mchua> I theorize that a static frontpage is faster and easier than an entire mw theme, but that's just me and I could be wrong
02:58:22 <mchua> and the final arbiter of that is you.
02:58:22 <ianweller> the fastest way is oft not the right way
02:58:34 <ianweller> plus, i feel like we will be integrating ptkb into mediawiki down the road anyway
02:59:04 <mchua> Okay. Can we say... if you don't get the mw skin done by the time you sleep tomorrow -- for whatever reason -- we'll go with a static, just to make sure something's up?
02:59:13 <mchua> that way, if it really does take a day, it gets Done Right
02:59:24 <ianweller> i think we can say that
02:59:34 <ianweller> i also think we need to discuss, at some point, on the list whether we do static or mw
02:59:39 <mchua> but if random things come up unanticipated, then we know that a temporary fix at least will not take more than a day
02:59:47 <mchua> and at latest we'll have a nice frontpage by thurs morning.
02:59:50 <mchua> agreed.
02:59:53 <mchua> so, shall we note that?
03:00:10 <ianweller> #action ianweller attempt to finish mw theme by tomorrow; if fail, do static page
03:00:23 <ianweller> #action ianweller bring up whether to have static home page or mw home page on list
03:00:49 <ianweller> mchua: that will be my goal #1 tomorrow then.
03:00:57 <mchua> ianweller: excellent, I'd say that's the right priority.
03:01:14 <mchua> ok. so etherpad is up, and backups will be happening
03:01:24 <mchua> (that's high *importance* but it's not urgent -- it can wait until weekend or after that)
03:01:37 <mchua> TOS frontpage is the most important *and* urgent right now
03:01:46 <mchua> meetbot is going to happen tomorrow
03:02:06 <ianweller> (hopefully)
03:02:08 <mchua> ianweller: so, re meetbot; if it does go up tomorrow, can you just take 20 minutes and get it in here and get me admin rights to it
03:02:23 <mchua> and then go back to the mw skin and let me handle the bot, because I've installed & configured & adminned zodbot before?
03:02:32 <ianweller> if meetbot does go up tomorrow it will take me 5 minutes to make it happen
03:02:35 <mchua> (basically, once it's out of OSU's hands, just give it to me)
03:02:37 * mchua nods
03:02:49 <ianweller> problem is, meetbot is on tos.osuosl.org, and you don't have ssh access to that last i recall
03:02:54 <mchua> I do not
03:02:57 <mchua> Should I?
03:02:57 <ianweller> so.
03:03:00 <ianweller> you probably should.
03:03:06 <ianweller> that will probably happen after deadline
03:03:08 <ianweller> ;)
03:03:28 <ianweller> mchua: once OSUOSL gets me what i need it will take five minutes of my time to get it in here and ready to log meetings
03:04:13 <mchua> okay.
03:04:14 <mchua> excellent.
03:04:32 <ianweller> and i sent a ping to jadudm about an IP address for the server, if it's possible to get that ahead of time
03:04:35 <ianweller> so i can set up necessary things
03:04:42 <ianweller> like an iline.
03:04:56 <mchua> ianweller: given that TOS frontpage may take Tues + Weds to finish and get up and running, and outstanding items re supybot and etherpad backups, how are we looking on the irc proxy?
03:05:09 <ianweller> irc proxy blocks on getting the iline
03:05:21 <ianweller> we can't connect too many clients to freenode before that gets set up and confirmed
03:08:10 <mchua> Okay.
03:08:20 <mchua> ianweller: when will we have a go-nogo on bip?
03:08:30 <mchua> I assume that bip itself is easy for you to setup now that you've done it
03:08:32 <ianweller> mchua: whenever you want a go-nogo
03:08:33 <mchua> and that the question is the iline.
03:08:40 <mchua> fri morning
03:08:45 <ianweller> can do
03:08:50 <ianweller> please note in ticket
03:08:55 <ianweller> because i promise i will forget
03:17:58 <mchua> ianweller: done. what else?
03:18:15 <mchua> ianweller: I think that covers everything for pre-POSSE.
03:18:18 <ianweller> mchua: i can't think of anything else.
03:18:20 <mchua> the 2 immediate things after this weekend are going to be
03:18:23 <mchua> 1) rit posse list
03:18:26 <mchua> (already in the tracker)
03:18:33 <ianweller> (and already in OSUOSL)
03:18:34 <mchua> and 2) whatever individual infrastructure needs professors bring with them
03:18:37 * mchua nods
03:18:39 <ianweller> mchua: oh the last thing is, email me the actual POSSE logo ;)
03:18:53 <mchua> ianweller: what does your availability look like this weekend & next week for TOS infra stuff?
03:19:10 <mchua> I know you are at RDU and need to deal with the team box, but do not know how much bandwidth you have for this.
03:19:16 <ianweller> next week, sunday, tuesday and wednesday afternoon are out
03:19:21 <ianweller> friday is most likely out
03:20:18 <mchua> ianweller: do you think you might be about saturday?
03:20:27 <ianweller> mchua: if i'm not packing, probably
03:20:38 <ianweller> or doing last minute stuff for salina wifi project
03:20:46 <mchua> ianweller: okay, so we'll play it by ear
03:20:50 <ianweller> yup
03:20:55 <mchua> I'll find you if you're around and we can take down individual infra requests.
03:20:58 <mchua> good good.
03:21:00 <mchua> and we'll figure out the timing of that later.
03:21:03 <mchua> all right, with that I'm EOF
03:36:06 <mchua> #endmeeting