14:01:23 <mchua> #startmeeting
14:01:23 <zodbot> Meeting started Wed Sep  7 14:01:23 2011 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:26 <mchua> #chair heidie sdziallas
14:01:26 <zodbot> Current chairs: heidie mchua sdziallas
14:01:31 <mchua> #meetingname Heidi Ellis POSSE coachin'
14:01:31 <zodbot> The meeting name has been set to 'heidi_ellis_posse_coachin''
14:01:44 <mchua> Sweet.
14:01:50 <heidie> Yeah!
14:01:56 <mchua> Okay -- as this is the first session, let's see if we can get the stuff out on the table we want to go through...
14:02:03 <heidie> Yes.
14:02:13 <mchua> Heidi, one thing I know that's been up is project selection -- is Cheese the right one to go for, how long is too long to spend on setup, etc?
14:02:34 <heidie> Yes, exactly.
14:02:54 <heidie> That is my main question.
14:03:07 <mchua> Anything in particular on that front you want to address, or anything else? I also had a few administrative questions about how you'd like us to follow your class, infrastructure, etc. & scheduling for these meetings for the rest of the semester, but that can wait 'till end.
14:03:08 <heidie> mchua, as I'm in my second week and need to make a decision, fast.
14:03:20 * mchua nods. What are the students doing right now?
14:03:33 <heidie> I had a question for Sebastian about coordinating guest speakers.
14:03:40 <heidie> So that can wait until he gets back.
14:03:43 <mchua> Ok, so we'll note that for when... yup.
14:04:07 <heidie> Syllabus: http://mars.wnec.edu/~hellis/CS490/syllabus.html
14:04:16 <mchua> ...I was just about to ask about that. :)
14:04:19 <mchua> How many students this term?
14:04:29 <mchua> #link Connecting to iTunes U.
14:04:29 <mchua> Loading
14:04:29 <mchua> Purdue University
14:04:29 <mchua> Purdue University
14:04:33 <heidie> Eleven students, 9 CS, 2 Computer Engineering
14:04:36 <heidie> :-)
14:04:37 <mchua> ...that was not what I was going to paste. Er.
14:04:46 <mchua> #link http://mars.wnec.edu/~hellis/CS490/syllabus.html
14:04:47 * heidie chuckling
14:05:23 <mchua> Ok -- I see cultural overviews and project assessments, blog creation right now -- that's awesome.
14:05:27 <mchua> (Would you like a Planet set up?)
14:05:28 <heidie> And what I did last year:
14:05:31 <heidie> #link http://mars.wne.edu/~hellis/CS490/syllabus%20fa10.html
14:05:41 <heidie> Ah, I've had my students sign up for TOS planet.
14:06:06 <heidie> Sure, a planet for our stuff would be wonderful!
14:06:21 <mchua> #action mchua get up a Planet for heidie
14:06:23 <heidie> I'm having them blog as part of some homework so that would make grading easy.
14:06:49 <heidie> Other administrative stuff?
14:06:49 * sdziallas waves.
14:06:54 <sdziallas> (reading backlog.)
14:07:00 <mchua> heidie: I'll get that planet up for you before 9/13 when folks have to submit their blog urls.
14:07:05 <heidie> sdziallas: Hey, hope its good coffee.
14:07:09 <heidie> Great!
14:07:27 <mchua> heidie: last admin question -- do you want an IRC logging bot set in any channel?
14:07:32 <sdziallas> http://mars.wnec.edu/~hellis/CS490/syllabus.html
14:07:34 <sdziallas> http://mars.wnec.edu/~hellis/CS490/syllabus.html
14:07:45 * sdziallas sighs, openes the syllabus.
14:07:50 <mchua> whether that's #wne if you want a school channel, or the channel of whatever project you pick (with the consent of the channel moderators)
14:08:25 <mchua> and after that we should probably dive into project selection now that sdziallas is back :)
14:08:25 <sdziallas> heidie: "I'm a college student, as long as it's coffee..."
14:08:49 <heidie> :-) Right!
14:09:04 <sdziallas> Alright, project selection, huh?
14:09:05 * heidie pondering meet bot and channels
14:09:07 <mchua> sdziallas: That is so not what you told me about hotel coffee. You do have things like "taste" and "standards." :P
14:09:11 <sdziallas> I read the post on TOS...
14:09:14 <heidie> :-) right!
14:09:24 <heidie> And yes, I'm floundering a bit.
14:09:25 <mchua> heidie: it's something that's easy to set up so no worries if you don't know now -- just wanted to point out that it's an option. :)
14:09:27 <heidie> And learning asl well.
14:09:31 <mchua> Always good!
14:09:31 * sdziallas grins. That's why I put quotes around it. I like the coffee here, mostly.
14:09:44 <mchua> #topic project selection
14:09:59 <heidie> This is one of those "lessons learned".
14:10:29 <heidie> I should have thought about infrastructure issues during project selection,.
14:10:44 <mchua> so, heidie -- you've been trying to get GNOME Cheese as the class project, but even setting it up is a challenge (as you wrote to TOS) -- is that right? Can you tell us a little more about what's going on?
14:10:51 <heidie> I can't get a good feel as to how well videocams work with VB.
14:10:54 <heidie> Sure.
14:10:54 <mchua> #note Think about infrastructure issues during project selection -- is it hard to set up & install?
14:11:07 <mchua> heidie: er, usually VB + hardware == ouch... based on my personal experience.
14:11:12 <sdziallas> heidie: well, to some extent, you... well, anybody can't really know that Gnome 3 is not doing well with Ubuntu...
14:11:14 <mchua> virtualization does not take well to having random things plugged into it.
14:11:24 <heidie> mchua, yes, this is what i'm learning, too late.
14:11:28 * sdziallas nods. Would it be an option to drop the virtualiztion?
14:11:34 <sdziallas> (and still go ahead with cheese?)
14:11:48 <mchua> heidie: but it's a good lesson to learn, and a good lesson for your students too -- there isn't some All Knowing Source of Excellent Projects
14:12:03 <heidie> Ah, so the issue is that students have almost exclusively Windows machines. I've got a couple with dual boot.
14:12:05 <mchua> you do have to poke and find out whether things work or not, and... that's exactly what you're doing, exactly the right way, asking questions and everything.
14:12:13 <sdziallas> From what I've heard, it sounds like it's not actually cheese's fault, but rather a lot of things coming together.
14:12:21 <heidie> I have my lab person coming at 1 today to talk about options.
14:12:26 * sdziallas nods.
14:12:40 <mchua> heidie: Hm, the cross-platform can be a challenge -- and I'm guessing "everyone, install and learn Linux" would be a bit... much to add to class overhead.
14:13:05 <mchua> heidie: I know you've worked with GNOME in the past -- I'm guessing you want to continue working under that umbrella?
14:13:12 <heidie> Yes, I have two main problems: 1) Can't get USB support in VB; 2) Can't get Cheese to build.
14:13:17 <sdziallas> mchua: I was surprised that she got by without doing it last time (having everybody install.)
14:13:22 <heidie> I think that 2) is a path issue and solveable.
14:13:24 <mchua> sdziallas: trying to think about what kinds of things can be done with GNOME without requiring everyone to have Linux machines...
14:13:37 <sdziallas> heidie: I was going to say that I can help with (2)...
14:13:42 <heidie> Yes, right. We were successful in Caribou and OCRFeeder.
14:13:45 <heidie> Right.
14:13:50 <sdziallas> I'm wondering about (1), because it *should* support USB...
14:13:50 <heidie> But I think that 1) is the larger problem.
14:14:02 <mchua> heidie: and in those cases, students just used lab computers to test, or...?
14:14:06 <heidie> Yes, right! But I'm not seeing anyone with my particular porblem.
14:14:14 <sdziallas> heidie: does it detect it but simply not pass it through?
14:14:29 <heidie> Right! :-) So the sorry state is that we have no lab computers running native linux. :-(
14:14:39 <heidie> Right now it doesn't even detect it.
14:14:50 <sdziallas> Okay, that's strange.
14:14:56 <heidie> I've tried plugging in a flash drive unsuccessfully and it doesn't detect it.
14:14:58 <heidie> Yes, right.
14:15:07 <sdziallas> Because what *should* happen is that VB goes "oh, there's a USB thing" and then you select it...
14:15:13 <sdziallas> Mhm.
14:15:21 <mchua> Er... pulling back a moment -- you're not necessarily tied to Cheese as a project, right? Project criteria is "GNOME-based, small project that needs software work and has supportive developers"?
14:15:31 <heidie> Right, yes.
14:15:33 <sdziallas> And it's just your computer. heidie?
14:15:45 <heidie> sdziallas: Yes, so far as I know.
14:16:04 <heidie> Students have been able to get Cheese to run from Ubuntu live CDs.
14:16:23 <sdziallas> heidie: well, then... *you* could do a Fedora installation and... take it from there?
14:16:27 <mchua> Oh, so it may not be a blocker for the class, okay.
14:16:47 <heidie> sdziallas, umm do a Fedora installation on my laptop?
14:16:57 <sdziallas> heidie: exactly. or another random laptop.
14:17:02 <heidie> mchua: Yes, Cheese isn't a show stopper.
14:17:11 * mchua was wondering whether it might make sense to get you one or two dedicated Linux boxes -- cheap used machines to put in a corner of the lab -- just to have known working platforms available for access.
14:17:13 <heidie> sdziallas: I'd have to repartition my hard drie.
14:17:23 <heidie> Oh! Right! Duh!
14:17:53 * sdziallas thinks course funding... :)
14:18:09 <ErkanYilmaz> you could get a usb drive or usb stick + install there a linux on it - may be slower but could work
14:18:31 <heidie> Yes, having funding does change the equation. And I'm really not used to having it!
14:19:03 <heidie> #action Heidi explore buying 2 linux boxes for lab
14:19:45 <heidie> Ah, yes, I have Fedora on a stick, but I don't know how to use that as a development platform on a Windows machine.
14:20:17 <mchua> #note Big infrastructure challenge -- doing Linux app development when students have primarily Windows laptops.
14:20:54 <mchua> I wonder (stepping back a bit) if looking for more OS-neutral projects in the longer-term might help, but GNOME is pretty awesome and not particularly cross-platform. :)
14:20:57 <heidie> #note VirtualBox is only a partial solution and can pose problems with apps that require hardware.
14:21:06 <heidie> Yes.
14:21:25 <ErkanYilmaz> did you try other virtual machines besides VB?
14:21:33 <ErkanYilmaz> since Windows: VMware migt be another option
14:21:51 <heidie> Additional context: I've been looking at Cheese because it was suggested. However another option is Ekiga, which used to be known as Gnome Meeting.
14:21:56 <heidie> And this is cross-platform
14:21:57 * mchua nods
14:21:59 <mchua> ...ooh.
14:22:16 <mchua> heidie: Who's your primary contact(s) within GNOME? Do they have Cheese or Ekiga expertise?
14:22:23 * sdziallas thinks that ekiga is likely to be more of a pain than cheese...
14:22:24 <mchua> (Does either project have code mentors?)
14:22:45 <mchua> sdziallas: depends on the bugs they're trying to fix -- I've never tried to set up ekiga though.
14:22:58 <heidie> I've been working with Joanie Diggs and an evaluation of both projects indicates that Cheese doesn't have mentors but Ekiga has a fairly well-defined on-ramp.
14:23:26 <heidie> And I don't know how widely used Ekiga is and if it comes bundled in GNOME 3 (as does Cheese).
14:23:53 <sdziallas> heidie: alright, let me ask you this: what would you need right now to make you worry less / unblock you?
14:23:53 <mchua> #note GNOME mentor - Joanie Diggs
14:24:10 <heidie> #item Heidi Look at dev platform for Ekiga. Can we do development on Windows platform?
14:24:17 <sdziallas> because I think we want to make sure that you *are* unblocked, worrying less, whatever.
14:24:20 <heidie> Erkan, thank you for the suggestions.
14:24:38 <heidie> I'm working on a tight time constraint so I may not have time to look at other virtual options.
14:24:49 <ErkanYilmaz> ok
14:24:54 <heidie> sdziallas, Thank you. Me too. :-)
14:25:56 <heidie> So would the following seem like a reasonable plan?
14:26:19 <heidie> #note Make a decision on project by Friday 9/9.
14:26:35 <heidie> #note Investigate Ekiga on Windows
14:26:52 * mchua has an alt.suggestion, but listening
14:26:57 <heidie> #note Investigate linux machines for lab and ease of installation as part of the plan
14:27:00 <heidie> I'm all ears!
14:27:03 * sdziallas mhms, wants to say something too.
14:27:08 <sdziallas> mchua: can I go first?
14:27:11 <mchua> sdziallas: go for it.
14:27:33 <heidie> #note and revert to a non-webcam project if neither Cheese nor Ekiga looks like it will work.
14:27:35 <heidie> OK, go!
14:28:02 <sdziallas> heidie: I personally don't think that the issues with cheese are unfixable, and I feel like looking at Ekiga (with an unclear outcome) might cause more trouble.
14:28:20 <sdziallas> heidie: I know that's easy to say from my perspective sitting here and not having to deal with your students.
14:28:33 <heidie> sdziallas, OK, so I need to get the VB issue fixed.
14:28:38 <heidie> And then the path issue.
14:28:53 <sdziallas> heidie: well, one at a time. :)
14:29:13 <heidie> I do have some time before students need to actually code as they'll work on requirements first, but I do need to have some confidence that I'm not leading them down a path we can't go.
14:29:14 <sdziallas> heidie: if we can get you a machine just for the purpose of running Fedora on it, would that help?
14:29:15 <heidie> RIght!
14:29:30 <heidie> Yes, that would help. That would give us a known platform.
14:29:51 <sdziallas> heidie: also, just to test, you can indeed boot your laptop from a Fedora Live USB without installation... (hi, says the SoaS person)
14:30:20 <sdziallas> heidie: basically, I assumed *everybody* was affected by the VB issue. If it's just you, it makes me much more confident that we can just circumvent it. :)
14:30:24 <heidie> sdzialla, Ummm, haven't tried my machine yet with the stick from summer POSSE.
14:30:46 <heidie> sdziallas, yes, I agree. But I'm also not finding any solutions on google or the VB forum.
14:31:24 <ErkanYilmaz> is the problem installing an OS or a software in VB?
14:31:26 <sdziallas> heidie: and then, I'm happy to sit down with you at any time on IRC and just walk you through the compilation (I'd have to set it up myself, but if that's needed, I'll do it) and fix anything that comes up. Now that doesn't mean that it'll work, but I feel that this is the closest I can get.
14:31:37 <ErkanYilmaz> if OS: you could install an older OS version and do a dist upgrade that migt work
14:31:46 <heidie> Ah, OK, thanks. That would be immensely helpful.
14:32:28 <sdziallas> heidie: essentially: once we find a place for a Fedora installation for you, you could hopefully be running at full steam... :)
14:32:42 <mchua> heidie: Also, while the hw/sw issues are getting fixed... I noticed you have your students assessing both Cheese and Ekiga as projects this week, and also that you have them on IRC starting tomorrow -- is there going to be any sort of comparison/debate between projects ("I'd rather contribute to X than Y because of Z...") -- because one thing we could do is come on IRC at the start of class on a Tues or Thurs and help
14:32:46 <heidie> Erkan, I don't think that the USB issue is OS, and there are reports that Cheese works OK in Fedora 15. So I'm inclined to debug the VB thing first.
14:33:25 <ErkanYilmaz> ok
14:33:38 <heidie> sdziallas, I think so. And I say that as I never know how much time things take to set up on platforms. :-)
14:34:04 * sdziallas grins, nods.
14:34:07 <heidie> mchua, Yes, that's a great idea!
14:34:22 <mchua> heidie: and we could do it in the a11y channel, so that convo would be overhearable by GNOME folks.
14:34:35 <heidie> Right, yes. That makes sense.
14:34:48 <heidie> Would tomorrow work? Or is that too soon?
14:35:15 <mchua> I can do tomorrow before 10:30am.
14:35:28 <mchua> Are students already comfortable on IRC?
14:35:59 <heidie> mchua, right this is why I thought maybe Tuesday as I haven't introduced IRC yet.
14:36:03 * mchua nods
14:36:08 <heidie> Was going to demo on Thursday.
14:36:21 <heidie> Although I did ask them to install the client for tomorrow.
14:36:54 <heidie> OK, would Tuesday at 9:30 work?
14:37:15 <mchua> heidie: Tuesday 9:30-10:30 worksforme.
14:37:21 <heidie> Great, thank you :-)
14:37:36 <mchua> I've got class myself at 10:30, but my office is right down the hall from the classroom.
14:37:43 <mchua> so I'll be there 'till 10:27 or so.
14:37:51 <heidie> #note Heidi's class will have an IRC with mchua Tuesday at 9:30
14:37:58 * sdziallas ponders action items...
14:38:01 <mchua> #action mchua prepare for 9:30am Tuesday IRC class with Heidi
14:38:02 <heidie> Sure, not a problem. We may not need all of the time.
14:38:26 <mchua> heidie: and that will be mostly to ask q's and facilitate a discussion about project health/selection?
14:38:31 <heidie> #action heidie prepare students for 9:30 AM Tuesday class IRC
14:38:35 <heidie> Yes.
14:38:45 <mchua> Okeydokey.
14:39:11 <heidie> That is what I'm expecting. But I'm also guessing we'll get into how to proceed. Onramp issues such as how to joint the community.
14:39:17 <mchua> and in the meantime sdziallas is working on the Cheese issues (getting you a working box of some sort, even if it's not your laptop)?
14:39:41 <heidie> Students did an initial assessment of the projects, but they spaced on looking at places like Ohloh.
14:39:46 <mchua> heidie: Yup yup. I'll be coming in as "someone who doesn't know about Cheese either, but has a decent nose as to where to look and what questions to ask."
14:39:53 <heidie> Right, yes, exactly.
14:40:04 <heidie> And I've told students that I'm not a Cheese expert either.
14:40:16 <mchua> heidie: Hrm -- would it be possible for me to (pre-tuesday's chat) see the things they wrote up for hw1 on assessing a project?
14:40:32 <heidie> And I can get a box, if you have suggestions for what to get.
14:40:35 <heidie> Sure!
14:41:52 <mchua> #action heidie send mchua HW1 responses re: project assessment in advance of Tuesday's class
14:42:15 <mchua> heidie: whatever you need to do FERPAwise -- anonymizing, etc. -- I totally understand, and any confidentiality you need me to keep on it I'll do that as well.
14:42:44 <heidie> Since they're not going public, I simply sent them.
14:43:12 <mchua> heidie: I'm happy to blog up a quick response to HW1s (in aggregate, just noting trends, not naming names -- would anonymous quotes be ok?) if that would be useful
14:43:24 <heidie> Sure!
14:43:33 <mchua> #action mchua blog up HW1 response
14:43:39 <heidie> That would both show students the usefulness of a blog and give them feedback.
14:44:01 <mchua> heidie: anonymous quoting from assignments ok, in that blog post?
14:44:10 <mchua> (if it's anywhere even near the sketchy-FERPA line, I'll not)
14:44:14 <heidie> Having said this, don't do anything that you don't have time for.
14:44:25 <heidie> mchua, yes, anonymous quotes is fine.
14:44:29 <mchua> Okeydokey.
14:44:48 <heidie> mchua, hmmm, let me retract that.
14:44:58 <heidie> Let me ask students first.
14:45:14 <heidie> And I'll let you know if its OK.
14:45:20 <mchua> heidie: I've got time for this blog post, Planet setup, and Tuesday class chat, but that more or less taps out my Heidi-POSSE time 'till October. (I figure a little more time during start-of-term is normal.)
14:45:38 <mchua> heidie: Ok -- I'll go quoteless this first time, but it would be good to know okayness for future reference.
14:46:03 <mchua> (though if you don't get around to asking, that's ok -- I'll just go quoteless unless it's public on the web already, unless otherwise notified.)
14:46:05 <heidie> mchua, Yes, fine to wait on the rest. I want you to focus on school. I definitely want you to succeed there.
14:46:40 <mchua> I'm reading my grad school assignments way too fast so I do have a bit of extra time right now. :)
14:46:45 <heidie> OK, thats fine.
14:46:48 <heidie> Good for you!
14:46:50 <heidie> :-)
14:48:33 * sdziallas wonders... so what's the way forward with the infrastructure?
14:48:44 <sdziallas> mchua: are we suggesting a device for heidie?
14:49:00 <mchua> sdziallas: "get a cheap used computer or netbook"?
14:49:03 * heidie Thinks that I need to go in 8 minutes to introduce myself to the freshman...
14:49:16 <sdziallas> heidie: are we setting up a time on IRC (actually, I like phone more / skype) and I'll talk with you about anything that comes up?
14:49:32 <sdziallas> mchua: there are eeeboxes (eee pc in box form) for $200 out there.
14:49:36 <heidie> I'm meeting with an IT person and see if there is something we could use.
14:49:58 <heidie> sdziallas, sure
14:50:11 <heidie> mchua, what is an eeebox?
14:50:55 <sdziallas> heidie: have you seen the little eee pcs from asus? essentially, they are a brand of netbooks. and the eeeboxes are based on the same technology, except that they are like a little computer, rather than a little laptop.
14:51:13 <sdziallas> http://en.wikipedia.org/wiki/ASUS_EeeBox_PC
14:51:17 <heidie> And is the protocol for using support funds to purchase and get reimbursed? I seem to remember that.
14:51:30 <sdziallas> I believe so.
14:51:36 <mchua> heidie: anything you need from me that isn't on the #action list already?
14:51:46 <heidie> I think we're goos!
14:51:51 <heidie> Well, "good"
14:51:55 <mchua> heidie: You can either do that (reimbursal) or send me the purchase specs and shipping address and I'll get it for you.
14:51:58 <heidie> No feathers on me!
14:52:02 <mchua> woo!
14:52:12 <mchua> okay, remember to #endmeeting at the end -- I'll see you folks later. :)
14:52:13 <heidie> OK, I'll likely get it and get reimbursed.
14:52:20 <heidie> Bye
14:52:22 <sdziallas> I think if we purchase it online, it make make sense to do that soon
14:52:39 <heidie> Ah, right.
14:52:42 * heidie looks at web site
14:52:50 <sdziallas> Unless you want to hit a store or something.
14:53:00 <sdziallas> I should also make sure that this stuff *actually* works with Fedora.
14:53:37 <sdziallas> heidie: I know it's a long ride, but if you wanted to come out some day, we could also go shopping for it together and work through the compilation in person then, but I feel like that might not be the best use of your time. :)
14:53:40 <heidie> Let me talk to my tech guy whom I'm meeting at 1.
14:53:46 <sdziallas> (just saying that I'd be happy to do that too)
14:53:46 <heidie> Ah, right!
14:53:58 <sdziallas> Yeah. Maybe they have a machine around somewhere...
14:53:58 <heidie> Thank you. :-)
14:54:04 <heidie> I might take you up on the offer!
14:54:12 <heidie> Right, thats what I'm checking.
14:54:18 <heidie> OK, I need to go talk to freshman.
14:54:22 <sdziallas> Okay. :)
14:54:32 <sdziallas> Just... email or text me and we'll take it from there.
14:54:40 <heidie> OK, thats fine.
14:54:49 <heidie> And do I know where the meeting notes will be?
14:55:03 <sdziallas> Let me find them.
14:55:16 <sdziallas> #endmeeting