19:59:58 <kwurst_> #startmeeting
19:59:58 <zodbot> Meeting started Mon Feb  6 19:59:58 2012 UTC.  The chair is kwurst_. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:01 <gregdek> 4. Debian
20:00:07 <gregdek> ...in roughly that order, I guess.
20:00:18 <mikeiudi> gregdek: thank you sir.
20:13:15 <gregdek> kwurst_: any other questions?
20:13:41 <kwurst_> gregdek: We're arguing in real-space about projects...
20:13:41 * gregdek notes that meetbot is happily running :)
20:13:47 <gregdek> YAY ARGUING!
20:14:33 <davexunit> kwurst_ just needs to be the benevolent dictator and pick
20:14:53 <Jforks> We currently have 6 projects that all have pros and cons.  I think we could drop off VLC easily and be down to 5, then play the 5-3-1 game.
20:15:00 <thodde> davexunit: which project do you think would be best?
20:15:16 <davexunit> thodde: No idea. at all. at all.
20:15:24 <JamesC_WSU> sudo  vote
20:15:32 <thodde> we could knock out firefox too probably
20:15:34 <davexunit> you don't need root permissions for that
20:16:30 <Jforks> thodde: I agree.
20:16:46 <dimJ> s u always likes being involved.
20:18:44 <Jforks> I think the top two are Irrlicht and Eucalyptus, is it really that far fetched to make 2 groups?  This is a large class and I am not sure how many contributers Irrlicht wants to add to their list.
20:18:44 <mikeiudi> everybody who votes for Eucalyptus gets a free Patriots Super Bowl Champions shirt.
20:18:54 <thodde> I like Eucalyptus, Libre Office and Sage
20:19:27 <JamesC_WSU> I'm not sure about Sage, some people haven't taken as much math as needed for the higher level work
20:19:35 <ndoe049> Sage, Irrlicht, or Eucalyptus I'd say
20:19:43 <thodde> nah we would be going coding though. no math needed
20:19:54 <thodde> *doing
20:20:01 <JamesC_WSU> can't even spell
20:20:11 <blabbe> Irrlicht would be so awesome, who doesn't want to work with game development tools?
20:20:18 <thodde> you've taken calc 3 with me. I know you know math haha
20:20:36 <JamesC_WSU> Yeah but, aside from you Matt, and myself who has?
20:20:48 <thodde> up through calc 1 is required for CS majors
20:20:54 <davexunit> I know Irrlicht won't be picked.
20:20:55 <JamesC_WSU> We'll group working on 3D modeling, and all the multi-variable fun
20:20:56 <Jforks> I agree, Irrlicht sounds interesting, but how many people are they kosher with adding to their contributers list?
20:21:00 <gregdek> Hey, if you end up doing irrlicht, do me a favor and use openkinect with it. :)
20:21:18 * gregdek dreams of an open source virtual sport using the kinect.
20:21:20 <Jforks> hahaha, that's awesome.
20:21:44 <blabbe> Heh, if we did Irrlicht we would be writing a benchmark suite to help them improve performance
20:21:44 <davexunit> Irrlicht to this class like Ron Paul is to the republican party
20:21:47 <davexunit> is to*
20:21:49 * gregdek may end up hacking bzflag to use the kinect...
20:21:57 <thodde> hahaha
20:22:12 <gregdek> RUNRUNRUNRUNRUN SHOOT!
20:22:20 <gregdek> good times.
20:22:37 <blabbe> I would just like t say, you REALLY don't want to work on libre office
20:22:54 <blabbe> I don't want to get into the argument over it but trust me, libreoffice would be painful
20:22:55 <mikeiudi> mass effect 3 will be using minor biometrics...were heading in that direction
20:23:05 <thodde> that actually helps
20:23:13 <davexunit> blabbe: but it is actually useful in the real world. but i will probably agree with you that it would kind of horrible.
20:23:15 <thodde> i haven't really looked into it much yet
20:23:19 <Jforks> I REALLY don't want to work on firefox, or libreoffice, to be honest.
20:23:20 <dimJ> ballot stuffing!
20:23:32 <blabbe> It's only useful for people who have some terrible aversion to proprietary software :P
20:23:54 <blabbe> I hate firefox as well, but it would be a sensible project to get started with
20:23:56 * davexunit hates proprietary software
20:24:03 <JamesC_WSU> Si
20:24:10 <thodde> I don't want to work on firefox really either
20:24:21 <mikeiudi> I DEMAND A RECOUNT! (sorry for caps ahead of time)
20:24:53 <Jforks> blabbe: Only in regards to a "starting off" project, much more than that it's not interesting in the least, in my opinion.
20:25:10 <JamesC_WSU> It all comes down to this
20:25:21 <JamesC_WSU> the final moments of indecision
20:25:24 <JamesC_WSU> 2012
20:25:33 <JamesC_WSU> the last ballot is in
20:26:05 <thodde> no one wrote in Sarah Palin right?
20:26:13 <JamesC_WSU> (maybe)
20:26:31 <gregdek> ...what is this "colbertsoft" thing?
20:26:53 <JamesC_WSU> Firefox and Sage have been cast aside
20:26:55 <davexunit> we ranked the projects we wanted to work on and voted
20:27:15 <thodde> VLC is gone too
20:27:22 <gregdek> Has CNN projected a winner?
20:27:33 <dimJ> so I guess Euca it is...I  call for ballot stuffing.
20:27:35 <JamesC_WSU> Inconclusive
20:27:47 <mikeiudi> Change you can believe in!
20:27:48 <JamesC_WSU> voters were paid
20:27:51 <JonH_WSU> Photo finish
20:27:53 <mikeiudi> We can do it!
20:28:27 <jochy> leace
20:30:08 <kwurst_> gregdek: So, we voted, and Eucalyptus came out first.
20:30:23 <mikeiudi> hazzah!
20:30:39 <gregdek> HURRAH!
20:30:41 <JamesC_WSU> ballots were destroyed, no need to recount.
20:30:46 <gregdek> Best of luck with that! ;)
20:31:12 <blabbe> Irrlicht was 2nd we might get to workon two projects
20:31:24 <blabbe> Throw items at kwurst_ until he less s work on two projects :D
20:31:42 <davexunit> Irrlicht really is Ron Paul
20:31:49 <gregdek> That's kwurst's cross to bear, lol
20:31:50 <dimJ> ..
20:31:56 <blabbe> No Irrlicht isn't racist D:<
20:31:58 <kwurst_> gregdek: Do you have suggestions for what the class should be looking at for the next week to prep.
20:32:00 <davexunit> alright
20:32:04 <davexunit> let's settle down here
20:32:06 <gregdek> Yes, I do.
20:32:09 <gregdek> First:
20:32:20 <gregdek> Play with Amazon EC2.  It's free.  Lots of documentation.
20:32:33 <blabbe> It's free for one year. If you sign up for it the clock starts ticking
20:32:40 <gregdek> Specifically, learn about ec2ools, because euca2ools is very similar.
20:32:57 <thodde> luckily the semester is only a few months which is < a year
20:33:05 <JamesC_WSU> woah woah math man
20:33:10 <blabbe> Right but you use up your persona free year on this class
20:33:11 <blabbe> class*
20:33:17 <blabbe> personal*
20:33:22 <davexunit> stop talking and let gregdek finish
20:33:26 * clacroix recognizes thodde's valid point
20:33:27 <davexunit> :)
20:33:30 <kwurst_> gregdek: Is there an option to use ECC? Since some students are concerned about using up their free year of EC2.
20:33:31 <Jforks> gregdek: What's the price on Amazon EC2 after the one year, just in case some students were looking to reserve their free year for future use?
20:33:31 <gregdek> Lots of reading to be done about both, but mostly it's about learning how to manage instances with commandline tools.
20:33:49 <gregdek> kwurst_: we can also set up students to use ECC, yes.
20:33:59 <blabbe> http://aws.amazon.com/ec2/pricing/ <== EC2 pricing
20:34:10 <kwurst_> I can also look at what it would cost for WSU to pay for EC2.
20:34:16 <gregdek> And ECC is free -- but the thing about ECC is that we blast the instances every 6 hours, heh.
20:35:01 <JamesC_WSU> As in clear all data?
20:35:09 <gregdek> Yep. Instance go bye-bye.
20:35:17 <gregdek> Now that's enough for learning the tools.
20:36:49 <kwurst_> I'm looking at EC2 pricing, if we need to go with that.
20:37:19 <kwurst_> gregdek: Ok, Second?
20:37:32 <gregdek> Networking.
20:37:39 <gregdek> The networking model around cloud is weeeeird.
20:38:08 <kwurst_> gregdek: So, reading up on that?
20:38:09 <gregdek> So there's a document that Eucalytpus has about its networking stack:
20:38:19 <gregdek> http://open.eucalyptus.com/wiki/EucalyptusNetworkConfiguration_v2.0
20:38:33 <gregdek> This is for the 2.0 stuff, but shoudl still be valid for 3.0.
20:39:09 <kwurst_> #action Play with Amazon EC2 or ECC.  It's free.  Lots of documentation.
20:39:20 <kwurst_> #action Get ECC accounts.
20:39:39 <kwurst_> #action Read http://open.eucalyptus.com/wiki/EucalyptusNetworkConfiguration_v2.0
20:39:59 <gregdek> When it's time to get into the nitty gritty of install, we've got some install notes -- but the 3-devel code is brand new, and changing.  :)
20:40:02 <gregdek> EXCITING!
20:40:07 <kwurst_> #action Decide who is on infrastructure team
20:40:25 <kwurst_> #action Contact IT about configuring network port for off-campus access
20:40:36 <dimJ> 1 person per grou?
20:40:40 <dimJ> group*
20:45:34 <kwurst_> gregdek: Is that all for this week for them?
20:45:51 <gregdek> I think for now, yes.  We need to come back and figure out more stuff.  :)
20:45:54 <kwurst_> gregdek: Where do we want to discuss this stuff in the future?
20:46:15 <kwurst_> gregdek: I set up a listserv for the class. Do you want to be on it?
20:46:19 <gregdek> Come on over to #eucalytpus if you like -- we can come here ifyou're more comfortable, but more people will be able to respond over there.
20:46:33 <gregdek> kwurst_: that would be great.
20:46:44 <kwurst_> gregdek: Moving to #eucalyptus would be best, I think
20:46:46 <gregdek> We may end up dragging some of you onto our listserv as well if that makes sense.
20:47:04 <kwurst_> gregdek: I already suggested that they sign up to the EuCa listerv
20:47:45 <kwurst_> gregdek: When I subscribe you to our listerv should I use the email we've be communicating on?
20:48:02 <kwurst_> gregdek: I'll ask Mel if she wants to be subscribed too.
20:48:14 <gregdek> kwurst_: yes pls.
20:48:43 <kwurst_> #action Subscribe to eucalyptus listserv
20:49:08 <kwurst_> #action start haunting #eucalyptus channel
20:49:20 <danspc> kwurst which list there are 4
20:50:25 <gregdek> Ah. community@eucalyptus.com.
20:50:29 <gregdek> I mean...
20:50:40 <gregdek> community@ the lists.eucalyptus.com site.
20:50:56 <gregdek> danspc: ^^^
20:51:45 <danspc> gotcha thx
20:54:12 <davexunit> #action Open the following ports in firewall: 22, 23, 80
20:54:45 <dimJ> why do you need telnet
20:54:50 * dimJ confused.
20:55:06 <davexunit> 23 is also FTP
20:55:22 <dimJ> ah
20:55:50 <davexunit> no wait i mixed them up
20:56:21 <davexunit> #action Firewall addendum: Change port 23 to 21
21:01:04 <JamesC_WSU> Welp, that about does it for our class.
21:03:57 <kwurst_> #endmeeting