#teachingopensource Meeting

Meeting started by mchua at 00:02:29 UTC (full logs).

Meeting summary

  1. Getting started (mchua, 00:02:49)
  2. introductions (mchua, 00:10:40)
    1. Lots of people have used FOSS, and had their students use FOSS in classes, but very few have gotten students to contribute. (mchua, 00:13:50)
    2. http://teachingopensource.org/index.php/SIGCSE_2012/Workshop_materials (mchua, 00:15:01)
    3. http://openetherpad.org/TOSworkshop2012 (kwurst, 00:15:26)
    4. The average FOSS project has 1 contributor. (mchua, 00:17:58)

  3. What is FOSS and TOS (kwurst, 00:18:11)
    1. 50% of FOSS contributions are by employees paid to do it. (mchua, 00:18:15)

  4. FOSS Fieldtrip (kwurst, 00:23:35)
    1. ohloh.net (kwurst, 00:25:47)
    2. http://ohloh.net (kwurst, 00:26:04)
    3. http://sourceforge.net (kwurst, 00:26:35)
    4. "Decreasing year-over-year activity" may not be a warning sign - it may just mean that the project is becoming stable. (kwurst, 00:34:21)
    5. Ohloh will let you compare (up to) 3 projects to each other (kwurst, 00:41:02)
    6. "updated about x hours ago" means the Ohloh data, project commmits (kwurst, 00:42:00)
    7. "updated about x hours ago" means the Ohloh data, *not* project commits (kwurst, 00:43:24)
    8. You need to hit enter after each project name you put into the Ohloh project comparison (kwurst, 00:45:24)
    9. Mel's recommendation: choose a large project (not a small one) for your first community. (mchua, 00:56:02)
    10. http://openetherpad.org/TOSworkshop2012 (mchua, 00:56:24)
    11. http://lists.teachingopensource.org/pipermail/tos/ (mchua, 00:57:20)
    12. IDEA: Use IRC for "office hours" (mchua, 00:58:48)
    13. http://fedoraproject.org/w/index.php?title=Zodbot&oldid=262493 (mchua, 00:59:34)
    14. You can use bots on IRC to help you keep track of meeting notes (the above link is an example with documentation) (mchua, 00:59:51)
    15. IDEA: IRC logs of open source project meetings provide good artifacts for class discussion of professional behavior (mchua, 01:04:03)
    16. "Why use this old-fashioned 80's technology?" Because that's where everyone is, *and* low-bandwidth internet connections in some parts of the world means it's the only one that's equally accessible by all. (mchua, 01:04:42)
    17. "IRC is the water cooler -- it's where people who know things hang out." (mchua, 01:04:55)
    18. Some projects have their version control systems automatically make announcements into an IRC channel. (mchua, 01:05:21)
    19. Holding office hours on IRC means students can also see and answer each other's questions. (mchua, 01:05:35)
    20. Etherpad is a brower-based collaborative text editor. (mchua, 01:07:18)
    21. people have etherpad instances hosted that you can try (mchua, 01:08:14)
    22. http://openetherpad.org (mchua, 01:08:17)

  5. break (kwurst, 01:27:34)
  6. FOSS culture principles step-back (kwurst, 01:30:56)
    1. ACTION: Take photos of the walls and post them on the wiki (kwurst, 01:32:20)
    2. In FOSS, the feature set is continually being developed. (heidie, 01:36:43)
    3. A release involves first making a set of features happen and then deciding which features in that set should be included in the release. (heidie, 01:37:14)
    4. http://quaid.fedorapeople.org/TOS/Practical_Open_Source_Software_Exploration/html/sn-Introduction_to_Free_and_Open_Source_Software-Climbing_Contributor_Mountain.html (kwurst, 01:46:43)
    5. http://teachingopensource.org/index.php/Textbook (kwurst, 01:48:28)

  7. Course examples (Greg, Heidi, Karl, and Sebastian - Mel leads backchannel notes) (kwurst, 01:58:28)
    1. http://www.xcitegroup.org/softhum/doku.php?id=f:assignments Beginning activities, some of which are useful for students with no background in computing (heidie, 02:13:24)
    2. lurking is a great way to start learning -- see how your students understand what they're observing (mchua, 02:13:52)
    3. http://www.xcitegroup.org/softhum/doku.php?id=g:getting_started Getting started... (heidie, 02:15:17)
    4. opensouce.com (kwurst, 02:15:55)
    5. http://www.xcitegroup.org/softhum/doku.php?id=s:initialconversation Actual student conversation getting started in a project. (heidie, 02:16:00)
    6. http://sububi.org/2009/07/27/the-busy-students-guide-to-project-blogging/ (mchua, 02:16:22)
    7. Do community first, code second. (mchua, 02:19:22)
    8. core developers are usually too busy to fix the tiny easy bugs -- which means they're left undone for students to do (and get great gratitude for!) (mchua, 02:21:20)

  8. Course workshopping (individual instructors lead small groups) (kwurst, 02:21:35)
  9. wrap-up (kwurst, 02:54:04)
    1. http://teachingopensource.org (kwurst, 02:55:23)
    2. : http://teachingopensource.org/index.php/TeachingOpenSource_Mailing_List/Join (kwurst, 02:56:38)
    3. ACTION: Post these minutes to the wiki (kwurst, 02:57:50)
    4. ACTION: Email the minutes links to the attendees (kwurst, 02:58:12)
    5. ACTION: Email the wiki link to the attendees (kwurst, 02:58:25)
    6. ACTION: Organizers will update the wiki page with more resources (kwurst, 02:59:13)


Meeting ended at 03:00:11 UTC (full logs).

Action items

  1. Take photos of the walls and post them on the wiki
  2. Post these minutes to the wiki
  3. Email the minutes links to the attendees
  4. Email the wiki link to the attendees
  5. Organizers will update the wiki page with more resources


People present (lines said)

  1. mchua (72)
  2. kwurst (53)
  3. heidie (17)
  4. heidinow (7)
  5. zodbot (4)
  6. kis (3)
  7. sdziallas (3)
  8. ianweller (2)
  9. Joe____ (1)
  10. mpurcell (1)
  11. JBB_ (1)
  12. ghislop (0)


Generated by MeetBot 0.1.4.