14:01:36 <sayan> #startmeeting #fedora-hubs
14:01:36 <zodbot> Meeting started Tue Sep 20 14:01:36 2016 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:36 <zodbot> The meeting name has been set to '#fedora-hubs'
14:01:39 <stickster> sayan: jcline is also joining, talked to him earlier
14:01:41 <abompard> .hello abompard
14:01:42 <zodbot> abompard: abompard 'Aurelien Bompard' <aurelien@bompard.org>
14:01:47 <sayan> jcline: welcome :)
14:01:47 <stickster> .hello pfrields
14:01:48 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
14:01:51 <sayan> .hello sayanchowdhury
14:01:53 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
14:01:55 <a2batic> .hello a2batic
14:01:56 <zodbot> a2batic: a2batic 'Kanika Murarka' <kmurarka@redhat.com>
14:02:00 <jcline> .hello jcline
14:02:02 <zodbot> jcline: jcline 'Jeremy Cline' <jeremy@jcline.org>
14:02:15 <devyani7> .hello devyani7
14:02:15 <zodbot> devyani7: devyani7 'Devyani Kota' <devyanikota@gmail.com>
14:02:22 <mizmo> .hello duffy
14:02:23 <zodbot> mizmo: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
14:03:16 <sayan> #topic Weekly updates
14:03:30 <sayan> a2batic: want to go first?
14:03:50 <a2batic> sayan, yes
14:04:15 <a2batic> I am pushing the final code for PR#255
14:05:08 <a2batic> sayan, you can suggest me if there are any other issues
14:05:16 <a2batic> <eom>
14:05:20 <sayan> a2batic: no, rest looks fine to me
14:05:42 <sayan> This PR would integrate the Plus Plus service with Hubs
14:05:56 <sayan> and close all the current PRs
14:06:04 <sayan> devyani7: want to go next?
14:06:07 <devyani7> a2batic++ :)
14:06:10 <devyani7> sayan: sure
14:06:22 <stickster> sayan: When you say it would close all the current PRs, do you mean all the PRs about plusplus?
14:06:25 <stickster> like https://pagure.io/fedora-hubs/issue/57
14:06:34 <sayan> stickster: yes
14:06:39 <stickster> Oh!
14:06:46 <sayan> stickster: and the one open for contact widget also
14:07:05 <sayan> stickster: the widget a2batic is working on integrates plus-plus and the contact widget
14:07:36 <sayan> so that means all the 3 PRs will be closed https://pagure.io/fedora-hubs/pull-requests
14:07:38 <abompard> a2batic++
14:07:38 <zodbot> abompard: Karma for a2batic changed to 8 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:07:42 <stickster> abompard: we were talking about issues yesterday... looks like you'll be free to pick up something else off the high-priority list
14:07:57 <stickster> sayan: if you have ideas for that ^^ let us know
14:07:59 <abompard> stickster: yep:
14:08:02 <abompard> :-)
14:08:05 <a2batic> :)
14:08:18 <fedmsg-hubs> pagure.pull-request.comment.added -- a2batic commented on pull-request#255 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/255#comment-10075
14:08:46 <devyani7> so, I was facing a CSS issue, even after doing a fresh install. And,
14:08:50 <sayan> abompard: mizmo: I think maybe abompard can start working on the meeting widgets https://pagure.io/fedora-hubs/issues?status=Open&tags=meeting
14:09:06 <devyani7> I needed the screenshots for the commblog post.
14:09:42 <devyani7> Anyway, I figured out that if the user isn't logged it, the bookmarks bar doesn't show. so...
14:09:45 <sayan> There are quite some of them to be implemented so maybe jcline and abompard can pick issues from there
14:10:02 <devyani7> that is how I got the user hub pages from there.
14:10:06 <mizmo> sayan, cool sounds like a good idea
14:10:19 <devyani7> ok, sorry, I thought it got over :)
14:10:28 <mizmo> abompard, jcline - i did most of those mockups so if any confusions come up or if you just want a run through lemme know
14:10:33 <sayan> devyani7: no issues, we are listening
14:10:51 <abompard> mizmo: thanks. jcline: let's synchronize after the meeting
14:10:56 <jcline> Cool, sounds good
14:11:10 <sayan> mizmo: maybe you can have a look at the meeting tickets needmockup tag?
14:11:10 <stickster> Oooh, nice!
14:11:33 <sayan> devyani7: so I was not able to replicate the issue which you were facing
14:11:54 <devyani7> sayan: a2batic was facing the same as well
14:11:55 <sayan> but then I was able to replicate after going to the pixel range I specified over email
14:12:03 <devyani7> nod nod
14:12:24 * a2batic is also facing the issue
14:12:31 <devyani7> saw that, so do you know how we can fix that?
14:12:42 <devyani7> sayan^^^
14:13:00 <sayan> mizmo: The issue is because the bookmark is not on the same level
14:13:18 <sayan> mizmo: maybe we need to change the layout of the page
14:13:28 <mizmo> sayan, ok for meetings ill look at 26, 24, 91
14:13:38 <mizmo> #action mizmo to work on #26, #24, #91
14:13:53 <mizmo> sayan, yeh it's just the html on that one has to be updated to match the others to support the bar
14:14:02 <mizmo> sayan, ill make a bug for it and assign to myself, im sure ill be able to figure it out and fix
14:14:11 <mizmo> devyani7, you didnt make an issue/bug for it yet did you?
14:14:20 <devyani7> ok, mizmo  fixes that ,cool :)
14:14:31 <devyani7> mizmo: nope. I didn't
14:14:47 <sayan> mizmo: yeah, I have thought of an solution as in to get in the same container and then position the bookmark bar using the position
14:15:07 <sayan> s/get in/get in the bookmarks bar/
14:15:46 <sayan> we can use position: relative and adjust the top, left, right, bottom :)
14:16:02 <sayan> devyani7: do you want to pick up any other issue by that time?
14:16:30 <mizmo> sayan, it's working on group pages, just not on person pages, so i can just emulate the group page structure on person pages
14:16:30 <devyani7> sayan: this weekend I had a diversity call to help new contributors,
14:16:40 <devyani7> so didn't get much time to work on...
14:16:45 <sayan> devyani7: ok
14:16:48 <devyani7> the bookmarks issue
14:16:59 <sayan> mizmo: ok
14:17:00 <devyani7> guess, will work on that issue itself !
14:17:06 <devyani7> Apart from that, I also have a fedora-magazine blog post lined up that is going to deal with an Introduction to hubs.
14:17:16 <sayan> mizmo: do you want to go next?
14:17:20 * devyani7 thinks she is not managing time properly :(
14:17:26 <devyani7> </update>
14:19:19 <sayan> Let me go ahead an update my status
14:19:31 <mizmo> (sorry, trying to make that bug)
14:19:38 <stickster> devyani7: do tell!
14:19:44 <sayan> mizmo: no issues, do you to go ahead?
14:19:54 <mizmo> sure
14:20:05 <fedmsg-hubs> pagure.issue.new -- duffy opened a new ticket fedora-hubs#256: "Vertical bookmarks bar covers up avatars on personal pages" https://pagure.io/fedora-hubs/issue/256
14:20:13 <mizmo> so i finished off the two tickets that have been on my plate for the past 2 meetings
14:20:15 <mizmo> https://pagure.io/fedora-hubs/issue/98
14:20:24 <mizmo> this is the help widget
14:20:44 <mizmo> added a couple of views too, modal 'full' views
14:20:47 <devyani7> stickster: :)
14:20:54 <mizmo> which should probably be patternized
14:21:00 <mizmo> and
14:21:01 <mizmo> https://pagure.io/fedora-hubs/issue/63
14:21:06 <mizmo> this is the release cycle status widget
14:21:37 <mizmo> there's two variations - one that gives the status of the current in-development release, the other gives an overall view of currently active fedora releases (and recently inactive) and their statuses
14:22:03 <mizmo> any feedback you folks have on these greatly appreciated
14:22:20 <sayan> oops! I forgot to update the comment there
14:22:41 * devyani7 checking
14:22:46 <devyani7> :P
14:22:48 <sayan> mizmo: I find the first mockup more informative
14:22:49 <mizmo> #action mizmo to work on #256 (vertical bookmarks bar covering stuff up)
14:22:58 <mizmo> sayan, for 63?
14:23:07 <sayan> mizmo: yes
14:23:10 <mizmo> sayan, the original reporter asked for statuses across fedora releases which is why i made that one
14:23:17 <mizmo> they're really two separate widgets, not two options
14:23:26 <fedmsg-hubs> pagure.issue.edit -- duffy edited the priority fields of ticket fedora-hubs#256 https://pagure.io/fedora-hubs/issue/256
14:23:28 <sayan> oh
14:23:29 <fedmsg-hubs> pagure.issue.edit -- duffy edited the milestone fields of ticket fedora-hubs#256 https://pagure.io/fedora-hubs/issue/256
14:23:59 <mizmo> i think probaly the first one would be more interesting to a developer/packager and the second one more interesting to someone less technical
14:24:27 <mizmo> but, i agree the first in hubs context is more useful / should be higher priority
14:24:38 <mizmo> eg if we had to pick one, that one for sure
14:24:41 <mizmo> want me to note tha tin the ticket?
14:24:56 <sayan> Since the information in both the widgets are more or less the same
14:25:17 <mizmo> sayan, the first one only shows one release; the second shows multiple releases - i dont consider that the same
14:25:56 <sayan> mizmo: sorry :(
14:26:01 <mizmo> eg the kinds of questions the second one answers, "is my release still supported?" "should i wait to upgrade or is my release going to be unsupported soon?" "how long do i have to wait for $NEWRELEASE to GA for planning when to upgrade"
14:26:04 <sayan> In that case It makes sense
14:26:31 <sayan> mizmo: yes, right
14:26:34 <mizmo> whereas the first one answers questions like, "when do i need to get my code checked in by?" "how long do i have to get the newest wallpaper packaged" eg
14:26:36 <mizmo> okay cool
14:27:00 <mizmo> how about the halp one? any thoughts?
14:27:00 <mizmo> https://pagure.io/fedora-hubs/issue/98
14:27:21 <mizmo> im not super happy with the form on the last one
14:27:44 <mizmo> but i like the idea of using a 'header' in the modal to have controls
14:27:47 <sayan> mizmo: actually looked good to me
14:27:52 <mizmo> okay cool!
14:28:50 <sayan> I was actually planning if abompard could work on this one
14:29:37 <sayan> This is also of high priority
14:29:53 <mizmo> yep halp is for comm ops which is one of our goals
14:29:54 <abompard> Sure can.
14:29:59 <mizmo> \o/
14:30:04 <sayan> cool
14:30:05 <stickster> Wow, I love this widget design
14:30:08 <mizmo> i dont have anything else, top on my list next is #256
14:30:16 <stickster> sorry, took me a minute to find and read thru
14:30:19 <mizmo> and the other three meeting related needsmockup ones
14:30:22 <mizmo> stickster, glad you like it :)
14:30:37 <stickster> abompard: ^^ this looks like a cool one to work on, and is in fact one of the *most important* reasons to have Hubs to begin with
14:30:37 <mizmo> its built on the work radhika did
14:30:51 <abompard> stickster: 100% agreed
14:30:53 <stickster> linking contributor <--> opportunity
14:31:02 <sayan> stickster: right
14:31:18 <mizmo> abompard, one thing to know about this design -
14:31:32 <mizmo> abompard, we were originally thinking you could 'dismiss' help opportunities once they were 'claimed'
14:31:43 <mizmo> but we thought that would be a lot of overhead and a lot of busy work ppl wouldn't tend to do
14:32:01 <mizmo> so the idea is that it always shows the most recent things at the top - and as a request gets old it just sorts of scrolls off
14:32:20 <mizmo> the idea being you really want to help with things people want help with *right now* and wouldn't really ever want to dig through super old archives bc the needs have likely changed etc
14:32:35 <abompard> very agile ;-)
14:32:36 <mizmo> so it pushes people to talk to the help requestor and work it out
14:32:49 <mizmo> and the thought is if an old request never got answered, someone would ask fo rhelp again
14:33:11 <abompard> mizmo: okay, thanks
14:33:12 <mizmo> *in practice* that may not work out so great so we may need to put in some kind of thing where the person who's listed as owning a request can log in and delete it
14:33:23 <mizmo> eg 'omg i answered 6 ppl about helping me frobble my fribs today'
14:33:29 <mizmo> 'make it stop'
14:33:30 <mizmo> :)
14:33:42 <mizmo> ill copy pasta this into the ticket for ref
14:33:48 <abompard> thanks!
14:34:07 <abompard> I was gonna copy it to a text file here ;-)
14:34:52 <sayan> abompard: great
14:34:53 <mizmo> great minds think alike :) done
14:34:54 <fedmsg-hubs> pagure.issue.comment.added -- duffy commented on ticket fedora-hubs#98: "#halp/help widget: Default in the CommOps Hub" https://pagure.io/fedora-hubs/issue/98#comment-6329
14:34:59 <fedmsg-hubs> pagure.issue.edit -- duffy edited the milestone fields of ticket fedora-hubs#98 https://pagure.io/fedora-hubs/issue/98
14:35:01 <mizmo> /me status done
14:35:06 <sayan> mizmo: thanks
14:35:16 <sayan> I am going over with my update
14:35:31 <sayan> I worked on the waartaa login page, but facing some issues with the CSS
14:35:54 <sayan> mizmo: the mockup has the social login buttons but I don't know the classes to use to get that
14:36:31 * mizmo looks
14:36:54 <sayan> https://cloud.githubusercontent.com/assets/799683/17908871/24609fee-6950-11e6-8596-8a6f68e38e2c.png
14:36:58 <sayan> This is the mockup
14:36:59 <mizmo> so the icons except for the fedora one are font awesome
14:37:25 <sayan> okay
14:37:38 * mizmo trying to find the button class
14:37:50 <sayan> yes the button class to get those square boxes
14:38:15 <sayan> s/square/rectangle/ :p
14:38:19 * mizmo shakes fist at bootstraps docs
14:38:32 <mizmo> dont wait on me, ill find it lol
14:38:51 <sayan> Ok
14:38:57 <sayan> I could find the classes actually
14:39:14 <sayan> mizmo: Also what happens if the user already has an account
14:39:33 <sayan> should we show a "Already have an account" link
14:39:45 <sayan> and clicking on it changes the right form to login?
14:39:59 <mizmo> sayan, so for that - i wasn't sure if there were waartaa specific accts or if they were linked to social media accts during the account creation process
14:40:45 <sayan> mizmo: there can be waartaa specific accounts
14:40:48 <mizmo> sayan, ahh ok
14:41:07 <mizmo> so normally having a link like that would make sense, except, we already have a 'use existing account' area so it could be confusing
14:41:09 <sayan> so does my idea makes sense? or maybe show the login form first
14:41:31 <mizmo> so what i would do ...
14:41:52 <mizmo> hm
14:41:59 <mizmo> this is a tough one, needs more thought than i can whip out right now
14:42:30 <mizmo> ill look at some patterns for how other sites handle this
14:42:50 <mizmo> #action mizmo figure out how preexisting waartaa accts log in via login mockup design
14:43:05 <sayan> I generally find the login form first and then a link to create account
14:43:18 <sayan> that would bring up the signup form
14:43:21 <sayan> in the same place
14:43:45 <mizmo> so this was meant to do signup / login on the same screen, and i designed it with the assumption waartaa didnt have its own seperate db of user accounts and just used social media ones
14:43:55 <mizmo> i need to rethink it for having a separate local acct system
14:44:08 <sayan> Ok, sure
14:44:22 <mizmo> bc you'll want to log into a social media acct maybe if you have no acct, but if you have an acct and you used social media you also want to use those same buttons, for sign up and log in
14:45:15 <sayan> So, this is the thing I do
14:45:59 <sayan> I join via social buttons and if I need to login via the login form I just create a password using forgot password technique
14:46:17 <sayan> or some also have the option to connect accounts in their profile settings page
14:46:59 <mizmo> im not sure a lot of users are savvy enough to figure out the forgot password trick tho
14:47:03 <mizmo> i just need some time / space to figure it out
14:47:06 <sayan> Yeah
14:47:11 <sayan> sure
14:47:20 <sayan> mizmo: also keep a forget password link too :)
14:47:26 <mizmo> yep
14:47:49 <sayan> I am also right now working on the bagdes widget again
14:47:56 <sayan> using HTML and not React
14:48:37 <pingou> back to html?
14:48:40 <sayan> Maybe sometime later move the code to React
14:48:45 <sayan> pingou: nope
14:49:07 <sayan> pingou: just writing the widgets in HTML for now
14:49:16 <pingou> ok
14:49:17 <sayan> pingou: I still need to work on the generic widget in React
14:49:34 <sayan> pingou: so, I'll do that when I a bit more free
14:49:40 <pingou> 2045?
14:50:02 <sayan> it will be quicker than you think :)
14:50:20 <pingou> stickster: cool, sayan has a lot of free time coming up
14:50:27 <stickster> ha
14:50:44 <sayan> haha
14:50:56 <sayan> the from my side
14:51:00 <sayan> </update>
14:51:36 <sayan> we have 9 minutes left. so lets move to open floor today rather than triaging bugs
14:51:44 <devyani7> +1
14:51:49 <sayan> #topic Open Floor
14:52:10 <mizmo> theres a recurring thread about onboarding contirbutors on commops
14:52:19 <mizmo> ankur is working on a new site thats like what can i do for fedora but isn't like it
14:52:26 <mizmo> i've encouraged him to build it as a hubs feature instead
14:52:53 <devyani7> +1 :) nice
14:52:57 <devyani7> yes, saw that
14:53:01 <mizmo> (i think the overall argument is that what can i do for fedora is terse pointers and he was hoping for something more guiding)
14:53:06 <mizmo> (which is what hubs was meant to do)
14:53:19 * sayan looks for the thread
14:53:19 <mizmo> so just a heads up on that, hope he'll join us
14:53:37 <a2batic> Is fedora-hubs participating for outreachy this time?
14:53:46 <sayan> https://lists.fedoraproject.org/archives/list/commops@lists.fedoraproject.org/thread/A4VTKXNB3LD7H2IIFNERVGWZHDGTVQRB/
14:54:17 <sayan> jcline: abompard: stickster: devyani7: a2batic: anything you want to share in the open floor?
14:54:29 <devyani7> a2batic: rather dev participation than UX, right?
14:54:37 <a2batic> yes
14:54:48 <devyani7> sayan: ^^
14:55:03 <sayan> mizmo has more info on outreachy
14:55:14 <mizmo> a2batic, afaik we just have a hubs UX position for outreachy (i'm mentoring it)
14:55:15 <sayan> It would be on UX
14:55:27 <a2batic> :(
14:55:32 <a2batic> oh
14:55:49 <stickster> sayan: One thing I wanted to mention is that if it would be helpful, I can help with these meetings... with the objective of helping the team identify priorities and reach milestones successfully
14:56:03 <devyani7> a2batic: sorry :/
14:56:19 * stickster not looking to take over anyone's work, just offer services if helpful
14:56:28 <devyani7> stickster++ :)
14:56:37 <a2batic> sayan, please assign me some issue :)
14:56:45 <jcline> So I had not heard of hubs before today, so my plan is to do a lot of research today and update https://fedoraproject.org/wiki/Fedora_Hubs as I go along. I'll probably be asking for lots of pointers today, so sorry in advance :)
14:56:48 <sayan> stickster: would be happy to get some help
14:56:51 <stickster> jcline++
14:56:53 <zodbot> stickster: Karma for jcline changed to 3 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:56:57 <stickster> COOKIE PARTY
14:57:00 <mizmo> jcline++ that page really needs love
14:57:00 <zodbot> mizmo: Karma for jcline changed to 4 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:57:19 <mizmo> jcline, there's a lot of stuff here: http://blog.linuxgrrl.com/category/fedora/fedora-hubs/
14:57:24 <devyani7> jcline++ :)
14:57:24 <zodbot> devyani7: Karma for jcline changed to 5 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:57:32 <stickster> mizmo: Yeah, I was just looking at it precisely to see if jcline could learn from it, we discovered at the same time and he volunteered to update it :-)
14:57:46 * sayan points jcline to https://hubs-dev.fedorainfracloud.org/
14:57:52 * stickster slapped {{needs love}} on it in meantime
14:58:14 <sayan> jcline: you can browse around
14:58:36 <jcline> sayan, thanks, I noticed the link in the README was down. I'll update that too.
14:58:53 <sayan> jcline: right
14:59:00 <devyani7> jcline++ I noticed that too !
14:59:17 <sayan> jcline: I noticed it yesterday, you can send your first fix
14:59:31 <mizmo> sayan, so i could have sworn i saw buttons with the square on the left in the bootstrap docs but i cant find them now. there is bootstrap-social which is somewhat close, can you use those?
14:59:36 <devyani7> I noticed it on sunday during the diversity call :(
14:59:52 <sayan> mizmo: ok, I will look into them
14:59:56 * jcline races off to clone the repo
15:00:03 <sayan> and ping you if I need help
15:00:14 <mizmo> is anybody working on the zanata stuff
15:00:25 <sayan> mizmo: no, I did not check
15:00:28 <fedmsg-hubs> pagure.project.forked -- jcline forked project "fedora-hubs" to "jcline/fedora-hubs" https://pagure.io/fork/jcline/fedora-hubs
15:00:33 <sayan> But I did see improvements on the ticket
15:00:34 * stickster suggests that if anyone's available, the next hour could be used to help jcline and abompard sync up on (1) fixing the wiki page; and (2) assigned (or to-be-assigned) tickets
15:00:42 <stickster> right here in channel
15:01:06 <sayan> The status of the ticket changed from review to QA yesterday
15:01:43 <stickster> *nod -- there was also some info there about how the webhooks are implemented, probably needs someone in the team to verify they're usable
15:01:46 <mizmo> cool
15:01:56 <sayan> mizmo: and no, nobody is working on zanata right now
15:02:05 <mizmo> sayan, do we want to drop it from the mid oct milestone list?
15:02:14 <sayan> a2batic: you want to pick this up?
15:03:17 <a2batic> sayan, Yes :)
15:03:29 <sayan> a2batic: https://pagure.io/fedora-hubs/issue/165
15:03:43 <sayan> mizmo: this needs a mockup too
15:03:57 <sayan> a2batic: https://zanata.atlassian.net/browse/ZNTA-1166
15:04:00 <mizmo> oh there are mockups for this... i wonder why they arent on the ticket sayan
15:04:05 <mizmo> i sent them to alex for sure
15:04:16 * mizmo digs
15:04:20 <sayan> mizmo: got it
15:04:22 <sayan> mizmo: https://pagure.io/fedora-hubs/issue/167
15:04:34 <sayan> a2batic: check this ticket ^^
15:04:42 <a2batic> sayan, ok
15:04:55 <sayan> a2batic: have a look at the ticket and ping me
15:04:55 <mizmo> ah thats a large overview without the individual translation widgets seperated out
15:06:21 <sayan> mizmo: you can then update the ticket there
15:06:36 <a2batic> sayan, ok :)
15:06:55 <sayan> We are overtime so ending the meeting
15:06:59 <sayan> 3.
15:07:01 <sayan> 2.
15:07:03 <sayan> 1.
15:07:05 <sayan> #endmeeting