18:00:14 <felixfontein> #startmeeting Ansible Community Meeting
18:00:14 <zodbot> Meeting started Wed Sep 1 18:00:14 2021 UTC.
18:00:14 <zodbot> This meeting is logged and archived in a public location.
18:00:14 <zodbot> The chair is felixfontein. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:14 <zodbot> The meeting name has been set to 'ansible_community_meeting'
18:00:14 <felixfontein> #topic Agenda https://github.com/ansible/community/issues/539
18:00:14 <felixfontein> abadger1999 acozine andersson007_ baptistemm bcoca briantist cyberpear cybette dericcrago dmsimard felixfontein geerlingguy gundalow gwmngilfen ikhan_ jillr jtanner lmodemal misc nitzmahone resmo samccann tadeboro cidrblock thaumos zbr: ping!
18:00:18 <felixfontein> #info Agenda: https://github.com/ansible/community/issues/539 / Topics: https://github.com/ansible-community/community-topics
18:00:21 <tadeboro> o/
18:00:36 <felixfontein> #chair tadeboro
18:00:36 <zodbot> Current chairs: felixfontein tadeboro
18:00:40 <cidrblock[m]> hey ho
18:00:40 <briantist> o/
18:00:40 <acozine> o/
18:00:45 <felixfontein> #chair cidrblock[m] briantist acozine
18:00:45 <zodbot> Current chairs: acozine briantist cidrblock[m] felixfontein tadeboro
18:00:47 <felixfontein> #topic Updates
18:00:47 <felixfontein> #info Ansible 4.5.0 has been released
18:00:47 <felixfontein> #info there is a reminderbot now :)
18:00:47 <felixfontein> #info gwmngilfen is researching how other communities are handling community meetings, but not finished yet
18:00:50 <felixfontein> #info moderation setup is about 50% done
18:00:54 <gwmngilfen-work> o/
18:01:00 <felixfontein> #chair gwmngilfen-work
18:01:00 <zodbot> Current chairs: acozine briantist cidrblock[m] felixfontein gwmngilfen-work tadeboro
18:01:13 <acozine> reminder: I'll be on PTO/vacation/holiday for the next two weeks
18:01:30 * dericcrago waves
18:01:31 <abadger1999> Bom dia
18:01:31 <andersson007_> o/
18:01:31 <cybette> o/
18:01:31 <gundalow> o/
18:01:31 <andersson007_> tadeboro: ok, i'll take a look, thanks!
18:01:34 <acozine> back in the community meetings Step 22
18:01:35 <cybette> #info Please register for Ansible Contributor Summit 2021.09 if you haven't done so! https://ansiblecs202109.eventbrite.com/?aff=irc
18:01:43 <felixfontein> #chair DerekRobinson[m] abadger1999 andersson007_ cybette gundalow
18:01:43 <zodbot> Current chairs: DerekRobinson[m] abadger1999 acozine andersson007_ briantist cidrblock[m] cybette felixfontein gundalow gwmngilfen-work tadeboro
18:01:55 <felixfontein> cybette: not sure whether #info registers when you're not #chair yet
18:02:02 <dericcrago> felixfontein - almost ;)
18:02:04 <felixfontein> #chair dericcrago
18:02:04 <zodbot> Current chairs: DerekRobinson[m] abadger1999 acozine andersson007_ briantist cidrblock[m] cybette dericcrago felixfontein gundalow gwmngilfen-work tadeboro
18:02:08 <acozine> #chair dericcrago
18:02:08 <zodbot> Current chairs: DerekRobinson[m] abadger1999 acozine andersson007_ briantist cidrblock[m] cybette dericcrago felixfontein gundalow gwmngilfen-work tadeboro
18:02:08 <felixfontein> #unchair DerekRobinson[m]
18:02:08 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] cybette dericcrago felixfontein gundalow gwmngilfen-work tadeboro
18:02:20 <dericcrago> thanks!
18:02:20 <felixfontein> sorry DerekRobinson[m] for the noise :)
18:02:34 <felixfontein> (if you want to take part in the meeting, just say hi, we'll #chair you again)
18:02:41 <felixfontein> dericcrago: sorry :)
18:03:10 <samccann> o/
18:03:43 <felixfontein> #chair samccann
18:03:43 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] cybette dericcrago felixfontein gundalow gwmngilfen-work samccann tadeboro
18:04:28 <felixfontein> any more updates?
18:04:33 <dericcrago> #info The community team will be hosting a hackathon during contributor summit, check / watch the hackmd (https://hackmd.io/AcI9TZf_SZqi7NG3ZyplnA#Hackathon) for more info or message me directly to get involved.
18:05:11 <felixfontein> the Zurich meetup is on the 1st day of the contributor summit, so I'll probably be offline for a couple of hours around that one
18:05:18 <felixfontein> #topic A space for welcome / offtopic chat
18:05:18 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/42
18:05:22 <felixfontein> gwmngilfen-work: ^
18:05:22 <cybette> felixfontein: it's ok, I'll info it again at the end of the meeting just in case :)
18:05:28 <felixfontein> cybette: +1
18:05:41 <gundalow> #info there is a reminderbot now :)
18:05:54 <gundalow> #info gwmngilfen-work is researching how other communities are handling community meetings, but not finished yet
18:06:00 <gundalow> #info moderation setup is about 50% done
18:06:01 <felixfontein> gundalow: I already #info'ed these :)
18:06:13 <gundalow> felixfontein: oh, too efficient
18:06:25 <gwmngilfen-work> @felixfontein:libera.chat thanks. I guess my question is whether anyone sees any problems with my suggestion
18:07:09 <gundalow> I see jillr had a good suggestion:
18:07:09 <gundalow> > Maybe `#ansible-general`? Would be familiar to folks without an irc background since `#general` is a default channel in Slack and Discord.
18:07:18 <gwmngilfen-work> I raised the idea of a social room a while back, and shelved it, but with fest approaching, a place for new folks to discuss would be good
18:07:31 <felixfontein> we could also use #ansible-chat (assuming that doesn't exist already)
18:07:40 <gwmngilfen-work> general works. Centos use -social which I like too
18:07:51 <cybette> Gwmngilfen: I am for it since I suggested that room in the first place :) on the IRC side I like jillr 's suggestion of #ansible-general (rather than #ansible-welcome)
18:08:17 <andersson007_> there can be influx of people from community.general in case of ansible-general:)
18:08:18 <gwmngilfen-work> The irc name is the only thing we have to decide up front, matrix aliases can be changed :)
18:08:34 <misc> irc channels can be redirected
18:08:43 <felixfontein> andersson007_: I was wondering about that too. I'm not sure that will really happen though, but who knows :)
18:08:50 <misc> (at least, they could in the time before the freenode invasion)
18:08:56 <andersson007_> felixfontein: :)
18:09:12 <misc> (but I guess that's likely a rather obscure feature of the server)
18:10:00 <felixfontein> are there more proposals? if we have a list of names, we could do a quick poll to see what people here like
18:10:45 <acozine> sorry, I think I missed the purpose of the channel
18:10:57 <gwmngilfen-work> Plumbing emergency, have to go
18:11:01 <acozine> just a general default channel?
18:11:04 <felixfontein> it's probably the place where all the `hi` and `morning` messages from this channel move to ;)
18:11:22 <acozine> ah, okay, so not specifically for new people?
18:11:31 <acozine> gwmngilfen-work: yikes!
18:11:53 <gundalow> > Context: Offtopic chat is hugely important in building a cohesive social group, and we should be thinking clearly about how to encourage it, rather than letting it happen by accident.
18:12:05 <gundalow> > The upcoming Summit-as-part-of-Fest is likely to bring a lot of new members (even if temporarily) and it feels wrong to swamp the purpose of #community with people getting to know us. A place for new folks to get oriented, be signposted to the right place for their topic (whether the support room, a working group room, etc) or just to talk about our weekends seems right.
18:12:16 <gundalow> > With the adoption of Matrix, we also inherit the 300+ user #ansible:matrix.org room, and that currently represents a fragmented community, as user support is happening there and in #users:ansible.im / #ansible. Forcing them all to abandon that room destroys a community that has existed for 4+ years.
18:12:21 <cybette_> general chat, welcoming new people, social stuff, redirecting people to specific rooms for technical questions, etc.
18:12:48 <gundalow> Sort of a Lobby, off-topic room
18:12:58 <andersson007_> `ansible-hello` or `ansible-hi` ?
18:13:00 <samccann> not being in any other communities, take this w a grain of salt, but ansible-chat sounds like what you describe
18:13:14 <cybette_> have we asked the 300+ users in the room if they're ok with it?
18:13:21 <gundalow> Likely with a newsfeed of things that are happening elsewhere in the Ansible ecosystem
18:13:23 <gwmngilfen-work> Back
18:13:48 <gwmngilfen-work> @cybette:ansible.im yes I have. No negative views, slight support
18:14:03 <misc> given that there is likely a upper limit to the number of people who discuss in a group, shouldn't it be taken in account by having several social groups ? (since I fear 1 big group will be too noisy, while several smaller could mean more overall discussion)
18:14:07 <samccann> or `ansible-social` etc. Something in the name that screams 'this is just for fun'
18:14:10 <andersson007_> felixfontein: `ansible-morning`:))
18:14:23 <samccann> heh
18:14:25 <felixfontein> lol
18:14:26 <acozine> heh
18:14:39 <tadeboro> I will still spam my good mornings into channels I frequent ;)
18:14:39 <gwmngilfen-work> @acozine for new folks to get oriented, for conference chat, for social stuff, in my viee
18:14:40 <felixfontein> misc: good point. I guess the question is: how many people will actually be chatting in that group?
18:14:48 <misc> maybe not several group now, but plan for what happen once this happen
18:14:56 <andersson007_> morning is a good thing to say:)
18:14:58 <felixfontein> could be that it's not much more than the current handful, then it should be totally fine
18:15:11 <gwmngilfen-work> @misc we can make more when we need to, let's start with one :)
18:15:25 <andersson007_> especially when it's repeatable everyday. it gives a sense of something stable:)
18:15:29 <misc> felixfontein: yeh, the problem is that you do not know if the group is at its limit :/
18:16:47 <misc> (but also, we are not twitter, we do not have metrics on engagement)
18:18:37 <resmo> o/
18:18:41 <felixfontein> #chair resmo
18:18:41 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] cybette dericcrago felixfontein gundalow gwmngilfen-work resmo samccann tadeboro
18:19:18 <gwmngilfen-work> Seems like we're mostly tinkering with the idea rather than rejecting it outright
18:19:34 <jtanner> is #ansible-devel not the epitome of "fun"?
18:19:35 <felixfontein> POLL: which channel name(s) do you like? 1) #ansible-welcome, 2) #ansible-general, 3) #ansible-chat, 4) #ansible-hello, 5) #ansible-hi
18:19:56 <acozine> jtanner: heh
18:20:00 <andersson007_> 6) #ansible-social
18:20:07 <gwmngilfen-work> 6
18:20:18 <dericcrago> 6
18:20:20 <gundalow> welcome or social
18:20:21 <cybette> cyb-clock chimes: 20 minutes into the meeting, 15 min on "A space for welcome/offtopic chat"
18:20:23 <felixfontein> 3), 4), 6)
18:20:25 <andersson007_> 6, 1
18:20:42 <acozine> 4, 6
18:20:43 <andersson007_> 3
18:20:46 <cybette> 2, 6
18:20:52 <andersson007_> sorry 6, 1, 3
18:21:04 <jtanner> #ansible-puns
18:21:07 <samccann> 6 or 3
18:21:10 <samccann> AAAHAHA
18:21:11 <abadger1999> 3) 6) [wouldn't object to 2]
18:21:18 <gundalow> jtanner: Channel just for you?
18:21:20 <resmo> 2, 1
18:21:29 <misc> no #ansible-bonjour ?
18:21:31 <acozine> #chair jtanner
18:21:31 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] cybette dericcrago felixfontein gundalow gwmngilfen-work jtanner resmo samccann tadeboro
18:21:31 <felixfontein> jtanner: antsipun?
18:21:37 <jtanner> i'd call ryan brown and ask him to join me in #ansible-puns
18:21:45 <gundalow> felixfontein: Please don't encourage him
18:21:48 <gundalow> :)
18:21:49 <jtanner> =(
18:21:49 <felixfontein> 6 seems to come up a lot (without counting)
18:22:06 <tadeboro> 3, 6
18:22:06 * gwmngilfen pings ansipoll
18:22:13 <acozine> yeah, if we had ranked choice voting, 6 would win
18:22:20 <dericcrago> welcome & social feel like two different places to me. welcome feels like a place you're dropped into to start, social feels like where you hang out
18:22:34 <gwmngilfen-work> Cool, I can do that then. Renames are possible, let's start here
18:22:36 <andersson007_> true
18:22:36 <abadger1999> dericcrago: +1
18:22:42 <andersson007_> dericcrago: true
18:22:52 <gwmngilfen-work> @deric.crago:ansible.im maybe, but let's not fragment too much
18:22:54 <acozine> we've had this issue with the "newts" channel for RH writers, but nobody who has joined ever wants to leave
18:23:05 <samccann> heh
18:23:10 <acozine> so it has become the social channel
18:23:15 <jtanner> is that something jmckerr made?
18:23:18 <samccann> well the gchat newts is still for onboarding
18:23:19 <gwmngilfen-work> Commit to making social welcoming instead :)
18:23:49 <jtanner> #ansible-party
18:23:49 <acozine> that's not a bad thing, though
18:23:52 <samccann> but we are talking two things now - a place to hang (social) and a place to welcome and perhaps direct new people to other channels or training
18:24:08 <andersson007_> jtanner #ansible-commitment
18:24:19 <jtanner> we're all afraid of that channel
18:24:25 <gwmngilfen-work> Again if we reach the size that needs that distinction I will do a happy dance :)
18:24:37 <gwmngilfen-work> @acozine:libera.chat ^
18:24:41 <jtanner> #ansible-dance-party, moderated by abadger1999
18:24:47 <cybette> yeah let's start with one :)
18:24:48 <abadger1999> I'm +1 to using social for both for now; we can create a dedicated welcome channel later if need be.
18:24:50 <acozine> I'd say start with a place to hang, people will join that, and as gwmngilfen-work says, if it gets too big and we need a special room for newcomers, we can add one
18:24:57 <gwmngilfen-work> Uh, @samccann:libera.chat rather
18:25:10 <samccann> heh
18:25:14 <abadger1999> jtanner: Heh, although you are the one with the great moves :-)
18:25:20 <felixfontein> should we vote on whether we want one or two channels (or more) for that?
18:25:27 <samccann> one is fine
18:25:36 <misc> #ansible-dance-battle with abadger1999 and jtanner
18:25:44 <gwmngilfen> more is trivial when we're ready, one for now
18:25:45 <andersson007_> i'm expecting everyone hanging out in ansible-social instead of ansible-community
18:25:46 <cybette> one channel, no need to fragment now
18:26:00 <gundalow> Start with one, avoid fragmentation
18:26:07 <andersson007_> +1
18:26:09 <gwmngilfen> andersson007_: high five
18:26:11 <felixfontein> does anyone wants to vote instead of just going for one channel?
18:26:16 <cidrblock[m]> +1 for one ansible-social
18:26:17 <jtanner> #ansible-cookies, moderated by jillr
18:26:18 <felixfontein> (if nobody does, no need to vote)
18:26:22 <webknjaz> #ansible-procrastination?
18:26:41 <resmo> to late for #ansible-ginbar
18:26:46 <gwmngilfen> i have no need of help with that
18:26:49 <resmo> s/to/too
18:27:10 <gwmngilfen> resmo: i dont drink :P
18:27:18 <jtanner> resmo: might be confused with #ansible-therapy
18:27:19 <felixfontein> I don't like gin :D
18:27:31 <resmo> jtanner, hrhr
18:27:52 <resmo> gwmngilfen, why? you no work in IT?
18:27:59 <resmo> ;)
18:27:59 <cybette> let's start #ansible-band at some point, dibs on drums
18:28:09 <gwmngilfen> gave up for health reasons
18:28:12 <gundalow> ooooooooook
18:28:15 <gundalow> Lets focus people :)
18:28:20 <gwmngilfen> heh
18:28:23 <felixfontein> +1 on focus ;)
18:28:23 <acozine> #chair webknjaz
18:28:23 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] cybette dericcrago felixfontein gundalow gwmngilfen-work jtanner resmo samccann tadeboro webknjaz
18:28:24 <jtanner> cybette: just bring enough cowbells for all of us
18:28:25 <webknjaz> #ansible-focus
18:28:36 <gwmngilfen> ok, i will work on getting -social set up
18:28:37 <gwmngilfen> next topic ;)
18:28:37 <felixfontein> should we vote on #ansible-social?
18:28:38 <cybette> jtanner: you got it!
18:28:51 <felixfontein> VOTE: #ansible-social should be the welcome and social/chat channel
18:28:56 <acozine> +1
18:28:56 <felixfontein> +1
18:28:56 <andersson007_> +1
18:28:57 <resmo> gwmngilfen, congrat. man.
18:29:02 <tadeboro> +1
18:29:09 <webknjaz> +
18:29:13 <resmo> ++1
18:29:15 <gundalow> +1
18:29:21 <cybette> +1
18:29:21 <gwmngilfen> 👍️
18:29:47 <felixfontein> #chair
18:29:47 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] cybette dericcrago felixfontein gundalow gwmngilfen-work jtanner resmo samccann tadeboro webknjaz
18:30:05 <abadger1999> +1
18:30:11 <gwmngilfen> thanks folks
18:30:29 <dericcrago> +1
18:30:50 <andersson007_> thanks samccann for the option:)
18:31:02 <felixfontein> #agreed #ansible-social should be the welcome and social/chat channel
18:31:05 <felixfontein> great :)
18:31:25 <felixfontein> ok, another topic
18:31:25 <felixfontein> #topic [Meta] Collection requirements: expanding the section on best practices
18:31:29 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/33
18:31:32 <felixfontein> How should we continue with this one?
18:31:42 <felixfontein> this has been lingering around for some time now, and had several heated debates in this meeting already
18:32:27 <felixfontein> basically the main question is 'should resource modules only be alloewd for network (and maybe security), or allowed or even recommended in general?'
18:32:43 <felixfontein> (let's not discuss about that, otherwise we'll never finish today ;) )
18:33:28 <cidrblock[m]> There is a proposal in that one... If it is not acceptable to the majority, I can author an alternative
18:33:37 <cidrblock[m]> and bring it forward
18:35:21 <abadger1999> I think that tadeboro summarized the problems with the proposal in the last bulleted list in his comment here: https://github.com/ansible-community/community-topics/issues/33#issuecomment-897813323
18:35:24 <felixfontein> cidrblock[m]: what (roughly) would be the changes to the current one?
18:35:38 <abadger1999> The fact that it's doing the work of filters feels especially problematic to me.
18:35:39 <felixfontein> (if you already have something in mind)
18:36:11 <abadger1999> (info/facts are an ansible convention. But filters are a builtin-to-ansible separate plugin type)
18:37:06 <cidrblock[m]> felixfontein: I guess it would depend on the major points of concern
18:37:42 <felixfontein> I guess we have roughly three choices: 1) allow resource modules everywhere, 2) allow resource modules for network (and maybe security), but not allow them anywhere else, so that _facts/_info and filters are the preferred methods everywhere else, 3) also disallow them for network
18:37:55 <felixfontein> (I don't think 3 is a good idea, just wanted to list it for sake of completenes)
18:38:00 <cidrblock[m]> BTW, I don't think there is confusion about the current "best practises", the proposal is for a strict alternative to what we have today.
18:38:11 <tadeboro> I am not a fan of the resource modules (I love the concepts, hate the implementation), but since there are quite a few of them already existing, I am not sure if I want to block them from being included in the Ansible package. I would not suggest new modules to be created in that way though.
18:39:19 <tadeboro> So I would vote for 2 here.
18:39:45 <abadger1999> I would modify 1, 2 to also have allow this for things currently in ansible but an improved standard for anything new (where we can decide on definitions for what "currently in ansible" and "new" mean)
18:39:52 <cidrblock[m]> Can we vote on the proposal as it stands, and if it is not acceptable I will revise and bring another forward.
18:40:19 <felixfontein> cidrblock[m]: the current proposal would allow resource modules in all areas, right?
18:40:32 <cidrblock[m]> I can work with some of the other sc members that are passionate about this :)
18:40:33 <felixfontein> (and basically defines what currently exists in network?)
18:40:39 <abadger1999> Currently, (due to filters), I would vote for 3 (or 2 with my addition of new things being coded differently)
18:40:45 <cidrblock[m]> felixfontein: Yes, following the criteria in the proposal
18:40:48 <cybette> cyb-clock chimes: 40 mins into meeting, 9 min on "Collection requirements: expanding best practices"
18:42:10 <acozine> cidrblock[m]: would you be open to changing `As of 8/11/2021, this pattern is most commonly used with network and security modules.` to `As of 8/11/2021, this pattern is most commonly used with network and security modules, and new resource modules modules will only be accepted in those two areas.`?
18:43:10 <acozine> the descriptions of how resource modules are created, pros and cons, etc., are great, but it sounds like what most folks are discussing is a little different
18:43:22 <abadger1999> acozine: I think cidrblock is trying to guage whether he needs to compromise or if it could pass unchanged.
18:43:34 <felixfontein> acozine: +1
18:43:48 <cidrblock[m]> The proposal is for the definition of what a resource module is, acozine that seems like it would be in the inclusion criteria not the def?
18:44:15 * abadger1999 does note that it would be better in general to look for compromise first... it's better to get proposals as near to satisfying everyone as possible rather than just enough to get them to pass
18:44:23 <felixfontein> considering that most steering committee members haven't commented on this issue, it's hard to say. there has been a vocal opposition to it though.
18:44:37 <cidrblock[m]> abadger1999: :).... drawing a distinction between inclusion and an alternative approach
18:44:46 <acozine> yeah, I think that's where my confusion is coming from - the proposal is a description, but the discussion here seems to be focusing on whether or not this is a pattern we want to encourage
18:45:12 <felixfontein> I think the proposal as "this is what a resource module is" (but not where it is allowed) is ok
18:45:29 <felixfontein> (haven't read it carefully enough to definitely vote on that though)
18:45:39 <abadger1999> I'm a little unsure of what not voting on were it is allowed would prove.
18:46:13 <abadger1999> the definition of what it is is more of a factual statement.
18:46:24 <cidrblock[m]> felixfontein: Yes, the goal was to ensure if a resource module is written, it follows strict guidelines. The topic of whether or not resource modules would be allowed in the community package is a different topic I think
18:46:25 <abadger1999> doesn't need a vote, at least by us.
18:46:26 <felixfontein> but the proposal "allow resource modules (as defined here) everywhere" will have a large opposition (how large I can't say)
18:46:48 <samccann> yeah. just a comment from the peanut gallery here - but I have the same confusion as abadger1999 - why vote on just a definition?
18:47:17 <cidrblock[m]> The vote would be to include the defintion in the best practises, which was the original concern
18:47:28 <cidrblock[m]> (and why I thought the issue was raised)
18:47:31 <abadger1999> I think that's disingeous, then.
18:47:43 <felixfontein> including the definition in the best practice without saying where it is applicable indicates to readers that it can be used everywhere
18:47:47 <abadger1999> Including something in best practices that we're not going to accept doesn't seem friendly
18:47:52 <samccann> yeah that's where I get confused. defining something in best practices that will then never be allowed (outside networking) seems... odd.
18:47:57 <samccann> yeah what he said
18:48:32 <acozine> well, the description is also. useful for users
18:48:43 <acozine> though then it wouldn't be in Best Practices, I guess
18:48:47 <felixfontein> I think we should first decide (and mention that in the best practices) where resource modules are allowed (if anywhere), and then (if they are allowed somewhere) add a definition of what exactly a resource module should be
18:48:50 <cidrblock[m]> I was unaware of the bidirectional 1:1 mapping of best practises to community inclusion
18:49:33 <felixfontein> cidrblock[m]: inclusion is "follows best practices" + some additional conditions
18:50:07 <felixfontein> including a formal definition of resource modules in the docs section on resource modules is ok. but including that in best practices means that resource modules are a best practice in all areas.
18:50:25 <felixfontein> and then it would be pretty odd if inclusion rules say "no, don't use them!"
18:50:52 <cidrblock[m]> felixfontein: got it. I suspect, given the strict guidelines, few will go down the resource modules path
18:51:45 <felixfontein> ok, I guess there's something to think about now, so let's switch to open floor for now (almost in time) :)
18:51:52 <felixfontein> #topic open floor
18:52:27 <felixfontein> if someone wants to add more points to the previous discussion: please use the issue ;)
18:52:27 <cidrblock[m]> that said, if for a given discipline/technology/platform a collection owner does identify the resource module pattern providing the experience they want the user to have, IMO, that is the collection owners call
18:52:43 <cidrblock[m]> 👍️
18:52:59 <cybette> #info Please register for Ansible Contributor Summit 2021.09 if you haven't done so! https://ansiblecs202109.eventbrite.com/?aff=irc
18:53:06 <felixfontein> so: anyone has some spontaneous stuff to discuss, share, notify, ...?
18:54:09 <gundalow> #info Suggestions for Topics for Friday of Contributors Summit are low, please suggest via https://hackmd.io/AcI9TZf_SZqi7NG3ZyplnA#Potential-Topics
18:55:17 <cidrblock[m]> a little promotion ok? Ansible vscode plugin is released as preview on marketplace https://marketplace.visualstudio.com/items?itemName=redhat.ansible&ssr=false#overview folks using vscode please do install and try it out, in case of any issues feel free to raise it here https://github.com/ansible/vscode-ansible/issues
18:55:30 <felixfontein> cidrblock[m]: if it's related to Ansible, sure ;)
18:55:59 <felixfontein> #info Ansible vscode plugin is released as preview on marketplace https://marketplace.visualstudio.com/items?itemName=redhat.ansible&ssr=false#overview folks using vscode please do install and try it out, in case of any issues feel free to raise it here https://github.com/ansible/vscode-ansible/issues
18:56:00 <acozine> cidrblock[m]: w00t!
18:57:08 <samccann> woohoo!! fun times
18:57:42 <tadeboro> cidrblock[m]: Maybe this info could also be added to bullhorn?
18:57:42 <cidrblock[m]> felixfontein: too late, and it was :)
18:58:10 <cidrblock[m]> tadeboro: I believe that is the plan, will check on it
18:58:16 <cidrblock[m]> good idea btw
18:58:41 <cidrblock[m]> I think it hasn't yet, just due to timing
18:59:08 <tadeboro> cidrblock[m]: Just for convenience: https://github.com/ansible/community/issues/546 is the bug where stuff can be added to bullhorn.
18:59:26 <cidrblock[m]> tadeboro: ty
18:59:37 <cybette> cidrblock: if you comment in issue 546 I can still add it for tomorrow's release :)
19:00:19 <cidrblock[m]> Carol Chen: thx, will check with the team
19:00:23 <felixfontein> dmsimard: do you want to add your feed combiner to bullhorn as well?
19:00:29 <felixfontein> #endmeeting