00:00:00 <nitzmahone> #startmeeting Ansible Azure Working Group
00:00:00 <zodbot> Meeting started Thu Nov  8 00:00:00 2018 UTC.
00:00:00 <zodbot> This meeting is logged and archived in a public location.
00:00:00 <zodbot> The chair is nitzmahone. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:00:00 <zodbot> The meeting name has been set to 'ansible_azure_working_group'
00:00:00 <yungezz> Hello
00:00:06 <zikalino82> hi all
00:00:08 <jborean93> hey
00:00:22 <nitzmahone> #chair zikalino82 jborean93 yungezz yuwei
00:00:22 <zodbot> Current chairs: jborean93 nitzmahone yungezz yuwei zikalino82
00:01:41 <Kylie_> Hi
00:01:47 <nitzmahone> #chair Kylie_
00:01:47 <zodbot> Current chairs: Kylie_ jborean93 nitzmahone yungezz yuwei zikalino82
00:01:54 <nitzmahone> Howdy
00:02:14 <Kylie_> Do we
00:02:16 * nitzmahone hangs head in shame for not getting to module review again this week
00:02:40 <Kylie_> ;)
00:02:41 <yungezz> 🙂
00:02:48 <Kylie_> Do we start?
00:02:54 <yungezz> Yes
00:03:14 <nitzmahone> yep, meeting's running already
00:04:37 <Kylie_> For certified candidates, we checked notes. Zim, Catherine and yuwei will follow up notes.
00:05:17 <nitzmahone> #action nitzmahone still to review 46796, 46939, 47045, 47181
00:05:27 <nitzmahone> any others you need me to look at?
00:05:39 <yungezz> I have one more or for redis cache
00:05:39 <Kylie_> Zim mentioned he does not fully understand some notes. I will leave them to him to communicate with you.
00:06:00 <nitzmahone> Yeah, email's fine, or we can chat in IRC or whatever
00:06:37 <zikalino82> well, i just said i am not sure if i understand correctly... but as i go through fixing the issues i will know better
00:06:58 <nitzmahone> Feel free to reach out if anything's unclear
00:07:19 <yungezz> https://github.com/ansible/ansible/issues/47914
00:07:21 <nitzmahone> (or push back if you disagree with any of them, for that matter)
00:07:21 <Kylie_> From BI side, besides modules you marked, I also noticed high traffic for load balancer and availability set. Catherine and Matt, what’s you insights for those modules?
00:07:27 <zikalino82> yes, sure
00:08:02 <nitzmahone> Availability set should be pretty easy to get "over the line" (though expensive to test properly)
00:08:20 <nitzmahone> I can't remember if load balancer got rewritten to actually work yet
00:08:36 <nitzmahone> Initial module didn't produce a "usable" load balancer
00:09:09 <yungezz> Indempotence
00:10:05 <zikalino82> the pr is pending... however we were discussing if there should be more changes done or not
00:10:26 <zikalino82> i mean me and catherine
00:10:26 <nitzmahone> Yeah, there were a bunch of changes to it back in February, so maybe it's closer now. I haven't tried to use it since the most recent changes; would probably want to see some "real world" use of that (or at least an e2e sample) before we pull the trigger
00:10:39 <nitzmahone> (on certified)
00:11:25 <zikalino82> ok, i can try it together with merging current pr
00:12:36 <nitzmahone> So I'm not opposed to adding that one to the list if you think it's important, but maybe a lot more work needed on it since it's complicated
00:13:22 * nitzmahone has to duck out in 15m
00:13:41 <nitzmahone> Anything else exciting going on?
00:13:48 <Kylie_> No, let us see whether that is qualified to be a good candidate. I just shared learning from BI.
00:13:57 <nitzmahone> BI == ?
00:14:15 <yungezz> Business intelligence
00:14:27 <zikalino82> so bi says it's actually usable already
00:14:28 <nitzmahone> (summarized telemetry data, or ?)
00:14:29 <yuwei> telemetry
00:14:32 <yungezz> Yes
00:14:35 <yuwei> yes
00:14:47 <nitzmahone> Well, "being used" != "usable" necessarily ;)
00:15:11 <zikalino82> hmm... maybe... it's useful in some way to someone.... ;-)
00:15:19 <nitzmahone> But yeah, it's had changes made to it since I last played with it, so maybe it's great now
00:15:42 <nitzmahone> I didn't really even look at that one when I was making the list given my prior experience with it
00:15:55 <Kylie_> Btw, I don’t say we agree or not agree on the certified program since that is business call as we discussed. Here we only focus on customer learning and technical analysis.
00:16:17 <nitzmahone> Same; we let the business folks worry about the details there :)
00:16:35 <Kylie_> Nod
00:17:03 <nitzmahone> Regardless, I think the goals are in alignment anyway (about increasing quality/consistency)
00:17:16 <nitzmahone> It's not like it's a place we don't want to go ;)
00:18:40 * nitzmahone is jealous of telemetry data; Ansible could learn much from having our own telemetry, but it's kind of a non-starter with most customers
00:19:35 <Kylie_> Nod. So I heard some notes for the quality of LB. Let us add LB refactoring in our backlog ( if already there, great:))
00:20:53 <Kylie_> Can Ansible capture who are using provisioning, who are doing configuration and who are deploying app?
00:21:30 <Kylie_> Correction: No need to know who. How many
00:21:32 <nitzmahone> When you say "who"; do you mean a local username, or what?
00:21:56 <nitzmahone> We have no telemetry at all; Tower used to have a little bit, but I think it's all been removed
00:22:19 <yungezz> Maybe can distinguish it from arm call post or put/patch
00:22:31 <Kylie_> No, that is not allowed. Apologize for my typing. Not who he/she is.
00:23:45 <yungezz> But depends on api, some using put for both create and update
00:23:49 <Kylie_> I see. Thanks. No more topic from me for this meeting.
00:24:28 <Kylie_> PR review?
00:24:43 <nitzmahone> I have the same list from last week :(
00:24:45 <yungezz> I am ok
00:25:00 <zikalino82> we can help ;-)
00:25:23 <Kylie_> Catherine, you mentioned you had a new one for redid
00:25:26 <Kylie_> Redis
00:25:53 <zikalino82> reddit?
00:26:09 <Kylie_> Redis cache
00:27:05 <yungezz> Yes
00:27:06 <yungezz> https://github.com/ansible/ansible/issues/47914
00:27:06 <yungezz> https://github.com/ansible/ansible/issues/47914
00:27:06 <nitzmahone> Oh, Azure's hosted redis?
00:27:08 <yungezz> https://github.com/ansible/ansible/issues/47914
00:27:08 <yungezz> https://github.com/ansible/ansible/issues/47914
00:27:20 <yungezz> https://github.com/ansible/ansible/issues/47914
00:27:20 <yungezz> Yes
00:27:28 * nitzmahone adds to list
00:27:34 <yungezz> Yes
00:30:22 <Kylie_> Thank you. And heads-up for our plan - we will write facts module for them and add more for storage side.
00:30:54 <Kylie_> Any other topic?
00:31:24 <nitzmahone> Awesome
00:31:27 <nitzmahone> Nothing from me!
00:31:29 <yungezz> No from me
00:31:44 <Kylie_> #endmeeting