18:00:05 <felixfontein> #startmeeting Ansible Community Meeting
18:00:05 <zodbot> Meeting started Wed Aug 11 18:00:05 2021 UTC.
18:00:05 <zodbot> This meeting is logged and archived in a public location.
18:00:05 <zodbot> The chair is felixfontein. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:05 <zodbot> The meeting name has been set to 'ansible_community_meeting'
18:00:05 <felixfontein> #topic Agenda https://github.com/ansible/community/issues/539
18:00:05 <felixfontein> abadger1999 acozine andersson007_ baptistemm bcoca briantist cyberpear cybette dericcrago dmsimard felixfontein geerlingguy gundalow gwmngilfen ikhan_ jillr jtanner lmodemal misc nitzmahone resmo samccann tadeboro cidrblock thaumos zbr: ping!
18:00:09 <felixfontein> #info Agenda: https://github.com/ansible/community/issues/539 / Topics: https://github.com/ansible-community/community-topics
18:00:09 <andersson007_> o/
18:00:14 <dmsimard> \o
18:00:23 <felixfontein> #chair andersson007_ dmsimard
18:00:23 <zodbot> Current chairs: andersson007_ dmsimard felixfontein
18:00:40 <cidrblock[m]> Welcome to the next episode of this :)
18:00:47 <abadger1999> Bom día
18:00:47 <briantist> o/
18:01:10 * dericcrago waves
18:01:13 <acozine> o/
18:01:15 <felixfontein> #chair cidrblock[m] abadger1999 briantist dericcrago acozine
18:01:15 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] dericcrago dmsimard felixfontein
18:01:15 <tadeboro> o/
18:01:23 <felixfontein> #chair tadeboro
18:01:23 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] dericcrago dmsimard felixfontein tadeboro
18:01:46 <felixfontein> #topic Updates
18:01:46 <felixfontein> #info Ansible 4.4.0 has been released
18:01:51 <acozine> cidrblock[m]: which Matrix room are you/is the meeting in?
18:01:58 <felixfontein> (and various collections :) )
18:01:59 <dmsimard> #info There is a planned maintenance with up to 3 hours of downtime to move galaxy.ansible.com to a new and improved cluster August 24th @ 11AM UTC.
18:03:09 <tadeboro> acozine: IIRC, it is #community:ansible.im
18:03:15 <acozine> tadeboro: thanks
18:03:31 <dmsimard> can't think of another update for now
18:04:28 <lmodemal[m]> Hello, I'm lurking :)
18:04:34 <felixfontein> #topic ansible-core 2.11.4rc1 has been released yesterday, 2.11.4 should follow next week
18:04:37 <felixfontein> oops
18:04:38 <felixfontein> #undo
18:04:38 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f4732c89a90>
18:04:45 <felixfontein> #info ansible-core 2.11.4rc1 has been released yesterday, 2.11.4 should follow next week
18:04:51 <felixfontein> topic, info, all the same ;)
18:04:57 <felixfontein> #chair lmodemal[m]
18:04:57 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] dericcrago dmsimard felixfontein lmodemal[m] tadeboro
18:05:02 <acozine> heh, `#whatever`?
18:05:08 <felixfontein> like that :)
18:05:18 <felixfontein> #topic Revise planned schedule for the release of Ansible 5
18:05:18 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/37
18:05:42 <abadger1999> I put together the new schedule.
18:05:50 <felixfontein> #info Proposal: https://github.com/ansible/ansible/pull/75470/files
18:06:02 <abadger1999> It is largely a straightforward two week shift in our dates.
18:06:35 <abadger1999> However, I added three weeks to final because the US Thanksgiving holiday is right after rc1 comes out.
18:06:51 <abadger1999> So I think end user testing of rc1 will be lower than normal.
18:07:26 <abadger1999> I'd like to know if the committee thinks that that is necessary (for reference, we had no blockers reported with rc1 of ansible  2.10, 3, or 4)
18:08:15 <abadger1999> thoughts from anyone?
18:08:57 <felixfontein> I'm +-0
18:09:03 <tadeboro> I am +0 on extra week because thanksgiving is not a thing here and we will test things when they come out ;)
18:09:34 <acozine> how many post-release bug reports did we get for those releases? are people just testing "in production" and reporting stuff a few weeks later?
18:09:34 <felixfontein> I think that most things either have already been tested enough, or won't be tested enough anyway, no matter if there's one more week or not
18:09:57 <acozine> or have our releases been very clean?
18:10:18 <acozine> I guess either way, we're not seeing bugs in the RC phase
18:10:39 <acozine> which makes me think we wouldn't need an extra week
18:10:43 <abadger1999> acozine: it's hard to track that because ansible is a conglomerate of separate upstreams.  We'd hear about blockers because we're specifically asking people to tell us about them but otherwise we mostly don't hear anything.
18:10:52 <abadger1999> <nod>
18:11:15 <abadger1999> I'm hearing a slight leaning towards no extra week.
18:11:47 <andersson007_> +0 from me to the extra week
18:11:52 <gwmngilfen> acozine for the record, you can use "Irc_channel_name:libera.chat" for any room. As tadeboro noted there are shorter aliases too, but this is a handy fallback.
18:12:07 <acozine> gwmngilfen: thanks
18:12:07 <felixfontein> #chair gwmngilfen
18:12:07 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] dericcrago dmsimard felixfontein gwmngilfen lmodemal[m] tadeboro
18:12:07 <gwmngilfen> Was just passing, saw the ping, still on vacation ;)
18:12:12 <felixfontein> :)
18:12:18 <felixfontein> #unchair gwmngilfen
18:12:18 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] dericcrago dmsimard felixfontein lmodemal[m] tadeboro
18:12:32 <felixfontein> enjoy it!
18:12:44 <cidrblock[m]> revised timeline seems sane to me
18:13:16 <felixfontein> about the deadline for applying with new collections, and approving them: I agree with tadeboro, I think it's ok if these dates stay as-is
18:13:40 <felixfontein> then we also don't have to block a release if we decide to wait a bit longer for one collection
18:13:46 <felixfontein> (/me remembers the last deadline)
18:14:09 <abadger1999> Okay, I've updated the schedule to release ansible-5.0.0 on November 30.
18:14:18 <dmsimard> I was wondering about the collection inclusion deadline, is it OK to have it on the same date as the release of ansible 2.12 ? It feels late but it's also what we had agreed on previously (before the slip)
18:14:43 * cyberpear arrives late
18:14:48 <felixfontein> #chair cyberpear
18:14:48 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] cyberpear dericcrago dmsimard felixfontein lmodemal[m] tadeboro
18:16:27 <felixfontein> how about moving the deadline to one week earlier? that would be one week later as it is right now
18:16:52 <felixfontein> the more I think about it, the more I like if there are a few more days between that deadline and feature freeze
18:17:00 <abadger1999> I'm okay with the inclusion deadline coinciding with ansible-core-2.12's release.  I'd be okay with it moving earlier as well.  The real question is whether it is too close to ansible-5.0beta1.
18:17:06 <abadger1999> <nod>
18:17:51 <felixfontein> I think last time (i.e. for 4.0.0b1) it would have been nice if it would have been a week earlier (or even two)
18:18:08 <jtanner> hi
18:18:16 <tadeboro> What is the reason for moving the inclusion dates at all? Making sure inclusion candidates can be tested against particular core release?
18:18:21 <acozine> #chair jtanner
18:18:21 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] cyberpear dericcrago dmsimard felixfontein jtanner lmodemal[m] tadeboro
18:18:30 <felixfontein> also considering that reviewers often are also involved in collections that might need some work before that deadline :)
18:19:40 <abadger1999> I think it would make sense to move that to 11-8 (the same day that the committee) decides what contingencies [slip release, move on without accepting the collection, etc] to put in place.
18:19:57 <abadger1999> We could move it earlier but then we should move other things earlier as well.
18:20:22 <abadger1999> I'm okay doing that, but I can't easily summarize that in one sentence :-)
18:20:55 <abadger1999> Err...
18:20:59 <abadger1999> Move it from 11-8 to 11-3
18:21:00 <felixfontein> which other things would you move?
18:21:16 <felixfontein> ah
18:21:34 <felixfontein> sounds good to me
18:22:21 <felixfontein> does anyone else has an opinion on this? :)
18:22:23 <abadger1999> if we moved less than a week earlier than 11-3, I'd want to drop alpha3 and replace it with beta1.
18:23:27 <abadger1999> If we moved earlier than that, then probably have to move the last date for submission and the irc meeting topic to discuss collections which haven't been approved yet earlier as well.
18:24:09 <abadger1999> One related question: Do we want to move the last day for collections to make backwards incompatible changes along with the new collection inclusion?
18:24:40 <abadger1999> I would say yes.
18:24:44 <felixfontein> I would say no :)
18:24:48 <abadger1999> Heh :-)
18:24:52 <abadger1999> Need a tiebreaker ;-)
18:24:56 <dmsimard> that would have to be before beta, right ?
18:25:17 <abadger1999> Yeah.
18:25:41 <abadger1999> Right now, both are on 11-8, the day before beta1.
18:25:49 <felixfontein> if we find things that should be changed in a backwards incompatible way during the review process, but we still want to include the collection, having an extra week to implement that is good
18:26:56 <abadger1999> felixfontein: true.... otoh, we can just make an exception for that specific collection to be accepted no later than 11-8 if they make the required change.
18:27:26 <dmsimard> the release of 2.12 might somehow uncover issues (though I would hope that they have been caught by testing devel) so I think having a week of buffer before the freeze could be beneficial
18:27:30 <abadger1999> we don't yet have a policy for removing a collection so it feels less problematic to me to wait on approval until the change is made.
18:29:39 <tadeboro> I must admit I lost track of all the dates here.
18:29:42 <felixfontein> dmsimard: one would hope that issues uncovered by 2.12.0 would mostly require bugfixes, and not new features / breaking changes :)
18:29:54 <dmsimard> felixfontein: hope is not a strategy, but yes
18:30:28 <abadger1999> felixfontein: shall we split this into two votes/discussions?  My read of the room is that moving the new collection inclusion date will pass.
18:30:46 <felixfontein> sounds fine
18:30:56 * abadger1999 writes up vote.
18:31:08 <tadeboro> I am fine with proposed https://github.com/ansible/ansible/pull/75470/files, but would like to keep the dates for "Last day for new collections to be submitted ..." and "Last day for new collections to be **reviewed and approved**" as they were originally.
18:31:22 <abadger1999> VOTE: Move the new collection inclusion date back half a week from 11-8 to 11-3
18:31:36 <cidrblock[m]> +1
18:31:59 <felixfontein> +1 (I don't mind it to be moved back even more)
18:32:06 <felixfontein> #chair
18:32:06 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] cyberpear dericcrago dmsimard felixfontein jtanner lmodemal[m] tadeboro
18:32:07 <andersson007_> +1
18:33:10 <dmsimard> +1 (though I don't mind tadeboro's suggestion either)
18:33:11 <tadeboro> -1 (I would keep it 2021-10-26 as is now because I do not see a good reason for moving it).
18:33:15 <abadger1999> tadeboro: ah, you mean, keep those on 10-25?  Although I'm okay with that, I think we should move other items as well, in that case.
18:34:00 <abadger1999> I'm +1 to 11-3 but would go with tadeboro's dates if we move other things as well.
18:34:13 <acozine> +-0 because I am not called upon to do any reviewing or any collection updates before the deadline
18:34:55 <lmodemal[m]> abstain
18:35:06 <tadeboro> abadger1999: What other dates? I see inclusion process mostly orthogonal to everything else.
18:36:05 <tadeboro> Once collections are part of the ansible package, we can treat them as any other collection that is also part of Ansible.
18:36:13 <abadger1999> tadeboro: Definitely the discussions in this meeting since that's how we've decided what things need attention and which we're okay with not getting in.
18:37:09 <tadeboro> abadger1999: Ugh, yes, I missed that one. That one should also stay, yes.
18:37:25 <abadger1999> Possibly the choice of whether we're making alpha3 vs beta1.... ansible-core will be in rc itself so it feels like calling 11-2 release beta1 feels more right to me.
18:38:01 <dmsimard> alpha3 is probably not essential
18:38:40 <abadger1999> anyone want to support tadeboro's dates?  If so, I think it would be best if we table this for today and I'll work up an alternate schedule around 10-25 dates for next week and we can choose between them then.
18:39:05 <felixfontein> I'm +1 on tadeboro's dates
18:39:16 <tadeboro> There are also enough of you to vote me out ;)
18:39:34 <cyberpear> +0
18:39:40 <abadger1999> Cool.  Let's table this and we can look at both schedules side by side next week.
18:39:46 <felixfontein> sounds good.
18:39:50 <felixfontein> thanks abadger1999!
18:39:59 <abadger1999> no problem :-)
18:40:10 <felixfontein> since it's already somewhat late, let's switch to a topic we didn't had time yet to discuss:
18:40:13 <felixfontein> #topic ansible-plugin-builder
18:40:16 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/35
18:40:19 <felixfontein> cidrblock[m]: do you want to say something about this?
18:40:54 <cidrblock[m]> yes,  first, just an FYI that this is happening so I wanted to make sure everyone was aware
18:41:21 <cidrblock[m]> more importantly I think this might be great in the ansible community org where we can get more involvement as things progress.
18:41:54 <briantist> what does this part mean? `as well as examples files in the respective utils directory`
18:41:59 <acozine> so, this is a bit like a set of plugin templates?
18:42:09 <felixfontein> I guess it would also solve the "which module/... to copy as a base for a new one?" question :)
18:42:33 <acozine> yeah, it seems like a very useful idea, as long as it's maintained
18:43:04 <cidrblock[m]> that is intended to mean we would scaffold out files in both the module utils or plugin utils directories as examples
18:43:09 <felixfontein> briantist: no idea, I guess it is something network specific
18:43:28 <briantist> ah ok, thanks cidrblock[m]
18:43:32 <cidrblock[m]> yes, exactly, plugin templates.  Ask the user for basic information and scaffold out the requested plugins
18:44:04 <cidrblock[m]> no working example yet  (but a more generic version of the cli_rm builder)
18:44:34 <felixfontein> probably would be good if it also spits out some scaffolding for unit and/or integration tests
18:44:45 <dmsimard> what comes to mind: how does this come into the picture with the existing support for ansible-galaxy init skeletons ?
18:44:46 <tadeboro> I looked at the existing code and for some reason it felt wrong to (ab)use ansible as a code generator.
18:44:58 <cidrblock[m]> the repo will be at least maintained by the new ansible dev tools team, but ideally it has a community as well
18:45:05 <briantist> would this have a provision for collection-specific patterns? I'm already using a custom base class (which subclasses `LookupPlugin`) for example, but even stuff like common imports, etc. could be very specific to the use cases. Think the AWS collections' module class, etc.
18:45:59 <cidrblock[m]> undecided whether or not the ansible-galaxy command provides enough value here to use, the scaffolding tool really only needs a couple directories
18:46:00 <abadger1999> I wonder if putting it into a collection is a bit of "when you have a hammer, everything is a nail" but I do like the concept of example plugins for people to base their own plugins off of.  and we can always change the delivery method later if we want to.
18:46:19 <tadeboro> briantist: As far as I can tell, that thing would be quite oppinionated.
18:46:58 <briantist> yeah exactly, I'm wondering if a collection could provide "templates" that the general tool would be able to use
18:47:01 <felixfontein> dmsimard: for me ansible-galaxy init is for bootstrapping a collection, not bootstrapping a new module/plugin/... (which goes into an existing collection)
18:47:16 <cidrblock[m]> one reason I see for it being in a collection and largely being ansible content and templates is that it is easy to maintain for people familiar with ansible
18:47:18 <tadeboro> When I think about examples, cookiecutter comes to mind since this is what quite a few project use to "bootstrap" the things.
18:47:20 <dmsimard> felixfontein: I don't see that as mutually exclusive
18:47:33 <dmsimard> tadeboro: yes, that's why I mentioned galaxy init skeletons
18:47:35 <abadger1999> If we're encoding best practices, we probably need to have some mechanism for people to vote on what goes in to it.
18:47:42 <tadeboro> Molecule, for example, uses cookiecutter for scenario generation.
18:48:07 <cidrblock[m]> abadger1999: yes, my hope would be the PR/review process could help there
18:49:19 <abadger1999> I'm not sure if that's formal enough.
18:49:37 <abadger1999> I'm thinking about how both Debian and Fedora handle things like this.
18:50:11 * cidrblock[m] open to suggestions here, one reason to bring it up
18:50:35 <abadger1999> Fedora has an actual boy (The Fedora Packaging Committee) who hears proposals for changes and then votes on whether the changes should go in or not.
18:50:41 <abadger1999> s/boy/body/
18:51:31 <cidrblock[m]> I guess the only thing to decide on today is, can the initial repo go into ansible-community or should the work happen elsewhere
18:52:38 <abadger1999> Debian uses a mailing list: https://www.debian.org/doc/debian-policy/ap-process.html
18:53:03 <felixfontein> what's the main advantage/disadvantage of having it in gh.com/ansible-community, as opposed to say gh.com/ansible? that non-RH employees can have commit rights as well?
18:53:22 <abadger1999> +1 for allowing it into ansible-community; we can decide in what ways to promote or not promote it at a later date.
18:53:36 <dmsimard> felixfontein: the ansible organization implies official supportability
18:53:55 <felixfontein> dmsimard: true :)
18:54:14 <felixfontein> I'm fine if it goes into gh.com/ansible-community/
18:54:24 <dmsimard> right, ansible-community is open to any project
18:54:32 <dmsimard> as long as it's related to ansible, of course
18:54:45 <felixfontein> important qualifier :)
18:54:49 <felixfontein> should we have a quick vote on this?
18:55:34 <dmsimard> a vote on creating a repo in ansible-community ? unnecessary imo
18:55:55 <acozine> does anyone object to putting this repo in ansible-community?
18:56:14 <felixfontein> if nobody replies in a minute (with something quick), I'll switch to open floor :)
18:56:26 <briantist> no objection
18:56:51 <cidrblock[m]> ok, thanks all, will keep everyone posted as it progresses
18:57:12 <felixfontein> #agreed ansible-plugin-builder can go into github.com/ansible-community/
18:57:15 <felixfontein> #topic open floor
18:57:19 <felixfontein> anything for a quick open floor? :)
18:57:33 <dmsimard> got a quick thing
18:58:22 <briantist> I haven't written up a proposal for this (maybe next time), but I've created several small github actions within my collection, and I was thinking of seeing if they were interesting to anyone else, and if so we could put them in `ansible-collections` so anyone using GHA could use them.
18:58:54 <cidrblock[m]> https://github.com/ansible-community/community-topics/issues/33  this was updated and will get some more eyes on it over the next week
18:59:02 <dmsimard> I did a PoC a while back of a planet-style RSS feed aggregation for releases and found some time to clean it up a bit and push it to a repo: https://github.com/ansible-community/rss-feed-aggregator -- There isn't much work left to do and I'll find somewhere to host it soon enough
18:59:09 <briantist> Don't need to discuss now, I should add an actual agenda item, but in case anyone wants to browse: https://github.com/ansible-collections/community.hashi_vault/tree/main/.github/actions
18:59:10 <acozine> if those include the preview-your-collection-docs-changes briantist I'm very much in favor!
18:59:17 <abadger1999> There are some really interesting things in briantist's collection :-)
18:59:19 <felixfontein> briantist: do you mean gh.com/ansible-collections/collection_template?
18:59:30 <felixfontein> indeed!
18:59:55 <felixfontein> #info proposal on resource modules: https://github.com/ansible-community/community-topics/issues/33#issuecomment-897029700
18:59:57 <briantist> hehe they don't acozine , that's a workflow, and yeah would be more at home in collection_template. That docs thing would be a different thing to do
19:00:28 <acozine> that's too bad . . .
19:00:45 <acozine> dmsimard: the rss aggregator looks good
19:00:46 <briantist> still something I want to share more widely! just not the specific thing I was talking about this time
19:01:47 <briantist> dmsimard: that looks nice!
19:02:14 <felixfontein> #endmeeting