18:00:14 <dmsimard> #startmeeting Ansible Community Meeting
18:00:14 <zodbot> Meeting started Wed Feb 23 18:00:14 2022 UTC.
18:00:14 <zodbot> This meeting is logged and archived in a public location.
18:00:14 <zodbot> The chair is dmsimard. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:00:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:14 <zodbot> The meeting name has been set to 'ansible_community_meeting'
18:00:24 <dmsimard> #topic Agenda https://github.com/ansible/community/issues/645
18:00:31 <dmsimard> #info Agenda: https://github.com/ansible/community/issues/645 / Topics: https://github.com/ansible-community/community-topics
18:00:44 <dmsimard> #topic Active community discussions
18:00:49 <jillr> o/
18:00:58 <dmsimard> #info FEEDBACK WANTED: which directories / files / file patterns should be excluded from the Ansible installation? https://github.com/ansible-community/community-topics/issues/65
18:01:16 <dmsimard> #info unversioning some documentation guides https://github.com/ansible-community/community-topics/issues/68
18:01:17 <andersson007_> o/
18:01:28 <dmsimard> #info Revamping the community/contributor documentation https://github.com/ansible-community/community-topics/issues/60
18:01:29 <cybette> o/
18:01:34 <dmsimard> #chair jillr andersson007_ cybette
18:01:34 <zodbot> Current chairs: andersson007_ cybette dmsimard jillr
18:01:45 <cyberpear> o/
18:01:58 <dmsimard> #info How to handle moving of content from collections inside the Ansible package to collections outside the Ansible package? https://github.com/ansible-community/community-topics/issues/66
18:02:08 <samccann> o/
18:02:37 <dmsimard> #chair samccann
18:02:37 <zodbot> Current chairs: andersson007_ cybette dmsimard jillr samccann
18:02:55 <dmsimard> #info Collections included in Ansible should not use files outside of meta/, plugins/, roles/ and playbooks/ https://github.com/ansible-community/community-topics/issues/70
18:03:25 <dmsimard> I think that covers most of the recent active discussions, unless there's another one that someone wants to highlight we can move on to updates
18:03:34 <cybette> #chair cyberpear
18:03:34 <zodbot> Current chairs: andersson007_ cyberpear cybette dmsimard jillr samccann
18:03:57 * dericcrago waves
18:04:40 <dmsimard> #topic updates
18:04:56 <dmsimard> #info Ansible 5.4.0 has been released: https://groups.google.com/g/ansible-announce/c/razQPdsJXCs
18:05:21 <cybette> #chair deric.crago
18:05:21 <zodbot> Current chairs: andersson007_ cyberpear cybette deric.crago dmsimard jillr samccann
18:05:21 <acozine> o/
18:05:26 <acozine> sorry I'm late
18:05:36 <cybette> #chair acozine
18:05:36 <zodbot> Current chairs: acozine andersson007_ cyberpear cybette deric.crago dmsimard jillr samccann
18:07:26 <dmsimard> I don't have any other updates
18:07:31 <dmsimard> anything else ?
18:08:08 <andersson007_> yep, 30 seconds please
18:08:33 <dmsimard> I must say there's somewhat of an overlap between community meeting updates and bullhorn newsletter
18:08:53 <samccann> ;-)
18:08:55 <dmsimard> perhaps we could link to the newsletter from the meeting ?
18:09:18 <acozine> I don't mind being force-fed the news in meetings
18:09:25 <dmsimard> #info Latest bullhorn newsletter (#46) https://mailchi.mp/redhat/the-bullhorn-46
18:09:36 <acozine> I try to read the bullhorn when it comes out, but it doesn't always happen
18:10:11 <andersson007_> #info Any feedback on the steering committee policy update https://github.com/ansible/community-docs/pull/49 would be much appreciated. It contains updates like quorum, a casting vote, veto, inclusion workflow changes. After polishing the PR, we'll create a corresponding community topic.
18:10:36 <dmsimard> 👍
18:11:14 <cybette> we moved the bullhorn publication to thursdays so we could include updates from these meetings (once every 2 weeks), but now that it's weekly, maybe we don't need to release bullhorn on thursdays necessarily?
18:12:22 <dmsimard> cybette: I don't have a strong opinion, I was mentioning it because it may not be immediately clear what is suitable as a community meeting update vs an entry in the newsletter
18:12:37 <dmsimard> linking from the meeting to the latest bullhorn edition feels like a suitable workaround
18:12:48 <dmsimard> (without duplicating info, I mean)
18:14:36 <cybette> in that case, I'd still put important announcements in bullhorn, and then we can link to meeting minutes for the rest. I think a bit of duplication is fine, not everyone reads both sources.
18:14:54 <dmsimard> works for me
18:15:00 <remindbot[m]> @cybette:ansible.im cyb-clock chimes every 15 minutes during the community meeting
18:15:04 <cybette> 👍️
18:15:48 <dmsimard> Anyone have a topic they'd like to talk about ? I will otherwise pick one :)
18:16:32 <acozine> go for it dmsimard
18:16:48 <dmsimard> ¯\_(ツ)_/¯
18:17:12 <jillr> start from the top with numbered order?  :)
18:17:34 <dmsimard> The most recent one was created by felixfontein and it speaks to me so let's go with that: https://github.com/ansible-community/community-topics/issues/70
18:17:48 <dmsimard> #topic Collections included in Ansible should not use files outside of meta/, plugins/, roles/ and playbooks/ https://github.com/ansible-community/community-topics/issues/70
18:18:34 <dmsimard> This came up as part of discussing which files we should remove from the Ansible package because it contains a LOT of stuff not immediately useful to users: https://github.com/ansible-community/community-topics/issues/65
18:19:25 <acozine> it sounds like this is a preventive measure - we don't currently have lots of collections that break this rule, and we'd like to keep it that way
18:19:56 <acozine> which seems smart, and timely
18:20:12 <dmsimard> Every time this comes up, I kind of want to say that it's because the "ansible-galaxy collection build" mechanism takes every file in the current working directory and then there is a "manual" ignore list to filter things out. I really feel it should be the other way around but my understanding is that the ship has sailed and changing the behavior
18:20:12 <dmsimard> from within ansible-core may not be doable
18:21:13 <dmsimard> In other words, I believe "ansible-galaxy collection build" should only take a given set of directories (that are strictly defined within the scope of a role, playbook or collection) and then, perhaps if there are some extra things that the collection author or maintainer wants to add, they can add them manually
18:21:23 <dmsimard> i.e, opt-in instead of opt-out
18:21:50 <acozine> that makes sense, but I could see it being hard to change at this stage
18:22:01 <dmsimard> yeah, exactly :(
18:24:16 <andersson007_> maybe a dumb question but why? technically or politically?
18:25:11 <dmsimard> I don't see it as technical (in other words: it's possible) or even political -- it's from a UX standpoint, it would flip everything the other way around and could be interpreted as a major backwards-incompatible change
18:25:47 <samccann> is it something that could be part of a major release 'somewhere'?
18:26:20 <dmsimard> and then pretend you build a collection with a hypothetical ansible-core 2.13, the same collection would be different when built with 2.12
18:26:23 <samccann> Tho I guess we'd have to get every collection to flip to opt-in unless there's a script that could do it for them?
18:26:43 <jillr> I'm thinking about having to go and change that for every collection I maintain and it doesn't feel good at all
18:27:02 <jillr> I would assume other maintains would also not appreciate it
18:27:15 <jillr> *maintainers
18:27:33 <samccann> what if I script did it for you? Like 'run this script' and it creates the correct opt-in file for you?  From then on, you manually opt-in any new files you add?
18:27:35 <dmsimard> jillr: to be fair, though, do the collections you help maintain have necessary (or otherwise relevant) directories to include beyond meta/, plugins/, roles/ and playbooks/ ? I ask because if not, then it's basically no-op
18:28:27 <jillr> dmsimard: no but I would still want to go through and do a ton of testing to make sure the right things are and are not being included when built with different ansible-core releases, for QE reasons
18:28:52 <dmsimard> right, makes sense, and that's why changing it at this point in time could hurt
18:29:41 <dmsimard> does it mean we have to live with that decision forever and be stuck with random files though ? I don't know but having a discussion about it is interesting :)
18:30:01 <remindbot[m]> @cybette:ansible.im cyb-clock chimes every 15 minutes during the community meeting
18:30:15 <jillr> I wouldn't say we're stuck forever, but we should consider it a maintenance burden if we did
18:34:29 <dmsimard> I think it's worth bringing up to the core team for consideration even if the answer is no then we know we can't have that as an option moving forward
18:35:24 <jillr> +1
18:35:50 <acozine> +1
18:36:23 <andersson007_> +1
18:37:05 <dmsimard> #action dmsimard to ask whether it's possible to allow "ansible-galaxy collection build" to be opt-in rather than opt-out
18:37:38 <bcoca> dmsimard:  based on discussions from when this was designed, probasbly a no
18:38:18 <dmsimard> bcoca: I wasn't part of these discussions and it's probably a long time ago now so perhaps a good opportunity to talk about it :p
18:39:02 <dmsimard> that it is set in stone is one of the possible outcomes and it's ok (I guess)
18:40:38 <dmsimard> we can (and should) allow ourselves to think outside the box too, like could there be a configuration (or CLI) argument that provides the behavior we want, etc
18:40:46 <samccann> i wonder if part of that older decision was to allow collection owners to 'innovate' and if they came up with something great, others could follow?
18:41:23 <bcoca> not from what i remember
18:41:38 <dmsimard> or maybe it was designed that way so authors/maintainers could have the flexibility to include anything and everything
18:41:53 <dmsimard> I can only speculate since I wasn't part of it
18:41:58 <bcoca> mostly it was due to 3rd party requirements being shipped in collection
18:42:51 <dmsimard> makes me wonder if there are any collections actually leveraging that
18:43:09 <bcoca> not afaik
18:43:46 <acozine> what kinds of 3rd party requirements, do you remember?
18:44:05 <dmsimard> like a vendored python library perhaps ?
18:44:38 <dmsimard> like, I dunno, pretend community.aws would have a in-tree fork of boto3 for a specific patch or something
18:44:54 <dmsimard> (don't do this at home, folks)
18:44:58 <jillr> hehe, no I rejected that idea when it was made!
18:45:01 <remindbot[m]> @cybette:ansible.im cyb-clock chimes every 15 minutes during the community meeting
18:45:34 <jillr> libssh maybe though?  I think there was some work there for network collections at one point
18:47:01 <jillr> looks like ansible.netcommon doesn't currently have any other top-level repo directories though
18:48:16 <jillr> ah ok, it's all handled in the connection plugin https://github.com/ansible-collections/ansible.netcommon/blob/main/plugins/connection/libssh.py
18:48:51 <acozine> so that fits the pattern we're talking about
18:49:20 <dmsimard> well, it doesn't rely on a vendored library and would be included by way of being under the plugins directory
18:49:59 <acozine> yeah, that's what I mean, it already complies with our proposed "only these directories are legit" rule
18:50:05 <jillr> I don't know of any other possible scenarios, and also I promise I will never vendor boto3
18:50:19 <acozine> jillr: thank you, that is a relief
18:50:24 <jillr> :)
18:50:33 <dmsimard> jillr: I had to think about an example and it's what I came up with <3
18:50:56 <jillr> no worries!
18:51:54 <dmsimard> alright, thanks for discussing this topic with me :)
18:52:08 <dmsimard> I'd like to leave time for something else or open floor in case someone wants to chat about something else
18:54:52 <dmsimard> #topic open floor
18:59:02 <dmsimard> hum, I can't think of anything else other than DST time changes are coming up soonish and it could be an opportunity to revisit the meeting time (or have a poll or something)
18:59:12 <gundalow> dmsimard: Maybe a new dict in `galaxy.yml` `include-files:` to have opt-in?
18:59:43 <samccann> I think this meeting just stuck with UTC the last time?
18:59:44 <dmsimard> gundalow: yeah, it could be anything, my point being that we don't necessarily have to change the default behavior on everyone
18:59:59 <dmsimard> samccann: yeah, we kept it at the same time so it wound up being later for some folks (I think)
19:00:37 <dmsimard> We're up to the hour, time to wrap up. Thanks for coming everyone :)
19:00:40 <dmsimard> #endmeeting