18:02:49 <andersson007__> #startmeeting Ansible Community Meeting
18:02:49 <zodbot> Meeting started Wed Sep  7 18:02:49 2022 UTC.
18:02:49 <zodbot> This meeting is logged and archived in a public location.
18:02:49 <zodbot> The chair is andersson007__. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:02:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:02:49 <zodbot> The meeting name has been set to 'ansible_community_meeting'
18:03:11 <andersson007__> #chair DonNaro[m]
18:03:11 <zodbot> Current chairs: DonNaro[m] andersson007__
18:03:11 <DonNaro[m]> o/
18:03:18 <cybette_> o/
18:03:23 <cybette_> sorry I'm a bit late
18:03:27 <andersson007__> #chair cybette_
18:03:27 <zodbot> Current chairs: DonNaro[m] andersson007__ cybette_
18:03:27 <DonNaro[m]> hi cybette
18:03:33 <cybette_> hi Don Naro  :)
18:03:37 <andersson007__> hi cybette and DonNaro[m] :)
18:04:01 <andersson007__> #topic Agenda https://github.com/ansible/community/issues/645
18:04:26 <andersson007__> acozine andersson007_ baptistemm bcoca briantist cyberpear cybette dericcrago dmsimard felixfontein geerlingguy gundalow gwmngilfen ikhan_ jillr jtanner lmodemal misc nitzmahone resmo samccann tadeboro cidrblock thaumos zbr: ping!
18:04:43 <andersson007__> copied it from the previous log ^
18:04:55 <cybette_> :D
18:04:58 <cybette_> I'd have done the same!
18:05:05 <andersson007__> :)
18:05:12 <briantist> o/
18:05:16 <andersson007__> #topic Updates
18:05:18 <cyberpear> o/
18:05:21 <andersson007__> #chair briantist
18:05:21 <zodbot> Current chairs: DonNaro[m] andersson007__ briantist cybette_
18:05:28 <andersson007__> #chair cyberpear
18:05:28 <zodbot> Current chairs: DonNaro[m] andersson007__ briantist cyberpear cybette_
18:05:39 <andersson007__> does anyone have any updates?
18:05:56 <andersson007__> maybe summit related or whatever?
18:06:02 <cybette_> #chair briantist
18:06:02 <zodbot> Current chairs: DonNaro[m] andersson007__ briantist cyberpear cybette_
18:06:59 <acozine> o/
18:07:06 <andersson007__> #chair acozine
18:07:06 <zodbot> Current chairs: DonNaro[m] acozine andersson007__ briantist cyberpear cybette_
18:07:28 <andersson007__> i think we can end up soon with fully async discussions:)
18:07:47 <felixfontein> o/
18:07:50 <andersson007__> maybe it's time
18:07:55 <andersson007__> #chair felixfontein
18:07:55 <zodbot> Current chairs: DonNaro[m] acozine andersson007__ briantist cyberpear cybette_ felixfontein
18:07:56 <felixfontein> sorry, I completely forgot to mention that I might miss the meeting, or be late :(
18:08:01 <cybette_> hmm especially when my instance here seems to be lagging
18:08:02 <cybette> maybe this works better
18:08:34 <acozine> heh
18:08:56 <andersson007__> folks there's currently  the updates part, does anyone have anything to share?
18:09:05 <andersson007__> felixfontein: no worries
18:09:31 <acozine> I've been on vacation since our last meeting
18:10:05 <cybette_> #info The preliminary agenda for Ansible Contributor Summit is here, please share your comments and feedback: https://hackmd.io/@ansible-community/cs202210-agenda
18:11:07 <cybette_> #info We are still looking for a couple more topics if possible, please feel free to propose it here: https://hackmd.io/@ansible-community/cs202210-planning
18:11:11 <andersson007__> cybette_:  it looks like it's slowly but surely being filled up
18:11:35 <andersson007__> cool:)
18:12:11 <andersson007__> don't miss the last chance, folks:)
18:12:18 <cybette_> #info if you have any questions about Ansible Contributor Summit, just ping me or andersson007_
18:12:30 <andersson007__> ops
18:12:31 <cybette_> andersson007__: yep :)
18:12:40 <andersson007__> :)
18:13:31 <andersson007__> any other updates? if no, we can discuss something from the topics
18:14:08 <cybette> I don't have any more updates for now. It's been a long day and my mind is not really working anymore.
18:14:14 <cybette> (neither is my other matrix account)
18:14:43 <andersson007__> ok
18:14:49 <andersson007__> #topic https://github.com/ansible-community/community-topics/issues/131
18:14:54 <felixfontein> it was a long day indeed. though I didn't work today, so I have less reason on that part ;)
18:15:01 <remindbot[m]> @cybette:ansible.im cyb-clock chimes every 15 minutes during the community meeting
18:15:02 <andersson007__> it's still empty
18:15:23 <felixfontein> oh right, that one
18:15:23 <andersson007__> yep, it was a looong day
18:15:29 <felixfontein> sorry, forgot again :(
18:15:41 <andersson007__> no worries
18:16:02 <andersson007__> if someone remember all related topics, please put the links to the issue
18:16:15 <andersson007__> i could try to formulate questions myself
18:16:27 <andersson007__> though no promises
18:17:27 <andersson007__> my tired at this time as usual brain is making stupid grammar mistakes
18:18:14 <acozine> One possible question is: "Are we violating any licensing requirements if we fail to include every single file from a repository in the associated distribution artifact (Ansible collection)?"
18:19:02 <acozine> Or to put it another way, "Can we leave files out of the distribution artifact without violating the license?"
18:19:02 <andersson007__> acozine: feel free to put it in https://github.com/ansible-community/community-topics/issues/131
18:19:30 <acozine> I don't know if the question needs more detail than that, but I will put both versions into a comment.
18:19:30 <andersson007__> maybe "... the license or any other laws" ?
18:19:49 <andersson007__> acozine: sounds good, thanks
18:19:55 <felixfontein> also something like: Can we release collection artefacts which include not all parts of the repository used to create this artefact, by referencing a GitHub tag as the source version?
18:20:47 <andersson007__> sgtm
18:22:22 <andersson007__> ok, let's think about the questions and put our thoughts in the topic
18:22:41 <andersson007__> no objections if we proceed?
18:23:11 <acozine> I've put a comment on the ticket.
18:23:41 <andersson007__> +1
18:23:42 <cybette> thanks acozine !
18:24:13 <andersson007__> as i can see there are a lot of topics with no interest from the community, for example https://github.com/ansible-community/community-topics/issues/131
18:24:51 <andersson007__> the question is if we should keep them open forever or close them or (your ideas here) ?
18:25:27 <felixfontein> hmm, that's a very good question
18:25:42 <felixfontein> right now the number of open issues is growing faster than issues are closed
18:25:42 <andersson007__> i'm not talking about this one but in general
18:25:47 <andersson007__> yep
18:26:19 <felixfontein> I think some of them are really important, such as https://github.com/ansible-community/community-topics/issues/88, but apparently nobody is interested in that one :(
18:26:19 <andersson007__> if there's no desicion / no activity, should we establish a kind of term
18:26:28 <felixfontein> (except Brian and me, that is)
18:27:26 <andersson007__> should we maybe conduct a triage from time to time?
18:27:44 <andersson007__> and close stale topics?
18:28:15 <andersson007__> if no interest, what the point to keep them. it can be 6 months or 1 year since the last comment let's say
18:28:41 <andersson007__> just thinking out loud
18:29:13 <cybette> would it be useful to identify 2-3 of such topics, and have a discussion session at contributor summit where many of us are together (virtually) to hash it out?
18:29:15 <andersson007__> my feeling is that SC shouldn't vote on every topic created
18:29:16 <briantist> yeah that one comes up from time to time.. but I guess not often enough to catch anyone else's interest :(
18:29:23 <cybette> async discussions works fine for some topics but maybe not all. some topics benefit from a real time discussion
18:29:50 <briantist> nonetheless, despite no interest, I do think it should stay open, because it will come up again
18:30:03 <remindbot[m]> @cybette:ansible.im cyb-clock chimes every 15 minutes during the community meeting
18:30:17 <cybette> or is awareness the problem? should we share it every few weeks in the bullhorn?
18:30:47 <andersson007__> cybette_:  it's be a big and growing list:)
18:30:52 <andersson007__> it'll
18:30:59 <acozine> This one looks like we could close it: https://github.com/ansible-community/community-topics/issues/17
18:31:00 <cybette> hehe true
18:31:47 <andersson007__> :) let's maybe create a process for the triage?
18:32:08 <andersson007__> i can think about it and create a PR to update our SC workflows
18:33:06 <andersson007__> it can be a quarterly triage (topic) with a list of topics-candidates to get closed
18:33:15 <acozine> organized triage sounds good - I'm in favor of a quick review at the Contrib Summit since it's coming up
18:33:16 <andersson007__> and then we can vote
18:33:36 <cybette> +1
18:33:36 <andersson007__> on a bunch of topics
18:33:37 <acozine> and also some kind of recurring topic for "cleaning out old topics"
18:33:49 <andersson007__> yes yes
18:34:09 <andersson007__> that's what i was trying to say
18:34:13 <andersson007__> :)
18:36:58 <felixfontein> I hope the cleaning topic won't just be another inactive topic :)
18:37:07 <andersson007__> hehe
18:37:16 <cybette> 😅
18:37:21 <bcoca> hope
18:37:35 <acozine> heh, i wasn't suggesting we create an issue for it
18:37:44 <acozine> just put it on a quarterly reminder of some kind
18:38:14 <andersson007__> i'll set up a reminder on my phone
18:38:15 <cybette> the inactive issue about inactive issues
18:40:07 <andersson007__> that's fine as when we will be creating the second issue we can just refer to the first one still open
18:40:21 <andersson007__> will be like a chain of triage topics
18:42:32 <andersson007__> #action andersson007 to think about Steering Committee WF update related to triage of old topics
18:42:53 <acozine> I was thinking we could put "issue triage" on the agenda as a recurring topic, so maybe if it's quarterly, we announce for the last two weeks of September that we'll do triage the first week of October, then we start the first October meeting with a list of "here are some issues we could close" and by the end of the month we either close them or update them in some meaningful way
18:44:29 <acozine> I also think it's fair to just close topics with "closing for lack of interest/activity"
18:44:38 <andersson007__> sounds good to me
18:44:39 <acozine> in fact, sometimes that's the best way to generate interest/activity
18:45:00 <remindbot[m]> @cybette:ansible.im cyb-clock chimes every 15 minutes during the community meeting
18:45:03 <acozine> folks look at the issue and start saying, "wait, why did we close that? I'm interested . . ." and maybe the conversation starts up again
18:45:21 <andersson007__> yep
18:46:49 <resmo> o/
18:46:56 <andersson007__> #chair resmo
18:46:56 <zodbot> Current chairs: DonNaro[m] acozine andersson007__ briantist cyberpear cybette_ felixfontein resmo
18:48:23 <andersson007__> yes, it's important to handle old topics imo as people invested time in bringing them up. sometimes they get irrelevant before solving, so they need to be closed not to distract us from relevant ones
18:48:43 <cybette> +1
18:49:07 <andersson007__> ok, any other things to briefly discuss before open floor?
18:50:46 <andersson007__> #topic Open Floor
18:50:47 <felixfontein> +1
18:51:45 <andersson007__> does anyone wanna dance with Toshio today?:)
18:52:03 <DonNaro[m]> dance with Toshio?
18:52:14 <bcoca> dancing badger
18:52:18 <andersson007__> yep:)
18:53:03 <andersson007__> if nobody, I'll close the meeting in 3 minutes
18:53:39 <DonNaro[m]> I'm intrigued about this dancing badger. I did a search but I'm still not entirely sure...
18:54:02 <DonNaro[m]> I'll give it a shot even if I make a fool of myself
18:54:13 <cybette_> https://badges.fedoraproject.org/badge/dancing-with-toshio
18:55:54 <DonNaro[m]> now I know. and I've been using Fedora for years... there's always something new.
18:56:12 <andersson007__> DonNaro[m]: I'll tell you about him in our 1:1 if there's a chance
18:56:17 <andersson007__> #endmeeting