#ansible-meeting: ansible core

Meeting started by thaumos at 15:00:07 UTC (full logs).

Meeting summary

  1. fix for include_role unit tests (thaumos, 15:11:36)
    1. https://github.com/ansible/ansible/pull/31920 (thaumos, 15:11:44)
    2. ACTION: jimi|ansible to review https://github.com/ansible/ansible/pull/31920 as he made the original changes (gundalow, 15:15:09)
    3. https://gist.github.com/bcoca/acbb85fcddede006ea23a343bef6ed94 (bcoca, 15:21:46)
    4. AGREED: Not a blocker as: 1) It's a preview, 2) was broken in 2.3 (gundalow, 15:35:29)
    5. PR merged. (abadger1999, 15:37:49)

  2. overloaded --ask-pass (gundalow, 15:38:34)
  3. do we need a new cli arg to unlcok ssh key (thaumos, 15:38:38)
    1. https://github.com/ansible/community/issues/273#issuecomment-341108984 (gundalow, 15:38:48)
    2. Background discussion https://github.com/ansible/ansible/issues/31988 (gundalow, 15:39:02)
    3. We are overloading --ask-pass, sometimes it means: (gundalow, 15:39:08)
    4. a) Use this password to unlock an encrypted SSH Key (gundalow, 15:39:15)
    5. b) Use this for password auth (gundalow, 15:39:20)
    6. QUESTION: Do we need a new command line argument that's only used to unlock the SSH Key? (gundalow, 15:39:28)
    7. https://github.com/ansible/ansible/issues/32503 (bcoca, 15:40:00)
    8. https://github.com/ansible/ansible/pull/31024/files#diff-f24f238727907014621e8c7a84a5644dR47 <= my update to password docs in paramiko (bcoca, 15:49:10)
    9. http://docs.paramiko.org/en/2.3/api/client.html (bcoca, 15:50:12)


Meeting ended at 16:03:05 UTC (full logs).

Action items

  1. jimi|ansible to review https://github.com/ansible/ansible/pull/31920 as he made the original changes


Action items, by person

  1. jimi|ansible
    1. jimi|ansible to review https://github.com/ansible/ansible/pull/31920 as he made the original changes


People present (lines said)

  1. bcoca (33)
  2. thaumos (31)
  3. abadger1999 (30)
  4. gundalow (25)
  5. zodbot (10)
  6. alikins (7)
  7. Pilou (7)
  8. jimi|ansible (4)
  9. ryansb (2)
  10. Qalthos (1)
  11. orc_fedo (1)
  12. pilou (0)


Generated by MeetBot 0.1.4.