#ansible-meeting: ansible core

Meeting started by thaumos at 15:00:25 UTC (full logs).

Meeting summary

  1. Bulk code tidyups (autopep8) (gundalow, 15:04:13)
    1. As you all know we have a pep8 standard enforced by `ansible-test sanity --test pep8` (gundalow, 15:04:40)
    2. There are a number of files that are not compliant, which are listed in test/sanity/pep8/legacy-files.txt (gundalow, 15:05:12)
    3. There is a slow trickle of PRs to address pep8. Generally done by hand, and as is the way when humans are involved, then sometimes contains mistakes that are not spotted during review (such as missing `,` in lists) (gundalow, 15:06:32)
    4. I propose that we run `autopep8 -r --max-line-length 160 --in-place --ignore E305,E402,E722,E741 .` against the codebase (gundalow, 15:07:03)
    5. PR1: autopep8 for modules (gundalow, 15:07:15)
    6. PR2: hand crafted fixes for issues that autopep8 doesn't fix modules (gundalow, 15:07:43)
    7. pr3 & pr4 same for non-modules (gundalow, 15:07:53)
    8. AGREED: 11 (core) and 1 (comiter, but not core) people agreed to do this. Only -1 was from bcoca (gundalow, 15:16:49)
    9. HELP: (gundalow, 15:16:56)
    10. HELP: (gundalow, 15:17:01)

  2. Bulk code tidyups (non-pep8 related) (gundalow, 15:25:31)
    1. agreed A) Although `required: false` and `default: null` are redundent (as they are the default), removing them isn't required as they are just "redundent" rather than "incorrect". If while working on a modules and making improvements to the DOCUMENTATION, such as improveing the `descriptions` you wish to remove these lines, that is fine, though not required. (gundalow, 15:44:28)
    2. agreed B) Understand that PRs that improve the module for a users point of view (improved docs, bug fixes, error handling) are much more welcome that style only PRs. Generally speaking we do not welcome style only PRs, there is still overhead in triaging PRs. (gundalow, 15:44:51)
    3. agreed C) PRs that improve the quality of module documentation, including propper use of C(..), I(...), M(...), U(...) are welcome (gundalow, 15:45:05)
    4. ACTION: Gundalow to document ABC + update docs for pep8 (given autopep8) (gundalow, 15:45:24)
    5. AGREED: A) Although `required: false` and `default: null` are redundent (as they are the default), removing them isn't required as they are just "redundent" rather than "incorrect". If while working on a modules and making improvements to the DOCUMENTATION, such as improveing the `descriptions` you wish to remove these lines, that is fine, though not required. (gundalow, 15:46:17)
    6. AGREED: B) Understand that PRs that improve the module for a users point of view (improved docs, bug fixes, error handling) are much more welcome that style only PRs. Generally speaking we do not welcome style only PRs, there is still overhead in triaging PRs. (gundalow, 15:46:24)
    7. AGREED: C) PRs that improve the quality of module documentation, including propper use of C(..), I(...), M(...), U(...) are welcome. Changes that improve docs/docsite/ are always welcome - In this context doc/ui/presentation/formatting IS important (gundalow, 15:47:34)

  3. Open Floor (gundalow, 15:51:48)
    1. https://github.com/ansible/ansibullbot/blob/master/ansibullbot/wrappers/defaultwrapper.py#L1141-L1148 (jtanner, 16:00:21)
    2. ACTION: pilou add doc for https://github.com/ansible/ansibullbot/blob/master/ansibullbot/wrappers/defaultwrapper.py#L1141-L1148 (Pilou, 16:06:38)


Meeting ended at 16:26:32 UTC (full logs).

Action items

  1. Gundalow to document ABC + update docs for pep8 (given autopep8)
  2. pilou add doc for https://github.com/ansible/ansibullbot/blob/master/ansibullbot/wrappers/defaultwrapper.py#L1141-L1148


People present (lines said)

  1. gundalow (100)
  2. bcoca (53)
  3. sivel (27)
  4. dag (25)
  5. abadger1999 (21)
  6. jimi|ansible (15)
  7. zodbot (12)
  8. Pilou (11)
  9. jtanner (11)
  10. ryansb (9)
  11. akasurde (9)
  12. eikef (8)
  13. sdoran (7)
  14. mkrizek (4)
  15. mattclay (4)
  16. thaumos (4)
  17. Qalthos (3)
  18. shertel (3)
  19. kedarX (1)


Generated by MeetBot 0.1.4.