#ansible-meeting: ansible core

Meeting started by thaumos at 19:00:11 UTC (full logs).

Meeting summary

  1. adding a lock state and other functionality to pkg manager modules (thaumos, 19:07:02)
    1. https://www.youtube.com/watch?v=4MshXgbzcXs (bcoca, 19:07:09)
    2. https://github.com/ansible/ansible/pull/31438 (thaumos, 19:07:14)

  2. adding a non-native package manager plugin to a module (maxamillion, 19:07:57)
  3. how to best determine desired state when output from an api does not provide clear guidance (thaumos, 19:11:19)
    1. https://github.com/ansible/community/issues/286#issuecomment-352553549 (thaumos, 19:11:49)
    2. ACTION: maxamillion to close the PR (thaumos, 19:19:25)

  4. more concise messaging on smart quotes (thaumos, 19:19:52)
    1. https://github.com/ansible/ansible/issues/33044 (thaumos, 19:20:01)
    2. ACTION: abadger1999 to spit an error that says unbalanced quotes. ;) (thaumos, 19:31:52)

  5. eikef asking for feedback follow up on pr (thaumos, 19:32:41)
    1. https://github.com/ansible/ansible/pull/33419 (thaumos, 19:32:48)
    2. ACTION: sivel to follow up with eikef's pr (thaumos, 19:35:21)

  6. config toggles for playbook complaints (thaumos, 19:36:17)
    1. ACTION: don't all clammer at once (thaumos, 19:50:00)
    2. ACTION: bcoca to rename command_warnings to action_warnings and change working to all modules as opposed to calling out command and shell specifically. (thaumos, 19:51:42)

  7. Open floor (thaumos, 19:51:48)
    1. The meetings on 21-Dec, 26-Dec, and 28-Dec are cancelled. (thaumos, 19:54:41)


Meeting ended at 19:56:41 UTC (full logs).

Action items

  1. maxamillion to close the PR
  2. abadger1999 to spit an error that says unbalanced quotes. ;)
  3. sivel to follow up with eikef's pr
  4. don't all clammer at once
  5. bcoca to rename command_warnings to action_warnings and change working to all modules as opposed to calling out command and shell specifically.


Action items, by person

  1. abadger1999
    1. abadger1999 to spit an error that says unbalanced quotes. ;)
  2. bcoca
    1. bcoca to rename command_warnings to action_warnings and change working to all modules as opposed to calling out command and shell specifically.
  3. maxamillion
    1. maxamillion to close the PR
  4. sivel
    1. sivel to follow up with eikef's pr


People present (lines said)

  1. thaumos (106)
  2. sivel (72)
  3. abadger1999 (60)
  4. maxamillion (44)
  5. bcoca (41)
  6. gundalow (16)
  7. zodbot (10)
  8. jtanner (8)
  9. ryansb (5)


Generated by MeetBot 0.1.4.