15:01:46 <gundalow> #startmeeting Ansible Core IRC meeting
15:01:46 <zodbot> Meeting started Thu Feb  7 15:01:46 2019 UTC.
15:01:46 <zodbot> This meeting is logged and archived in a public location.
15:01:46 <zodbot> The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:46 <zodbot> The meeting name has been set to 'ansible_core_irc_meeting'
15:02:48 <gundalow> #info Agenda https://github.com/ansible/community/labels/core
15:03:00 <akasurde> o/
15:04:04 <gundalow> #chair sdoran akasurde maxamillion
15:04:04 <zodbot> Current chairs: akasurde gundalow maxamillion sdoran
15:04:44 <decentral1se> o/
15:06:02 <gundalow> #chair decentral1se alongchamps
15:06:02 <zodbot> Current chairs: akasurde alongchamps decentral1se gundalow maxamillion sdoran
15:06:22 <gundalow> #topic java_cert: support of different keystore type (JKS, JCEKS) #49953
15:06:26 <alongchamps> Good morning all
15:06:30 <gundalow> #info https://github.com/ansible/ansible/pull/49953
15:06:41 <gundalow> Update to an existing module to add keystore type
15:07:27 <gundalow> Not knowing anything about Java Cert, this PR looks OK
15:07:49 <akasurde> same here
15:07:56 <sdoran> Ditto.
15:08:01 * gundalow will merge
15:08:53 <gundalow> Thanks
15:09:12 <gundalow> #agreed merged 49953
15:09:18 <gundalow> #topic AWS PRs
15:09:29 <gundalow> #info https://github.com/ansible/ansible/pull/51535
15:09:50 <gundalow> akasurde: ah, see you are ahead of us, thank you
15:10:41 * gundalow pushes commit to remove blank line
15:11:03 <gundalow> oh, file is executable
15:11:43 <sdoran> We could also mention the AWS working group and #ansible-aws channel in IRC.
15:11:46 <gundalow> and has merge conflict
15:12:02 <gundalow> sdoran: Bot has done in https://github.com/ansible/ansible/pull/51535#issuecomment-459297763
15:12:06 <gundalow> though no AWS meetings
15:12:14 <sdoran> Sweetness.
15:12:25 <sdoran> I just assume we have a WG for everything these days. :)
15:12:46 <gundalow> #info We have many Working Groups: https://github.com/ansible/community/wiki
15:13:08 <gundalow> #topic Open Floor
15:13:12 <akasurde> gundalow, I will take care of that AWS PR
15:13:18 <gundalow> akasurde: Thanks :)
15:13:45 <gundalow> I see this is their first PR to Ansible so they may need some guidance
15:13:49 <gundalow> Anyone got anything else?
15:15:46 <maxamillion> .hello2
15:15:47 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:15:49 <maxamillion> sorry I'm late
15:16:53 <gundalow> forgiven
15:17:08 <gundalow> Anyone got anything else they've like to bring up?
15:17:15 <sdoran> maxamillion: We assigned everything to you. 😜
15:17:25 <maxamillion> sdoran: sounds about right
15:17:56 <gundalow> Thanks to akasurde for creating https://github.com/ansible/community/issues/437 please do add `easyfix` to issues and leave them for others to fix
15:18:34 <akasurde> thanks @gundalow
15:18:34 <decentral1se> oh, think I've got one
15:18:50 <decentral1se> but it's a proposal
15:18:51 <decentral1se> https://github.com/ansible/proposals/issues/23
15:19:09 <gundalow> #topic proposal#23 Role Versioning
15:19:15 <gundalow> decentral1se: floor is yours
15:19:21 <decentral1se> PR sitting here: https://github.com/ansible/ansible/pull/37880
15:19:33 <decentral1se> unsure of status. Anyone know? Is it blocked by some discussion issue etc.
15:19:39 * maxamillion looks
15:19:59 <sdoran> I'm not sure how this relates to the current work around collections.
15:20:43 <sivel> typically speaking, we aren't at the moment accepting new features for ansible-galaxy
15:21:04 <decentral1se> oh, I see
15:21:14 <sivel> New features and functionality are going into https://github.com/ansible/mazer
15:21:15 <gundalow> #chair sivel
15:21:15 <zodbot> Current chairs: akasurde alongchamps decentral1se gundalow maxamillion sdoran sivel
15:21:17 <alikins> I am curious about the scenarios where it is needed/desired
15:21:48 <decentral1se> my interest comes from this being mentioned as a prereq for auto installs
15:21:49 <alikins> what kind of problems it can solve, etc
15:21:51 <decentral1se> from requirements.yml
15:22:01 <decentral1se> bcoca mentioned ...
15:22:18 <decentral1se> in https://github.com/ansible/proposals/issues/7
15:22:57 <gundalow> bcoca is on holiday at the moment
15:23:40 <maxamillion> goodness that proposal has been bounced around quite a bit
15:24:11 <sdoran> The idea has been discussed a lot.
15:24:43 <sivel> I'm also not sure that autoinstalls will ever be a thing in ansible proper
15:24:51 <maxamillion> having suffered through a lot of pain in my life at the hands of the ruby bundler lock file, I'm not sure I'm a big fan of this but if there's enough of a need for it I'm not going to argue against it
15:25:10 <sivel> We recently discussed autoinstalls internally, recently, and it seemed to come to the conclusion that ansible would not add it
15:25:12 <decentral1se> well, I don't want to get into auto-installs but I think versioning has its own value
15:25:22 <decentral1se> is it the case that I need to make a stronger case for versioning?
15:25:32 <decentral1se> or is this all unclear due to mazer/collections/etc.
15:27:26 <alikins> I agree that handling multiple versions needs to supported better. I'm curious in any particular scenarios or uses that run into this sort of problem
15:29:23 <decentral1se> I can try to gather some use cases and requirements further
15:29:44 <alikins> That would be awesome.
15:31:16 <alikins> In theory mazer doesn't support multiple versions of collections in the same content root for the sake of simplicity, but I think it has to support multiple versions eventually
15:31:50 <alikins> (and/or, ansible-playbook role loader etc)
15:33:11 <gundalow> decentral1se: use cases would be really usefu;
15:34:42 <alikins> decentral1se: that pr more or less manages an unversioned symlink to whichever versioned role is approriate?  roles/foobar -> roles/foobar-1.2.3 more or less?
15:37:31 <decentral1se> OK, so, to return with further information then and let's see
15:37:47 <alikins> in theory 2.8 will have some mechanisms for supporting the idea of default resolution of role/plugin/module names, so may make sense to integrate versions there as well
15:37:48 <decentral1se> but can we say with any further information regarding mazer etc.
15:38:01 <decentral1se> that this would be a waste of time (or so... if not so bluntly said :))
15:38:30 <decentral1se> ah ok, so it's still on the table
15:38:54 <gundalow> #chair alikins
15:38:54 <zodbot> Current chairs: akasurde alikins alongchamps decentral1se gundalow maxamillion sdoran sivel
15:39:41 <gundalow> decentral1se: I need to drop off now, though I'll leave you in the capable hands of the rest of the team
15:39:43 <alikins> atm, the code for 'ansible-galaxy' is kind of 'stable'/'frozen', but whatever the ansible 2.8+ functional equiv is is a candidate
15:41:44 <decentral1se> gundalow: thanks :)
15:42:22 <alikins> decentral1se: https://github.com/ansible/mazer/issues/149 is another related feature request
15:45:56 <decentral1se> hmmmm
15:45:59 <decentral1se> sorry, have to run now
15:46:07 <decentral1se> any bullet points on where to go with this then?
15:46:12 <decentral1se> just want to push it forward a little :)
15:47:08 <maxamillion> alikins: thoughts on that?
15:49:45 <alikins> real world use cases would be my favorite.  "I tried to do X, but that needs Y. Solution Z would fix it by ...'
15:50:08 <maxamillion> tima: ping - do you have any thoughts on this topic?  ... I'm interested in your take
15:50:34 <maxamillion> alikins: iirc, geerlingguy also had some of those
15:50:35 <alikins> not really even the solution part needed at this point, but anything concrete is a bonus
15:50:47 <maxamillion> +1
15:50:57 <maxamillion> well defined use cases help drive things forward
15:51:32 <decentral1se> perfect, thank you all
15:54:48 <maxamillion> alikins: where should decentral1se provide that information? in the proposal or the mazer issue?
15:56:54 <alikins> hmm, good question. mazer issue I guess? I'm not sure
16:01:43 <sdoran> Anything else to discuss for today?
16:03:37 <maxamillion> sdoran: light the fuse
16:04:12 <sdoran> 🔥
16:05:56 <maxamillion> #endmeeting