#ansible-meeting: Ansible Core Meeting

Meeting started by abadger1999 at 19:02:50 UTC (full logs).

Meeting summary

  1. Agree to the general Agenda: https://github.com/ansible/community/pull/76 (abadger1999, 19:06:03)
    1. abadger1999 and jimi|ansible approve of the general agenda/purpose. (abadger1999, 19:09:11)
    2. ACTION: gundalow will get gregdek's blessing and merge (abadger1999, 19:10:27)

  2. PR and Issue review (abadger1999, 19:10:43)
    1. https://github.com/ansible/ansible/pull/15304 Travis to defend "make deb" (gundalow, 19:11:40)

  3. https://github.com/ansible/ansible/pull/15304 Travis to defend "make deb" (abadger1999, 19:13:47)
    1. https://github.com/ansible/ansible/pull/15304/files (gundalow, 19:18:07)
    2. ACTION: gundalow to update 15304 to build in the containers. (abadger1999, 19:19:15)

  4. Binary modules (abadger1999, 19:20:17)
    1. https://github.com/ansible/ansible/pull/13771 (sivel, 19:20:39)
    2. Current PR https://github.com/ansible/ansible/pull/13771 (abadger1999, 19:22:19)
    3. ACTION: sivel to rebase 13771 but wait for 2.1 release for merge (sivel, 19:23:50)
    4. https://github.com/ansible/ansible-modules-core/pull/3342 (gundalow, 19:24:12)

  5. https://github.com/ansible/ansible-modules-core/pull/3342 Corrections to documentation (abadger1999, 19:25:13)
    1. 3352 and 3342 merged. gundalow to work on ansible-validate-modules next. (abadger1999, 19:30:12)

  6. module 'tested on' documentation part (abadger1999, 19:30:45)
    1. ACTION: people can propose PRs with versions for requirements where it makes sense and we'll evaluate them as they come in. (abadger1999, 19:46:50)
    2. https://github.com/ansible/ansible/pull/14079 (bcoca, 19:48:43)

  7. open floor (abadger1999, 19:53:23)
    1. the 18th is the feature freeze date for 2.1, so if you have anything you want to get in, do it ASAP (abadger1999, 19:53:37)

  8. ziploader (abadger1999, 19:53:44)
    1. modules themselves should be encoded in utf-8. (abadger1999, 19:54:09)
    2. ziploader definitely will be in 2.1 (abadger1999, 19:54:29)
    3. https://github.com/ansible/ansible/pull/15344 (abadger1999, 19:54:50)

  9. Bug: Docs don't say you *have* to use a string, but fails when an integer is used (abadger1999, 19:56:02)
    1. https://groups.google.com/forum/#!msg/ansible-project/HdD1FD-lG4A/WrGXN7rFAQAJ (abadger1999, 19:56:12)

  10. https://github.com/ansible/ansible-modules-core/pull/2744 yum support for downgrading packages (abadger1999, 20:01:27)
    1. https://github.com/ansible/ansible-modules-core/compare/devel...jkugler:patch-1 (pedahzur, 20:07:04)

  11. Open floor (abadger1999, 20:22:09)
  12. Proposals (abadger1999, 20:23:45)
    1. ACTION: gregdek to put proposals onto the charter for the meeting. We'll spend some time on them each meeting -- make it more formal if we find we're not giving them enough time. (abadger1999, 20:30:51)


Meeting ended at 20:31:48 UTC (full logs).

Action items

  1. gundalow will get gregdek's blessing and merge
  2. gundalow to update 15304 to build in the containers.
  3. sivel to rebase 13771 but wait for 2.1 release for merge
  4. people can propose PRs with versions for requirements where it makes sense and we'll evaluate them as they come in.
  5. gregdek to put proposals onto the charter for the meeting. We'll spend some time on them each meeting -- make it more formal if we find we're not giving them enough time.


Action items, by person

  1. gregdek
    1. gundalow will get gregdek's blessing and merge
    2. gregdek to put proposals onto the charter for the meeting. We'll spend some time on them each meeting -- make it more formal if we find we're not giving them enough time.
  2. gundalow
    1. gundalow will get gregdek's blessing and merge
    2. gundalow to update 15304 to build in the containers.
  3. sivel
    1. sivel to rebase 13771 but wait for 2.1 release for merge


People present (lines said)

  1. abadger1999 (97)
  2. bcoca (51)
  3. gundalow (49)
  4. jimi|ansible (48)
  5. gregdek (37)
  6. kamsz (30)
  7. sivel (20)
  8. pedahzur (13)
  9. Shrews (8)
  10. nitzmahone (8)
  11. willusher (6)
  12. zodbot (6)
  13. Qalthos (1)
  14. ryansb (1)
  15. newtMcKerr (1)
  16. mordred (1)


Generated by MeetBot 0.1.4.