#ansible-meeting: Ansible Core Meeting
Meeting started by abadger1999 at 19:02:40 UTC
(full logs).
Meeting summary
-
- Agenda, feel free to add things, esp if their
any proposals you'd like to discuss
tohttps://github.com/ansible/community/issues/150 (abadger1999,
19:04:30)
- Overall guidance on reformatting code that is *not* covered by pep8 (eg, Powershell). (abadger1999, 19:09:15)
- nitzmahone proposing that committers should
currently strive not to rewrite powershell code to conform to any
personal style (preserves attribution in git blame), just try to
work with what's already there. Windows Working Group may make a
proposal for set style guidelines in the future. (abadger1999,
19:15:07)
- +1: 4, 0:0, -1:0 for nitzmahone's proposal
about powershell style-only changes. (abadger1999,
19:19:08)
- ACTION: nitzmah9one
to write up decision on powershell coding style for the windows
moduile checklist. (abadger1999,
19:19:49)
- open floor (abadger1999, 19:20:03)
- etc_hosts module (abadger1999, 19:20:47)
- ACTION: abadger will
close PR with results ofthe vote that was taken on 09-Feb
(abadger1999,
19:21:22)
- Wildcards inside of fileglob lookup: https://github.com/ansible/ansible/pull/19297 (abadger1999, 19:21:48)
- https://github.com/ansible/community/issues/150#issuecomment-277024953 win_file: fix error when creating an existing dir (abadger1999, 19:26:53)
- ACTION: nitzmahone to
review ansible/ansible#19070 (win_file fix) this week (probably
Thursaday) (abadger1999,
19:29:21)
- Extra metadata for non-module files (abadger1999, 19:30:50)
- abadger proposes that config files for dyn
inventory use the same metadata as the dyn inventory script.
(abadger1999,
19:33:38)
- there's one inventory script/config pair that
doesn't match: consul.ini and consul_io.py (ryansb,
19:36:31)
- ACTION: ryansb rename
consul.ini in repo, and search for both consul.ini and consul_io.ini
in consul_io dynamic inventory (ryansb,
19:37:56)
- WIndows Working Group https://github.com/ansible/community/issues/150#issuecomment-280354753 (abadger1999, 19:44:30)
- Windows Working group will meet Monday
afternoon and Friday morning US Pacific time (alternating weeks for
the meeting times). (abadger1999,
19:47:32)
- ACTION: mattclay and
nitzmahone to add time and dates to the public calendars
(abadger1999,
19:47:54)
- Open Floor (abadger1999, 19:48:12)
Meeting ended at 19:51:47 UTC
(full logs).
Action items
- nitzmah9one to write up decision on powershell coding style for the windows moduile checklist.
- abadger will close PR with results ofthe vote that was taken on 09-Feb
- nitzmahone to review ansible/ansible#19070 (win_file fix) this week (probably Thursaday)
- ryansb rename consul.ini in repo, and search for both consul.ini and consul_io.ini in consul_io dynamic inventory
- mattclay and nitzmahone to add time and dates to the public calendars
Action items, by person
- mattclay
- mattclay and nitzmahone to add time and dates to the public calendars
- nitzmahone
- nitzmahone to review ansible/ansible#19070 (win_file fix) this week (probably Thursaday)
- mattclay and nitzmahone to add time and dates to the public calendars
- ryansb
- ryansb rename consul.ini in repo, and search for both consul.ini and consul_io.ini in consul_io dynamic inventory
- UNASSIGNED
- nitzmah9one to write up decision on powershell coding style for the windows moduile checklist.
- abadger will close PR with results ofthe vote that was taken on 09-Feb
People present (lines said)
- abadger1999 (68)
- nitzmahone (23)
- bcoca (14)
- ryansb (14)
- zodbot (7)
- jtanner (7)
- mattclay (3)
- daBONDi (1)
- gundalow (1)
- shertel (1)
- Qalthos (0)
- jimi|ansible (0)
- rcarrillocruz (0)
- alikins (0)
- thaumos (0)
Generated by MeetBot 0.1.4.