#ansible-meeting: Ansible Core Meeting

Meeting started by gundalow at 15:00:03 UTC (full logs).

Meeting summary

  1. Proposal workflow ansible/proposals#50 (gundalow, 15:01:27)
    1. oh, that's not right (gundalow, 15:01:40)
    2. https://github.com/allanice001/ansible-template-for-proposals/blob/master/Proposal.md (allanice001, 15:01:49)

  2. Proposal workflow (gundalow, 15:01:49)
    1. https://github.com/allanice001/ansible-template-for-proposals/blob/master/Proposal.md (allanice001, 15:02:12)
    2. https://github.com/allanice001/ansible-template-for-proposals/blob/master/stage-0.md (allanice001, 15:04:56)
    3. AGREED: It's the responsibility of the proposer to drive the proposal through the process (gundalow, 15:22:25)
    4. people can throw other ideas into https://public.etherpad-mozilla.org/p/ansible-proposal-workflow (gundalow, 15:35:08)
    5. <gundalow> I've thrown some thought thoughts on https://public.etherpad-mozilla.org/p/ansible-proposal-workflow (allanice001, 15:35:58)

  3. win_copy: Add force parameter and check-mode support #20405 (gundalow, 15:36:21)
    1. https://github.com/ansible/ansible/pull/20405 (gundalow, 15:36:36)
    2. ACTION: nitzmahone to have a look at https://github.com/ansible/ansible/pull/20405 (gundalow, 15:38:05)
    3. https://github.com/ansible/ansible/pull/20405/files#diff-2ae7ee3819390895333fe91e1df8e365R157 (dag, 15:42:20)

  4. ansible/proposals#14 Proposal: Module Rename Lifecycle (gundalow, 15:47:44)
    1. https://github.com/ansible/proposals/issues/14 (gundalow, 15:47:57)
    2. https://github.com/ansible/proposals/issues/10 Proposal: Module names should be singular #10 (gundalow, 15:49:50)
    3. ACTION: ryansb update the cycle to a 4-release deprectaion cycle (ryansb, 15:56:21)
    4. ACTION: ryansb outline move/symlink process to happen at deprecation time, not after the 4 deprecation cycles (ryansb, 16:09:53)
    5. Much of Proposal #14 has been implemented already, but it has an incorrect deprecation cycle length and needed specific "how to deprecate" implementation details (ryansb, 16:26:45)
    6. discussed with him in #ansible-devel about status, so nothing new since an hour ago when that happened (ryansb, 16:29:38)
    7. https://github.com/ansible/community/issues/150#issuecomment-282033552 (ryansb, 16:29:48)
    8. https://github.com/ansible/community/issues/150#issuecomment-282036027 (ryansb, 16:30:35)
    9. https://github.com/ansible/ansible/blob/devel/MODULE_GUIDELINES.md <= or just update existing one? (bcoca, 16:45:21)
    10. We have some documentation in https://github.com/ansible/ansible/blob/devel/MODULE_GUIDELINES.md and https://github.com/ansible/ansibullbot/blob/master/ISSUE_HELP.md (gundalow, 16:46:49)

  5. Dag discussion about inactive/unresponsive maintainers (gundalow, 16:47:56)
    1. We have some documentation in https://github.com/ansible/ansible/blob/devel/MODULE_GUIDELINES.md and https://github.com/ansible/ansibullbot/blob/master/ISSUE_HELP.md (gundalow, 16:48:05)
    2. https://github.com/ansible/community/blob/master/PR-FLOW.md needs reviewing and most likely deleting, any references to that page should be replaced with a link to https://github.com/ansible/ansibullbot/blob/master/ISSUE_HELP.md (gundalow, 16:50:36)


Meeting ended at 16:51:25 UTC (full logs).

Action items

  1. nitzmahone to have a look at https://github.com/ansible/ansible/pull/20405
  2. ryansb update the cycle to a 4-release deprectaion cycle
  3. ryansb outline move/symlink process to happen at deprecation time, not after the 4 deprecation cycles


Action items, by person

  1. nitzmahone
    1. nitzmahone to have a look at https://github.com/ansible/ansible/pull/20405
  2. ryansb
    1. ryansb update the cycle to a 4-release deprectaion cycle
    2. ryansb outline move/symlink process to happen at deprecation time, not after the 4 deprecation cycles


People present (lines said)

  1. bcoca (121)
  2. gundalow (82)
  3. abadger1999 (75)
  4. jtanner (58)
  5. allanice001 (55)
  6. dag (34)
  7. nitzmahone (33)
  8. ryansb (29)
  9. jhawkesworth (13)
  10. alikins (11)
  11. zodbot (9)
  12. mikedlr (8)
  13. bjolivot (3)
  14. funzo (2)
  15. akasivel (2)
  16. grastogi23 (2)
  17. mattclay (1)
  18. shertel (1)
  19. rcarrillocruz (1)
  20. Qalthos (0)
  21. jimi|ansible (0)


Generated by MeetBot 0.1.4.