#ansible-meeting: Ansible Core Meeting

Meeting started by gundalow at 15:00:10 UTC (full logs).

Meeting summary

    1. Agenda https://github.com/ansible/community/issues/159 (gundalow, 15:00:24)
    2. Fresh agenda for June will be created after the meeting (gundalow, 15:00:43)

  1. `when:` conditions are warning even for variables composed of other variables (gundalow, 15:01:44)
    1. https://github.com/ansible/community/issues/159#issuecomment-304184556 (gundalow, 15:01:51)

  2. ansible/ansible#24580 (gundalow, 15:05:58)
    1. https://github.com/ansible/ansible/pull/24580 (gundalow, 15:06:08)

  3. ansible/proposals#65 Allow documenting option deprecatio (gundalow, 15:08:56)
    1. https://github.com/ansible/proposals/issues/65 (gundalow, 15:09:08)
    2. http://docs.ansible.com/ansible/dev_guide/developing_modules_documenting.html (gundalow, 15:17:53)
    3. Example of where this would be needed https://github.com/ansible/ansible/pull/25234/files#diff-954c42ec1d32c14a6e1e0351c7831692R116 (gundalow, 15:22:26)

  4. What constitutes authorship for a module (gundalow, 15:26:15)
    1. https://github.com/ansible/community/issues/159#issuecomment-304979822 (gundalow, 15:26:28)
    2. ACTION: gundalow gregdek and rbergeron to put some words together around expectation for maintainers and some thoughts about if we do/don't need "authors:", will be added to Contributors Smmit (gundalow, 15:42:57)

  5. Open Floor (gundalow, 15:48:27)
    1. ACTION: jtanner to move MAINTAINERS file into ansible/ansible repo once it makes sense. (abadger1999, 16:12:07)


Meeting ended at 16:20:13 UTC (full logs).

Action items

  1. gundalow gregdek and rbergeron to put some words together around expectation for maintainers and some thoughts about if we do/don't need "authors:", will be added to Contributors Smmit
  2. jtanner to move MAINTAINERS file into ansible/ansible repo once it makes sense.


Action items, by person

  1. gundalow
    1. gundalow gregdek and rbergeron to put some words together around expectation for maintainers and some thoughts about if we do/don't need "authors:", will be added to Contributors Smmit
  2. jtanner
    1. jtanner to move MAINTAINERS file into ansible/ansible repo once it makes sense.


People present (lines said)

  1. gundalow (85)
  2. sivel (42)
  3. bcoca (39)
  4. shertel (33)
  5. dag (20)
  6. jhawkesworth (14)
  7. abadger1999 (12)
  8. zodbot (11)
  9. jtanner (7)
  10. akasurde (4)
  11. alikins (3)
  12. Pilou (3)
  13. albertom (2)
  14. misc (1)
  15. rvgate (1)


Generated by MeetBot 0.1.4.