#ansible-network: Ansible Network Working Group
Meeting started by gundalow at 16:00:15 UTC
(full logs).
Meeting summary
- Core update (gundalow, 16:01:15)
- Ansible 2.5.0 has been released! Thank you all
that have contributed code, testing, support, coffee (gundalow,
16:02:12)
- Expect 2.5.1 in a few weeks. We've just
unlocked `stable-2.5` branch so we will start cherry-picking fixes
into that (gundalow,
16:04:49)
- What we cherry will cherry-pick, along with any
other things that need fixing in 2.5.* can be seen in
https://github.com/ansible/ansible/projects/20 if you think anything
is missing please ping us on IRC (gundalow,
16:06:23)
- NO MORE UNABLE TO OPEN SHELL (gundalow,
16:08:24)
- https://github.com/ansible/ansible/pull/37651
(samerd,
16:10:15)
- Team updates (gundalow,
16:20:29)
- Team updates (gundalow, 16:20:37)
- you may noticed that we've stopped doing daily
standup status in here (#ansible-network). We didn't get much
feedback, and we though that this was partly due to the bitty
task-level updates. So we've decided to give weekly project updates
in here, therefore they will end up in the IRC logs
https://meetbot.fedoraproject.org/sresults/?group_id=ansible-network&type=channel
(gundalow,
16:22:31)
- https://github.com/ansible/proposals/issues/102
(Qalthos,
16:22:58)
- This covers the work for a new connection
plugin for eAPI transport (Qalthos,
16:23:37)
- This week I've been getting up to speed with
Zuul, which is the CI framework that it used by OpenStack (and
friends). For those that know about DCI (Distributed CI) this will
be the *pre* commit replacement for that framework that allows us to
test PRs against a varity of test machines, including those in
partners labs. Nothing to currently demo or show, lots of learning
how to glue parts together. (gundalow,
16:25:47)
- This week I'm revising end-user network
documentation for 2.5. I also started a project for tracking
documentation changes at
https://github.com/ansible/ansible/projects/24 - if you have docs
issues that I've not added to the project, please add them.
(acozine1,
16:27:28)
- currently working on yang2spec action plugin
which will be used in openconfig role. Spec for openconfig role will
be available for review in
https://github.com/ansible-network/network-proposals by next
week (ganeshrn,
16:27:46)
- currently going through network-engine for
template-engine and text-parser
https://github.com/ansible-network/network-engine. Started working
on cli_config specification. Will have the proposal ready probably
next week. (trishnag,
16:30:18)
- Open Floor (gundalow, 16:36:03)
- ACTION: gundalow to
update 2.6 roadmap
https://github.com/ansible/ansible/pull/37926/files (gundalow,
16:37:35)
- I built and PR'd NIOS modules for A, AAAA,
CNAME, MX, and SRV records. Modified the nios_zone module to include
support for name server groups and restart_if_needed flag.
(brampling,
16:40:31)
- https://github.com/ansible/ansible/blob/devel/lib/ansible/module_utils/network/aci/aci.py#L291
(jmcgill298,
16:53:06)
Meeting ended at 17:00:54 UTC
(full logs).
Action items
- gundalow to update 2.6 roadmap https://github.com/ansible/ansible/pull/37926/files
Action items, by person
- gundalow
- gundalow to update 2.6 roadmap https://github.com/ansible/ansible/pull/37926/files
People present (lines said)
- gundalow (56)
- Qalthos (17)
- jmcgill298 (10)
- zodbot (9)
- brampling (6)
- samerd (5)
- itdependsnetwork (5)
- privateip (5)
- acozine1 (2)
- trishnag (2)
- ganeshrn (2)
- funzo (1)
- caphrim007 (0)
Generated by MeetBot 0.1.4.