16:00:17 <Qalthos> #startmeeting Ansible Network Working Group
16:00:17 <zodbot> Meeting started Wed Oct 30 16:00:17 2019 UTC.
16:00:17 <zodbot> This meeting is logged and archived in a public location.
16:00:17 <zodbot> The chair is Qalthos. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:17 <zodbot> The meeting name has been set to 'ansible_network_working_group'
16:00:39 <Qalthos> #chair ganeshrn ikhan justjais_ dmellado
16:00:39 <zodbot> Current chairs: Qalthos dmellado ganeshrn ikhan justjais_
16:00:47 <Qalthos> #topic Core Updates
16:02:03 <Qalthos> #info Ansible 2.9.0rc5 was released last week
16:02:42 <Qalthos> #info Ansible 2.9.0 is scheduled for final release tomorrow (2019-10-31)
16:03:37 <Qalthos> #link https://docs.ansible.com/ansible/devel/roadmap/ROADMAP_2_9.html for more
16:03:58 <Qalthos> (but mostly just more about things that have already happened)
16:05:14 <Qalthos> #info 2.10 module scoping & development have started for network modules
16:06:04 <Qalthos> #link https://github.com/ansible/community/wiki/Network%3A-2.10-Roadmap to see what we are planning
16:08:06 <Qalthos> I think that's about all for today
16:08:40 <Qalthos> #link https://github.com/ansible/community/labels/network is where the agenda for this meeting can be found, as always
16:09:00 <Qalthos> With that, let's move on
16:09:14 <Qalthos> #topic Onyx PRs
16:09:53 <Qalthos> I don't see samerd here, unless they go by a different name on IRC
16:11:04 <Qalthos> But, briefly, we're in a bit of a sticky spot with regards to community PRs at the monent, and our messaging has not been entirely clear so far
16:16:43 <Qalthos> I will try to get these PRs reviewed and acted on, but with cimmunity collections coming, it is not a priority that they get merged in ansible/ansible at this point
16:17:25 <Qalthos> Sorry for the lack of clarity, and I will try to announce a better path forward whenever one appears.
16:18:03 <Qalthos> #topic Refactor CLI prompt mode check
16:18:07 <Qalthos> #link https://github.com/ansible/ansible/pull/63945
16:18:45 <Qalthos> A bit of background here:
16:19:24 <Qalthos> In the intermediate future, I would like to be rid of all the weird action plugins in network modules
16:19:56 <Qalthos> Aside from handling `provider`, these plugins generally do two things
16:20:23 <Qalthos> 1) Fail the module if it's being run with the wrong connection type
16:21:12 <Qalthos> 2) Exit configuration mode if starting there on a fresh task over cli
16:21:47 <Qalthos> 2 is the subject of this PR, moving that check to cliconf where it arguably belongs.
16:22:10 <Qalthos> This touches all cli platforms that have this check so
16:22:51 <Qalthos> #action everybody review ansible/ansible#63945 to see if there are any issues with your network platform
16:23:34 <Qalthos> I would like to have some confidence that this isn't creating any problems that we can't detect or test
16:24:06 <Qalthos> #topic Open Floor
16:24:29 <Qalthos> Before we get into open discussion, one more thing I forgot at the top of the meeting
16:25:13 <Qalthos> #info There will be no IRC meeting next week (2019-11-06) due to an unavoidable internal conflict
16:25:34 <Qalthos> Now then
16:25:43 <Qalthos> Anyone have anything to bring up today?
16:35:55 <Qalthos> Alright, if there's nothing, I'll close at :40
16:40:11 <Qalthos> #endmeeting