16:18:19 <gundalow> #startmeeting Ansible Networking
16:18:19 <zodbot> Meeting started Wed Feb 15 16:18:19 2017 UTC.  The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:18:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:18:19 <zodbot> The meeting name has been set to 'ansible_networking'
16:18:26 <gundalow> #info Agenda https://github.com/ansible/community/issues/110 Feel free to add items
16:18:31 <gundalow> #topic Change the f5 modules to use f5_utils file #21466
16:18:36 <gundalow> #link https://github.com/ansible/ansible/pull/21466
16:18:47 <gundalow> #info looks good, just three pep issues, then gundalow will merge
16:18:59 <gundalow> #topic 2.3 Update
16:19:06 <gundalow> #info Corefreeze is today (West Coast evening). Module freeze in 2 weeks. Note that it takes us time to review, so get PRs in now
16:19:27 <gundalow> #info Network module developer guide will be out for review "soon", It will be linked from the agenda and mentioned next meeting
16:19:38 <gundalow> #info Devel should be stable and feature complete (apart from Junos and NXOS, those will be added in today), please test
16:19:43 <gundalow> #topic Open Floor
16:19:49 <gundalow> Sorry about that
16:19:57 <gundalow> ...............
16:19:58 <gundalow> ...............
16:20:08 <gundalow> Anyone else got anything?
16:20:12 <dgarros> yes I do
16:20:16 <andriusb> AnsibleFest London has been announced! Looking for networking sponsors and call for papers is OPEN!
16:20:26 <gundalow> #info AnsibleFest London has been announced! Looking for networking sponsors and call for papers is OPEN!
16:20:35 <gundalow> #chair dgarros
16:20:35 <zodbot> Current chairs: dgarros gundalow
16:20:43 <andriusb> https://www.ansible.com/ansiblefest#
16:20:49 <gundalow> dgarros: If you #topic, it's all yours
16:20:53 <dgarros> If possible I would like to discuss what are the next steps for all aos_* modules:
16:20:58 <gundalow> cool
16:21:05 <gundalow> #topic aos_* modules
16:21:07 <dgarros> what is needed to get these Merged ?
16:21:20 <allanice001> Pr link ?
16:21:23 <gundalow> #info https://github.com/ansible/ansible/pulls/dgarros
16:21:34 <dgarros> @gundalow, thanks for all your reviews BTW
16:21:46 <dgarros> thks
16:21:48 <gundalow> dgarros: No problem, the last set were 100% :)
16:22:24 <dgarros> Still too much manual process, we got to automate that :)
16:22:41 <gundalow> aye
16:22:51 <gundalow> http://docs.ansible.com/ansible/dev_guide/developing_modules_documenting.html#testing-documentation now tells you how to use  ./test/sanity/validate-modules/validate-modules --arg-spec --warnings  lib/ansible/modules/your/modules/
16:22:56 <privateip> we have gundalowbot :)
16:23:09 <dgarros> very effective for sure
16:23:17 <gundalow> or bungalow as I was typo'd recently
16:23:38 <privateip> lol
16:23:48 <allanice001> Doesn't scale to badly, but doesn't respond at 05:00 UTC
16:23:51 <allanice001> :P
16:23:53 <privateip> dgarros: will take a look probably tomorrow and get them merged
16:24:01 <dgarros> perfect, thanks
16:24:17 <allanice001> gundalow, #action that ?
16:24:21 <gundalow> FYI, I'm going to be drafting up a proposal to move the option docs into argspec, so they will be in sync, though that's a 2.4 thing
16:24:39 <gundalow> #action privateip to review https://github.com/ansible/ansible/pulls/dgarros and we can get them merged
16:24:45 <gundalow> allanice001: :)
16:25:06 * allanice001 not a chair here
16:25:12 <gundalow> dgarros: Once they are merged if you could update CHANGELOG.md in the root of the repo that would be cool
16:25:17 <gundalow> #chair allanice001
16:25:17 <zodbot> Current chairs: allanice001 dgarros gundalow
16:25:27 <dgarros> will do
16:25:42 <dgarros> I also need to update the doc to link them all to aos_login
16:25:50 <gundalow> #action dgarros to update CHANGELOG.md once merged
16:26:06 <gundalow> #action dgarros add in M(aos_login) (etc) once merged
16:26:13 <gundalow> Ace
16:26:21 <gundalow> dgarros: Anything else?
16:26:28 <dgarros> no perfect, thanks
16:26:33 <gundalow> #topic Open Floor
16:26:44 <gundalow> So, who's going to be in London for AnsibleFest
16:26:45 <gundalow> +1
16:27:04 <allanice001> #topic London AnsibleFest
16:27:20 * allanice001 waiting for org to give yay / nay
16:27:33 <allanice001> If I do attend, I'll let you know
16:28:03 <gundalow> #info We are looking for Networking Sponsors and call for papers. Ping me or andriusb for details
16:28:09 <gundalow> cool
16:28:18 <gundalow> #topic Open Floor
16:28:31 <gundalow> Will close in a few mins if their is nothing else
16:28:51 <gundalow> ismc: Did you have anything
16:29:25 <ismc> No.  I am in Vegas.  Brain is non-functional.  I bring up the asa issues later.
16:29:46 <gundalow> Ah, you AWSing?
16:29:54 <ismc> Yes.
16:29:57 <gundalow> cool
16:30:09 <ismc> For some values of cool.
16:30:13 <gundalow> :D
16:30:21 <gundalow> Closing in a minute...
16:32:29 <gundalow> cool
16:32:58 <gundalow> #info As always feel free to add items to the agenda https://github.com/ansible/community/issues/110
16:33:01 <gundalow> #endmeeting