18:04:08 <rbergeron> #startmeeting ansible new modules meeting
18:04:08 <zodbot> Meeting started Wed May 11 18:04:08 2016 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:04:08 <zodbot> The meeting name has been set to 'ansible_new_modules_meeting'
18:04:15 <rbergeron> you'd think i just learned this yesterday
18:04:21 <rbergeron> #chair gregdek
18:04:21 <zodbot> Current chairs: gregdek rbergeron
18:04:36 <rbergeron> #topic today's agenda
18:04:40 <rbergeron> #link https://github.com/ansible/community/issues/92
18:04:51 <rbergeron> as pointed out by MichaelBaydoun :)
18:05:02 <MichaelBaydoun> :)
18:05:11 <rbergeron> gregdek: you ready to start?
18:05:35 <MichaelBaydoun> he mentioned he might be a few minutes late
18:05:37 <gregdek> yes!
18:05:43 <gregdek> I am here. :)
18:05:59 <rbergeron> #topic sensu module - https://github.com/ansible/ansible-modules-extras/pull/205
18:06:02 <gregdek> #topic extras/205
18:06:06 <gregdek> Heh, sorry
18:06:10 <rbergeron> #link https://github.com/ansible/ansible-modules-extras/pull/205 :)
18:06:14 <rbergeron> all good
18:06:24 * rbergeron lets gregdek drive the car
18:07:18 <gregdek> So @andsens is understandably cranky about the slowness of getting this one done... but as gundalow points out, it's still in needs_revision.
18:07:49 <gregdek> But it is a very simple change.
18:08:42 <gregdek> Its companion, extras/203, went in almost a year ago now.
18:09:12 <gregdek> gundalow: around?
18:09:18 <rbergeron> yes, and i feel kind of bad that ... it's kind of just been the victim of "pretty much ready" and then we wouldn't notice the revisions, and then the version would change, and then we would have to change it because slow on our side, pausing it from actually going in.
18:09:33 <rbergeron> and i do kind of feel like we could just do that simple change while merging.
18:09:47 <MichaelBaydoun> is the only change needed how main is called?
18:09:52 <bcoca> hmm, core was not involved here at all
18:09:52 <rbergeron> gundalow did have some cmments relating to debuggers working with ziploader
18:10:11 <gregdek> that is the main call.
18:10:15 <gregdek> Which is a simple fix.
18:10:23 <rbergeron> along with the version #
18:10:23 <MichaelBaydoun> fix and merge?
18:11:08 <gregdek> Since gundalow actually looked it over, if he said "fix and merge" I would be inclined to agree.
18:11:34 <rbergeron> (is the main call thing something that is a new thing relating to ziploader work, or has that been there all along?)
18:11:44 <rbergeron> (needed to be there all along)
18:12:16 <gregdek> The method of calling main has been in the guidelines for quite a while.
18:12:35 <gregdek> In anticipation that we would do something like ziploader one day.
18:12:44 <rbergeron> ahh, got it
18:13:00 <gregdek> I will comment in the PR itself to gundalow, but in the meantime, sorry, still needs_revision
18:13:58 <rbergeron> nod - if gundalow comes back (he was just here a few minutes ago) maybe we can revisit real quick at the end of meeting
18:14:04 <gregdek> Yep.
18:14:11 <gregdek> In the meantime, any objection to moving on?
18:14:25 <gundalow> hey
18:14:38 <MichaelBaydoun> there he is
18:14:42 <rbergeron> oh hey ;)
18:15:01 <gundalow> we looking at https://github.com/ansible/ansible-modules-extras/pull/205 ?
18:15:24 <gregdek> Yes :)
18:15:42 <gundalow> I'm happy with a merge then fix
18:15:54 <jtanner> hi, late again
18:16:00 <gundalow> I understand the authors fustrations
18:16:33 <gundalow> gregdek: can we add a discussion about how to keep the modules moving/waffle to the end of the meeting please
18:17:17 <gregdek> Yep.
18:17:27 <bcoca> just flag shipit, if its 'main' and version_added, I'll change myself, just needs actual revie
18:17:29 <bcoca> w
18:17:39 <gregdek> So let's go ahead and mark "shipit" with a merge/fix note
18:17:48 * gregdek goes to do that
18:18:18 <gundalow> bcoca: Thank you :)
18:18:55 <gregdek> All right, moving on:
18:19:02 <gregdek> #topic extras/1987
18:19:35 <MichaelBaydoun> https://github.com/ansible/ansible-modules-extras/pull/1987
18:19:51 <gregdek> Looks like pwnall addressed your last comments, gundalow
18:20:06 <gregdek> Or at least made the attempt :)
18:21:49 <gregdek> Perhaps we should just wait on this one, and give it a shipit once gundalow has time to review the latest changes?
18:23:13 <gregdek> So mooted. That'll stay on the agenda for next time.
18:23:20 <MichaelBaydoun> sounds good
18:23:23 <bcoca> ^i do see a pattern of 'shipit' and then a bunch of obvious revisions ....
18:24:37 <gregdek> Obvious as in, they're in the guidelines and unaddressed?
18:25:13 <bcoca> yes/no, they were addresss later when others brought up, just pointing out that 'not all "shipit" seem equal'
18:25:19 <MichaelBaydoun> that goes to the idea of going back to meets_guidelines and tested_shipit or whatever
18:25:38 <bcoca> ^ but point for diff meeting
18:25:51 <gundalow> What stuff are we missing?
18:26:08 <bcoca> gundalow: mostly stuff you pointed out
18:26:10 <gundalow> which PRs demonstrate that
18:26:37 <bcoca> just reading in order, other people added 'shipit' and then there is back and forth with other contributors pointing at issues
18:26:50 <gregdek> Yes, we do need to get back to a difference between "meets_guidelines" and "tested_and_works_for_me." Not all shipits mean the same thing.
18:27:02 <gundalow> +1
18:27:11 <MichaelBaydoun> +1
18:27:14 <gundalow> so looking at 1987
18:27:47 <gundalow> the first ship it is from dorianj, which seems to be a "I've used this and it works for my use case"
18:28:19 <ryansb> shipit is supposed to equal the latter, right?
18:28:35 <gregdek> ryansb: trouble is, for new modules, it's somewhat undefined.
18:28:52 <gundalow> I like the idea of "shipit - What's I've tested"
18:29:13 <bcoca> ^ diff meeting for that
18:29:23 <bcoca> lets go back onto modules, sorry for sidetrack
18:29:28 <gregdek> (grr, I thought we had an open issue for this)
18:29:30 <bcoca> ^ was just good examples
18:29:52 * bcoca cowers in corner at angry greg
18:30:11 * gundalow hugs bcoca
18:30:15 <MichaelBaydoun> #action create issue for "meets_guidelines" and "tested_and_works_for_me" if one doesn't already exist
18:30:26 <gundalow> MichaelBaydoun: :)
18:30:51 <gregdek> Not angry, just annoyed at myself -- I know I created this issue and now I can't find it
18:31:02 <gregdek> Anyway, it's an action now, so we'll get it done. :)
18:31:16 <gundalow> I'll review 1987 in the next few days
18:31:29 <gundalow> next?
18:32:10 <gregdek> #topic extras/1765
18:32:48 <gregdek> https://github.com/ansible/ansible-modules-extras/pull/1765
18:33:07 <MichaelBaydoun> no shipits
18:33:09 <gundalow> Lines 30 and 36
18:33:17 <gregdek> This is an F5 module, and caphrim007 is definitely the guy for this one
18:33:21 <gregdek> Since he works at F5
18:33:23 <gundalow> Should I suggest that information be added to line 36?
18:33:31 <caphrim007> i heard my name
18:33:41 <bcoca> also loop in privateip/Qalthos
18:33:48 <gundalow> requirements: is human readable stuff right?
18:34:07 <bcoca> ^ they don't need to approve every network module, but should be aware of em
18:34:36 <gregdek> caphrim007: just discussing the state of PR extras/1765
18:34:46 <caphrim007> looking
18:34:58 <abadger1999> gundalow: somewhat -- we try to standardize but it is a list of freeform strings so when something is out of the ordinary, you can make a human readable explanation.
18:35:24 <gundalow> is "bigsuds >= 11.4" OK?
18:35:31 <abadger1999> gundalow: yes.
18:35:46 <abadger1999> "re" doesn't need to be i nthe requirements list (as it's part of the stdlib)
18:36:05 <gundalow> cool, I was about to ask about that, I'll add a comment
18:37:35 <gregdek> caphrim007: if the answer is "need more time to review," that's ok, we're just trying to get a status of close-to-ready new modules
18:37:35 <gundalow> lrn2capitallettersandfullstops
18:37:39 <caphrim007> one thing to note for the f5 modules is that we're also going to be making the f5-sdk a requirement for future modules that want to use rest
18:37:51 <MichaelBaydoun> gregdek: should guidelines/tested issue go in extras, core, community?
18:38:11 <gregdek> MichaelBaydoun: community for now, but it's probably an ansibullbot feature ultimately
18:38:13 <caphrim007> gregdek: I have not had a chance to run the PR's examples in my env yet
18:38:19 <gundalow> I would have thought community otherwise we'd never find it again :)
18:38:25 <caphrim007> but now that you have brought it to my attention...
18:38:29 <gregdek> caphrim007: should the f5-sdk requirement go in now? :)
18:38:48 <gregdek> I mean, the module's not in yet, and if there's a time to assert new requirements, maybe this is it
18:38:56 <caphrim007> hmm
18:39:21 <gundalow> and if that is a new requirement can http://docs.ansible.com/ansible/developing_modules.html#module-checklist please be updated (maybe add a network module section?)
18:40:18 <caphrim007> @gregdek: the gtm class is not part of the f5-sdk yet ( i will add it to my todo right now)
18:40:28 <caphrim007> so this can go through in the meantime i suppose?
18:40:38 <gregdek> You are the best authority. :)
18:41:35 <caphrim007> i'm ok with letting the current PR's go through without it since we haven't started using it ourselves in our PR's yet
18:41:50 <caphrim007> when I upstream one, then it will start being a req
18:42:02 <caphrim007> or for people interested in future modules that are not in the pipeline yet
18:43:12 <gregdek> OK. As you said before, you haven't had a chance to run the examples, so we should wait on that anyway.
18:43:27 <gregdek> So we'll leave it on the agenda for next time.
18:43:44 <caphrim007> k
18:44:07 <gregdek> Next:
18:44:15 <gregdek> #topic extras/1574
18:44:42 <gregdek> Nah.
18:44:58 <gregdek> Never mind. 1574 isn't far enough along, one +1 with no actual info at all.
18:45:05 <MichaelBaydoun> #action completed, created https://github.com/ansible/community/issues/95 for the guidelines/tested discussion
18:45:28 <gregdek> Thanks MichaelBaydoun
18:45:32 <MichaelBaydoun> yw
18:45:58 <gregdek> So that's all the PRs that were explicitly on the list this time around.
18:46:11 <gregdek> Anyone have any other specific PRs they want to address?
18:46:29 * MichaelBaydoun shakes head no
18:46:35 <gundalow> not from me
18:48:28 <gregdek> OK.
18:48:33 <gregdek> #topic Open Floor
18:48:43 <gregdek> Just in general, a couple of things I think we need:
18:49:13 <gregdek> Well, no.
18:49:30 <gregdek> I think what we really need is to commit to "worksforme" and "passes_guidelines".
18:49:52 <gregdek> I don't know if we want new labels for that or what, but it seems clear that's what we need.
18:49:52 <MichaelBaydoun> +1
18:49:54 <gundalow> _1
18:49:56 <gundalow> erm
18:49:58 <gundalow> +1
18:49:59 <gregdek> :)
18:50:48 <gregdek> And if we can set those as labels that triage.py assigns, it'll be much easier to bubble things up.
18:50:48 <gundalow> That would also address my (unasked) question of what to review next. Reviewing stuff that someone has already added a worksforme means I can kick it through the last bit of the process
18:51:02 <gregdek> Yep, exactly.
18:51:17 <gregdek> So I'll try to make it a priority to get that added in the next couple of weeks.
18:51:35 <gundalow> My question was going to be. There are a lot of PRs, It would be good to have some way of prioritising/swarming on PRs to get them through the process
18:51:46 <gundalow> gregdek: That would be great, thanks
18:52:04 <ryansb> pretty sensible, I try to start with oldest
18:52:20 <gregdek> I usually favor "most commented" because it's a good proxy for interest.
18:52:37 <gundalow> I was doing oldest, but I found people weren't getting back to me
18:53:09 <gundalow> I was (though haven't in the last couple of weeks) tried to give a quick once over on new PRs as they come in
18:53:49 <gregdek> OK. If no one has anything urgent, I'd like to wrap this one up. Any objection?
18:53:52 <ryansb> idk, if we do get some kind of prio system that'd be awesome though, it doesn't really matter to me what it is as long as it helps us focus on fewer PRs at a time
18:53:57 <bcoca> both sorts have falws
18:53:59 <bcoca> flaws
18:54:07 <gundalow> I wondered if waffle could help?
18:54:18 <bcoca> the 'most commented' might denote interest but not maturity nor readyness
18:54:33 <gundalow> hum, 5 mins left :P
18:54:34 <bcoca> gundalow: only in presentation, not in selection
18:54:52 <bcoca> the selection/sorting criteria is the hard issue here
18:55:06 <MichaelBaydoun> kanban would say take the PR's with one "shipit" first, and get those across the line
18:55:31 <gundalow> bcoca: aye, I was thinking in like with an Agile board of making sure you don't have too many tickets in each column (works for me, singl shipit
18:55:33 <gregdek> Which is why having labels for "worksforme" are critical.
18:55:39 <gundalow> MichaelBaydoun: aye
18:55:44 <gregdek> Without good inputs, there can be no good sorting mechanism.
18:55:55 <gundalow> Do we need single_ship, double_shipit
18:55:59 <gundalow> labels
18:56:21 <gregdek> I think what we're saying is "two shipits" becomes "one worksforme, one passes_guidelines".
18:56:21 <gundalow> ergh
18:56:25 <MichaelBaydoun> once we switch, it would be easy to sort on worksforme
18:56:26 <bcoca> gundalow: have you seen our backlog??!?1
18:56:45 <bcoca> there are too many tickets ... you need about several hundred queues to make it 'not too many per queue'
18:56:47 <gundalow> bcoca: I'm ignoring everything not "in progress"
18:56:49 <gregdek> So "shipit" for new module == has both.
18:57:08 <bcoca> gundalow: in progress only covers very recent stuff recently touched by someone in core
18:57:18 <gundalow> OK
18:57:41 <gundalow> Would it be good to be able to identify and focus on a PR that already has a single shipit
18:57:48 <bcoca> ^ that is a consequence of waffle
18:57:55 <MichaelBaydoun> gundalow: yes
18:58:05 <gundalow> MichaelBaydoun: I knew you were going to say that :)
18:58:59 <MichaelBaydoun> The issue as agenda worked well today, the PR's that someone wanted focused on got attention
18:59:26 <gundalow> aye
18:59:40 <gregdek> Anyway. We're at the hour. Gonna call this one and roll into cwg. Thanks!
18:59:42 <gundalow> Maybe for the moment if there are PRs we think are close we should add them to the agenda
18:59:51 <MichaelBaydoun> gundalow: aye
19:00:03 <gregdek> #endmeeting