#ansible-meeting: Ansible Public Core Meeting

Meeting started by jimi|ansible at 15:00:53 UTC (full logs).

Meeting summary

    1. agenda https://github.com/ansible/community/issues/83 (jimi|ansible, 15:02:17)
    2. https://github.com/ansible/ansible/pull/15489 (kei, 15:07:53)

  1. openswitch.py: Use new ops.dc declarative Config(DC) module https://github.com/ansible/ansible/pull/15489 (abadger1999, 15:08:04)
  2. net_template.py: Fix j2 file search path https://github.com/ansible/ansible/pull/15134 (abadger1999, 15:14:00)
    1. https://github.com/ansible/ansible/pull/15145 Work in Progress to fix the search path in a generic fashion (abadger1999, 15:26:21)

  3. Open Floor (abadger1999, 15:26:39)
  4. lookups and loops with comma joined strings (abadger1999, 15:27:12)
    1. ACTION: bcoca to write proposal on loop revamp (to include loop_control feature idea ticket) (bcoca, 15:28:05)

  5. backporting npm extras module for 1.9.7 (abadger1999, 15:34:47)
    1. https://github.com/ansible/ansible-modules-extras/pull/1663 (jimi|ansible, 15:41:17)

  6. PRs for consideration (jimi|ansible, 15:46:27)
    1. https://github.com/ansible/ansible/pull/12798 (bcoca, 15:46:56)
    2. decided that ansible <util> would conflict with current use of the CLI so going to not accept that PR for now. (abadger1999, 16:02:22)

  7. Meta questions around: https://github.com/ansible/ansible-modules-extras/pull/1593 What criteria are there for a Module in Extras? (abadger1999, 16:10:40)
    1. questions to resolve via these module criteria discussions: (0) What are the present means of distributing modules and what meaning is presently assigned to each? (abadger1999, 16:31:24)
    2. (1) is our goal for extras to be like galaxy: ansible hosted, but community managed? (abadger1999, 16:32:00)
    3. (2) (if 1) What are we willing to do until that goal is met? (abadger1999, 16:32:20)
    4. (3) (if 1): What is the roadmap for advancing towards that goal and who is working on it? (abadger1999, 16:32:53)
    5. https://galaxy.ansible.com/Juniper/junos/ <= example of vendor using galaxy to publish modules (bcoca, 16:34:15)
    6. https://public.etherpad-mozilla.org/p/Ansible_Module_Criteria (abadger1999, 16:51:29)

  8. Open floor (abadger1999, 17:03:42)
    1. https://github.com/ansible/ansible-modules-core/pull/1301 <-- seems legit (xaeth, 17:03:54)
    2. ACTION: xaeth to ask for rebase to remove merge commit or will do so himself (abadger1999, 17:11:02)
    3. ACTION: bcoca will cherrypick and test (abadger1999, 17:11:14)


Meeting ended at 17:22:46 UTC (full logs).

Action items

  1. bcoca to write proposal on loop revamp (to include loop_control feature idea ticket)
  2. xaeth to ask for rebase to remove merge commit or will do so himself
  3. bcoca will cherrypick and test


Action items, by person

  1. bcoca
    1. bcoca to write proposal on loop revamp (to include loop_control feature idea ticket)
    2. bcoca will cherrypick and test
  2. xaeth
    1. xaeth to ask for rebase to remove merge commit or will do so himself


People present (lines said)

  1. bcoca (180)
  2. abadger1999 (101)
  3. gregdek (54)
  4. kei (45)
  5. jimi|ansible (40)
  6. sivel (32)
  7. thaumos (25)
  8. rbergeron (19)
  9. xaeth (14)
  10. chouse (12)
  11. zodbot (7)
  12. jhawkesworth (4)
  13. Qalthos (2)
  14. Jmainguy (2)
  15. alikins_ (1)
  16. ryansb (1)
  17. nitzmahone (1)
  18. alikins (1)
  19. jtanner (1)


Generated by MeetBot 0.1.4.