#ansible-meeting: Ansible Public Core Meeting

Meeting started by abadger1999 at 15:08:54 UTC (full logs).

Meeting summary

  1. Roll call (abadger1999, 15:09:01)
  2. Agenda items (abadger1999, 15:11:46)
  3. Proposals (abadger1999, 15:12:53)
  4. Proposal: Module Rename Lifecycle https://github.com/ansible/proposals/issues/14 (abadger1999, 15:13:37)
    1. ACTION: Change deprecation warning period to two cycles instead of 1 (abadger1999, 15:27:20)
    2. ACTION: add a step to add deprecated modules to the CHANGELOG. (abadger1999, 15:28:23)
    3. ACTION: ryansb to work out the new code and design to implement warnings for deprecated modules (abadger1999, 15:31:54)
    4. ACTION: abadger1999 will add a section to the 2.2 roadmap for deprecations -- we'll work out what to put in it as we go along. Formalize it more for the 2.3 release. (abadger1999, 15:46:17)

  5. 2.1.0 release status (abadger1999, 15:46:41)
  6. Open floor (abadger1999, 15:52:04)
    1. https://github.com/ansible/ansible/pull/15692 (gundalow, 15:59:20)

  7. https://github.com/ansible/ansible/pull/15692 Adding dependencies into docker images to speed up tests. (abadger1999, 16:00:16)
    1. ACTION: gundalow to make final changes to docker dependencies PR, abadger1999 to merge, will ping jimi|ansible to review and rebuild docker images (abadger1999, 16:12:24)


Meeting ended at 16:13:51 UTC (full logs).

Action items

  1. Change deprecation warning period to two cycles instead of 1
  2. add a step to add deprecated modules to the CHANGELOG.
  3. ryansb to work out the new code and design to implement warnings for deprecated modules
  4. abadger1999 will add a section to the 2.2 roadmap for deprecations -- we'll work out what to put in it as we go along. Formalize it more for the 2.3 release.
  5. gundalow to make final changes to docker dependencies PR, abadger1999 to merge, will ping jimi|ansible to review and rebuild docker images


Action items, by person

  1. abadger1999
    1. abadger1999 will add a section to the 2.2 roadmap for deprecations -- we'll work out what to put in it as we go along. Formalize it more for the 2.3 release.
    2. gundalow to make final changes to docker dependencies PR, abadger1999 to merge, will ping jimi|ansible to review and rebuild docker images
  2. gundalow
    1. gundalow to make final changes to docker dependencies PR, abadger1999 to merge, will ping jimi|ansible to review and rebuild docker images
  3. ryansb
    1. ryansb to work out the new code and design to implement warnings for deprecated modules
  4. UNASSIGNED
    1. Change deprecation warning period to two cycles instead of 1
    2. add a step to add deprecated modules to the CHANGELOG.


People present (lines said)

  1. abadger1999 (77)
  2. gundalow (31)
  3. bcoca (29)
  4. Jmainguy (13)
  5. ryansb (11)
  6. zodbot (8)
  7. mattclay (4)
  8. nitzmahone (4)
  9. gregdek (3)
  10. Qalthos (2)
  11. misc (1)
  12. resmo (1)
  13. alikins (1)
  14. jtanner (1)


Generated by MeetBot 0.1.4.