#ansible-meeting: Ansible Public Meeting

Meeting started by abadger1999 at 19:07:13 UTC (full logs).

Meeting summary

  1. Proposals (abadger1999, 19:11:25)
    1. Five open proposals here: https://github.com/ansible/proposals/issues?utf8=%E2%9C%93&q=+is%3Aopen+ (abadger1999, 19:13:48)
    2. https://github.com/ansible/proposals/issues?q=is%3Aopen+sort%3Acreated-asc <= by order (bcoca, 19:14:22)

  2. https://github.com/ansible/proposals/pull/4 Roles revamp Proposal (abadger1999, 19:15:07)
    1. Consensus seems to be that we're okay with the proposed functionality but still need to look at what the syntax of using it in playbooks should look like. (abadger1999, 19:39:06)
    2. ACTION: Proposal accepted, bcoca to merge proposal to repo. (abadger1999, 19:45:01)
    3. ACTION: bcoca and jimi|ansible to nail down details of user-visible implementation and update the proposal. (abadger1999, 19:45:08)
    4. ACTION: bcoca to add example use cases to the proposal. (abadger1999, 19:46:01)

  3. https://github.com/ansible/proposals/issues/1 Docker Modules (abadger1999, 19:46:24)
    1. https://github.com/ansible/proposals/tree/master/docker (abadger1999, 19:49:38)
    2. We consider the docker proposals to have already been accepted. (abadger1999, 19:51:38)
    3. Docker proposals accepted as-is (abadger1999, 20:05:36)
    4. ACTION: rbergeron to move current docker proposals to final location and close ticket. (abadger1999, 20:12:05)
    5. ACTION: abadger1999 to write up a proposal for using singular for module names everywhere. (abadger1999, 20:15:56)

  4. https://github.com/ansible/proposals/issues/8 Publish / Subscribe for Handlers (abadger1999, 20:17:20)
    1. ACTION: proposal accepted. jimi|ansible has an implementation in mind to make it happen. (abadger1999, 21:00:07)
    2. ACTION: resmo to rework the proposal to reflect just what's going to be implemented. (abadger1999, 21:01:28)
    3. https://github.com/ansible/proposals/issues/8#issuecomment-212128606 (jimi|ansible, 21:03:41)

  5. Open floor (abadger1999, 21:05:43)
  6. 2.0.2 release (abadger1999, 21:06:19)
    1. jimi|ansible releasing 2.0.2 final as we speak (abadger1999, 21:06:45)

  7. Extend meetings to 1.5 hours (abadger1999, 21:07:26)
    1. Core Pulbic meetings extended to 1.5 hours (at least as long as people keep bringing us more work ;-) (abadger1999, 21:08:37)

  8. Open floor (abadger1999, 21:09:23)
    1. Agenda item for Thursday, k8s module PR (abadger1999, 21:10:10)
    2. https://github.com/ansible/ansible-modules-extras/compare/erjohnso-google-kubernetes (jimi|ansible, 21:10:25)
    3. remaining Proposals will be back on the agenda for next Tuesday's meeting. (abadger1999, 21:10:41)
    4. https://github.com/ansible/ansible-modules-core/issues/3123 (thaumos, 21:11:53)
    5. https://github.com/ansible/ansible-modules-core/issues/2930 (thaumos, 21:12:07)


Meeting ended at 21:18:18 UTC (full logs).

Action items

  1. Proposal accepted, bcoca to merge proposal to repo.
  2. bcoca and jimi|ansible to nail down details of user-visible implementation and update the proposal.
  3. bcoca to add example use cases to the proposal.
  4. rbergeron to move current docker proposals to final location and close ticket.
  5. abadger1999 to write up a proposal for using singular for module names everywhere.
  6. proposal accepted. jimi|ansible has an implementation in mind to make it happen.
  7. resmo to rework the proposal to reflect just what's going to be implemented.


Action items, by person

  1. abadger1999
    1. abadger1999 to write up a proposal for using singular for module names everywhere.
  2. bcoca
    1. Proposal accepted, bcoca to merge proposal to repo.
    2. bcoca and jimi|ansible to nail down details of user-visible implementation and update the proposal.
    3. bcoca to add example use cases to the proposal.
  3. jimi|ansible
    1. bcoca and jimi|ansible to nail down details of user-visible implementation and update the proposal.
    2. proposal accepted. jimi|ansible has an implementation in mind to make it happen.
  4. rbergeron
    1. rbergeron to move current docker proposals to final location and close ticket.
  5. resmo
    1. resmo to rework the proposal to reflect just what's going to be implemented.


People present (lines said)

  1. bcoca (220)
  2. abadger1999 (131)
  3. jimi|ansible (124)
  4. thaumos (39)
  5. resmo (32)
  6. jtanner (24)
  7. nitzmahone (22)
  8. alikins_ (17)
  9. chouse (15)
  10. rbergeron (13)
  11. zodbot (11)
  12. gregdek (6)
  13. ryansb (5)
  14. svg (1)
  15. Qalthos (1)
  16. Shrews (1)
  17. sivel (0)


Generated by MeetBot 0.1.4.