#ansible-galaxy: Ansiblefest: Galaxy

Meeting started by abadger1999 at 18:09:14 UTC (full logs).

Meeting summary

    1. https://etherpad.openstack.org/p/ansible-summit-october-2018-galaxy (abadger1999, 18:10:36)
    2. ACTION: jtanner to publish a link to the gathered statistics (abadger1999, 18:20:13)
    3. http://tannerjc.net/ansible/galaxy.html (jtanner, 18:22:43)
    4. https://galaxy-qa.ansible.com/testing/ansible_testing_content (alikins, 18:26:32)
    5. https://github.com/atestuseraccount/ansible-testing-content (alikins, 18:26:43)
    6. https://github.com/ansible/mazer/tree/devel/tests/ansible_galaxy/collection_examples/hello is a 'hello world' example (alikins, 18:27:48)
    7. https://gist.github.com/alikins/d09e34e68af2b7573b60f917b37846b4 example of the 'built' artifact (alikins, 18:31:52)
    8. we are not abandoning the traditional role format (tima, 18:40:46)
    9. versioning is staying at the repo level; subcomponents of a collection will not be independently versioned (defionscode, 18:42:03)
    10. we will version at the collection level. each piece of content will *not* have their own individual version number. (that would be insane) (tima, 18:42:05)
    11. packaging roles/content via mazer will be able to have versioned content (abadger1999, 18:44:46)
    12. migration guide and tool for going from traditional roles to content collections. (tima, 18:46:26)
    13. collection == repo (tima, 18:50:50)
    14. need to scan/check/warn of variables coming from multiple roles. (tima, 18:58:24)

  1. Molecule! (abadger1999, 19:20:48)
    1. https://github.com/ansible/galaxy (abadger1999, 19:38:39)
    2. https://github.com/pulp/pulp_ansible/ (bmbouter, 19:40:59)
    3. on-prem/self-hosted galaxy server will work with mazer. pulp and static-metadata-over-http may work/be implemented as well (abadger1999, 19:42:14)

  2. galaxy web ui update (abadger1999, 19:42:33)


Meeting ended at 19:46:44 UTC (full logs).

Action items

  1. jtanner to publish a link to the gathered statistics


Action items, by person

  1. jtanner
    1. jtanner to publish a link to the gathered statistics


People present (lines said)

  1. abadger1999 (43)
  2. geerlingguy (37)
  3. bcoca (32)
  4. defionscode (25)
  5. zodbot (9)
  6. bmbouter (7)
  7. tima (7)
  8. alikins (7)
  9. bearrito (5)
  10. gundalow (2)
  11. felixfontein (2)
  12. jtanner (2)
  13. willthames (1)
  14. mattclay (1)
  15. jhawkesworth_ (1)
  16. retr0h (0)
  17. gregdek (0)


Generated by MeetBot 0.1.4.