#ansible-meeting: Ansiblefest London

Meeting started by abadger1999 at 08:27:08 UTC (full logs).

Meeting summary

  1. Ansiblefest London: Agenda: https://public.etherpad-mozilla.org/p/ansible-summit-june-2017-agenda (abadger1999, 08:36:33)
    1. Agenda https://public.etherpad-mozilla.org/p/ansible-summit-june-2017-agenda (gundalow, 08:37:17)
    2. Blue jeans (video conference) meeting link: https://bluejeans.com/3008457278/ (abadger1999, 08:38:45)

  2. Summary of work accomplished since last year (abadger1999, 08:39:16)
    1. New irc channels for vmware and windows (abadger1999, 08:39:35)
    2. core extras merge (abadger1999, 08:39:45)
    3. ansible-container irc channel as well (abadger1999, 08:40:19)

  3. contributor docs (abadger1999, 08:40:21)
    1. gundalow spearheading putting all the documentation for contributing into one place. (abadger1999, 08:40:38)
    2. core engine deep dive documentation: https://github.com/ansible/ansible/commit/fa31043e7ee2a9fc74ccc39ddeb43587c2fea6d3 (abadger1999, 08:42:46)
    3. https://public.etherpad-mozilla.org/p/ansible-summit-june-2017-core (rbergero1, 08:43:32)

  4. Python 3 (gundalow, 08:44:14)
    1. python 3 progressing along nicely (rbergeron, 08:44:27)
    2. integration and unit tests are working on py3 (jimi|ansible, 08:44:39)
    3. py3 has integration tests and unit tests coverage in the core engine. Some tests still missing (flaper87, 08:44:39)
    4. serverless architectures on AWS begin to be supported. Lambda there / API gateway added in devel. More can come soon. (mikedlr, 08:44:52)
    5. no official data on users running modules on py3, but bugs are being fixed quickly as they're reported (jimi|ansible, 08:45:26)
    6. toshio getting about 5 tests a week (rbergeron, 08:45:31)
    7. mordred. does not matter. (rbergeron, 08:46:06)
    8. py2.6 is not going away any time soon (jimi|ansible, 08:46:20)
    9. integration tests on AWS now work and many run during CI with mattclay's new work (mikedlr, 08:46:58)

  5. Certified modules (gundalow, 08:47:32)
    1. introducing thaomos aka dylan irl! (rbergeron, 08:47:52)
    2. Working with partners on this new process and getting them to sign up to this (gundalow, 08:48:25)
    3. working on partner / vendor modules with daddy shadowman -- getting vendors to sign up for a process that they'll need to follow so they don't become vaporware (rbergeron, 08:48:42)
    4. sla, X # of maintainers required, unit tests, integration tests, etc. (rbergeron, 08:49:00)
    5. once the initial work with modules is worked out, will try to expand it to other plugins/roles etc (this is far future) (abadger1999, 08:50:54)
    6. ppl are expecting us to be grown-ups, vendors want to know how to get their modules "certified" ; hopefully this will be generalize-a-bull (rbergeron, 08:51:16)
    7. working on a generalized process for this (jimi|ansible, 08:51:19)
    8. ansible is the shizz (jimi|ansible, 08:51:38)
    9. we have a ton of modules; thaumos thinks we can't test them all; mordred and rbergeron disagree but it's a detail to get to later :DDDDDDDD (rbergeron, 08:51:55)
    10. this is acknowlegment that Ansible is partially a platform for people to write and support their modules on. Need to make it easier for people/organizations to get involved that way. (abadger1999, 08:52:51)

  6. Questions? (abadger1999, 08:53:03)
    1. All new network modules in 2.4 (core or from community or partner) have to include tests (gundalow, 08:53:20)
    2. ACTION: abadger1999 to review documentation on docs for swapping between py2/py3 (gundalow, 08:55:54)
    3. willthames thinks more info about required)if, require_of_of, etc. (rbergeron, 08:57:04)
    4. except with ... bettter testing of my typing (rbergeron, 08:57:14)
    5. Tima has question on certified modules: how to handle "certified modules" from the community (rbergeron, 08:58:33)
    6. has there been discussion of vendors who want to maintain modules but a module already exists that has been contributed by a community contributor. (abadger1999, 08:58:34)
    7. tima was just outed as the synchronize module guy. :D IN THE CORNER FOLKS :) (rbergeron, 08:59:28)
    8. gregdek saying that it will be case by case basis. (abadger1999, 08:59:30)
    9. people making vague references and inaudible sarcasm relating to third-party CI in the room (rbergeron, 09:02:30)
    10. ACTION: gundalow to pull his finger out and finish https://github.com/gundalow/ansible/blob/docs-argspec/docs/docsite/rst/dev_guide/developing_modules_general.rst#main-and-ansiblemodule-argument-spec (gundalow, 09:04:28)
    11. gundalow working on update to contributor docs (yay) (i think probably a proposal and things) (rbergeron, 09:04:35)
    12. mordred explaining the story from other open source projects about vendors and CI and testing and crazy hardware + drivers (rbergeron, 09:06:43)
    13. sometimes difficiult for companies until they learn from a bizdev perspective (rbergeron, 09:07:02)
    14. Contributor Involvement (gundalow, 09:10:36)

  7. Contributor Involvement (gundalow, 09:10:41)
    1. https://public.etherpad-mozilla.org/p/ansible-summit-june-2017-contributor-involvement (rbergeron, 09:11:02)
    2. (inaudiblenoise as jmckerr walks in and gregdek expects donuts) (rbergeron, 09:11:28)
    3. question: how's thing's goin for y'all? (says gregdek) (rbergeron, 09:12:07)
    4. tomas just submitted his first PR; hasn't gotten any feedback. (rbergeron, 09:13:14)
    5. jlk needs more direction on how to do bot commands / labelling (jimi|ansible, 09:13:33)
    6. jlk indicates labels / process / etc. for new folks (esp on modules) could be way more clear. Some of that is moved into the docs for the bot itself (rbergeron, 09:13:40)
    7. resmo is saying that maintainer of module has less power in the new workflow (because the bot needs more than just the maintainer to approve PRs) (abadger1999, 09:17:36)
    8. make the bot more friendly, and make sure it's always posting links to bot documentation (jimi|ansible, 09:17:44)
    9. a number of processes have gone from explicit to implicit (gundalow, 09:18:40)
    10. https://github.com/ansible/ansibullbot (jimi|ansible, 09:18:42)
    11. ACTION: gregdek and gundalow to loop jtanner into the discussions around contributor docs and process docs so that the bot can be updated (gundalow, 09:20:49)
    12. ACTION: jctanner - make the bot more friendly, and make sure it's always posting links to bot documentation (jimi|ansible, 09:21:10)
    13. gregdek wishes for more of a way to have a structure for special interest groups (rbergeron, 09:22:39)
    14. ACTION: gregdek and nitzmahone to look at how to better use the new GitHub permissions. For example ping @ansible-bsd group (gundalow, 09:23:58)
    15. gregdek types into etherpad things he could type here (rbergeron, 09:25:07)
    16. Nested groups and read-only collaborators in Github might be super useful to help with the "BSD" problem (spread out modules that aren't well namespaced but need a group of collaborators to help fix) (rbergeron, 09:25:38)
    17. robyn cuts and pastes for greg (rbergeron, 09:25:45)
    18. improvements to github continue to be nice. but then it also makes us need to rereview the entirety of everything every single time something changes (rbergeron, 09:26:26)
    19. IDEA: having a fixed slot / time of year to reconsider / rereview tooling would be nice (from hyperized) (rbergeron, 09:27:43)
    20. gregdek types into etherpad: (how do we make sure this is the bat signal and not the "everybody gets pinged all the time" thing) (https://github.com/blog/2378-nested-teams-add-depth-to-your-team-structure) (rbergeron, 09:28:41)
    21. discussion about having github alias/group/etc that is a directed quesetion "We need someone with expertise in XXX to look at this issue" rather than "Here's a XXX bug that you might be interested in" (abadger1999, 09:29:23)
    22. history lesson: https://www.redhat.com/archives/fedora-advisory-board/2006-April/msg00220.html (rbergeron, 09:29:48)
    23. http://sarah.thesharps.us/2016/11/17/impact-of-bots-on-github-communities/ (misc, 09:31:22)
    24. wiki = where information kills itself (jimi|ansible, 09:31:31)
    25. https://public.etherpad-mozilla.org/p/Ansible_Windows_Community_Plan (jborean93, 09:35:56)
    26. hey neat, best practices for a SIG (rbergeron, 09:36:09)
    27. gregdek proposing that ansible/community be setup as a repo that contains sig information. (abadger1999, 09:39:05)
    28. Model ansible/community after kubernetes/community for a place to create and manage SIGs. Enable Wiki on ansible/community. (samdoran, 09:39:39)
    29. ACTION: gregdek to copy k8's community into ansible/community (gundalow, 09:39:45)
    30. gregdek proposing giving out commit on ansible/community to anyone who asks. (abadger1999, 09:39:48)
    31. ACTION: plagiarize kubernetes for sigs and wikis (jimi|ansible, 09:40:26)
    32. gregdek proposing turning on wiki in the ansible/community space. (Identify owners for wiki spaces who are responsible for cleaning up old pages) (abadger1999, 09:41:56)
    33. greg defining what he thinks a SIG is: lightweight body that allows people to collaborate on common interests together. (abadger1999, 09:47:20)
    34. ACTION: write up onboard for each SIG (gundalow, 09:54:35)
    35. https://public.etherpad-mozilla.org/p/ansible-summit-june-2017-backlog (rbergeron, 10:16:42)
    36. ACTION: gundalow to speak to jtanner to see if we can get the stats he collects public (gundalow, 10:22:05)
    37. the average time for a PR to work through the process is an important stat (gundalow, 10:24:25)
    38. bot currently allows for contributors to a file to approve PRs for that file. (abadger1999, 10:28:49)
    39. current Bot maintainers https://github.com/ansible/ansibullbot/blob/master/MAINTAINERS.txt (gundalow, 10:29:05)
    40. I think there are too many committer modules (particularly in aws, as an example I'm most familiar with) (willthames, 10:29:46)
    41. We are currently working on adding docs and metadata to other plugins (gundalow, 10:29:55)
    42. modules that have a specific maintainer then do not fall under group maintainance. (abadger1999, 10:32:49)
    43. greg talking about potential to create a triage sig (abadger1999, 10:34:54)
    44. Getting reproducers from issues is one of the biggest problems. (jlk, 10:36:33)
    45. IDEA: Have a metrics SIG if there are people who care about metrics and want to use math to start figuring ot what the sources of problems are rather than bikeshedding? :) (rbergeron, 10:39:09)
    46. shipit_on_tests_passing might be a useful bot flag :) (willthames, 10:41:26)
    47. Discussion about how the bot can discourage a submitter because the bot will autodetect problems and make the contributer do things. But then if the maintainer (core or community) isn't actually looking at the PRs then the submitter did all this work for no apparent end ability to merge. (abadger1999, 10:46:19)
    48. zuul will fix everything (jimi|ansible, 10:46:36)
    49. greg assembling a list of questions, stats to gather, and some ideas of policy in the etherpad https://public.etherpad-mozilla.org/p/ansible-summit-june-2017-backlog#lineNumber=67 (abadger1999, 10:52:25)
    50. https://docs.ansible.com/ansible/honeybadger_deployment_module.html (rbergeron, 10:53:02)
    51. IDEA: add labels to all module PRs (willthames, 10:57:37)
    52. ACTION: stats - more, and more public (jimi|ansible, 10:57:49)
    53. ACTION: stats - see in-room discussion in etherpad for specific stats (jimi|ansible, 10:58:13)
    54. https://ansible.sivel.net/byfile.html (bcoca, 11:01:02)
    55. https://public.etherpad-mozilla.org/p/ansible-summit-june-2017-testing (rbergeron, 12:03:29)
    56. gundalow giving out information about testing. (abadger1999, 12:05:30)
    57. 2.3 => devel, large percentage increase in coverage for both integration and unit tests. But we started from a low number of tests to begin with so still a large amount to do (abadger1999, 12:07:02)
    58. problems to overcome: test instability (abadger1999, 12:07:13)
    59. tests that talk to external resources that go away (like installing packages from external package resource) (abadger1999, 12:07:41)
    60. macos hosts for shippable are taken care of by spinning up a virtual mac box via a hosting service. (abadger1999, 12:10:02)
    61. want to select some tests as good examples in various categories (standar, network, aws, windows) (abadger1999, 12:11:16)
    62. zuul working on reference implementation tests for themselves as well. (abadger1999, 12:11:42)
    63. ACTION: mordred and gundalow/mattclay to talk about reference implementations for tests that will help with both zuul and ansible (abadger1999, 12:12:55)
    64. for reference implementations, also looking for good modules (esp. windows) (abadger1999, 12:14:33)
    65. ACTION: gundalow to look for both simple and complex examples for reference integration tests. (abadger1999, 12:20:34)
    66. stale_ci label: added to tickets if ci hasn't been run in ~7 days. meant to tell committers to trigger a new ci run before merging. (abadger1999, 12:22:17)
    67. if picking a word to feed the bot, please pick "recheck" -- Monty (jlk, 12:24:56)
    68. mattclay says that it is a known feature request to add a bot command to rerun ci but it hasn't been written yet. (abadger1999, 12:25:00)
    69. note: features need to be available in shippable's API in order to implement. (abadger1999, 12:26:16)
    70. remember, 2.3 needs python-2.4 module-side compat. (abadger1999, 12:27:38)
    71. question about how to run tests: see a tox file and it doesn't work. See a make test and it doesn't work. etc. (abadger1999, 12:37:16)
    72. https://github.com/ansible/ansible/pull/25915 (misc, 12:38:18)
    73. jeblair mentions that openshift writes a shell script to do all the setup for making a test environment. (abadger1999, 12:40:24)
    74. gundalow says that ansible-test has a --requiremenets cli that can help with that for pypi packages. (abadger1999, 12:40:53)
    75. https://docs.openstack.org/infra/bindep/ (rbergeron, 12:41:08)
    76. https://docs.openstack.org/infra/bindep/readme.html#examples (rbergeron, 12:41:34)
    77. monty mentions that there's a further file that they have (bindep) that helps install non-pypi things. (abadger1999, 12:41:47)
    78. https://docs.openstack.org/infra/bindep/readme.html#examples (rbergeron, 12:41:55)
    79. ACTION: monty to ping gundalow with information about bindep. (abadger1999, 12:42:06)
    80. ACTION: gundalow to add "when cherry picking to detail what release will be released in. Also must do cherry pick -x (gundalow, 12:46:16)
    81. want to start pushing people to ansible-test as the Makefile is going to stop working as we add more things to makefile (abadger1999, 12:49:43)
    82. ACTION: gundalow to speak to Mattclay about deleting the old old win_groups.yml (gundalow, 12:50:46)
    83. mattclay says we can leave the toplevel make test but will get rid of the test/integration/Makefile targets. (abadger1999, 12:50:57)
    84. If anyone has trouble with ansible-test (usage, argcomplete not working, etc.) please ask me on IRC (mattclay, 12:51:40)
    85. Code Coverage https://codecov.io/gh/ansible/ansible/ (gundalow, 12:53:21)
    86. https://github.com/ansible/ansible/pull/25962 <- fixes one issue for running tox the first time on a local system (pabelanger, 12:59:50)
    87. mikedlr pointing out that the module coverage won't account for things like code which could raise multiple exceptions and we're only testing that it catches one of those. (abadger1999, 13:01:09)
    88. testing working group, gundalow, mattclay are points of contact for more testing questions (abadger1999, 13:01:42)

  8. 10 minute overview of zuul (abadger1999, 13:03:27)
    1. zuul is a "gating engine" from openstack. Used for CI. (abadger1999, 13:03:52)
    2. jobs in zuul v3 are written in ansible. (abadger1999, 13:04:14)
    3. Zuul v3 is alive (gundalow, 13:05:19)
    4. https://softwarefactory-project.io/sf/welcome.html (rbergeron, 13:07:04)
    5. software factory stuff, plus ... (rbergeron, 13:07:42)
    6. https://github.com/softwarefactory-project/software-factory (rbergeron, 13:07:44)
    7. zuul does multi-repo dependencies (commit to one repo can trigger CI runs for other repos) (abadger1999, 13:09:05)
    8. to rollout for ansible: (abadger1999, 13:10:54)
    9. Enable a github app "openstack Zuul" (abadger1999, 13:11:08)
    10. Run zuul's test suite on PRs to Ansible. (abadger1999, 13:11:34)
    11. run shade's test suite on PRs to Ansible Openstack Modules (abadger1999, 13:11:48)
    12. Then spin up "Ansible Zuul" github App which runs ansible tests when commits are made. (abadger1999, 13:12:20)

  9. INTRODUCTIONS (rbergeron, 13:20:24)
    1. https://public.etherpad-mozilla.org/p/ansible-summit-june-2017-agenda (jtanner, 13:48:11)


Meeting ended at 13:53:27 UTC (full logs).

Action items

  1. abadger1999 to review documentation on docs for swapping between py2/py3
  2. gundalow to pull his finger out and finish https://github.com/gundalow/ansible/blob/docs-argspec/docs/docsite/rst/dev_guide/developing_modules_general.rst#main-and-ansiblemodule-argument-spec
  3. gregdek and gundalow to loop jtanner into the discussions around contributor docs and process docs so that the bot can be updated
  4. jctanner - make the bot more friendly, and make sure it's always posting links to bot documentation
  5. gregdek and nitzmahone to look at how to better use the new GitHub permissions. For example ping @ansible-bsd group
  6. gregdek to copy k8's community into ansible/community
  7. plagiarize kubernetes for sigs and wikis
  8. write up onboard for each SIG
  9. gundalow to speak to jtanner to see if we can get the stats he collects public
  10. stats - more, and more public
  11. stats - see in-room discussion in etherpad for specific stats
  12. mordred and gundalow/mattclay to talk about reference implementations for tests that will help with both zuul and ansible
  13. gundalow to look for both simple and complex examples for reference integration tests.
  14. monty to ping gundalow with information about bindep.
  15. gundalow to add "when cherry picking to detail what release will be released in. Also must do cherry pick -x
  16. gundalow to speak to Mattclay about deleting the old old win_groups.yml


Action items, by person

  1. abadger1999
    1. abadger1999 to review documentation on docs for swapping between py2/py3
  2. gregdek
    1. gregdek and gundalow to loop jtanner into the discussions around contributor docs and process docs so that the bot can be updated
    2. gregdek and nitzmahone to look at how to better use the new GitHub permissions. For example ping @ansible-bsd group
    3. gregdek to copy k8's community into ansible/community
  3. gundalow
    1. gundalow to pull his finger out and finish https://github.com/gundalow/ansible/blob/docs-argspec/docs/docsite/rst/dev_guide/developing_modules_general.rst#main-and-ansiblemodule-argument-spec
    2. gregdek and gundalow to loop jtanner into the discussions around contributor docs and process docs so that the bot can be updated
    3. gundalow to speak to jtanner to see if we can get the stats he collects public
    4. mordred and gundalow/mattclay to talk about reference implementations for tests that will help with both zuul and ansible
    5. gundalow to look for both simple and complex examples for reference integration tests.
    6. monty to ping gundalow with information about bindep.
    7. gundalow to add "when cherry picking to detail what release will be released in. Also must do cherry pick -x
    8. gundalow to speak to Mattclay about deleting the old old win_groups.yml
  4. jtanner
    1. gregdek and gundalow to loop jtanner into the discussions around contributor docs and process docs so that the bot can be updated
    2. gundalow to speak to jtanner to see if we can get the stats he collects public
  5. mattclay
    1. mordred and gundalow/mattclay to talk about reference implementations for tests that will help with both zuul and ansible
  6. mordred
    1. mordred and gundalow/mattclay to talk about reference implementations for tests that will help with both zuul and ansible
  7. nitzmahone
    1. gregdek and nitzmahone to look at how to better use the new GitHub permissions. For example ping @ansible-bsd group
  8. UNASSIGNED
    1. jctanner - make the bot more friendly, and make sure it's always posting links to bot documentation
    2. plagiarize kubernetes for sigs and wikis
    3. write up onboard for each SIG
    4. stats - more, and more public
    5. stats - see in-room discussion in etherpad for specific stats


People present (lines said)

  1. abadger1999 (140)
  2. jimi|ansible (132)
  3. rbergeron (101)
  4. hyperized (89)
  5. jlk (78)
  6. misc (61)
  7. gundalow (60)
  8. willthames (47)
  9. bcoca (34)
  10. zodbot (21)
  11. jborean93 (20)
  12. jtanner (17)
  13. tima (12)
  14. ryansb (11)
  15. square1 (9)
  16. mikedlr (8)
  17. pabelanger (8)
  18. thaumos (8)
  19. j00bar (6)
  20. dag (6)
  21. mattclay (5)
  22. flaper87 (5)
  23. resmo (5)
  24. nitzmahone (4)
  25. mordred (3)
  26. P-NuT (2)
  27. rbergero1 (2)
  28. samdoran (2)
  29. jeblair (2)
  30. shertel (2)
  31. jhawkesworth_ (2)
  32. newtMcKerr (1)
  33. trishnag (1)
  34. ttomecek (1)
  35. fale (1)
  36. akasurde (1)
  37. spredzy (1)
  38. dag_ (0)
  39. gregdek (0)


Generated by MeetBot 0.1.4.