16:03:15 <jbrooks> #startmeeting atomic_community
16:03:15 <zodbot> Meeting started Mon Aug 21 16:03:15 2017 UTC.  The chair is jbrooks. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:03:15 <zodbot> The meeting name has been set to 'atomic_community'
16:03:15 <centbot> Meeting started Mon Aug 21 16:03:15 2017 UTC.  The chair is jbrooks. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:15 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:03:21 <jberkus> hmmm, no ....
16:03:35 <jberkus> maybe
16:03:36 <jberkus> not sure
16:03:40 <dustymabe> .hello dustymabe
16:03:41 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
16:03:43 <jberkus> I have some event-related announcements
16:03:47 <jberkus> and jzb had on eitem
16:03:48 <maxamillion> .hello maxamillion
16:03:50 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:03:50 <jberkus> .hello jberkus
16:03:52 <jzb> .hellomynameis jzb
16:03:55 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
16:03:58 <yzhang> .hello yzhang
16:03:58 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
16:04:01 <zodbot> yzhang: yzhang 'Yu Qi Zhang' <jzehrarnyg@gmail.com>
16:04:09 <jzb> Zodbot seems a little sluggish today.
16:04:23 <jbrooks> #chair jberkus jzb dustymabe maxamillion yzhang
16:04:23 <zodbot> Current chairs: dustymabe jberkus jbrooks jzb maxamillion yzhang
16:04:23 <centbot> Current chairs: dustymabe jberkus jbrooks jzb maxamillion yzhang
16:04:59 <jbrooks> I think 7/24 was the last one. We had four action items:
16:05:01 <jbrooks> aweiteka to verify that oc cluster up can be used for standalone registry
16:05:01 <jbrooks> jberkus to replace Registry docs on pa.io with standalone blog post
16:05:01 <jbrooks> jberkus to look into replacing docs.projectatomic.io/registry with directive to that standalone page
16:05:02 <jbrooks> aweiteka to clear some lingering atomic registry GH issues
16:05:05 <jberkus> bexelbie cdrage_ ttomecek trishnag thomasmckay gbraad jlebon kushal atomic community meeting now
16:05:23 <kushal> Hello
16:05:38 <jberkus> jbrooks: haven't done that yes, because still dealing with website hosting
16:05:41 <jberkus> jbrooks: re-action me
16:05:43 <jbrooks> #chair kushal
16:05:43 <zodbot> Current chairs: dustymabe jberkus jbrooks jzb kushal maxamillion yzhang
16:05:43 <centbot> Current chairs: dustymabe jberkus jbrooks jzb kushal maxamillion yzhang
16:06:06 <jbrooks> #action jberkus to look into replacing docs.projectatomic.io/registry with directive to that standalone page
16:06:06 <jzb> jberkus: can you clarify Re: website hosting?
16:06:21 <jberkus> jzb: we have an openshift v3 account now
16:06:30 <whenry> aweiteka out today (?)
16:06:35 <jberkus> in the process of getting www.pa.io and docs.pa.io moved
16:07:01 <jzb> jberkus: ah. I didn't know that. Is the publishing from middleman going to break?
16:07:16 <jberkus> if anyone is good with image streams on openshift online, I could use help
16:07:22 <jberkus> jzb: TBD
16:07:31 <jbrooks> whenry, ack
16:07:39 <jberkus> jzb: middleman has been having some memory-eating issues, which OSv3 will terminate
16:07:47 <jberkus> so we'll see
16:07:53 <jligon> .hello jligon
16:07:57 <zodbot> jligon: jligon 'Jeff Ligon' <jligon@redhat.com>
16:08:13 <jbrooks> #action jberkus to replace Registry docs on pa.io with standalone blog post
16:08:24 <jbrooks> #chair jligon
16:08:24 <zodbot> Current chairs: dustymabe jberkus jbrooks jligon jzb kushal maxamillion yzhang
16:08:24 <centbot> Current chairs: dustymabe jberkus jbrooks jligon jzb kushal maxamillion yzhang
16:08:55 <whenry> +q (adding myself to the queue for a question) re registry
16:09:10 <jbrooks> OK
16:09:50 <jbrooks> jberkus, You have an event topic?
16:09:54 <jberkus> yes
16:09:58 <jbrooks> #topic Upcoming Events
16:10:12 <jberkus> First, deadline for Kubecon US talks is TODAY, in 7 hours
16:10:25 <jberkus> so submit 'em if you got 'em
16:10:35 <jbrooks> #info kubecon cfp https://events.linuxfoundation.org/events/cloudnativecon-and-kubecon-north-america/program/cfp
16:10:45 <jberkus> proposal assistance available on this channel starting at 3pm EDT
16:10:55 <jberkus> second, OSS-prague acceptances are out
16:11:09 <jberkus> who got accepted?
16:11:12 <jbrooks> #chair whenry
16:11:12 <zodbot> Current chairs: dustymabe jberkus jbrooks jligon jzb kushal maxamillion whenry yzhang
16:11:12 <centbot> Current chairs: dustymabe jberkus jbrooks jligon jzb kushal maxamillion whenry yzhang
16:11:12 <maxamillion> not I
16:11:35 <maxamillion> I'm also not sure what I'd submit to Kubecon but would really like to attend
16:11:41 * whenry got declined for 2 talks - hoping a good Brno showing
16:11:57 <kushal> I have 2 points for open floor.
16:11:58 <jberkus> maxamillion: that's doable if you want to work the booth
16:12:10 <jberkus> maxamillion: PM me
16:12:19 <jberkus> that's it for event
16:12:22 <jberkus> events
16:12:25 <jbrooks> Ok
16:12:29 <jberkus> jzb has a renaming issue on the agenda
16:12:33 <jbrooks> #topic Container Runtime Naming
16:12:36 <jbrooks> shoot, jzb
16:12:38 <jberkus> jbrooks: you should also do CAH update
16:12:40 <jzb> OK
16:12:42 <strigazi> .hello strigazi
16:12:43 <zodbot> strigazi: strigazi 'Spyros Trigazis' <strigazi@gmail.com>
16:12:52 <jzb> basically, we all know that there's been some upstream churn in naming
16:12:54 <jbrooks> jberkus, yes
16:13:13 <jzb> so we're looking at changing the name of the container runtime *package* in Fedora
16:13:14 <maxamillion> jberkus: +1
16:13:22 <whenry> @jbrooks thanks. re registry. I have been trying to develop a demo and wonder the status of our registry - i.e. just using docker private registry or should be using something else ?
16:13:42 <jzb> I wanted to give a heads up here in case there are any things that changing the "docker" package to "foo" would break
16:13:48 <jzb> (not the actual name in dicussion)
16:14:09 <jzb> note that this is only currently pertaining to package name and repository on GitHub.
16:14:21 <jzb> Any comments, concerns, etc.?
16:14:28 <jbrooks> jzb, when will it happen?
16:14:38 <yzhang> there's also container/docker for the docker system container in the packagedb
16:14:42 <jzb> jbrooks: soon? Proposed name is currently w/legal to approve.
16:14:44 <yzhang> so I guess both have to change
16:15:03 <jbrooks> So, like, for f27, or in the middle of f26?
16:15:06 <jberkus> eclipse has started in oregon
16:15:16 <jzb> jberkus: I'm not sure. Probably f27.
16:15:35 <jzb> Hoping anything that's already shipped can stay same.
16:15:50 <jzb> if everyone agrees, just blot out the sun.
16:15:58 <jbrooks> :)
16:16:02 <jbrooks> Seems legit
16:16:15 <jbrooks> whenry, this is the current recommended thing: http://www.projectatomic.io/blog/2017/05/oo-standalone-registry/
16:16:48 <jbrooks> jzb, My comment is, bring it on
16:16:51 <whenry> jbrooks: but if you only want to show buildah/skopeo etc. this is a bit much
16:16:53 <whenry> right?
16:17:14 <jzb> jbrooks: +1
16:17:15 <dustymabe> jzb: i'm hoping we get a better name than 'atomic image' :)
16:17:22 <jbrooks> you could use whatever, that's just what we're pointing ppl to instead of the other atomic registry
16:17:35 <jberkus> jzb: I move to postpone the eclipse until late rin the day when I don't have conflicting meetings
16:17:54 * jbrooks looks at the window and still sees grey
16:17:57 <jbrooks> out
16:17:59 <dustymabe> jberkus: is this the prime viewing time?
16:18:05 <jzb> jberkus: sorry, you would have had to file that ticket a few billion years ago :-)
16:18:08 <dustymabe> or is this just when it starts?
16:18:12 <jberkus> 10% impingement right now
16:18:26 <jberkus> total eclipse is still ~~ 1 hour off
16:18:39 <jbrooks> OK, anything more on jzb's topic?
16:18:44 <whenry> jbrooks: ack.  so I think we may want to have a demo that is more bare minimum atomic tools based that includes the registry. i.e. the atomic alternative to the deocker demos you'd have done three years ago. no kube etc.
16:18:53 <whenry> s/deocker/docker/
16:19:06 <jbrooks> #topic registry example
16:19:12 <jzb> jberkus: this is just a reboot anyway. We did this in 1979
16:19:14 <whenry> :)
16:19:25 <jbrooks> jberkus, do we have a simple registry case on the atomic docs list?
16:19:30 <jberkus> jzb: I missed it, I was at Empire Strikes Back
16:19:38 <whenry> so a dockerless demo of buildah and skopeo is limited at the moment
16:19:40 <jberkus> jbrooks: not sure what you mean?
16:20:00 <jbrooks> jberkus, like, not the openshift-based one, but something lighter
16:20:17 <jbrooks> whenry, Does the docker one work? Like, just use those same pkgs, etc
16:20:18 <whenry> it turns out that buildah/skopeo equivalents of push aren't working with a private docker registry
16:20:19 <jberkus> jbrooks: you mean using the docker registry?
16:20:57 <whenry> so that lifecycle of build/run and push isn't capable yet
16:21:00 <whenry> yes
16:21:15 <whenry> something about the buildah format being off
16:21:19 <jbrooks> OK, do we have buildah/skopeo ppl here right now?
16:21:37 <dustymabe> dwalsh: or nalind ^^
16:21:38 <jberkus> jbrooks: dwalsh was a no for the meeting
16:21:56 <whenry> tsweeny malind et al know about this
16:22:04 <jzb> jberkus: early release? ;-) ESB came out in 1980
16:22:12 <jbrooks> whenry, I think an issue on the skopeo or buildah issue tracker might be a good next step
16:22:19 <whenry> just thought we should track this as something around the registry
16:22:36 <whenry> jbrooks: ack will do
16:23:01 <jbrooks> #action whenry to file issue re skopeo/buildah registry issue
16:23:13 <jbrooks> #topic CentOS Atomic Update
16:23:33 <jbrooks> quick update on cah -- we had a recent release: https://seven.centos.org/2017/08/new-centos-atomic-release-and-kubernetes-system-containers-now-available/
16:23:56 <dustymabe> jbrooks++
16:24:08 <jbrooks> It was very minor, pkgs-wise, but we started offering system containers for kube, both in the from-rhel 1.5.x and from-fedora 1.7.x flavors
16:24:16 <yzhang> jbrooks++
16:24:17 <zodbot> yzhang: Karma for jasonbrooks changed to 3 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:24:18 <jzb> jbrooks: based on 7.4?
16:24:41 <jbrooks> No, the release that will correspond to 7.4 will be out soon after that CentOS release happens
16:24:47 <jbrooks> It's supposed to be the end of this month
16:25:28 <jbrooks> That's all for CentOS Atomic at the moment
16:25:56 <jbrooks> #info latest cah release and system containers https://seven.centos.org/2017/08/new-centos-atomic-release-and-kubernetes-system-containers-now-available/
16:26:03 <jbrooks> #topic Open Floor
16:26:07 <jbrooks> kushal, you have a couple?
16:27:31 <jberkus> kushal: ?
16:28:06 <jbrooks> Anyone else w/ open floor items?
16:28:20 <dustymabe> jbrooks: not that I can think of
16:28:20 <jzb> who all will be at Flock next week?
16:28:26 <dustymabe> jzb: /me
16:28:31 <jbrooks> I will
16:28:48 <yzhang> me
16:28:51 <jzb> jbrooks: you're traveling? Whoa. :-)
16:29:10 <jbrooks> Heh
16:29:14 <jbrooks> My first flock
16:29:17 <jberkus> strigazi: you have an announcement?
16:29:57 <strigazi> We would like to have a member from the atomic team in the CERN CentOS dojo event https://lists.centos.org/pipermail/centos-devel/2017-August/016094.html
16:30:41 <jbrooks> strigazi, I can attend that, if there isn't someone more local
16:30:54 <strigazi> What we are interested in is, atomic hosts and as a subject "Immutable infrastructure"
16:31:24 <strigazi> jbrooks You are very welcome to join :)
16:32:09 <dustymabe> yeah unfortunately I'll be in texas :(
16:32:14 <dustymabe> otherwise would love to come
16:32:23 <jbrooks> dustymabe, An event there?
16:32:25 <kushal> I have 2 fedora related questions.
16:32:31 <jbrooks> kushal, shoot
16:32:59 <kushal> 1. Any one knows why the vagrant image size kept growing so much? Now it is around 650MB iirc.
16:33:06 <jberkus> strigazi: speaking of which, I should get my ignite talk on that topic online
16:33:12 <maxamillion> dustymabe: you'll be in Texas????
16:33:12 <dustymabe> jberkus: a wedding
16:33:18 <dustymabe> maxamillion: yeah
16:33:20 <dustymabe> :)
16:33:27 <strigazi> jberkus that would be great
16:33:36 <maxamillion> dustymabe: I'm going to nag you offline to find out where and when and if you're going to have any semblance of free time :)
16:33:44 <dustymabe> k
16:34:09 <dustymabe> kushal: i'm not surprised
16:34:16 <dustymabe> kushal: is it causing problems?
16:34:25 <maxamillion> strigazi: oooo! I gave a talk a few years back at Summit literally titled "Immutable Infrastructure" ... is there any chance for travel compensation? I'd be happy to join in
16:34:25 <dustymabe> also the rawhide/f27 images should be smaller because no kube
16:34:29 <kushal> dustymabe, downloading takes more time :D
16:34:34 <kushal> 2. It is less of a question, but a comment. We saw two vagrant libvirt failure in the last week, I am still trying to reproduce the issues, the images happily passing till now locally.
16:35:54 <dustymabe> kushal: do you mind looking at how it has changed over time? has it really got that much bigger?
16:36:23 <jbrooks> The current cah vagrant libvirt is 560M
16:36:50 <kushal> dustymabe, I will do that, and get back to the list.
16:36:51 <kushal> Thanks.
16:37:08 <jbrooks> #action kushal to check on vagrant image growth and report to list
16:37:13 <jbrooks> OK, any other items?
16:37:28 <strigazi> maxamillion I don't know details. The subject would be around how to use atomic hosts and system containers in the conext of immutable infrastructure
16:37:39 <maxamillion> strigazi: +1
16:37:54 <maxamillion> strigazi: I have a slide deck I can share, it can be catered to that narative pretty easily
16:38:42 <strigazi> maxamillion thanks. If you can join us, please do :)
16:39:14 <maxamillion> strigazi: https://maxamillion.fedorapeople.org/12017_Miller.pdf
16:39:16 <jbrooks> OK, if there's nothing else for the meeting, we'll close
16:39:26 <dwalsh> whenry, dustymabe I am here now
16:40:02 <dwalsh> The only issue I know about buildah right now is on credentials.
16:41:42 <dustymabe> whenry: maybe you and dwalsh can chat after the meeting?
16:42:38 * dustymabe brb
16:42:52 <dustymabe> jbrooks: are you running this thing?
16:42:52 <jbrooks> OK, we'll close for the week. Thanks all!
16:42:56 <jbrooks> #endmeeting