15:00:29 <nshaikh> #startmeeting Atomic Developer Bundle Weekly Meeting
15:00:29 <zodbot> Meeting started Mon Feb 15 15:00:29 2016 UTC.  The chair is nshaikh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:29 <zodbot> The meeting name has been set to 'atomic_developer_bundle_weekly_meeting'
15:00:50 <lalatenduM> .hellomynameis lalatendu
15:00:51 <zodbot> lalatenduM: lalatendu 'Lalatendu Mohanty' <lmohanty@redhat.com>
15:00:51 <dharmit> .fas dharmit
15:00:54 <zodbot> dharmit: dharmit 'Dharmit Shah' <shahdharmit@gmail.com> - shahdharmit 'Dharmit Shah' <shahdharmit@gmaill.com>
15:01:04 <bamacharan> .fas bamachrn
15:01:04 <zodbot> bamacharan: bamachrn '' <bamachrn@gmail.com> - bamacharankundu 'Bamacharan Kundu' <bamacharan.kundu@gmail.com>
15:01:09 <lalatenduM> ping tuxdna: ccaf
15:01:13 <nshaikh> ping budhram
15:01:15 <tuxdna> dustymabe: I would like to have some feedback on this question: - https://github.com/projectatomic/adb-atomic-developer-bundle/issues/118#issuecomment-183320634
15:01:15 <preeti> .hellomynameis preeti
15:01:17 <zodbot> preeti: Sorry, but you don't exist
15:01:34 <lalatenduM> mzee1000_: ^
15:01:50 <budhram> .hellomynameis budhram
15:01:50 <ccaf> .hellomynameis containscafeine
15:01:50 <zodbot> budhram: Sorry, but you don't exist
15:01:53 <zodbot> ccaf: containscafeine 'Shubham Minglani' <shubham@linux.com>
15:02:42 <nshaikh> #topic Release of ADB 1.7.0
15:03:13 <lalatenduM> Yeah
15:03:19 <tuxdna> lalatenduM: yes
15:03:25 <lalatenduM> I am still working on it
15:03:29 <tuxdna> .fas
15:03:29 <zodbot> tuxdna: (fas <query>) -- Search the Fedora Account System usernames, full names, and email addresses for a match.
15:03:40 <tuxdna> .fas tuxdna
15:03:40 <zodbot> tuxdna: tuxdna '' <tuxdna@gmail.com>
15:03:53 <lalatenduM> There are some issue with including a RPM in ADB build
15:04:13 <lalatenduM> the RPM has to be signed by CentOS
15:04:17 <nshaikh> lalatenduM, okay - is this regarding adb-utils package ?
15:04:38 <lalatenduM> and has to be available in a plublic YUM repo
15:04:41 <lalatenduM> nshaikh: yes
15:04:48 <nshaikh> okay
15:05:02 <lalatenduM> basically the adb-utils should live at http://mirror.centos.org/centos-7/7/atomic/x86_64/repo/
15:05:09 <lalatenduM> as it is part of atomic sig
15:05:18 <lalatenduM> but http://mirror.centos.org/centos-7/7/atomic/x86_64/repo/ is just ostree content
15:05:24 <surajd> .hellomynameis surajd
15:05:25 <zodbot> surajd: surajd 'Suraj Deshmukh' <surajssd009005@gmail.com>
15:05:31 <nshaikh> okay
15:05:31 <lalatenduM> from CentOS rebuild of RHEL atomic
15:05:37 <nshaikh> #info adb-utils should live at http://mirror.centos.org/centos-7/7/atomic/x86_64/repo/ and part of atomic-sig
15:05:39 <lalatenduM> and the content is distro signed
15:05:57 <lalatenduM> and adb-utils can't be signed by distributions GPG key
15:06:09 <lalatenduM> distro signed = distributions GPG key
15:06:22 <lalatenduM> distribution = centos core
15:06:25 <nshaikh> okay
15:06:36 <lalatenduM> as adb-utils a new rpm whch is not part of RHEL
15:06:53 <lalatenduM> so we are trying to work aorund the issue.
15:07:01 <lalatenduM> Also created https://github.com/LalatenduMohanty/centos-release-adb
15:07:21 <nshaikh> #info: adb-utils package to be signed by CentOS and will be part of atomic SIG.
15:07:26 <lalatenduM> we will include this in ADB , so users can update if a new version of adb-utils come
15:08:09 <lalatenduM> the release wont be possible today as CentOS projetc dont sign RPMs on Monday and Friday
15:08:23 <lalatenduM> I will update my original mail in container-tools
15:08:27 <lalatenduM> thats it
15:09:09 <nshaikh> #action: Lala to send email on container-tools detailing about adb-utils package and its signing and release schedule.
15:09:38 <nshaikh> #info: tracker bug for ADB 1.7 release <https://github.com/projectatomic/adb-atomic-developer-bundle/issues/229>
15:09:43 <budhram> .hellomynameis budhram
15:09:43 <zodbot> budhram: budhram 'Budh Ram Gurung' <bgurung@redhat.com>
15:10:04 <nshaikh> need more volunteer to test the latest build and provide feedback.
15:10:19 <nshaikh> bamacharan, budhram surajd ccaf ^
15:10:23 <lalatenduM> nshaikh: +1
15:10:27 <surajd> nshaikh, yes
15:10:35 <lalatenduM> everyone should give it a spin
15:10:41 <surajd> nshaikh, i can do that
15:10:46 <surajd> lalatenduM, yes
15:10:47 <ccaf> nshaikh, done
15:10:53 <bamacharan> nshaikh, sure
15:10:55 <nshaikh> cool, thanks.
15:11:01 <budhram> nshaikh, sure
15:11:13 <mzee1000_> yea we will :D
15:11:36 <nshaikh> lalatenduM, okay-  anything else on ADB release side? or we move to next topic ?
15:12:26 <nshaikh> #topic Release of vagrant-service-manager v0.0.2
15:12:50 <nshaikh> #info vagrant-service-manager plugin to be release aligned with ADB 1.7 release
15:13:12 <lalatenduM> nshaikh: are we planning a release tomorrow
15:13:43 <nshaikh> lalatenduM, yes, its waiting on few discussions to be settled on few PRs.
15:13:56 <lalatenduM> nshaikh: ok
15:14:07 <mzee1000_> nshaikh: Just finished my presentation, went well :)
15:14:20 <budhram> doing POC for (config + action hook) approach for docker daemon restart
15:14:23 <lalatenduM> mzee1000_: awesome
15:14:25 <nshaikh> OpenShift connection information need to be finalized check <https://github.com/projectatomic/vagrant-service-manager/pull/43>
15:14:35 <nshaikh> mzee1000_, cool
15:14:41 <mzee1000_> it will be published on youtube O_O
15:14:52 <lalatenduM> nshaikh: ack
15:15:03 <lalatenduM> budhram: cool
15:15:04 <budhram> will test it on my side too
15:15:15 <mzee1000_> oops meeting sorry!
15:15:16 <budhram> PR#43
15:15:22 <nshaikh> budhram, okay
15:15:54 <nshaikh> #info: We have first cut on re-generating TLS certs as part of provisioning for docker provider <https://github.com/projectatomic/vagrant-service-manager/pull/48>
15:16:29 <mzee1000_> .fas mohammedzee1000
15:16:31 <zodbot> mzee1000_: mohammedzee1000 'Mohammed Zeeshan Ahmed' <mohammed.zee1000@gmail.com>
15:16:40 <nshaikh> It needs a bit more work on how we present it in Vagrantfile, idea is to have simple as less as possible lines in Vagrantfile.
15:17:12 <nshaikh> that's it from my side on plugin
15:17:33 <lalatenduM> nshaikh: cool
15:17:59 <lalatenduM> somehow I had missed the PR
15:17:59 <nshaikh> thats all from today's agenda.
15:18:13 <nshaikh> lalatenduM, give it a spin.
15:18:22 <nshaikh> anybody else would like to add ?
15:18:27 <ccaf> nshaikh, #118?
15:18:48 <nshaikh> ccaf, sure, go ahead
15:18:54 <ccaf> [GoerN] tuxdna maxandersen dustymabe lalatenduM nshaikh, any feedback on the ongoing mailing list thread/issue #118? https://www.redhat.com/archives/container-tools/2016-February/msg00108.html or https://github.com/projectatomic/adb-atomic-developer-bundle/issues/118
15:19:05 <lalatenduM> nshaikh: looks fine to me , but I think we need a config.rb and then add some functions
15:19:26 <lalatenduM> nshaikh: will talk about it later
15:19:27 <nshaikh> #topic ADB: Mounted volumes
15:19:32 <[GoerN]> ccaf, nack
15:20:01 <lalatenduM> ccaf: as I understand we need 2 way sync, right?
15:20:09 <ccaf> lalatenduM, yes
15:20:21 <maxandersen> ccaf i think I already followed up on mailing list with my concerns.
15:20:43 <maxandersen> lalatenduM yeah - or if possible, mounted volumes so there is no need for any 2 way sync.
15:24:15 <ccaf> maxandersen lalatenduM: so what do we proceed with? Some pros and cons have been discussed.
15:24:15 <lalatenduM> maxandersen: ccaf my concern around if we are using differnet solution on diff OS
15:24:16 <lalatenduM> e.g. NFS for Linux and SMB for Windows
15:24:16 <lalatenduM> maxandersen: do you see that as an issue?
15:25:19 <lalatenduM> ccaf: also kbsingh was interested for a 2 way sync solution for Vagrantbox
15:25:19 <lalatenduM> ccaf: you might want to get some feedback from him
15:25:20 <ccaf> nshaikh, just thinking out loud, can this be made into a plugin? I don't how that works, but it will shorten the Vagrantfile.
15:25:23 <ccaf> maxandersen lalatenduM, 2 solutions, agreed. But how does that affect the use case/end user experience/support?
15:25:24 <nshaikh> ccaf, the solution is spread across different components and also depends on which path we go take.
15:25:24 <lalatenduM> ccaf: volumesync config should be in vagrantfile IMO as this is a usual practice in vagrant eco system
15:26:17 <nshaikh> ccaf, the required services / tooling need to be baked in the box so that we do have to set up things on the fly (if thinking about execution from plugin) for smooth user experience.
15:26:17 <lalatenduM> ccaf: expect a Vagrant user to add volume sync tweaks to Vagrantfile
15:26:17 <nshaikh> *we do  not have to
15:26:19 <nshaikh> lalatenduM, +1 or via plugin.
15:26:23 <ccaf> lalatenduM nshaikh, true.
15:26:34 <lalatenduM> ccaf: I would like to get that feedback from maxandersen and see if that work for them
15:27:31 <nshaikh> ccaf, preferably I will vote for mounts over sync, as this provide better user experience. A user does not have to worry about syncs everytime file at host is updated.
15:27:34 <lalatenduM> ccaf: tuxdna do you guys need a Vagrantbox with cifs-util package? if yes let me know
15:27:46 <lalatenduM> nshaikh: +1
15:28:00 <ccaf> lalatenduM, that depends on the path we take
15:28:03 <lalatenduM> ccaf: mount is prefereable , as it is more transparant
15:28:25 <ccaf> lalatenduM nshaikh, yes, and all are mounts. SMB and NFS and SSHFS.
15:28:47 <lalatenduM> right
15:29:10 <lalatenduM> ccaf: dont have a clear answer for you now
15:29:25 <lalatenduM> ccaf: need to spend more time on this
15:29:34 <ccaf> lalatenduM, okay.
15:29:47 <nshaikh> Added the topic in next week meeting as well.
15:29:53 <lalatenduM> nshaikh: +1
15:30:09 <nshaikh> ccaf, consider discussing this in upcoming cabal call ?
15:30:18 <nshaikh> okay - we are at the end of meeting.
15:30:19 <ccaf> nshaikh, sure.
15:30:33 <nshaikh> #action: ccaf to discuss mounted volumes in next cabal call.
15:30:45 <nshaikh> #endmeeting