13:01:19 <lalatenduM> #startmeeting Atomic Developer Bundle Weekly Meeting
13:01:19 <zodbot> Meeting started Mon Apr 18 13:01:19 2016 UTC.  The chair is lalatenduM. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:01:19 <zodbot> The meeting name has been set to 'atomic_developer_bundle_weekly_meeting'
13:01:44 <lalatenduM> Who all are here for the meeting
13:01:55 <praveenkumar> .fas kumarpraveen
13:01:55 <zodbot> praveenkumar: kumarpraveen '' <kumarpraveen.nitdgp@gmail.com>
13:01:58 <lalatenduM> .fas lalatendu
13:01:58 <zodbot> lalatenduM: lalatendu 'Lalatendu Mohanty' <lmohanty@redhat.com>
13:02:42 <praveenkumar> #link https://titanpad.com/adbmeeting
13:02:59 <lalatenduM> praveenkumar: looks like it is just you and me
13:03:04 <dharmit> .fas dharmit
13:03:04 <zodbot> dharmit: dharmit 'Dharmit Shah' <shahdharmit@gmail.com> - shahdharmit 'Dharmit Shah' <shahdharmit@gmaill.com>
13:03:11 <lalatenduM> tkral: ^
13:03:21 <lalatenduM> surajd: ccaf ^
13:03:32 <lalatenduM> dharmit: welcome
13:03:44 <tkral> .hellomynameis tkral
13:03:45 <zodbot> tkral: tkral 'Tomas Kral' <tkral@redhat.com>
13:03:51 <surajd> .fas surajd
13:03:52 <ccaf> .hellomynameis containscafeine
13:03:52 <zodbot> surajd: surajd 'Suraj Deshmukh' <surajssd009005@gmail.com>
13:03:52 <dharmit> lalatenduM: thank you! :-)
13:03:55 <zodbot> ccaf: containscafeine 'Shubham Minglani' <shubham@linux.com>
13:03:56 <lalatenduM> I think we should move ahead with topics
13:04:07 <lalatenduM> #topic previous action items
13:04:18 <lalatenduM> https://meetbot.fedoraproject.org/nulecule/2016-04-04/atomic_developer_bundle_weekly_meeting.2016-04-04-10.03.html
13:04:26 <lalatenduM> this was teh last meeting
13:04:38 <lalatenduM> bexelbie has to send code freeze and release workflow mail.
13:04:59 <lalatenduM> I have seen a mail from bexelbie in container-tools about it
13:05:10 <lalatenduM> so it is done
13:05:37 <lalatenduM> #topic ADB 2.0 release
13:05:55 <lalatenduM> I have sent a mail for ADB 2.0 release in container-tools
13:06:02 <lalatenduM> have you guys seen it ?
13:06:32 <lalatenduM> also any concern about calling it ADB 2.0 release?
13:06:52 <praveenkumar> lalatenduM: yes I think that is a good plan to market our project and get more envolvement from contributors.
13:07:13 <lalatenduM> praveenkumar: ack
13:07:49 <praveenkumar> lalatenduM: So we are going from 1.8 => 2.0 right?
13:07:55 <lalatenduM> We need volunteer for these tasks
13:08:00 <lalatenduM> praveenkumar: yes
13:08:28 <lalatenduM> praveenkumar: it will also keep CDK 2.0 relevent to ADB 2.0
13:08:38 <lalatenduM> otherwise we will diverse
13:08:48 <praveenkumar> lalatenduM: Agree.
13:08:53 <preeti> .fas preeti
13:08:54 <zodbot> preeti: pri013 'preeti' <py29958@gmail.com> - preetish 'c.preetish' <preetishnandhreddy@gmail.com> - preeti 'Preeti Chandrashekar' <preetipagad@gmail.com> - tripathp 'Preetish Tripathi' <preetish.tripathi@gmail.com>
13:09:07 <lalatenduM> Who wants to create a ADB video and upload it to youtube?
13:09:32 <ccaf> lalatenduM, I can
13:09:33 <lalatenduM> the installation steps and starting openshift , kubernetes and mesos
13:09:46 <lalatenduM> ccaf: awesome
13:10:07 <ccaf> lalatenduM, by when?
13:10:12 <praveenkumar> ccaf: those videos should be part of https://www.youtube.com/channel/UCDFLt2fl262b9n0tSW_4vyQ (project atomic channel) I think
13:10:14 <praveenkumar> lalatenduM: ^^
13:10:29 <lalatenduM> #action ccaf to create a video of ADB installation , openshift , k8s and  mesos
13:10:51 <lalatenduM> ccaf: by 26th or 27th April
13:10:59 <ccaf> lalatenduM, np
13:11:05 <lalatenduM> praveenkumar: yes, agree
13:11:16 <ccaf> lalatenduM, I'll do it this weekend. Thanks.
13:11:26 <lalatenduM> ccaf: thanks
13:11:31 <lalatenduM> We need blogs too
13:11:48 <lalatenduM> one on kubernetes and another on openshift
13:12:05 <praveenkumar> ccaf: Meanwhile I will find out how we can upload to channel (I mean who have access to project-atomic channel)
13:12:13 <praveenkumar> lalatenduM: I will blog about openshift one.
13:12:19 <lalatenduM> I think Mesos blog is out already , thanks to dharmit
13:12:20 <surajd> lalatenduM, blog o/
13:12:25 <surajd> k8s
13:12:36 <dharmit> Yep, it's out! :-)
13:12:37 <lalatenduM> surajd: awesome
13:12:57 <surajd> lalatenduM, blog will contain what?
13:12:59 <preeti> Whoever volunteers to write them, I could coordinate with them, edit stuff etc
13:13:07 <surajd> preeti, +1
13:13:09 <praveenkumar> preeti: +1
13:13:10 <lalatenduM> #action surajd will write blog about ADB+k8s
13:13:23 <lalatenduM> preeti: +1
13:13:37 <praveenkumar> #action praveenkumar will write blog about ADB+openshift
13:13:48 <lalatenduM> #action praveenkumar will write blog about openshift+ADB
13:14:08 <praveenkumar> #undo
13:14:24 <lalatenduM> sounds good
13:14:32 <lalatenduM> anything elese for ADB 2.0 release
13:14:36 <lalatenduM> ?
13:14:43 <surajd> lalatenduM, blog by?
13:15:00 <lalatenduM> 26th April
13:15:37 <lalatenduM> surajd: ^
13:15:50 <surajd> okay cool
13:16:08 <lalatenduM> Moving to next topic
13:16:14 <praveenkumar> lalatenduM: I think we can also market about VSM, how it will make things easy. may be a blog by nshaikh or budhram.
13:16:28 <lalatenduM> praveenkumar: yes I agree
13:16:36 <lalatenduM> bexelbie: can help also
13:16:53 <praveenkumar> yes
13:17:08 <lalatenduM> but we dont have anyone presesent now. so we co-ordinate offline
13:17:32 <preeti> We will need to mail him as Bex is in China this week
13:17:35 <praveenkumar> I will co-ordinate with nshaikh or budhram ofline.
13:17:43 <lalatenduM> sounds good
13:18:06 <praveenkumar> lalatenduM: let's go to next topic.
13:18:27 <lalatenduM> #topic sccli script enhancement
13:18:44 <lalatenduM> praveenkumar: you want to speak about it
13:18:46 <lalatenduM> ?
13:18:59 <praveenkumar> https://github.com/projectatomic/adb-utils/pull/108 we have PR, want someone to review + test it.
13:19:19 <praveenkumar> surajd: ccaf ^^ if you folks interested to test out or do a code-review.
13:19:33 <surajd> okay
13:20:12 <praveenkumar> lalatenduM: also we need to discuss about docker pull, where we have to skip it.
13:20:13 <surajd> sccli has become python?
13:20:24 <praveenkumar> surajd: yes also now it smcli :)
13:20:36 <lalatenduM> praveenkumar: are we planning it to be backward compatible with previous versions of sccli?
13:21:21 <praveenkumar> lalatenduM: currently it is because it only contain same functionality which sccli had only changed in python.
13:22:28 <praveenkumar> lalatenduM: I didn't add any new feature in this script. will add once this PR get merge.
13:22:58 <lalatenduM> praveenkumar: name change is a trcky thing , it breaks integration points
13:23:10 <nshaikh> .fas nshaikh
13:23:10 <zodbot> nshaikh: nshaikh 'Navid Ahmed Shaikh' <shaikhnavid14@gmail.com>
13:23:32 <lalatenduM> vsm, Vagrantfiles , documentation etc
13:23:42 <praveenkumar> lalatenduM: yep, but now script is not doing service change it also manage and provide status.
13:24:47 <praveenkumar> lalatenduM: we can file issue to respective project which are consuming sccli so they can make changes in code base.
13:24:55 <lalatenduM> praveenkumar: right, may be we can do  a similar thing like dnf and yum
13:25:08 <praveenkumar> lalatenduM: agree.
13:25:29 <lalatenduM> praveenkumar: I mean provide a symlink to sccli and deprecate it
13:25:44 <lalatenduM> praveenkumar: we can discuss that offline
13:25:47 <praveenkumar> yeah got it.
13:26:02 <lalatenduM> Moving to next topic
13:26:20 <lalatenduM> #topic ADB tests, Feedback on https://github.com/projectatomic/adb-tests/pull/19 @dharmit
13:26:37 <lalatenduM> dharmit: you want to add anything
13:26:42 <nshaikh> I went through dharmit's PR
13:26:50 <nshaikh> Its a fat patch.
13:27:10 <nshaikh> I am yet to go through it completely, also I had a discussion with dharmit about testing it out.
13:27:31 <lalatenduM> nshaikh: thanks
13:27:34 <dharmit> I had a talk with praveenkumar last week. It seems like, at least for openshift, there's possibly some duplication of effort.
13:27:46 <dharmit> Nothing to add to what nshaikh already said.
13:27:51 <lalatenduM> I will also go through it
13:28:10 <lalatenduM> #action lalatenduM nshaikh to go through https://github.com/projectatomic/adb-tests/pull/19
13:28:13 <dharmit> Just that, if anyone gets time, it'd be good to get feedback. It's fat so might take some time before we can patch it in. :-)
13:28:18 <praveenkumar> I did some code review for patch and had a call around an hour to understand complete flow.
13:28:35 <dharmit> half an hour?
13:28:40 <lalatenduM> dharmit: big patches are difficult to review
13:28:40 <dharmit> Hmm.
13:28:59 <nshaikh> Since this will be like kickoff work, lets accept this big patch.
13:29:08 <dharmit> lalatenduM: Yep, I get it. Just want to try to get 1-2 hours from maintainers in a week. That should be great!
13:29:15 <nshaikh> Henceforth, dharmit make a point to have "atomic" PRs! :-)
13:29:27 <dharmit> nshaikh: Haha. Sure thing.
13:29:28 <lalatenduM> dharmit: agree
13:29:50 <lalatenduM> Also I think it is time for us to move towards a automated release
13:29:57 <lalatenduM> I have some plans around it
13:30:11 <nshaikh> lalatenduM, lets add it to our next week meeting agenda ?
13:30:29 <lalatenduM> nshaikh: yeah lets do that
13:30:53 <lalatenduM> #action lalatenduM to discuss plans around automated release in next ADB weekly meeting
13:30:54 <praveenkumar> lalatenduM: +1 for automated release.
13:31:33 <lalatenduM> Anything else for this topic?
13:31:33 <dharmit> +1 for all possible automation. :-D
13:31:50 <nshaikh> Nope, sounds good.
13:32:13 <lalatenduM> ah forgot to add , we shoudl abe able to add o2n in ADB 2.0 , cc tkral
13:32:31 <nshaikh> nice!
13:32:34 <lalatenduM> I will send a PR for that
13:32:47 <nshaikh> okay
13:32:47 <tkral> lalatenduM, that is good news, thx ;-)
13:32:56 <lalatenduM> If we dont have anything else we can close the meeting
13:33:02 <lalatenduM> tkral: np :)
13:33:57 <lalatenduM> going 1..
13:34:25 <lalatenduM> 2..
13:34:41 <lalatenduM> 3..
13:34:46 <lalatenduM> #endmeeting