13:00:41 <bexelbie> #startmeeting Atomic Developer Bundle Weekly Meeting
13:00:41 <zodbot> Meeting started Mon May 16 13:00:41 2016 UTC.  The chair is bexelbie. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:41 <zodbot> The meeting name has been set to 'atomic_developer_bundle_weekly_meeting'
13:00:52 <bexelbie> #chair nshaikh
13:00:52 <zodbot> Current chairs: bexelbie nshaikh
13:00:55 <bexelbie> .hello bex
13:00:56 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
13:01:18 <nshaikh> .fas nshaikh
13:01:18 <zodbot> nshaikh: nshaikh 'Navid Ahmed Shaikh' <shaikhnavid14@gmail.com>
13:01:19 <bexelbie> praveenkumar, lalatenduM tkral ccaf dharmit surajd ADB Meeting PING
13:01:28 <nshaikh> budhram, ping
13:01:28 <zodbot> nshaikh: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
13:01:40 <bexelbie> #info https://titanpad.com/adbmeeting
13:01:42 <praveenkumar> .fas kumarpraveen
13:01:43 <zodbot> praveenkumar: kumarpraveen '' <kumarpraveen.nitdgp@gmail.com>
13:01:45 <budhram> .hello budhram
13:01:46 <zodbot> budhram: budhram 'Budh Ram Gurung' <bgurung@redhat.com>
13:01:49 <bexelbie> While people join, I will add last weeks AIs to the etherpad
13:02:01 <nshaikh> okay.
13:03:53 <surajd> .fas surajd
13:03:54 <zodbot> surajd: surajd 'Suraj Deshmukh' <surajssd009005@gmail.com>
13:04:10 <surajd> Nothing to report on ADB though
13:04:14 <bexelbie> #chair surajd budhram praveenkumar
13:04:14 <zodbot> Current chairs: bexelbie budhram nshaikh praveenkumar surajd
13:04:28 <bexelbie> Ok, is everyone here?  I think I see "quorum"
13:04:35 <bexelbie> If you aren't here, please say so now
13:05:19 <bexelbie> Ok, starting from the top on the etherpad
13:05:36 <bexelbie> ADB 2.1 Release
13:05:44 <bexelbie> #link https://github.com/projectatomic/adb-atomic-developer-bundle/issues/383
13:05:48 <bexelbie> release issue ^^
13:06:10 <bexelbie> there are 1.5 PRs that need to be merged before this can be released.  The first PR is just the required changes to the build script.  That should be easy to merge
13:06:18 <bexelbie> the second is a potential merge of the removal of hte @development packaes
13:06:27 <bexelbie> praveenkumar, do you know what is holding this up, other than a rebase?
13:07:07 <praveenkumar> bexelbie: nothing I can know off, I will do the rebase and I think that will be enough.
13:07:38 <bexelbie> praveenkumar, nshaikh bexelbie please review #382/3375 for an ACK
13:07:49 <bexelbie> #action praveenkumar, nshaikh bexelbie please review #382/3375 for an ACK
13:08:02 <bexelbie> I've named the maintianers int his meeting with an action to review those two PRs for merge
13:08:08 <bexelbie> any open questions about the ADB release?
13:08:14 <bexelbie> lalatenduM, who is not here, is driving the release/build
13:08:36 <bexelbie> #undo
13:08:36 <zodbot> Removing item from minutes: ACTION by bexelbie at 13:07:49 : praveenkumar, nshaikh bexelbie please review #382/3375 for an ACK
13:08:43 <bexelbie> #action praveenkumar, nshaikh bexelbie please review #382/#375 for an ACK
13:08:55 <bexelbie> going once
13:09:36 <bexelbie> ok, next item
13:09:42 <bexelbie> #info adb-utils release
13:09:51 <bexelbie> praveenkumar, what is the status of this release?  we need it to build aDB 2.1
13:10:15 <praveenkumar> bexelbie: I already did release which can be used for ADB-2.1
13:10:22 <bexelbie> Great answer!
13:10:29 <bexelbie> #info release completed on time
13:10:43 <bexelbie> any questions about adb-utils or status?
13:11:03 <nshaikh> Sounds good.
13:11:17 <bexelbie> #info vagrant-service-manager release to coincide with ADB 2.1
13:11:22 <bexelbie> nshaikh, status of vsm and a release?
13:11:47 <nshaikh> bexelbie, We had a vsm 1.0.2 release last week <https://github.com/projectatomic/vagrant-service-manager/releases/tag/v1.0.2>
13:12:04 <bexelbie> #info vsm 1.0.2 release last week:
13:12:07 <bexelbie> #undo
13:12:08 <zodbot> Removing item from minutes: INFO by bexelbie at 13:12:04 : vsm 1.0.2 release last week:
13:12:11 <bexelbie> #info vsm 1.0.2 release last week: <https://github.com/projectatomic/vagrant-service-manager/releases/tag/v1.0.2>
13:12:26 <bexelbie> Ok, it appears from the etherpad there is a new release pending ADB 2.1
13:12:28 <bexelbie> is this right?
13:12:45 <nshaikh> Correct. That is for the name of kubernetes service.
13:13:05 <bexelbie> Is there anything needed by you, budhram or others for this to be able to go forward post adb-2.1 from lalatenduM ?
13:13:33 <budhram> No. Only rebase with upstream
13:13:34 <nshaikh> We have some outstanding issues for next release, which are not expected to be fixed within this week.
13:13:56 <bexelbie> nshaikh, any you want to share (with an info tag :) - to highlight for the group?
13:14:16 <bexelbie> #info post 2.1 ADB there will be new vsm features
13:15:00 * lalatenduM is here
13:15:00 <nshaikh> I think thats all. budhram would you like to add more info ?
13:15:28 <bexelbie> nshaikh, is the new feature set the 4 issues tagged 1.0.3?
13:15:49 <nshaikh> bexelbie, yes.
13:16:02 <nshaikh> One of the feature we would like to have for next release is https://github.com/projectatomic/vagrant-service-manager/issues/210
13:16:13 <budhram> PR for naming of kubernetes will be ready after ADB 2.1 release. May be new PR related to extending --debug feature might come.
13:16:26 <bexelbie> # vsm 1.0.3 - Integrate CI server
13:16:26 <bexelbie> # vsm 1.0.3 - Expose docker registry url for the CDK enhancement focus:devex
13:16:26 <bexelbie> # vsm 1.0.3 - Vagrant native --debug flag showing command help
13:16:26 <bexelbie> # vsm 1.0.3 - Put Gemfile.lock under version control
13:16:54 <bexelbie> #210 is the 2nd issue above
13:16:54 <budhram> one more
13:17:04 <budhram> https://github.com/projectatomic/vagrant-service-manager/issues/206
13:17:06 <bexelbie> #info vsm 1.0.3 - Integrate CI server
13:17:12 <bexelbie> #info vsm 1.0.3 - Expose docker registry url for the CDK enhancement focus:devex
13:17:17 <bexelbie> #info vsm 1.0.3 - Put Gemfile.lock under version control
13:17:26 <bexelbie> #info vsm 1.0.3 - Vagrant native --debug flag showing command help
13:17:50 <bexelbie> #206 is the last one I just added .. correctly :P
13:18:00 <bexelbie> any other questions/conversation around vagrant-service-manager?
13:18:06 <bexelbie> actually, I have one ...
13:18:16 <budhram> #info vsm 1.0.3 - Extend --debug flag to show vagrant-service-manager activity
13:18:19 <bexelbie> nshaikh, is there an issue/milestone time for enabling kubectl?
13:18:23 <bexelbie> or client packaging yet?
13:18:43 <lalatenduM> nope
13:18:47 <nshaikh> not yet.
13:19:03 <bexelbie> ok
13:19:07 <bexelbie> any other conversation around vsm?
13:19:21 <nshaikh> bexelbie, can we add an action item for scanning all the issues and tagging to milestones?
13:19:33 <bexelbie> sure
13:19:45 <bexelbie> #action nshaikh to scan and add milestones to all issues in vsm repo
13:20:03 <bexelbie> #action other repo maintainers are encouraged to do the same to help with comprehension of the roadmap
13:20:11 <bexelbie> other vsm questions?
13:20:13 <nshaikh> thats all from vsm side.
13:20:44 <bexelbie> #topic Old AI: Lala to send email about delayed ADB release
13:20:46 <bexelbie> #info this was done
13:20:53 <bexelbie> I don't think anyone needs to discuss this so ...
13:21:06 <bexelbie> #topic Old AI: reviewers needed for github.com/projectatomic/adb-tests/pull/31
13:21:17 <bexelbie> This issue is still open and appears to have had no reviews
13:21:31 <bexelbie> who can take point on reviewing this ... this will enable you to have some fun with CI
13:21:55 <bexelbie> tkral, is this something you can help with - you have mesos experience
13:23:07 <bexelbie> What would people need to feel more comfortable reviewing this PR?
13:23:18 <bexelbie> presuming it is a technology/system issue and not a desire for chocolate or a pony?
13:23:45 <bexelbie> What if we put together a demo of this PR by dharmit ?  would that help folks?
13:23:46 <tkral> bexelbie, I'll look. It will force me to look into centos ci ;-)
13:23:59 <bexelbie> Cool -
13:24:11 <bexelbie> #action tkral to review github.com/projectatomic/adb-tests/pull/31
13:24:32 <bexelbie> If you run into problems tkral, obvs ping dharmit but also let lalatenduM know so we can look at how to help move this forward
13:24:32 <budhram> bexelbie, yes that would too.
13:24:50 <bexelbie> dharmit, would you be wililng to do a demo meeting on this for everyone so we can see what you are setting up?
13:25:54 <bexelbie> I will give dharmit and AI to put together a quick time for a review of the PR in a group
13:26:02 <bexelbie> I'll make sure he knows I voluntold him too :)
13:26:07 <bexelbie> I'll ask it to be announced on the ML
13:26:17 <bexelbie> #action dharmit to put together a review and announce to ML re: Topics For 16th May 2016
13:26:23 <bexelbie> #undo
13:26:23 <zodbot> Removing item from minutes: ACTION by bexelbie at 13:26:17 : dharmit to put together a review and announce to ML re: Topics For 16th May 2016
13:26:33 <bexelbie> #action dharmit to put together a review and announce to ML re: github.com/projectatomic/adb-tests/pull/31
13:26:41 <bexelbie> #topic open floor
13:26:46 <bexelbie> any other questions/comments/issues?
13:26:55 <nshaikh> I have one.
13:26:59 <bexelbie> go for it
13:27:06 <nshaikh> The VSM release is not really following with ADB release.
13:27:15 <lalatenduM> We need to discuss the video series of ADB , it is starting next week
13:27:35 <bexelbie> ok, let's start with nsh
13:27:37 <bexelbie> ok, let's start with nshaikh
13:27:43 <bexelbie> then we will talk about lala's issue
13:27:51 <bexelbie> #topic VSM releases are not really following ADB releases
13:27:55 <bexelbie> nshaikh, can you elaborate on that
13:28:00 <nshaikh> The VSM release could be in sync with ADB release.
13:28:19 <bexelbie> could or should?
13:28:30 <nshaikh> *should
13:28:32 <nshaikh> However the issues resolution and the number of issues fixed for a new release is not really considerable to have a new release.
13:29:04 <lalatenduM> I do not think VSM releases need to follow ADB releases
13:29:05 <nshaikh> We need to discuss (offline) if we want to sync the release? Yes - then how.
13:29:07 <bexelbie> nshaikh, are we required to build new code for every ADB release or could we only release vsm when there is either enough change to warrant a release or ADB version dependent changes?
13:29:35 <nshaikh> bexelbie, later of your sentence.
13:29:40 <nshaikh> lalatenduM, okay
13:29:50 <nshaikh> I think only one minute left and we have one more topic.
13:29:57 <nshaikh> I am happy to take it offline with other maintainers.
13:30:04 <bexelbie> ok, how about an email notice to this change and move forward with other maintainers
13:30:12 <nshaikh> works.
13:30:18 <bexelbie> #action nshaikh to mail ML about release schedule for VSM and set up a convo with maintainers
13:30:33 <bexelbie> #topic Video series for ADB
13:30:36 <bexelbie> lala ... go for it
13:30:55 <lalatenduM> Regarding teh ADB video series we need to publish a schedule
13:30:56 <bexelbie> since we started late, let's run a few min over and at least feel this topic out
13:31:21 <lalatenduM> so we need to discuss offline whois doing the sessions
13:31:24 <bexelbie> Have you had suggestions on topics, etc.?  Perhaps jberkus could help with the schedule/topics list?
13:31:40 <lalatenduM> and also what we should cover in each one of them
13:31:46 <lalatenduM> bexelbie: we have list of topics
13:31:48 <bexelbie> I can't speak for everyone else, but I would prefer to agree to do a topic rather to agree to cover a week
13:31:59 <bexelbie> lalatenduM, cool - is that list somewhere where people can sign up?
13:32:04 <bexelbie> we can info/link it to the minutes
13:32:21 <lalatenduM> bexelbie: actually the initial mail asked for suggestions and voluenteers
13:32:25 <lalatenduM> so have got some
13:32:43 <bexelbie> lalatenduM, can you aggregate them into a list that would be easy for folks to read/sign up against?
13:32:59 <lalatenduM> bexelbie: yeah , lets do it tomorrow
13:33:07 <lalatenduM> thats it
13:33:18 <bexelbie> #action lalatenduM to create a list of topics for the video series and solicit signups
13:33:24 <bexelbie> #topic open floor
13:33:27 <bexelbie> going once ....
13:33:34 <lalatenduM> bexelbie: signups for speakers right?
13:33:41 <bexelbie> yep
13:33:44 <lalatenduM> cool
13:33:50 <bexelbie> going twice
13:33:53 <bexelbie> and .. we are done
13:33:56 <bexelbie> #endmeeting