15:00:30 <bowlofeggs> #startmeeting Bodhi stakeholders (2016-10-11)
15:00:30 <zodbot> Meeting started Tue Oct 11 15:00:30 2016 UTC. The chair is bowlofeggs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:30 <zodbot> The meeting name has been set to 'bodhi_stakeholders_(2016-10-11)'
15:00:32 <bowlofeggs> #meetingname bodhi_stakeholders
15:00:32 <zodbot> The meeting name has been set to 'bodhi_stakeholders'
15:00:33 <bowlofeggs> #topic salutations
15:00:34 <bowlofeggs> #chair acarter bowlofeggs dgilmore masta mboddu nirik pbrobinson puiterwijk trishnag
15:00:34 <zodbot> Current chairs: acarter bowlofeggs dgilmore masta mboddu nirik pbrobinson puiterwijk trishnag
15:00:38 <trishnag> .hello trishnag
15:00:39 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
15:00:50 <bowlofeggs> .hello bowlofeggs
15:00:51 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
15:01:01 * masta is here
15:01:09 * nirik is sort of here, but also sort of watching beta release for any issues.
15:02:10 <bowlofeggs> excellent. i will move on to announcements, there are only two
15:02:19 <bowlofeggs> #topic announcements and information
15:02:20 <bowlofeggs> #info Since our last meeting, 2.2.0 - 2.2.4 were released and deployed
15:02:22 <bowlofeggs> #info There is a meeting on Friday at 14:00 UTC about OSTree multi-arch in #fedora-meeting-1
15:02:43 <bowlofeggs> if you care about OSTree multi-arch support, then friday is the day for you!
15:03:08 <bowlofeggs> whoops, i forgot that it's next friday
15:03:10 <bowlofeggs> let me fix that
15:03:20 <bowlofeggs> #info There is a meeting on Friday Oct. 21 at 14:00 UTC about OSTree multi-arch in #fedora-meeting-1
15:03:47 <bowlofeggs> that's all the announcements i know of
15:03:55 <bowlofeggs> we'll move on to the first topic
15:04:05 <bowlofeggs> #topic bodhi-2.3
15:04:06 <bowlofeggs> #info bodhi-2.3 was planned to be deployed to stg before now, but we are holding it for the gated signing feature
15:04:08 <bowlofeggs> #info Outside of the gated signing feature, there are some minor bug fixes and not much else (read, lower risk update than 2.2 was!)
15:04:49 <masta> sounds good
15:04:51 <bowlofeggs> during the last stakeholders meeting, i had proposed having the 2.3 beta in stg during this meeting. though that was a good goal, we noticed that the signing gating wasn't quite right
15:04:58 <bowlofeggs> so we're just holding it to get that in
15:05:07 <bowlofeggs> other than that, 2.3 is mostly just minor bug fixes
15:05:17 <bowlofeggs> all the major bugs were fixed in the 2.2.x series
15:05:44 <bowlofeggs> well, not 'all' the major bugs, but what i mean is that we aren't holding any major bug fixes that we've already done for 2.3 ☺
15:06:01 <masta> did we solve the nfs file locks thing?
15:06:18 <nirik> yes, it was a createrepo bug
15:06:22 <nirik> createrepo_c
15:06:25 <masta> I knew it!
15:06:32 <bowlofeggs> masta: i think puiterwijk figured out some of the problems in that area, but fixing it exposed some new problems (too many open file handles)
15:06:47 <bowlofeggs> so we've traded for a new problem, but it is progress!
15:07:20 <bowlofeggs> i don't have much more to say about 2.3. it should be much lower risk than 2.2 was, so that's good
15:07:27 <bowlofeggs> i'll move on to the next topic
15:07:36 <bowlofeggs> #topic e-mails every six hours https://github.com/fedora-infra/bodhi/issues/1009
15:07:46 <bowlofeggs> #info These e-mails will begin when a non-autopush update hits the karma threshold, and will end when it's either pushed or hits 7 days in testing
15:07:48 <bowlofeggs> #info Is this bad enough to warrant a 2.2.5 bugfix release after the freeze, or can it wait for 2.3.0 which should land soon?
15:08:06 <bowlofeggs> so that's the question i'd like to poll the audience for ^
15:08:32 <nirik> I'd be fine waiting for 2.3.0 if it's not far out... end of week? or more than that?
15:08:34 <bowlofeggs> it's mostly an annoyance. i'm happy to make a 2.2.5, but it takes me time to make a release, so it's not "free"
15:08:45 <masta> so nag emails?
15:09:13 <bowlofeggs> nirik: i think puiterwijk has a fix PR up that i need to review for the gating feature. after that i will need to write tests and a migration. i think end of week is a realistic possibility
15:09:32 <bowlofeggs> masta: yeah, and they stop once the update is pushed, or once it hits 7 days
15:09:37 <bowlofeggs> so they aren't endless
15:10:44 <masta> yeah, I'd say 2.3
15:11:03 <bowlofeggs> cool that is what i lean towards as well
15:11:08 <bowlofeggs> nirik: you too?
15:11:16 * nirik nods
15:12:21 <bowlofeggs> #action We will fix https://github.com/fedora-infra/bodhi/issues/1009 with 2.3.0
15:12:27 <bowlofeggs> ok, next topic
15:12:36 <bowlofeggs> #topic Looking forward
15:12:38 <bowlofeggs> #info These are the issues highest on the Bodhi priority list https://github.com/fedora-infra/bodhi/issues?q=is%3Aopen+is%3Aissue+label%3ACritical
15:12:39 <bowlofeggs> #info There is also a high priority issue list https://github.com/fedora-infra/bodhi/issues?q=is%3Aopen+is%3Aissue+label%3A%22High+priority%22
15:12:41 <bowlofeggs> #info Critical means we can't go on living in this squalor
15:12:43 <bowlofeggs> #info High priority means it's important, but not a show stopper
15:12:44 <bowlofeggs> Any filed issues that aren't on these lists that should be?
15:14:01 <bowlofeggs> and/or, do you disagree with priorities of any filed bugs in general?
15:14:03 <nirik> I think 328 can be closed
15:14:26 <nirik> since there is 988 to track the too many files thing
15:14:36 <nirik> (which I haven't actually seen so far this week)
15:14:52 <bowlofeggs> oh right, i think that is the createrepo_c bug that puiterwijk fixed
15:15:11 <nirik> yeah
15:15:17 <bowlofeggs> puiterwijk++ by the way, he was a huge help to me over the past month. i think he fixed more bugs on bodhi than i did ☺
15:15:29 <masta> haha
15:15:30 <nirik> There was some bug about the bodhi1 client not working against bodhi2...
15:15:32 * nirik digs
15:15:44 <trishnag> puiterwijk++
15:16:00 <puiterwijk> for reference: the createrepo_c bug was https://github.com/rpm-software-management/createrepo_c/pull/66
15:16:46 <bowlofeggs> nirik: i think there are a million bugs filed about the bodhi 1 client
15:17:22 <bowlofeggs> to be honest, i am not sure whether i should spend my time on those bugs or not. on one hand, most people are probably still using the bodhi 1 client, but over time it will be phased out
15:17:35 <bowlofeggs> bodhi 2 won't be in a stable fedora until f26 though
15:17:40 <nirik> https://bugzilla.redhat.com/show_bug.cgi?id=1258532
15:17:47 <nirik> https://bugzilla.redhat.com/show_bug.cgi?id=1376798
15:18:03 <nirik> yeah, the big thing appears to be 'bodhi -D' not working
15:18:10 <nirik> lots of people use that.
15:19:07 <bowlofeggs> what are people's feelings about whether i do or don't put effort into fixing the bodhi 1 client?
15:19:32 <nirik> perhaps it's worth just pushing the bodhi2 client back to older releases?
15:19:52 <bowlofeggs> to be transparent, i'm not supposed to put 100% of my time into bodhi in general, which is why i'd prefer to focus on making the bodhi 2 client better
15:20:06 <trishnag> bowlofeggs: +1
15:20:06 <bowlofeggs> nirik: i could do that as a new package i suppose
15:20:19 <bowlofeggs> that's not a bad idea
15:20:28 <nirik> well, I think thats too much work...
15:20:35 <bowlofeggs> nirik: i feel like bodhi 2 doesn't have the -D feature
15:20:47 <nirik> it doesn't have -D but it does have the feature...
15:20:58 <bowlofeggs> ah, so it's just a different flag
15:21:12 <nirik> bodhi updates download --updateid <updateid>
15:21:19 <bowlofeggs> nirik: i hadn't wanted to push the new client out to the older releases becase it's not backwards compatible
15:21:28 <bowlofeggs> and who knows what kind of scripting people might have written against it
15:21:58 <bowlofeggs> i do also maintain a Copr with the new bodhi client if people want to use that
15:22:52 <nirik> hum, perhaps a copr ? and you could point people to that when they file bugs?
15:22:52 <nirik> please try this copr, sorry we can't fix the bodhi1 client... closed->sorry
15:23:16 <bowlofeggs> yeah i've got one actually: https://copr.fedorainfracloud.org/coprs/bowlofeggs/bodhi/
15:24:07 <bowlofeggs> i've got a task warrior task to go through the big backlog of bodhi tickets and basically state why i'm not going to fix bodhi 1, that the copr exists, and that bodhi 2 is coming starting with f26
15:24:15 <bowlofeggs> probably with more polish than that ☺
15:24:46 <bowlofeggs> does anyone have thoughts on any other ticket priorities?
15:25:18 <masta> I guess for the -D there are other ways to get the packages out of koji.
15:25:39 <nirik> sure, but bodhi -D was very handy...
15:26:00 <nirik> think about the gnome megaupdates... would be a massive pain to look up each package and go try and download
15:26:35 <masta> very true
15:26:48 <nirik> actually I wonder if that might be a nice RFE? a link on the web page that downloads all the packages in the update...
15:26:59 <bowlofeggs> that could be cool
15:26:59 <nirik> also, bodhi -D might have downloaded signed ones...
15:27:02 <masta> bowlofeggs, fix just that one, then say those things about copr for the rest of them.
15:27:44 <bowlofeggs> keep in mind that i'm only 50-60% on bodhi, and there are a ton of things that sound much higher priority to me
15:28:09 <bowlofeggs> like getting non-rpm content into bodhi, making the masher more stable, etc.
15:28:41 <bowlofeggs> fixing that flag might take longer than it sounds like (i have no idea) and is part of a codebase that's completely different than the bodhi 2 codebase
15:29:11 <bowlofeggs> i'd be happy to accept a patch for the spec file though, if someone is inclined to write one ☺
15:29:19 <masta> ok, then I think you need help. Maybe we can ask for patched from those who request fixes.
15:29:30 <bowlofeggs> yeah i think that's a great way to go
15:29:47 <bowlofeggs> i will express that on the ticket
15:30:11 <bowlofeggs> #action comment on https://bugzilla.redhat.com/show_bug.cgi?id=1258532 that I need help maintaining the bodhi 1 CLI
15:32:01 <bowlofeggs> alright, if there are no other tickets to repriroritize, we'll move on
15:32:07 <bowlofeggs> #topic Open floor
15:33:22 * masta has nothing
15:33:33 <nirik> nothing from me...
15:33:50 <trishnag> Nothing from my side.
15:35:10 <bowlofeggs> cool
15:35:14 <bowlofeggs> well want 25 min back?
15:35:22 <masta> yes
15:35:31 <bowlofeggs> excellent
15:35:48 <bowlofeggs> thank you all for participating, and for your patience over the wild ride that was the last month of bodhi
15:35:58 <bowlofeggs> #endmeeting