09:02:59 <nishanth> #startmeeting check-in_20161219
09:02:59 <zodbot> Meeting started Mon Dec 19 09:02:59 2016 UTC.  The chair is nishanth. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:02:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
09:02:59 <zodbot> The meeting name has been set to 'check-in_20161219'
09:03:22 <neha> anmol, ok I will add the comments in the spec then
09:03:32 <nishanth> #topic anmol's updates
09:04:50 <nishanth> #info anmol need some time to prepare the update; will circle back on him later
09:05:31 <nishanth> #topic dahorak 's updates
09:07:19 <dahorak> GitHub Link: https://github.com/Tendrl/specifications/pull/61
09:07:19 <dahorak> Progress: working on review
09:07:19 <dahorak> Status: Good, not blocked
09:07:41 <dahorak> otherwise working on Tendrl unrelated tasks
09:08:44 <nishanth> dahorak, there are some comments on the PR to be addressed
09:09:02 <nishanth> dahorak, hope you are working on that?
09:09:16 <dahorak> nishanth: ah ... sorry I copy&paste bad link :-/
09:10:35 <dahorak> GitHub Link: https://github.com/Tendrl/usmqe-setup/pull/6
09:10:35 <dahorak> this is the correct link
09:11:16 <nishanth> ok
09:11:38 <nishanth> dahorak, are you planning work on the https://github.com/Tendrl/specifications/pull/61 ?
09:12:25 <dahorak> nishanth: yep, and probably mbukatov will have more updates
09:13:01 <nishanth> #info dahorak reviewing https://github.com/Tendrl/usmqe-setup/pull/6
09:13:39 <nishanth> #action dahorak to continue working on the  https://github.com/Tendrl/specifications/pull/61 to address the review comments
09:14:27 <nishanth> #topic fbalak 's update
09:14:34 <fbalak> Issue: https://github.com/Tendrl/usmqe-tests/pull/6 - Writing negative test cases for gluster
09:14:36 <fbalak> Progress: Working on it
09:14:37 <fbalak> Status: Good
09:16:41 <brainfunked> nishanth, please ping me during anmol's updates as well
09:17:07 <nishanth> fabalak, I remember you were planning to help with some spec reviews as well , able to make some progress
09:17:16 <nishanth> brainfunked sure
09:18:44 <nishanth> fbalak, https://github.com/Tendrl/specifications/pull/20 and https://github.com/Tendrl/specifications/pull/63 and  https://github.com/Tendrl/specifications/pull/18/
09:20:13 <nishanth> Looks like fbalak is away
09:20:57 <nishanth> #info fbalak to update the status of review  https://github.com/Tendrl/specifications/pull/20 ,  https://github.com/Tendrl/specifications/pull/63 and  https://github.com/Tendrl/specifications/pull/18/
09:22:06 <fbalak> nishanth: our team is working on it
09:22:36 <nishanth> fbalak, ok any ETA ?
09:22:56 <fbalak> next year
09:23:32 <fbalak> nishanth: most of our team have PTO from wednesday
09:25:48 <nishanth> #info fbalak will complete the reviews next year as the team is on PTO from Wed
09:26:03 <nishanth> #action fbalak and team to complete  reviews https://github.com/Tendrl/specifications/pull/20 ,  https://github.com/Tendrl/specifications/pull/63 and  https://github.com/Tendrl/specifications/pull/18/
09:26:19 <nishanth> #topic anmol 's updates
09:26:22 <anmol> please view my update @ http://paste.fedoraproject.org/509599/13921714/
09:27:03 <nishanth> brainfunked ^^
09:30:05 <brainfunked> right, I've approved and merged the pluggable alerts delivery spec at https://github.com/Tendrl/specifications/issues/40
09:30:19 <brainfunked> nishanth, that's what I wanted to update wrt anmol's work
09:30:42 <brainfunked> anmol would be able to update regarding the implemenation status
09:31:07 <nishanth> brainfunked, https://github.com/Tendrl/specifications/issues/42  also require approval from your side?
09:31:32 <anmol> brainfunked, nishanth I realised the merge only now :) Implementation is @ https://github.com/Tendrl/alerting/pull/15
09:31:32 <brainfunked> checking
09:31:52 <anmol> https://github.com/Tendrl/alerting/pull/15 is WIP
09:32:10 <nishanth> #accept brainfunked has reviewed and merged anmol's pluggable alerting delivery endpoints specification https://github.com/Tendrl/specifications/issues/40
09:32:20 <brainfunked> nishanth, yes, but it's blocked on that node agenst spec I need to put up. Let me create an issue for that, so that you can add that as an action item on me
09:33:03 <nishanth> brainfunked, ok
09:33:39 <nishanth> anmol, are you good on implementation or any blockers
09:33:40 <nishanth> ?
09:34:02 <anmol> nishanth, I have no blockers as of now
09:35:34 <anmol> nishanth: except for review of https://github.com/Tendrl/specifications/pull/81
09:35:43 <brainfunked> nishanth, writing the issue description, will give you the link in a bit
09:35:59 <nishanth> #info  https://github.com/Tendrl/specifications/issues/42 blocked on node_agent spec
09:36:00 <brainfunked> nishanth, if I don't finish before the check-in meeting is to end, please ping me
09:36:06 <brainfunked> before ending the meeting
09:36:11 <nishanth> ok
09:36:48 <nishanth> #action @shtripat, @nthomas-redhat, @anivargi, @r0h4n and @brainfunked to review https://github.com/Tendrl/specifications/issues/62
09:37:21 <nishanth> #action @shtripat, @nthomas-redhat, @r0h4n and @brainfunked to review https://github.com/Tendrl/specifications/issues/71
09:39:43 <nishanth> #action anmol continue to work on the monitoring PR's, address the comments and to add UT cases
09:40:34 <nishanth> #topic gowtham_ 's updates
09:40:45 <gowtham_> Adding disk details in hardware inventory
09:40:45 <gowtham_> git-issue: https://github.com/Tendrl/node_agent/issues/7
09:40:45 <gowtham_> spec file: https://github.com/Tendrl/specifications/pull/21
09:40:46 <gowtham_> code-PR: https://github.com/Tendrl/node_agent/pull/64
09:40:50 <gowtham_> all changes are done
09:40:58 <gowtham_> review is required
09:41:35 <gowtham_> currently working on  : Logging implementation
09:41:48 <gowtham_> git hub issue : https://github.com/Tendrl/specifications/issues/28
09:42:17 <gowtham_> i have small doubts once i clear i will start spec file for this
09:42:31 <gowtham_> Adding Network details in hardware inventory
09:42:31 <gowtham_> git-issue: https://github.com/Tendrl/node_agent/issues/78
09:42:32 <gowtham_> spc file: https://github.com/Tendrl/specifications/pull/19
09:42:32 <gowtham_> code-PR: https://github.com/Tendrl/node_agent/pull/79
09:42:47 <gowtham_> Network details also in under review
09:42:54 <gowtham_> status
09:43:01 <gowtham_> status: good
09:43:31 <gowtham_> not blocked , But have some doubts in logging implementation
09:43:36 <nishanth> gowtham_, is there anything pending on https://github.com/Tendrl/specifications/pull/21 ?
09:43:52 <gowtham_> no all done
09:44:39 <gowtham_> i have stored disks in two diff keys with two diff object .. i want to know this approach is correct or not?
09:45:23 <gowtham_> please give your suggestion in git bub
09:45:29 <gowtham_> *git hub
09:46:08 <gowtham_> i am done
09:46:49 <nishanth> #info brainfunked to review and approve https://github.com/Tendrl/specifications/pull/21
09:47:35 <nishanth> #undo
09:47:35 <zodbot> Removing item from minutes: INFO by nishanth at 09:46:49 : brainfunked to review and approve https://github.com/Tendrl/specifications/pull/21
09:47:47 <nishanth> #action  brainfunked to review and approve https://github.com/Tendrl/specifications/pull/21
09:49:07 <nishanth> gowtham_ looks like still there are some comments to be addressed on  https://github.com/Tendrl/specifications/pull/19 ?
09:51:01 <gowtham_> nishanth,  i solved all
09:52:00 <nishanth> gowtham, ok
09:52:41 <nishanth> #action brainfunked to review and approve https://github.com/Tendrl/specifications/issues/19
09:53:26 <nishanth> #topic kaverma 's updates
09:54:15 <kaverma> Title: Donut Chart Component.
09:54:23 <kaverma> Spec-PR: (working on specs PR. very soon send pr for this).
09:54:36 <kaverma> Spec-Issue: https://github.com/Tendrl/specifications/issues/84
09:54:44 <kaverma> Github-PR: https://github.com/Tendrl/tendrl_frontend/pull/68 (just now sent PR)
09:54:55 <kaverma> Github-Issue: https://github.com/Tendrl/tendrl_frontend/issues/67
09:55:04 <kaverma> Progress: done with "Donut Chart Component" and sent PR ( neha: request you to review this PR. before list-view implementation goes in. we should have this chart component in place to draw charts in list view )and also completed "Sparkline Chart component" very soon will send PR for this one also. and now going to review neha specs related to list-view and will incorporate nishanth's comments on "import cluster ui" specs.
09:55:14 <kaverma> [ Actually i will be on leave on tuesday (tomorrow) so i have worked in this last weekend and got completed "donut" and "Sparkline" chart component for list-view. (considering as time constraints)  i need to go for checkup and also have some personal work . but sure i will be able to join evening call on tuesday(tomorrow). ]
09:55:21 <kaverma> Status: good . not blocked.
09:55:23 <kaverma> End
09:57:08 <nishanth> kaverma, you want the reviews on PR  to be done by neha right?
09:57:14 <kaverma> yes
09:57:25 <neha> kaverma, I have reviewed it
09:57:39 <kaverma> neha, ok than .. thanks
09:57:45 <nishanth> kaverma, any progress on https://github.com/Tendrl/specifications/pull/64 ?
09:58:19 <kaverma> nishanth, i am taking "list-view" as priority
09:58:39 <kaverma> because we need some more discussion on import cluster
09:59:14 <kaverma> nishanth, but i will incorporate your comment as we discussed on bj
09:59:38 <nishanth> #info kaverma on PTO 20161220
10:00:47 <nishanth> #action kaverma to incorporate review comments on https://github.com/Tendrl/tendrl_frontend/issues/67, create a spec PR https://github.com/Tendrl/specifications/issues/84.
10:01:20 <nishanth> #info kaverma will work on 'list view' on priority
10:02:00 <nishanth> #topic ltrilety 's update
10:02:55 <ltrilety> nishanth: no update, cause till now I had sick leave
10:03:34 <nishanth> #info no update from ltrilety, on sick leave
10:03:59 <nishanth> #topic mbukatov 's updates
10:04:42 <mbukatov> I'm almost done with updates/review of tendrl-setup
10:04:59 <mbukatov> only minor tweaks and reporting of few issues are needed
10:05:11 <mbukatov> reference: https://github.com/Tendrl/usmqe-setup/pull/6
10:05:32 <mbukatov> besides that, I reported/closed few minor issues related to tendrl-api
10:06:05 <mbukatov> #action mbukatov finish https://github.com/Tendrl/usmqe-setup/pull/6
10:06:20 <mbukatov> #action mbukatov provide feedback on https://github.com/Tendrl/specifications/pull/61
10:06:59 <mbukatov> also, I talked with selinux people about https://github.com/Tendrl/tendrl-api/issues/42 and there was no clear consensus at first sight
10:07:49 <mbukatov> that said, we are going to get a hint from the selinux people under the issue
10:08:16 <mbukatov> besides that, I had some pto
10:08:20 <mbukatov> that's all from me
10:09:04 <nishanth> #info mbukatov talked to selinux team regarding  https://github.com/Tendrl/tendrl-api/issues/42 and expect to get some solution
10:09:18 <nishanth> thanks for the update
10:10:49 <nishanth> #action mbukatov to follow up on  https://github.com/Tendrl/tendrl-api/issues/42 with selinux folks
10:11:03 <nishanth> #topic mkudlej 's updates
10:13:22 <nishanth> #info looks like mkudlej is away. Will circle back to mkudlej later
10:13:35 <nishanth> #topic neha 's updates
10:13:45 <neha> issue - https://github.com/Tendrl/tendrl_frontend/issues/66
10:14:09 <mkudlej> nishanth: I'm working on https://github.com/Tendrl/specifications/pull/61 and https://github.com/Tendrl/specifications/pull/53 and import ceph cluster test
10:14:47 <neha> I will give update after mkudlej
10:14:54 <nishanth> mkudlej, can we do your update after neha is done?
10:15:11 <nishanth> neha, thanks ok
10:17:15 <nishanth> mkudlej, you are work on the CI stuff with dahorak right?
10:18:17 <nishanth> #info mkudlej working on https://github.com/Tendrl/specifications/pull/61 with dahorak
10:18:40 <mkudlej> nishanth: I check those specification and would like to do review and comments
10:19:05 <nishanth> #undo
10:19:05 <zodbot> Removing item from minutes: INFO by nishanth at 10:18:17 : mkudlej working on https://github.com/Tendrl/specifications/pull/61 with dahorak
10:19:25 <nishanth> #info mkudlej reviewing https://github.com/Tendrl/specifications/pull/61
10:20:03 <nishanth> mkudlej, do you have any issue to track the import cluster related activity ?
10:20:21 <nishanth> writing test cases or testing?
10:20:42 <mkudlej> nishanth: not yet
10:21:29 <nishanth> #action mkudlej to review the spec https://github.com/Tendrl/specifications/pull/61
10:21:56 <nishanth> mkudlej, please create one
10:22:44 <nishanth> #topic neha 's updates
10:23:36 <neha> issue - https://github.com/Tendrl/tendrl_frontend/issues/66
10:23:45 <neha> Needs review for PRs -
10:23:51 <neha> https://github.com/Tendrl/specifications/pull/85
10:23:51 <neha> https://github.com/Tendrl/specifications/pull/83
10:23:51 <neha> https://github.com/Tendrl/specifications/pull/82
10:23:51 <neha> https://github.com/Tendrl/specifications/pull/77
10:24:02 <neha> Host list implementation is blocked by PR - https://github.com/Tendrl/specifications/pull/81
10:24:02 <neha> I can start the implementation with mock data but it will be good if Anup can provide API response format for the list views.
10:24:28 <neha> noopq ^
10:25:59 <neha> as these specs needs to be updated with the API responses
10:26:38 <nishanth> neha, looks like you need updates from anmol and noopq in spec right ?
10:26:56 <neha> yes
10:27:52 <nishanth> #action noopq to provide details on specs - https://github.com/Tendrl/specifications/pull/85, https://github.com/Tendrl/specifications/pull/83,  https://github.com/Tendrl/specifications/pull/82, https://github.com/Tendrl/specifications/pull/77
10:28:29 <anmol> nishanth, I have provided the details I had
10:28:30 <nishanth> #action anmol to provide details on specs -  https://github.com/Tendrl/specifications/pull/85, https://github.com/Tendrl/specifications/pull/83,  https://github.com/Tendrl/specifications/pull/77
10:29:16 <nishanth> anmol, edit the doc, create a pull request on neha's branch so that  she can merge that
10:29:35 <nishanth> neha, who should review the specs?
10:30:06 <anmol> nishanth, I have my own PR I have asked neha to add link to my PR in her pr
10:30:23 <neha> I have added yours, brainfunked, noopq, anmol, kamlesh names there
10:30:26 <neha> in PR
10:30:39 <nishanth> anmol, all the above said PR's taken care?
10:31:13 <nishanth> #action  brainfunked, noopq, anmol, kamlesh, nishanth to review  https://github.com/Tendrl/specifications/pull/85, https://github.com/Tendrl/specifications/pull/83,  https://github.com/Tendrl/specifications/pull/82, https://github.com/Tendrl/specifications/pull/77
10:31:41 <anmol> nishanth, I commented on 1 pr the details related to other's are not available from monitoring at this point in time
10:31:55 <anmol> nishanth, I have conveyed this to her as well
10:32:05 <nishanth> anmol, please discuss that in PR
10:32:09 <anmol> ok
10:32:41 <nishanth> noopq, can you provide the API format details to neha?
10:34:18 <nishanth> #action, noopq to provide API response format for list views
10:34:38 <nishanth> thanks neha for updates
10:35:01 <nishanth> #topic noopq 's updates
10:36:05 <nishanth> #info noopq is away, will take the update's later
10:36:37 <nishanth> #topic shu6h3ndu 's updates
10:37:39 <Shu6h3ndu> nishanth, sure
10:37:40 <Shu6h3ndu> Issue: https://github.com/Tendrl/specifications/issues/30 (Accomodate gluster get-state cli changes post gluster 3.9)
10:37:40 <Shu6h3ndu> Spec: https://github.com/Tendrl/specifications/pull/6 (Added specification for refactoring gluster get-state output)
10:37:40 <Shu6h3ndu> Progress: No major review comments. Ready to merge
10:37:40 <Shu6h3ndu> Status: WAITING FOR MERGE
10:37:41 <Shu6h3ndu> Issue: https://github.com/Tendrl/specifications/issues/31 (Refactor Tendrl framework sub modules)
10:37:47 <Shu6h3ndu> Spec: https://github.com/Tendrl/specifications/pull/7 (Added specifications for refactoring tendrl code)
10:37:50 <Shu6h3ndu> Progress: code change PR under review. Pushed gluster_integration changes on 16-dec-2016. Working on ceph_integration refactor now
10:37:53 <Shu6h3ndu> Status: NOT BLOCKED
10:37:55 <Shu6h3ndu> Issue: https://github.com/Tendrl/gluster_integration/issues/74 (Implement the pre and post runs for volume operations)
10:38:00 <Shu6h3ndu> Spec: NA (OLD ONE)
10:38:02 <Shu6h3ndu> Progress: Comments incorporated. Nishanth to review
10:38:04 <Shu6h3ndu> Status: BLOCKED ON REVIEW
10:38:06 <Shu6h3ndu> Issue: https://github.com/Tendrl/gluster_integration/issues/73 (Delete the volume entry from etcd as well while volume delete)
10:38:09 <Shu6h3ndu> Spec: NA (OLD ONE)
10:38:11 <Shu6h3ndu> Progress: Comments incorporated. Nishanth to review
10:38:17 <Shu6h3ndu> Status: BLOCKED ON REVIEW
10:38:19 <Shu6h3ndu> Summary, working on refactoring of ceph_integration module and kind of done. will be pushing PR today sometime soon
10:38:22 <Shu6h3ndu> need reviews of other code PRs
10:38:38 <mkudlej> nishanth: here is missing issue https://github.com/Tendrl/usmqe-tests/issues/9
10:41:33 <nishanth> #action nishanth/brainfunked to review and approve https://github.com/Tendrl/specifications/issues/30
10:43:02 <nishanth> #action nishanth to review  https://github.com/Tendrl/gluster_integration/issues/74,  https://github.com/Tendrl/gluster_integration/issues/73
10:44:00 <nishanth> shu6h3ndu, what about the rafactoring patches?
10:44:19 <Shu6h3ndu> nishanth, will request to start review on re-factoring code as well
10:44:38 <nishanth> ok
10:44:47 <Shu6h3ndu> nishanth, Issues are linked to https://github.com/Tendrl/specifications/pull/7
10:45:05 <Shu6h3ndu> nishanth, there are many so havent listed in status update here
10:46:17 <nishanth> #action shu6h3ndu complete the re-factoring activity and get the patches reviewed
10:46:35 <nishanth> #topic brainfunked 's updates
10:47:15 <Shu6h3ndu> nishanth, I have added reviewers to all the PRs. will send a list for patches fro review in a mail as well :)
10:47:32 <nishanth> ok
10:48:24 <brainfunked> I've added an issue for the node agent specification https://github.com/Tendrl/specifications/issues/87. I'll need the rest of today and tomorrow to finish the specification for review.
10:48:35 <brainfunked> Will be going through the reviews I've been tagged in, above
10:49:22 <brainfunked> on Friday, we sorted out the priorities on the UI and are now in sync about any dependencies to finish off the list views on the UI
10:49:43 <brainfunked> EOM
10:50:34 <nishanth> #topic nishanth 's updates
10:50:51 <nishanth> Reviews
10:50:51 <nishanth> - https://github.com/Tendrl/specifications/pull/67
10:50:51 <nishanth> - https://github.com/Tendrl/tendrl-api/issues/39
10:50:51 <nishanth> - https://github.com/Tendrl/specifications/pull/63
10:51:36 <nishanth> Spec-PR: https://github.com/Tendrl/specifications/pull/73
10:51:52 <nishanth> status: Planning to work on today
10:52:40 <nishanth> Planing to complete all the pending reviews as well
10:54:04 <nishanth> #topic t1m1 updates
10:54:30 <t1m1> Fix patch for the issue https://github.com/Tendrl/node_agent/issues/97 (Pull 100) is ready for merge
10:54:30 <t1m1> Working on fixing following bugs:
10:54:30 <t1m1> https://github.com/Tendrl/tendrl-api/issues/45
10:54:30 <t1m1> https://github.com/Tendrl/tendrl-api/issues/46
10:54:30 <t1m1> https://github.com/Tendrl/gluster_integration/issues/82
10:54:30 <t1m1> https://github.com/Tendrl/node_agent/issues/105
10:54:32 <t1m1> Waiting for review: https://github.com/Tendrl/node_agent/pull/107 (issue: 89)
10:54:34 <t1m1> Review is required for tendrl-api config section: https://github.com/Tendrl/documentation/pull/69
10:54:36 <t1m1> Review is required for https://github.com/Tendrl/specifications/issues/68 which resolves: https://github.com/Tendrl/ceph_integration/issues/57 and https://github.com/Tendrl/gluster_integration/issues/86
10:56:36 <nishanth> t1m1, all the issues mentioned above, do you have PR's ?
10:56:42 <brainfunked> nishanth, when would you be able to pick up https://github.com/Tendrl/specifications/issues/55?
10:57:19 <nishanth> brainfunked, Yes I can
10:57:30 <brainfunked> nishanth, right now?
10:58:37 <nishanth> I need to work on  https://github.com/Tendrl/specifications/pull/73, reviews. Probably by tomorrow I can start on that.
10:59:03 <nishanth> again based on priority we can re-shuffle if required, brainfunked^
11:00:22 <t1m1> working on pr, I have not yet send any pr for the bugs 45, 46, 82, 105, today or tomorrow morning i will send the pr after verifying
11:00:25 <brainfunked> nishanth, will review that, in the meanwhile, I suppose you could pick up https://github.com/Tendrl/specifications/issues/55
11:01:30 <nishanth> brainfunked, ok
11:01:48 <nishanth> t1m1, who should review the PR's?
11:02:26 <t1m1> noop for pull 69
11:03:20 <nishanth> #info t1m1 started working on  https://github.com/Tendrl/tendrl-api/issues/45, https://github.com/Tendrl/tendrl-api/issues/46, ttps://github.com/Tendrl/gluster_integration/issues/82, https://github.com/Tendrl/node_agent/issues/105
11:03:22 <t1m1> hope brainfunked reviewing issue 68 (tendrl/spec)
11:03:44 <brainfunked> ack, will review
11:05:23 <nishanth> #action tendrl-core to review  https://github.com/Tendrl/node_agent/pull/107
11:05:23 <Shu6h3ndu> nishanth, I would be picking  https://github.com/Tendrl/specifications/issues/80 next as current work is under review now and only rework has to be taken care
11:05:51 <nishanth> #action noopq to review : https://github.com/Tendrl/documentation/pull/69
11:07:06 <nishanth> #action nishanth to complete the pending reviews and start work on   https://github.com/Tendrl/specifications/issues/55
11:07:48 <nishanth> #action brainfunked to finish reviews and start work on  https://github.com/Tendrl/specifications/issues/87
11:08:41 <nishanth> #action shu6h3ndu to start work on https://github.com/Tendrl/specifications/issues/80
11:09:00 <nishanth> anything else?
11:09:17 <nishanth> Thanks for the updates
11:09:22 <nishanth> #endmeeting