09:09:24 <Shu6h3ndu> #startmeeting check-in_20170104
09:09:24 <zodbot> Meeting started Wed Jan  4 09:09:24 2017 UTC.  The chair is Shu6h3ndu. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:09:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
09:09:24 <zodbot> The meeting name has been set to 'check-in_20170104'
09:09:39 <Shu6h3ndu> #topic anmol's updates
09:09:46 <anmol> Please find the details @ https://paste.fedoraproject.org/519606/20168148/
09:09:46 <anmol> Summary:
09:09:47 <anmol> Upddates:
09:09:47 <anmol> [1] Worked on requirements from @anivargi and comments from @shtripat on https://github.com/Tendrl/performance_monitoring/pull/2 and updated the PR accordingly.
09:09:47 <anmol> [2] Worked on review comments from @shtripat, requirements from @anivargi (based on [1] above) on https://github.com/Tendrl/alerting/pull/15 and also fixed 1 observed issue and updated PR accordingly.
09:09:51 <anmol> [3] Working on comments from @shtripat on https://github.com/Tendrl/common/pull/87.
09:09:53 <anmol> Agenda for today:
09:09:55 <anmol> [a] Complete [3] above.
09:09:57 <anmol> [b] Post fixes for travis failure on above mentioned PRs.
09:10:33 <Shu6h3ndu> #accept anmol worked on requirements from @anivargi and comments from @shtripat on https://github.com/Tendrl/performance_monitoring/pull/2 and updated the PR accordingly
09:11:05 <Shu6h3ndu> @accept anmol worked on review comments from @shtripat, requirements from @anivargi on https://github.com/Tendrl/alerting/pull/15 and also fixed 1 observed issue and updated PR
09:11:19 <Shu6h3ndu> #action anmol working on comments from @shtripat on https://github.com/Tendrl/common/pull/8
09:11:33 <Shu6h3ndu> #accept anmol worked on review comments from @shtripat, requirements from @anivargi on https://github.com/Tendrl/alerting/pull/15 and also fixed 1 observed issue and updated PR
09:12:07 <anmol> Awaiting further reviews on :
09:12:08 <anmol> * https://github.com/Tendrl/alerting/pull/15
09:12:08 <anmol> * https://github.com/Tendrl/node_agent/pull/67
09:12:08 <anmol> * https://github.com/Tendrl/performance_monitoring/pull/2
09:12:08 <anmol> * https://github.com/Tendrl/specifications/pull/81
09:12:08 <anmol> * https://github.com/Tendrl/specifications/pull/63
09:12:20 <Shu6h3ndu> #action anmol to take care of travis failure on different PRs
09:13:18 <Shu6h3ndu> #action nishanth brainfunked to review https://github.com/Tendrl/alerting/pull/15  https://github.com/Tendrl/node_agent/pull/67
09:14:40 <Shu6h3ndu> #action nishanth brainfunked to review and close  https://github.com/Tendrl/performance_monitoring/pull/2 https://github.com/Tendrl/specifications/pull/81  https://github.com/Tendrl/specifications/pull/63
09:14:46 <Shu6h3ndu> anmol, looks fine?
09:14:59 <anmol> Shu6h3ndu, yes
09:15:12 <Shu6h3ndu> #topic dahorak's updates
09:16:13 <dahorak> Summary: Updating QE installation playbooks, jenkins jobs and other parts of the automated installation to be able to use master branch from usmqe-setup for CI and automated installation.
09:16:13 <dahorak> Link: https://github.com/Tendrl/usmqe-setup/pull/16 tendrl_gluster_peer_bricks playbook
09:16:13 <dahorak> Otherwise working on QE infrastructure and Tendrl unrelated tasks.
09:16:42 <Shu6h3ndu> #accept dahorak updating QE installation playbooks, jenkins jobs and other parts of the automated installation to be able to use master branch from usmqe-setup for CI and automated installation
09:17:06 <Shu6h3ndu> #accept dahorak working on QE infrastructure and Tendrl unrelated tasks
09:17:19 <Shu6h3ndu> #topic fbalak's updates
09:17:43 <fbalak> Issue: https://github.com/Tendrl/usmqe-tests/pull/6#pullrequestreview-14957901 - Correct review
09:17:44 <fbalak> Status: blocked by issues related to missing api call for retrieving job status - https://github.com/Tendrl/tendrl-api/issues/24 and https://github.com/Tendrl/tendrl-api/issues/33
09:18:45 <Shu6h3ndu> #accept fbalak working on review comments on  https://github.com/Tendrl/usmqe-tests/pull/6
09:19:19 <Shu6h3ndu> #accept fbalak blocked by issues related to missing api call for retrieving job status ( https://github.com/Tendrl/tendrl-api/issues/24 and https://github.com/Tendrl/tendrl-api/issues/33)
09:19:31 <Shu6h3ndu> #topic gowtham's updates
09:19:41 <gowtham> working on :
09:19:42 <gowtham> https://github.com/Tendrl/specifications/pull/94
09:19:42 <gowtham> needs some informations from anmol, me and anmol discussing about this
09:19:42 <gowtham> specification reviews pending for :
09:19:42 <gowtham> https://github.com/Tendrl/specifications/pull/21 - can be merge
09:19:42 <gowtham> https://github.com/Tendrl/specifications/pull/19 - can be merge
09:19:44 <gowtham> https://github.com/Tendrl/specifications/pull/110
09:19:46 <gowtham> implementation review pending for :
09:19:48 <gowtham> https://github.com/Tendrl/node_agent/pull/64
09:19:50 <gowtham> https://github.com/Tendrl/node_agent/pull/79
09:20:00 <gowtham> status: good
09:20:20 <Shu6h3ndu> #accept gowtham working on   https://github.com/Tendrl/specifications/pull/94 (Specification file for logging implementation )
09:21:09 <gowtham> not blocked
09:21:11 <Shu6h3ndu> #action nishanth brainfunked to review and close https://github.com/Tendrl/specifications/pull/110 (LGTM  from ndarshan and Shu6h3ndu)
09:22:14 <Shu6h3ndu> #action nishanth to review https://github.com/Tendrl/node_agent/pull/64 and https://github.com/Tendrl/node_agent/pull/79 (LGTM from Shu6h3ndu)
09:22:40 <Shu6h3ndu> #accept https://github.com/Tendrl/specifications/pull/21 and  https://github.com/Tendrl/specifications/pull/19 ready to merge
09:22:53 <Shu6h3ndu> #topic mbukatov's updates
09:23:56 <mbukatov> hello
09:24:14 <mbukatov> #info tendrl installed from latest sources (master branch used) doesn't work, blocked by:
09:24:23 <mbukatov> #link https://github.com/Tendrl/tendrl-api/issues/3
09:24:29 <mbukatov> #link https://github.com/Tendrl/tendrl_frontend/issues/7
09:25:07 <Shu6h3ndu> #info tendrl installed from latest sources (master branch used) doesn't work
09:25:07 <mbukatov> #info I did review of python upstream packaging https://tendrl.atlassian.net/browse/AR-8
09:25:27 <Shu6h3ndu> #accept mbukatov blokced by https://github.com/Tendrl/tendrl-api/issues/3 and https://github.com/Tendrl/tendrl_frontend/issues/7
09:26:00 <mbukatov> #link https://github.com/Tendrl/common/issues/88
09:26:07 <mbukatov> #link https://github.com/Tendrl/gluster_integration/issues/98
09:26:14 <mbukatov> #link https://github.com/Tendrl/ceph_integration/issues/70
09:26:20 <mbukatov> #link https://github.com/Tendrl/node_agent/issues/118
09:26:29 <mbukatov> #link https://github.com/Tendrl/performance_monitoring/issues/18
09:26:35 <mbukatov> #link https://github.com/Tendrl/alerting/issues/18
09:26:42 <mbukatov> #link https://github.com/Tendrl/alerting/issues/17
09:26:50 <mbukatov> #link https://github.com/Tendrl/performance_monitoring/issues/17
09:27:22 <Shu6h3ndu> #accept mbukatov created issues https://github.com/Tendrl/common/issues/88 https://github.com/Tendrl/gluster_integration/issues/98  https://github.com/Tendrl/ceph_integration/issues/70  https://github.com/Tendrl/node_agent/issues/118 https://github.com/Tendrl/performance_monitoring/issues/18 https://github.com/Tendrl/alerting/issues/18  https://github.com/Tendrl/alerting/issues/17  https://github.com/Tendrl/performance_monitoring/
09:27:22 <Shu6h3ndu> issues/17
09:27:30 <mbukatov> I created issue for each component, because I don't know how to create a signle issue related to multiple repositories so that people watching it would notice it
09:27:52 <Shu6h3ndu> #action nishanth brainfunked to go through the list of issues and assign accordingly
09:27:52 <mbukatov> but basically it's 2 type of issues, all related to handling of requirements
09:28:10 <mbukatov> I guess that some discussion is needed
09:28:27 <Shu6h3ndu> mbukatov, can you schedule one for the same?
09:28:49 <mbukatov> Shu6h3ndu: ok, will do
09:28:54 <Shu6h3ndu> #undo nishanth brainfunked to go through the list of issues and assign accordingly
09:28:54 <zodbot> Removing item from minutes: ACTION by Shu6h3ndu at 09:27:52 : nishanth brainfunked to go through the list of issues and assign accordingly
09:29:18 <kaverma> Shu6h3ndu, sorry to interrupt you but i missed my updates due to net issue .. can i give my update right away ..
09:29:19 <Shu6h3ndu> #action mbukatov would schedule a discussion over issues created related to requirements
09:29:39 <Shu6h3ndu> kaverma, wait. i will ask for
09:29:42 <kaverma> ok
09:29:55 <Shu6h3ndu> mbukatov, are we good?
09:30:04 <mbukatov> yes
09:30:08 <mbukatov> that's all
09:30:10 <Shu6h3ndu> #topic kaverma;s updates
09:30:20 <kaverma> title- import cluster workflow
09:30:27 <kaverma> Spec-PR - https://github.com/Tendrl/specifications/pull/105 (under review .got reviewed by anup only.. i need review by nishanth, shubhendu and mrugesh as well )
09:30:28 <kaverma> Spec-issue - https://github.com/Tendrl/specifications/issues/56
09:30:28 <kaverma> github-issue - https://github.com/Tendrl/tendrl_frontend/issues/63
09:30:28 <kaverma> Progress - I have fully done the UI part for import cluster workflow with mocked data. and tested properly .
09:30:28 <kaverma> and got response from anup regarding response format of import cluster . currently he is working on it.
09:30:31 <kaverma> i will update frontend code accordingly.
09:30:33 <kaverma> Status: Good.
09:30:47 <Shu6h3ndu> #accept kaverma working on  https://github.com/Tendrl/specifications/pull/105
09:31:03 <Shu6h3ndu> #action nishanth Shu6h3ndu brainfunked to review  https://github.com/Tendrl/specifications/pull/105
09:31:40 <Shu6h3ndu> #accept kaverma donw with UI changes for  https://github.com/Tendrl/specifications/pull/105 with mock data
09:32:17 <Shu6h3ndu> #action noopq would provide response format of import cluster to kaverma
09:32:37 <Shu6h3ndu> #topic mkudlej's updates
09:34:45 <Shu6h3ndu> mkudlej, any updates?
09:35:31 <Shu6h3ndu> moving ahead, will come back to mkudlej later
09:35:38 <Shu6h3ndu> #topic ndarshan's updates
09:35:56 <ndarshan> -----Github specification issue title and link-----
09:35:56 <ndarshan> tag based job routing (https://github.com/Tendrl/specifications/issues/44) -->start implementation for this spec
09:35:56 <ndarshan> Issues:
09:35:56 <ndarshan> Fixed travis failure for: https://github.com/Tendrl/ceph_integration/pull/69 and https://github.com/Tendrl/gluster_integration/pull/97
09:35:59 <ndarshan> Spent time reviewing:
09:36:01 <ndarshan> https://github.com/Tendrl/specifications/pull/110
09:36:03 <ndarshan> https://github.com/Tendrl/specifications/pull/104
09:36:05 <ndarshan> https://github.com/Tendrl/specifications/pull/94
09:36:31 <Shu6h3ndu> #accept ndarshan would start on implementation for https://github.com/Tendrl/specifications/issues/44
09:37:01 <Shu6h3ndu> #accept ndarshan fixed travis failures for https://github.com/Tendrl/ceph_integration/pull/69 and https://github.com/Tendrl/gluster_integration/pull/97
09:37:19 <Shu6h3ndu> #accept reviewed specs PRs
09:37:37 <Shu6h3ndu> #action ndarshan to work on code changes PR for https://github.com/Tendrl/specifications/issues/44
09:37:42 <Shu6h3ndu> ndarshan, anything else?
09:37:55 <ndarshan> thats all
09:38:11 <Shu6h3ndu> #topic neha__'s updates
09:38:32 <neha__> working on issue - https://github.com/Tendrl/tendrl_frontend/issues/80
09:38:57 <Shu6h3ndu> #accept neha__ working on https://github.com/Tendrl/tendrl_frontend/issues/80  (Cluster list unit testing)
09:39:11 <neha__> This PR needs to reviewed by nishanth and Mrugesh
09:39:18 <neha__> https://github.com/Tendrl/specifications/pull/105
09:39:29 <Shu6h3ndu> #action nishanth brainfunked to review https://github.com/Tendrl/specifications/pull/105
09:39:47 <Shu6h3ndu> #topic nishanth's updates
09:39:51 <neha__> noopq, are the list APIs desployed somewhere so that we can test the views with real data?
09:39:56 <mkudlej> Shu6h3ndu: sorry, for late response. I've done review of https://github.com/Tendrl/usmqe-tests/pull/6 and I will work on https://github.com/Tendrl/usmqe-tests/issues/9
09:40:00 <noopq> neha__, no
09:40:09 <noopq> but I would recommend you install it locally
09:40:26 <Shu6h3ndu> mkudlej, would add the details of once nishanth's done
09:41:01 <nishanth> Shu6h3ndu, I have completed the reviews of the re-factoring patches
09:41:21 <Shu6h3ndu> #accept nishanth completed reviews of refactoring patches
09:41:25 <nishanth> Shu6h3ndu, working on other reviews mentioned in the AIs
09:41:40 <Shu6h3ndu> #action nishanth working on other pending reviews now
09:41:57 <nishanth> Shu6h3ndu, Also I am working on  downstream specific install doc for ccs
09:42:16 <Shu6h3ndu> #action nishanth worling on downstream specific install doc for ccs
09:42:30 <noopq> nishanth, I need a instance of etcd with latest changes if that's possible
09:42:32 <nishanth> Shu6h3ndu, that's all from my side
09:42:40 <Shu6h3ndu> #topic mkudlej's updates
09:42:43 <noopq> with RBS's and also monitoring
09:43:07 <Shu6h3ndu> #accept mkudlej reviewed https://github.com/Tendrl/usmqe-tests/pull/6
09:43:19 <Shu6h3ndu> #action mkudlej would work on  https://github.com/Tendrl/usmqe-tests/issues/9
09:43:31 <Shu6h3ndu> #topic noopq's updates
09:43:54 <Shu6h3ndu> anmol, do you have an instance which neha can use for testing?
09:43:57 <noopq> Shu6h3ndu, I will finish https://github.com/Tendrl/specifications/pull/95 today and start with import cluster specs and issues
09:44:12 <noopq> Also reviewed a few specs
09:44:35 <Shu6h3ndu> #action noopq would try to finish  https://github.com/Tendrl/specifications/pull/95 and would continue with  import cluster specs and issues
09:44:44 <Shu6h3ndu> #accept noopq reviewed spec PRs
09:44:46 <noopq> Shu6h3ndu, I am stuck since there is not instance of etcd which has the latest definitions changes
09:44:57 <noopq> and also all the objects in a cluster
09:45:01 <anmol> Shu6h3ndu, I have it installed in 10.70.43.26 but I would prefer installing monitoring pieces in another machine and then I'll provide that instance
09:45:26 <noopq> anmol the monitoring data needs to assicate with real node and cluster data in the same instance
09:45:35 <noopq> so we can test fully
09:45:38 <Shu6h3ndu> anmol, can you work with noopq on this and if required we can get some volume's etc created for testing in the same instance?
09:45:53 <anmol> Shu6h3ndu, noopq, ok
09:46:12 <Shu6h3ndu> anmol, thanks. if you need some help from me as well please ping me
09:46:29 <Shu6h3ndu> #topic Shu6h3ndu's updates
09:46:29 <anmol> Shu6h3ndu, ok
09:46:30 <noopq> Shu6h3ndu, if I am blocked, it also blocks the UI folks
09:46:51 <noopq> Also the tagging thing is needed for import cluster workflow
09:47:02 <noopq> that needs to br part of definitions files
09:47:08 <Shu6h3ndu> #accept https://github.com/Tendrl/common/pull/71, https://github.com/Tendrl/node_agent/pull/84 https://github.com/Tendrl/gluster_integration/pull/94 approved by nishanth
09:47:37 <Shu6h3ndu> #action https://github.com/Tendrl/gluster_integration/pull/79 https://github.com/Tendrl/ceph_integration/pull/63 needs approval from nishanth
09:47:59 <Shu6h3ndu> #accept Shu6h3ndu reviewed most of the spec PRs
09:48:11 <Shu6h3ndu> #action https://github.com/Tendrl/specifications/pull/104 LGTM from Anmo and Darshan. Nishanth to review
09:48:25 <Shu6h3ndu> #action https://github.com/Tendrl/specifications/pull/98 LGTM from Anmol. Mrugesh to review and close
09:48:39 <Shu6h3ndu> #action https://github.com/Tendrl/specifications/pull/93 Anup and Nishanth to review the spec PR
09:49:00 <Shu6h3ndu> #accept Shu6h3ndu would push changes for  https://github.com/Tendrl/specifications/pull/104 ones refactoring one merged
09:49:21 <Shu6h3ndu> thats all from my side. thanks everyone for joining the check in meeting
09:49:25 <Shu6h3ndu> #endmeeting