09:02:39 <nishanth> #startmeeting check-in_20170105
09:02:40 <zodbot> Meeting started Thu Jan  5 09:02:39 2017 UTC.  The chair is nishanth. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:02:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
09:02:40 <zodbot> The meeting name has been set to 'check-in_20170105'
09:03:58 <nishanth> #topic dahorak's  updates
09:05:46 <dahorak> Small update of CentOS CI (related to yesterday's update) - installation done by usmqe-setup from master branch.
09:05:47 <dahorak> Otherwise focusing on various topics related to HW and testing infrastructure.
09:06:46 <nishanth> dahorak, you mean the dev builds from the top of master?
09:08:20 <dahorak> nishanth: no, I mean to use the installation playbooks from master branch from https://github.com/Tendrl/usmqe-setup/ (till now we were using temporary branch with various fixes)
09:09:30 <dahorak> nishanth: we are using the builds from https://copr-be.cloud.fedoraproject.org/results/tendrl/tendrl/epel-7-x86_64/
09:10:23 <nishanth> dahorak, okay
09:12:04 <nishanth> #info dahorak working on various tasks related to HW and testing infrastructure
09:12:21 <nishanth> #topic fbalak's updates
09:12:34 <fbalak> Issue: https://github.com/Tendrl/usmqe-tests/pull/6 - work on pull request
09:12:35 <fbalak> Status: good
09:15:37 <nishanth> fbalak, this task is related to automated test development right?
09:16:07 <fbalak> nishanth: yes
09:18:05 <nishanth> #info fbalak working on  https://github.com/Tendrl/usmqe-tests/pull/6 - related to automated test development
09:18:28 <nishanth> #topic gowtham's updates
09:18:40 <gowtham> working on: logging implementation
09:18:40 <gowtham> https://github.com/Tendrl/specifications/pull/94 - review required
09:18:40 <gowtham> Need some information from anmol
09:18:50 <gowtham> need some review for this spec
09:19:12 <gowtham> Review required:
09:19:20 <gowtham> 1. spec file: https://github.com/Tendrl/specifications/pull/21 - can be merge
09:19:20 <gowtham> code-PR: https://github.com/Tendrl/node_agent/pull/64
09:19:30 <gowtham> 2. spc file: https://github.com/Tendrl/specifications/pull/19 -  can be merge
09:19:30 <gowtham> code-PR: https://github.com/Tendrl/node_agent/pull/79
09:19:41 <gowtham> status : good
09:19:46 <gowtham> not blocked
09:22:08 <nishanth> gowtham, who should review   https://github.com/Tendrl/specifications/pull/94 ?
09:22:32 <gowtham> nishanth, mrugesh
09:22:51 <gowtham> nishanth, is this come with different spec or i will do that as part of my logging spec : https://github.com/Tendrl/specifications/issues/55
09:23:08 <gowtham> nishanth, because it depends on my spec i think
09:23:56 <nishanth> gowtham, This should be different spec, as it requires changes in the job handling as well
09:24:07 <gowtham> nishanth, ok
09:24:17 <nishanth> gowtham, you can provide reference
09:24:25 <gowtham> nishanth, ok
09:24:48 <nishanth> gowtham, all others completed the review on   https://github.com/Tendrl/specifications/pull/94 ?
09:25:18 <nishanth> #action nishanth, brainfunked, k4n0 to review   https://github.com/Tendrl/specifications/pull/94
09:25:46 <gowtham> gowtham, Shu6h3ndu and anmol is done
09:25:53 <gowtham> nishanth,  Shu6h3ndu and anmol is done
09:26:27 <nishanth> gowtham,  https://github.com/Tendrl/specifications/pull/21 and  https://github.com/Tendrl/specifications/pull/19, are approved ?
09:26:55 <gowtham> nishanth, https://github.com/Tendrl/specifications/pull/21 is aproved
09:27:11 <gowtham> nishanth, https://github.com/Tendrl/specifications/pull/19 is looks good from all
09:27:29 <gowtham> nishanth, but not approved
09:28:35 <nishanth> gowtham, what about code PRs?
09:28:58 <gowtham> nishanth, code pr also looks good from Shu6h3ndu and ndarshan
09:29:15 <gowtham> nishanth, needs mrugesh and your review
09:30:36 <nishanth> #action k4n0 to approve and merge  https://github.com/Tendrl/specifications/pull/21 and  https://github.com/Tendrl/specifications/pull/19
09:31:16 <nishanth> #action nishanth, brainfunked and k4n0 to review  https://github.com/Tendrl/node_agent/pull/64,  https://github.com/Tendrl/node_agent/pull/79
09:31:26 <nishanth> gowtham thanks for updates
09:31:55 <gowtham> ok
09:31:59 <nishanth> #topic k4n0's updsates
09:32:04 <nishanth> #undo
09:32:04 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x48a035d0>
09:32:18 <k4n0> Ill have updates tomorrow
09:32:20 <nishanth> #topic k4n0's updates
09:33:03 <nishanth> #info k4n0 just back from vocation, catching up with current state
09:33:09 <k4n0> merging PRs (refactoring), then will look at pending specs (mine and other's) , then will review any other PRs (as per spec priority)
09:33:30 <nishanth> #topic ltrilety's updates
09:35:14 <nishanth> Looks like ltrilety is away, will check later
09:35:21 <nishanth> #undo
09:35:21 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x48a03d90>
09:35:43 <nishanth> #topic mbukatov's updates
09:36:05 <mbukatov> #info scheduled packaging meeting (today 17:00 IST), see Tendrl calendar
09:36:12 <mbukatov> #info filed issues related to versioning:
09:36:18 <mbukatov> #link https://github.com/Tendrl/node_agent/issues/119
09:36:24 <mbukatov> #info and config file maintenance:
09:36:30 <mbukatov> #link https://github.com/Tendrl/common/issues/89
09:36:36 <mbukatov> #info updated status of AR-8 task
09:36:41 <mbukatov> #link https://tendrl.atlassian.net/browse/AR-8
09:36:46 <mbukatov> #info added yamllint check for usmqe-setup
09:36:54 <mbukatov> #link https://github.com/Tendrl/usmqe-setup/pull/18
09:37:29 <mbukatov> #action create issues/fix for remaining rpm packaging issues (minor ones)
09:37:50 <mbukatov> #action work on webstr
09:37:55 <mbukatov> that's all
09:39:26 <ltrilety> nishanth: sorry, I missed that request
09:40:12 <nishanth> mbukatov, thanks for the updates
09:40:34 <nishanth> ltrilety, can we do it now?
09:40:44 <ltrilety> nishanth: yep
09:40:53 <nishanth> #topic ltrilety's updates
09:41:45 <ltrilety> #info I am back from PTO, so not much update from me, I will work on:
09:41:52 <ltrilety> #link https://github.com/Tendrl/usmqe-tests/issues/10
09:42:24 <ltrilety> #action try to use actual webstr in our code
09:42:36 <ltrilety> that's all from me
09:44:38 <k4n0> Shu6h3ndu, please fix https://github.com/Tendrl/gluster_integration/pull/94#pullrequestreview-15272276
09:45:03 <k4n0> Shu6h3ndu, ill merge it as soon as fixed, rest LGTM, good work on the refactor btw!
09:45:20 <Shu6h3ndu> k4n0, sure. on top it
09:45:30 <nishanth> ltrilety, thanks for the updates
09:45:46 <nishanth> #topic mkudlej's updates
09:46:04 <mkudlej> nishanth: I'm still working on https://github.com/Tendrl/usmqe-tests/issues/9
09:46:17 <mkudlej> nishanth: that's all from me
09:46:41 <nishanth> #info mkudlej is working on  https://github.com/Tendrl/usmqe-tests/issues/9
09:47:23 <nishanth> #topic ndarshan's updates
09:47:50 <ndarshan> Spec:
09:47:51 <ndarshan> Specification for adding tendrl-common utils (https://github.com/Tendrl/specifications/issues/72)
09:47:51 <ndarshan> Issue:
09:47:51 <ndarshan> https://github.com/Tendrl/common/issues/80
09:47:51 <ndarshan> Summary:
09:47:51 <ndarshan> PR https://github.com/Tendrl/common/pull/79 got merged for this
09:47:53 <ndarshan> -----------------------------------------
09:47:55 <ndarshan> Spec:
09:47:57 <ndarshan> Node agent tagging (https://github.com/Tendrl/specifications/issues/44)
09:47:59 <ndarshan> Issue:
09:48:01 <ndarshan> https://github.com/Tendrl/node_agent/issues/121
09:48:03 <ndarshan> Summary:
09:48:05 <ndarshan> pushed a WIP PR: https://github.com/Tendrl/node_agent/pull/120 for node agent, will continue working on this.
09:50:45 <ndarshan> -----------------------------------------------------
09:50:46 <ndarshan> Now that the re-factoring patches are getting in, I will continue on few my PRs that were blocked on this
09:51:29 <nishanth> ndarshan, what is pending on (https://github.com/Tendrl/specifications/issues/72 ?
09:52:59 <ndarshan> nishanth, that issue as such is kind of complete....Now I have to make sure that node agent uses these common utils....For this node_agent refactoring PR should get merged
09:54:09 <nishanth> #accept specification and PR for adding common utils got merged
09:54:34 <nishanth> #info ndarshan working on  https://github.com/Tendrl/node_agent/pull/120
09:54:50 <nishanth> ndarshan, thanks for the updates
09:55:08 <nishanth> #topic neha__'s updates
09:55:43 <neha__> Completed issue: https://github.com/Tendrl/tendrl_frontend/issues/80, Sent PR for it - https://github.com/Tendrl/tendrl_frontend/pull/81
09:55:56 <neha__> Started working on issue: https://github.com/Tendrl/tendrl_frontend/issues/82
09:56:43 <neha__> Need yours and Mrugesh's review on https://github.com/Tendrl/specifications/pull/105
09:56:48 <neha__> thats all
09:59:07 <nishanth> neha__, working on the UT right?
09:59:34 <nishanth> neha__, does the PR for feature impl got merged?
10:00:55 <neha__> Kamlesh has completed the Import cluster with mock json and its not yet merged as we are waiting for the spec of Import cluster to get approved
10:01:43 <nishanth> ok
10:02:30 <nishanth> #info neha__ is working on UT cases  https://github.com/Tendrl/tendrl_frontend/issues/80 and  https://github.com/Tendrl/tendrl_frontend/issues/82
10:03:02 <nishanth> #action nishanth and brainfunked to review  https://github.com/Tendrl/specifications/pull/105
10:03:13 <nishanth> neha__ thanks for updates
10:03:34 <nishanth> #topic noopq's updates
10:04:07 <noopq> nishanth, I am still working on https://github.com/Tendrl/tendrl-api/pull/52 after changes made by anmol for the configuration
10:04:42 <noopq> I was working on a instance which was created by Anmol but it does not seem to work anymore.
10:05:18 <noopq> nishanth, I will work on Import cluster API if I am done today on the above issue.
10:05:22 <noopq> that's all
10:05:38 <nishanth> noopq, looks like there is some issue with infra
10:06:01 <noopq> nishanth, oh ok, I can try later.
10:06:23 <nishanth> noopq, any github issue for import cluster API related work?
10:06:28 <Shu6h3ndu> noopq, anmol has created a new setup but need to do some more work regarding monitoring and alerting
10:06:39 <Shu6h3ndu> noopq, he would do in the evening and hand over the instance to you
10:06:51 <noopq> Shu6h3ndu, yeah we had discussed some changes yesterday about the json containing escape characters
10:06:55 <nishanth> #info noopq is working on  https://github.com/Tendrl/tendrl-api/pull/52
10:07:44 <noopq> nishanth, I don't think there is a spec for it as yet, I am still to completely understand the tagging things to write that
10:08:02 <nishanth> noopq,  ok, thanks for updates
10:08:36 <nishanth> #topic Shu6h3ndu's updates
10:08:44 <Shu6h3ndu> sure
10:08:53 <Shu6h3ndu> https://github.com/Tendrl/common/pull/71 merged
10:09:05 <Shu6h3ndu> Rohan is reviewing other refactoring PRs
10:09:11 <Shu6h3ndu> Working on https://github.com/Tendrl/gluster_integration/issues/99
10:09:12 <Shu6h3ndu> Created https://github.com/Tendrl/ceph_integration/issues/71
10:09:19 <Shu6h3ndu> https://github.com/Tendrl/gluster_integration/pull/79 Nishanth, Roahn to review and close
10:09:19 <Shu6h3ndu> https://github.com/Tendrl/specifications/pull/104 Nishanth, Rohan to review
10:09:19 <Shu6h3ndu> https://github.com/Tendrl/specifications/pull/98 Mrugesh to review and close
10:09:20 <Shu6h3ndu> https://github.com/Tendrl/specifications/pull/93 Anup, Roahn and Nishanth to review the spec PR
10:09:24 <Shu6h3ndu> Old PRs for review https://github.com/Tendrl/gluster_integration/pull/62 and https://github.com/Tendrl/gluster_integration/pull/63
10:09:30 <Shu6h3ndu> will push changes for  https://github.com/Tendrl/specifications/pull/104 ones refactoring one merged
10:10:20 <nishanth> #accept https://github.com/Tendrl/common/pull/71 got merged
10:11:27 <nishanth> #action nishanth and k4n0 to review https://github.com/Tendrl/gluster_integration/pull/79, https://github.com/Tendrl/specifications/pull/104 and https://github.com/Tendrl/specifications/pull/93
10:11:59 <nishanth> #info working on  https://github.com/Tendrl/gluster_integration/issues/99
10:13:35 <nishanth> Shu6h3ndu, thanks for the updates
10:14:02 <nishanth> #endmeeting