09:02:14 <nishanth> #startmeeting check-in_20170109
09:02:14 <zodbot> Meeting started Mon Jan  9 09:02:14 2017 UTC.  The chair is nishanth. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:02:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
09:02:14 <zodbot> The meeting name has been set to 'check-in_20170109'
09:02:36 <nishanth> #topic anmol's updates
09:02:39 <anmol> Updates from @anmolbabu
09:02:39 <anmol> [1] Split the patch https://github.com/Tendrl/performance-monitoring/pull/2 into:
09:02:40 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/2 -- Modify performance monitoring docs and add samples
09:02:40 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#7, Tendrl/performance-monitoring#8
09:02:40 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/19 -- Add support for host listing page in UI
09:02:42 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#15
09:02:46 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/20 -- Add rest apis
09:02:48 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#7
09:02:50 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/21 -- Add a way to intiate collectd configuration generation
09:02:53 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#8
09:02:55 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/22 -- Add default values monitoring configurations
09:02:58 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#8
09:03:00 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/23 -- Add time series db interface as a pluggable inteface
09:03:03 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#7
09:03:05 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/24 -- Add performance monitoring manager and flows associated
09:03:08 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#7, Tendrl/performance-monitoring#8
09:03:10 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/27 -- Add collectd plugins
09:03:12 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#26
09:03:16 <anmol> Spec Implemented by PR: https://github.com/Tendrl/specifications/pull/81, https://github.com/Tendrl/specifications/pull/63
09:03:19 <anmol> [2] Split the patch https://github.com/Tendrl/alerting/pull/15 into:
09:03:21 <anmol> * https://github.com/Tendrl/alerting/pull/15 -- Alerting doc changes and sample files
09:03:23 <anmol> tendrl-bug-id: Tendrl/alerting#10,Tendrl/alerting#11,Tendrl/alerting#12,Tendrl/alerting#14
09:03:25 <anmol> * https://github.com/Tendrl/alerting/pull/19 -- Add rest apis
09:03:27 <anmol> tendrl-bug-id: Tendrl/alerting#14
09:03:29 <anmol> * https://github.com/Tendrl/alerting/pull/20 -- Add helper to fetch details from etcd
09:03:31 <anmol> tendrl-bug-id: Tendrl/alerting#10,Tendrl/alerting#11,Te
09:03:33 <anmol> aah !!
09:03:35 <anmol> [2] Split the patch https://github.com/Tendrl/alerting/pull/15 into:
09:03:37 <anmol> * https://github.com/Tendrl/alerting/pull/15 -- Alerting doc changes and sample files
09:03:39 <anmol> tendrl-bug-id: Tendrl/alerting#10,Tendrl/alerting#11,Tendrl/alerting#12,Tendrl/alerting#14
09:03:41 <anmol> * https://github.com/Tendrl/alerting/pull/19 -- Add rest apis
09:03:43 <anmol> tendrl-bug-id: Tendrl/alerting#14
09:03:47 <anmol> * https://github.com/Tendrl/alerting/pull/20 -- Add helper to fetch details from etcd
09:03:49 <anmol> tendrl-bug-id: Tendrl/alerting#10,Tendrl/alerting#11,Tendrl/alerting#12,Tendrl/alerting#14
09:03:51 <anmol> * https://github.com/Tendrl/alerting/pull/21 -- Add mail handler
09:03:53 <anmol> tendrl-bug-id: Tendrl/alerting#12
09:03:55 <anmol> * https://github.com/Tendrl/alerting/pull/22 -- Add alerting manager, definations and generic exceptions
09:03:58 <anmol> tendrl-bug-id: Tendrl/alerting#10,Tendrl/alerting#11,Tendrl/alerting#12,Tendrl/alerting#14
09:04:00 <anmol> * https://github.com/Tendrl/alerting/pull/23 -- Watch alerts directory and trigger notification on change
09:04:04 <anmol> tendrl-bug-id: Tendrl/alerting#10
09:04:05 <anmol> Spec implemented by PR: https://github.com/Tendrl/specifications/blob/master/specs/pluggable_alert_delivery.adoc
09:04:08 <anmol> [3] Rebasing https://github.com/Tendrl/node_agent/pull/67 to allow gluster-integration in its latest form to function.
09:04:11 <anmol> This is because my PR on node-agent relies on older common while gluster-integration relies on latest common and hence is blocking the cluster setup requested by UI team.
09:04:16 <anmol> I hope the UI team is not blocked by this as they wanted this setup only for real data.
09:04:18 <anmol> Spec implemented by PR: https://github.com/Tendrl/specifications/blob/master/specs/pluggable_alert_delivery.adoc
09:04:21 <anmol> tendrl-bug-id: Tendrl/node-agent#70
09:04:23 <anmol> [4] Incorporated comments from @shtripat on https://github.com/Tendrl/common/pull/87.
09:04:25 <anmol> tendrl-bug-id: tendrl-bug-id: Tendrl/alerting#10,Tendrl/alerting#11,Tendrl/alerting#12,Tendrl/alerting#14
09:04:28 <anmol> Will update PR once issue mentioned above is resolved as this PR is required by most of the above mentioned PRs
09:04:31 <anmol> Spec implemented by PR: https://github.com/Tendrl/specifications/blob/master/specs/pluggable_
09:04:33 <anmol> [4] Incorporated comments from @shtripat on https://github.com/Tendrl/common/pull/87.
09:04:35 <anmol> tendrl-bug-id: tendrl-bug-id: Tendrl/alerting#10,Tendrl/alerting#11,Tendrl/alerting#12,Tendrl/alerting#14
09:04:38 <anmol> Will update PR once issue mentioned above is resolved as this PR is required by most of the above mentioned PRs
09:04:41 <anmol> Spec implemented by PR: https://github.com/Tendrl/specifications/blob/master/specs/pluggable_alert_delivery.adoc
09:04:46 <anmol> [5] Rebased patches in [1] and [2] in accordance with refactoring patches merged recently(probably on thursday last week).
09:04:49 <anmol> [6] Facing issues in [3], [4] and [5] so fixing them as and when observed.
09:04:51 <anmol> I would like to request @Tendrl/tendrl-core to review the above mentioned PRs in addition to:
09:04:53 <anmol> * https://github.com/Tendrl/specifications/pull/81 -- Add spec for monitoring section of host listing backend apis
09:04:56 <anmol> * https://github.com/Tendrl/specifications/pull/63 -- Specification for exposing apis to access time-series data
09:05:24 <nishanth> ah! its a huge update
09:05:33 <nishanth> so you are blocked on reviews?
09:05:38 <anmol> yes
09:05:59 <nishanth> does it undergone any reviews from anyone?
09:06:17 <anmol> 1 or 2 rounds by Shubhendu and 1 round by you
09:07:20 <anmol> After the split the conversations are maintained but the commit history only is lost in main PRs
09:07:26 <anmol> *split of PRs
09:07:53 <anmol> The patch reviews are maintained on original mother PRs
09:09:20 <nishanth> anmol, does it have all the UT implemented and it passes all the checks on git(travis etc)?
09:09:50 <anmol> nishanth, I have seen it fail only for dependent PRs not merged
09:10:00 <anmol> nishanth, I have verified UTs locally
09:10:09 <nishanth> anmol ok
09:10:27 <anmol> nishanth, some UTs as I am rebasing yet might fail they need some fix which I'll work on once rebasing is complete
09:10:41 <anmol> *complete == dev test completed also
09:10:48 <nishanth> #info anmol is blocked on reviews
09:12:40 <nishanth> #action k4n0, brainfunked, nishanth to review the patches -->(  https://github.com/Tendrl/performance-monitoring/pull/2,  https://github.com/Tendrl/performance-monitoring/pull/19,  https://github.com/Tendrl/performance-monitoring/pull/20,  https://github.com/Tendrl/performance-monitoring/pull/21,  https://github.com/Tendrl/performance-monitoring/pull/22,  https://github.com/Tendrl/performance-monitoring/pull/23,  https://github.com/Tendrl/performa
09:12:40 <nishanth> nce-monitoring/pull/24,  https://github.com/Tendrl/performance-monitoring/pull/27  )
09:14:00 <nishanth> #action k4n0, brainfunked, nishanth to review the patches -->(  https://github.com/Tendrl/alerting/pull/15,  https://github.com/Tendrl/alerting/pull/19,  https://github.com/Tendrl/alerting/pull/20,  https://github.com/Tendrl/alerting/pull/21,  https://github.com/Tendrl/alerting/pull/22,  https://github.com/Tendrl/alerting/pull/23
09:14:28 <nishanth> #action k4n0, brainfunked, nishanth to review  https://github.com/Tendrl/specifications/pull/81 ,  https://github.com/Tendrl/specifications/pull/63
09:14:44 <nishanth> anmol, anything else you are working on?
09:15:09 <anmol> nishanth, 2 more https://github.com/Tendrl/common/pull/87 and https://github.com/Tendrl/node_agent/pull/67
09:15:32 <nishanth> anmol, that also blocked on review?
09:15:54 <anmol> nishanth, Reviews have not happened recently but I am working on it yet
09:16:04 <anmol> nishanth, Rebase
09:16:13 <nishanth> okay
09:16:46 <nishanth> anmol thanks for the updates. Will try to review your patches on priority
09:16:57 <anmol> nishanth, thanks
09:17:11 <nishanth> #topic dahorak's updates
09:17:27 <dahorak> I have no update related to Tendrl today.
09:19:04 <nishanth> #info dahorak has no update related to tendrl
09:20:19 <nishanth> #topic fbalak's updates
09:20:30 <fbalak> Issue: Working on https://github.com/Tendrl/usmqe-tests/pull/6
09:20:31 <fbalak> Status: good
09:21:51 <nishanth> #info fbalak is working on  https://github.com/Tendrl/usmqe-tests/pull/6
09:22:17 <nishanth> #topic gowtham_'s updates
09:22:38 <gowtham_> Adding disk details in hardware inventory
09:22:42 <gowtham_> spec file: https://github.com/Tendrl/specifications/pull/21 - merged
09:22:51 <gowtham_> code-PR: https://github.com/Tendrl/node_agent/pull/64 - need review
09:22:56 <gowtham_> Adding Network details in hardware inventory
09:23:26 <gowtham_> spc file: https://github.com/Tendrl/specifications/pull/19 - needs mrugesh aproval
09:23:36 <gowtham_> code-PR: https://github.com/Tendrl/node_agent/pull/79 needs review
09:24:11 <gowtham_> logging implementation
09:24:23 <gowtham_> https://github.com/Tendrl/specifications/pull/94 - needs suggestion for anmols comments
09:24:47 <gowtham_> i am stuck of that anmols comment
09:25:12 <gowtham_> i want need suggestion for that comment
09:26:01 <gowtham_> i have helped srijita to learn unittesting
09:26:18 <nishanth> #action k4n0 and nishanth to review  https://github.com/Tendrl/node_agent/pull/64
09:26:25 <gowtham_> i have explained tendrl architecture to srijita from morning
09:27:08 <gowtham_> status : stuck because for anmols comment , needs others suggestion for that
09:27:44 <nishanth> #undo
09:27:44 <zodbot> Removing item from minutes: ACTION by nishanth at 09:26:18 : k4n0 and nishanth to review  https://github.com/Tendrl/node_agent/pull/64
09:28:13 <nishanth> #action  k4n0 and nishanth to review  https://github.com/Tendrl/node_agent/pull/64,  https://github.com/Tendrl/node_agent/pull/79
09:28:34 <nishanth> #action brainfunked to review and approve https://github.com/Tendrl/specifications/pull/19
09:30:07 <gowtham_> i am done
09:30:49 <nishanth> gowtham_, can you discuss with anmol on  https://github.com/Tendrl/specifications/pull/94  and sort that out?
09:31:04 <gowtham_> nishanth, ok
09:31:14 <nishanth> #action gowtham_ and anmol to sort out the comments on  https://github.com/Tendrl/specifications/pull/94
09:31:20 <anmol> nishanth, we discussed we need other's inputs on it
09:31:38 <anmol> nishanth, I have put a note of the discussion on the PR
09:31:50 <anmol> nishanth, so that everyone can comment
09:32:01 <anmol> teir opinion
09:32:06 <anmol> *their :)
09:33:27 <nishanth> anmol, ok.
09:33:36 <nishanth> #undo
09:33:36 <zodbot> Removing item from minutes: ACTION by nishanth at 09:31:14 : gowtham_ and anmol to sort out the comments on  https://github.com/Tendrl/specifications/pull/94
09:34:21 <nishanth> #action gowtham_ and anmol to sort out the comments on  https://github.com/Tendrl/specifications/pull/94 . Also require brainfuned, k4n0, shubhendu and nishanth to comment on that
09:34:37 <nishanth> gowtham, thanks for the updates
09:34:59 <nishanth> #topic k4n0's updates
09:37:00 <nishanth> looks like k4n0 not available, will come back later
09:37:03 <nishanth> #undo
09:37:03 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x4eb997d0>
09:37:17 <nishanth> #topic kaverma 's updates
09:37:21 <kaverma> i was reviewing neha's PRs (https://github.com/Tendrl/tendrl_frontend/pull/86 , https://github.com/Tendrl/tendrl_frontend/pull/81 - related to unit testing)
09:37:30 <kaverma> and also reviewed ankush's PR - ( https://github.com/Tendrl/tendrl_frontend/pull/85 - some css changes ) .
09:37:30 <kaverma> and i sent one pr (https://github.com/Tendrl/tendrl_frontend/pull/87) related to file-share expansion (for rebalancing) removable which is not required right now.
09:37:30 <kaverma> and want to response format for GetNodeList api for import cluster's support. and @anup: i want to be tendrl-api installed on 10.70.42.142 machine for front-end guys so that we can access the server api.
09:37:38 <kaverma> end
09:39:03 <nishanth> kaverma, list views are completed?
09:39:23 <kaverma> yes but with mocked data .. we have not any real server for test it now
09:39:35 <nishanth> #info kaverma was doing code reviews
09:40:28 <nishanth> kaverma, anything else you are working on?
09:41:10 <kaverma> currently i am blocked for response format GetNodeList api for import cluster's support. and also i want to be tendrl-api installed on 10.70.42.142 machine for front-end guys so that we can access the server api.
09:41:52 <nishanth> kaverma, what is block in installing tendrl-api?
09:43:20 <kaverma> anmol given one vm with all monitoring setup and tendrl-api is not there . and i don't know backend stuff and installation for tendrl-api . expecting this should be done by anup
09:45:57 <nishanth> kaverma, I suggest you don't wait for someone to install the api server. All the install doc is up there. ping any of us if you are stuck
09:46:38 <kaverma> nishanth, sure
09:46:51 <nishanth> kavema, who should provide GetNodeList rsp format anup?
09:47:01 <kaverma> yes
09:48:33 <nishanth> #action noopq to provide GetNodeList API response format to kaverma
09:48:33 <nishanth> kaverma, Thanks for updates
09:48:33 <nishanth> #topic mbukatov's updates
09:49:04 <mbukatov> #info updated (and closed when needed) packaging issues from prev week
09:49:13 <mbukatov> #info tried to propose a change in tox.ini file as was agreed last week, but noticed multiple minor issues with the CI setup for running unit tests
09:49:19 <mbukatov> #link https://github.com/Tendrl/alerting/issues/24
09:49:25 <mbukatov> #action look into the tox.ini issue, check if I can propose some fixes
09:49:31 <mbukatov> #action file the rest of minor rpm packaging issues
09:49:39 <mbukatov> #action work on webstr (we have both legal and security approval, close to the opensourcing)
09:49:45 <mbukatov> that's all
09:51:09 <nishanth> mbukatov, you are working on https://github.com/Tendrl/alerting/issues/24 right?
09:52:11 <nishanth> mbukatov,  Thanks for the updates
09:52:22 <nishanth> #topic mkudlej's updates
09:53:02 <mkudlej> nishanth: hi, I'm working on https://github.com/Tendrl/usmqe-tests/issues/9 + other tasks unrelated to Tendrl. Is there any update about blocker? https://github.com/Tendrl/usmqe-tests/wiki
09:53:17 <mkudlej> nishanth: is there any update about continuous package building?
09:53:28 <mkudlej> nishanth: that's all
09:53:59 <nishanth> mkudlej, tim started working on the CI stuff
09:54:34 <nishanth> mkudlej, will update issue on git with required information
09:54:34 <mkudlej> nishanth: ok, I'll ping tim
09:55:10 <nishanth> #info mkudlej working on  https://github.com/Tendrl/usmqe-tests/issues/9
09:56:09 <nishanth> #topic, ndarshan's updates
09:56:43 <ndarshan> Spec:
09:56:43 <ndarshan> Introduce Flows tied to objects (https://github.com/Tendrl/specifications/issues/34)
09:56:43 <ndarshan> Issues:
09:56:43 <ndarshan> https://github.com/Tendrl/ceph_integration/issues/66
09:56:43 <ndarshan> https://github.com/Tendrl/gluster_integration/issues/95
09:56:44 <ndarshan> https://github.com/Tendrl/common/issues/94
09:56:45 <ndarshan> PRs:
09:56:47 <ndarshan> https://github.com/Tendrl/gluster_integration/pull/96  --> to be merged(trying to verify)
09:56:49 <ndarshan> https://github.com/Tendrl/ceph_integration/pull/67  -->  to be merged(trying to verify)
09:56:51 <ndarshan> https://github.com/Tendrl/common/pull/95 --> merged
09:56:53 <ndarshan> Summary:
09:56:55 <ndarshan> Trying to verify these patches after refactoring, Latest master seems to
09:56:57 <ndarshan> have some issue. Trying to debug and Fix that. After that will verify these
09:56:59 <ndarshan> patches and try to get them merged.
09:57:34 <nishanth> ndarshan, any of these patches pending review?
09:58:45 <ndarshan> no, not blocked on review, will ping them once verification is done
10:00:05 <nishanth> #info ndarshan is working on  https://github.com/Tendrl/gluster_integration/pull/96 and https://github.com/Tendrl/ceph_integration/pull/67
10:00:10 <nishanth> Thanks for the updates
10:00:23 <nishanth> #topic neha__'s updates
10:02:33 <neha__> Completed https://github.com/Tendrl/tendrl_frontend/issues/82, PR - https://github.com/Tendrl/tendrl_frontend/pull/86
10:02:34 <nishanth> looks like neha__ is away, get back later
10:02:38 <nishanth> ok
10:02:47 <neha__> working on https://github.com/Tendrl/tendrl_frontend/issues/88
10:02:56 <neha__> end
10:03:22 <nishanth> neha__, merged?
10:03:44 <neha__> yes
10:04:32 <nishanth> #accept neha__ completed https://github.com/Tendrl/tendrl_frontend/pull/86
10:04:38 <neha__> nishanth, https://github.com/Tendrl/specifications/pull/105 this PR is still not reviewed
10:04:51 <neha__> I need yours and Mrugesh comment on the same
10:05:17 <nishanth> ok
10:05:39 <nishanth> #info neha__ is working on https://github.com/Tendrl/tendrl_frontend/issues/88
10:06:00 <nishanth> #action nishanth, brainfunked to review https://github.com/Tendrl/specifications/pull/105
10:06:10 <nishanth> neha, Thanks for the updates
10:06:31 <nishanth> #topic nishanth's updates
10:07:44 <nishanth> #info nishanth is working on https://github.com/Tendrl/specifications/issues/113 and https://github.com/Tendrl/specifications/issues/112
10:08:02 <nishanth> #info nishanth is reviewing PRs
10:08:37 <nishanth> #info nishanth is working on downstream repo mapping
10:08:52 <nishanth> #topic t1m1's updates
10:09:00 <t1m1> WorkingOn:-
10:09:00 <t1m1> Working on evaluating/planning nightly builds for Tendrl
10:09:00 <t1m1> Update:-
10:09:00 <t1m1> 1: Updated service detection spec file based on review comments
10:09:00 <t1m1> https://github.com/Tendrl/specifications/pull/73
10:09:01 <t1m1> Need Anup review for api related changes
10:09:03 <t1m1> 2: Fixed Jerrit-Jenkins-Server.lab.eng.blr.redhat.com ansible installation issue
10:09:05 <t1m1> by finding the chain of required sub dependencies and its related versions and
10:09:07 <t1m1> updated the jenkin repo.
10:09:09 <t1m1> Ready for Merge:-
10:09:11 <t1m1> Issue1: Service name renamed as tendrl-node-agent
10:09:13 <t1m1> Issue url: https://github.com/Tendrl/node_agent/issues/97
10:09:17 <t1m1> Patch ready for merge: https://github.com/Tendrl/node_agent/pull/100
10:09:19 <t1m1> Issue2: After=network.target missing in tendrl-apid.service
10:09:21 <t1m1> Issue url: https://github.com/Tendrl/tendrl-api/issues/45
10:09:23 <t1m1> Issue3: Service name changed to tendrl-api and enhance service
10:09:25 <t1m1> https://github.com/Tendrl/tendrl-api/issues/46
10:09:27 <t1m1> Patch ready for merge: https://github.com/Tendrl/tendrl-api/pull/49
10:10:23 <nishanth> t1m1, all the ready for merge items are already reviewed and approved?
10:10:29 <t1m1> yes
10:12:35 <t1m1> regarding issue : https://github.com/Tendrl/tendrl-api/issues/31, I want anoop to reply and take the issue
10:12:50 <nishanth> t1m1,  what is the pR's for  https://github.com/Tendrl/tendrl-api/issues/45 and  https://github.com/Tendrl/tendrl-api/issues/46?
10:13:55 <t1m1> issue 45 -> https://github.com/Tendrl/tendrl-api/pull/49
10:15:05 <t1m1> issue 46 -> also https://github.com/Tendrl/tendrl-api/pull/49
10:15:17 <nishanth> #action k4n0/nishanth to review and approve  https://github.com/Tendrl/node_agent/pull/100,  https://github.com/Tendrl/tendrl-api/pull/49
10:16:12 <nishanth> #info t1m1 is working on tendrl nightly builds
10:16:52 <nishanth> t1m1, you need make a new package hwinfo which is dependency added as part of gowtham's disk inventory patch
10:17:17 <t1m1> nishanth, sure
10:17:21 <nishanth> t1m1 , get the details form gowtham on this
10:17:27 <t1m1> nishanth, i will do it
10:18:11 <nishanth> #action t1m1 to build a new package for hwinfo. gowtham will provide information about the package
10:18:23 <nishanth> thanks t1m1 for updates
10:18:36 <t1m1> nishanth, welcome
10:18:40 <nishanth> #endmeeting