09:01:24 <brainfunked> #startmeeting check-in_20170110
09:01:25 <zodbot> Meeting started Tue Jan 10 09:01:24 2017 UTC.  The chair is brainfunked. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
09:01:25 <zodbot> The meeting name has been set to 'check-in_20170110'
09:01:33 <brainfunked> #topic anmol's updates
09:01:45 <anmol> [1] Working on latest comments from @shtripat on:
09:01:45 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/2 -- Modify performance monitoring docs and add samples
09:01:45 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#7, Tendrl/performance-monitoring#8
09:01:45 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/19 -- Add support for host listing page in UI
09:01:46 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#15
09:01:48 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/20 -- Add rest apis
09:01:50 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#7
09:01:52 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/21 -- Add a way to intiate collectd configuration generation
09:01:55 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#8
09:01:57 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/22 -- Add default values monitoring configurations
09:02:00 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#8
09:02:02 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/23 -- Add time series db interface as a pluggable inteface
09:02:07 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#7
09:02:09 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/24 -- Add performance monitoring manager and flows associated
09:02:12 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#7, Tendrl/performance-monitoring#8
09:02:14 <anmol> * https://github.com/Tendrl/performance-monitoring/pull/27 -- Add collectd plugins
09:02:16 <anmol> tendrl-bug-id: Tendrl/performance-monitoring#26
09:02:18 <anmol> Spec Implemented by PR: https://github.com/Tendrl/specifications/pull/81, https://github.com/Tendrl/specifications/pull/63
09:02:21 <anmol> [2] Working on latest comments from @shtripat on:
09:02:23 <anmol> * https://github.com/Tendrl/alerting/pull/15 -- Alerting doc changes and sample files
09:02:25 <anmol> tendrl-bug-id: Tendrl/alerting#10,Tendrl/alerting#11,Tendrl/alerting#12,Tendrl/alerting#14
09:02:27 <anmol> * https://github.com/Tendrl/alerting/pull/19 -- Add rest apis
09:02:30 <anmol> tendrl-bug-id: Tendrl/alerting#14
09:02:31 <anmol> * https://github.com/Tendrl/alerting/pull/20 -- Add helper to fetch details from etcd
09:02:33 <anmol> tendrl-bug-id: Tendrl/alerting#10,Tendrl/alerting#11,Tendrl/alerting#12,Tendrl/alerting#14
09:02:37 <anmol> * https://github.com/Tendrl/alerting/pull/21 -- Add mail handler
09:02:39 <anmol> tendrl-bug-id: Tendrl/alerting#12
09:02:41 <anmol> * https://github.com/Tendrl/alerting/pull/22 -- Add alerting manager, definations and generic exceptions
09:02:44 <anmol> tendrl-bug-id: Tendrl/alerting#10,Tendrl/alerting#11,Tendrl/alerting#12,Tendrl/alerting#14
09:02:46 <anmol> * https://github.com/Tendrl/alerting/pull/23 -- Watch alerts directory and trigger notification on change
09:02:49 <anmol> tendrl-bug-id: Tendrl/alerting#10
09:02:51 <anmol> Spec implemented by PR: https://github.com/Tendrl/specifications/blob/master/specs/pluggable_alert_delivery.adoc
09:02:54 <anmol> [3] Rebased https://github.com/Tendrl/node-agent/pull/67 and updated verifed PR.
09:02:56 <anmol> Spec implemented by PR: https://github.com/Tendrl/specifications/blob/master/specs/pluggable_alert_delivery.adoc
09:02:59 <anmol> tendrl-bug-id: Tendrl/node-agent#70
09:03:01 <anmol> [4] Rebased https://github.com/Tendrl/commons/pull/87 and updated verified PR . Working on comments from @shtripat
09:03:06 <anmol> tendrl-bug-id: tendrl-bug-id: Tendrl/alerting#10,Tendrl/alerting#11,Tendrl/alerting#12,Tendrl/alerting#14
09:03:09 <anmol> Spec implemented by PR: https://github.com/Tendrl/specifications/blob/master/specs/pluggable_alert_delivery.adoc
09:03:12 <anmol> [5] Yesterday I completed "Compliance and Ethics Training" which was due this month end.
09:03:14 <anmol> so was on it for almost whole of second half yesterday.
09:03:16 <anmol> I would like to request @Tendrl/tendrl-core to review the above mentioned PRs in addition to:
09:03:18 <anmol> * https://github.com/Tendrl/specifications/pull/81 -- Add spec for monitoring section of host listing backend apis
09:03:21 <anmol> * https://github.com/Tendrl/specifications/pull/63 -- Specification for exposing apis to access time-series data
09:03:24 <anmol> end
09:04:34 <brainfunked> anmol, did you you and noopq sort out the API integration details?
09:04:45 <noopq> brainfunked, the API is integrated.
09:04:53 <anmol> +1
09:05:24 <anmol> brainfunked, also whatever we discussed from monitoring perspective it is documented in https://github.com/Tendrl/specifications/pull/81
09:05:40 <anmol> brainfunked, I think noopq also has 1 from tendrl-api perspective
09:05:46 <anmol> noopq, ^
09:06:09 <noopq> brainfunked, https://github.com/Tendrl/tendrl-api/pulls/anivargi
09:06:22 <noopq> brainfunked, Sorry this one https://github.com/Tendrl/tendrl-api/pull/52
09:06:46 <brainfunked> ok thanks
09:09:12 <brainfunked> #topic dahorak's updates
09:09:37 <Shu6h3ndu> brainfunked, looks like there is some internet outage in Brno office and QE wont be available for updates
09:09:57 <dahorak> brainfunked: sorry, we have connection issues here ...
09:10:11 <mkudlej> Shu6h3ndu: it's fine now
09:10:18 <Shu6h3ndu> mkudlej, oh ok
09:10:19 <dahorak> brainfunked: but I have no update from my side related to Tendrl
09:10:53 <brainfunked> ok
09:11:02 <brainfunked> #info dahorak has no updates related to tendrl
09:11:11 <brainfunked> #topic darshan's updates
09:11:24 <darshan> Spec:
09:11:24 <darshan> Introduce Flows tied to objects (https://github.com/Tendrl/specifications/issues/34)
09:11:24 <darshan> Issues:
09:11:24 <darshan> https://github.com/Tendrl/ceph_integration/issues/66
09:11:24 <darshan> https://github.com/Tendrl/gluster_integration/issues/95
09:11:25 <darshan> https://github.com/Tendrl/common/issues/94
09:11:29 <darshan> PRs:
09:11:31 <darshan> https://github.com/Tendrl/gluster_integration/pull/96  --> Review pending
09:11:33 <darshan> https://github.com/Tendrl/ceph_integration/pull/67  -->  Review pending
09:11:35 <darshan> Summary:
09:11:37 <darshan> Was verifying these PRs after refactoring change, updated above 2 PRs to
09:11:39 <darshan> work correctly after refactoring.
09:11:41 <darshan> ---------------------------------
09:11:43 <darshan> ISSUES:
09:11:45 <darshan> Noticed some issues in latest master, have sent PRs to fix the same:
09:11:47 <darshan> https://github.com/Tendrl/node-agent/pull/129
09:11:49 <darshan> https://github.com/Tendrl/commons/pull/98
09:12:55 <darshan> noopq, might have to make some changes in API layer to accommodate the changes related to spec : https://github.com/Tendrl/specifications/issues/34
09:13:16 * noopq checks
09:13:56 <brainfunked> darshan, anything else you're looking to pick up?
09:14:05 <noopq> darshan, the nodes and clusters API's are hard coded now, its what is needed for the list view and import cluster
09:14:39 <darshan> brainfunked, I will be working on node agent tagging and tag based routing
09:14:45 <brainfunked> darshan, the implementation of the same?
09:15:19 <darshan> yes, will need to collaborate with folks working on service detection modules
09:15:33 <brainfunked> cool
09:15:44 <brainfunked> each detection module should have a hardcoded tag that it assigns
09:16:15 <darshan> okay
09:16:48 <brainfunked> if the check passes, the appropriate tag should be assigned to that node agent
09:16:53 <brainfunked> or node, basically
09:17:24 <brainfunked> #accept darshan has sent pull requests to implement the object specific flows (https://github.com/Tendrl/specifications/issues/34)
09:18:03 <brainfunked> #action darshan is working on the implementation for node agent tagging and tag based job routing (https://github.com/Tendrl/specifications/issues/44)
09:18:11 <brainfunked> #topic fbalak's updates
09:18:21 <fbalak> No update related to tendrl today.
09:19:52 <brainfunked> #info fbalak has no updates related to tendrl
09:19:58 <brainfunked> #topic gowtham_'s updates
09:20:01 <gowtham_> code-PR: https://github.com/Tendrl/node_agent/pull/64 - merged successfully
09:20:09 <gowtham_> Adding Network details in hardware inventory
09:20:14 <gowtham_> spc file: https://github.com/Tendrl/specifications/pull/19
09:20:14 <gowtham_> code-PR: https://github.com/Tendrl/node_agent/pull/79
09:20:23 <gowtham_> Please see the comment for global network structure, i have put two approches for
09:20:24 <gowtham_> global network strucute please give your suggestion.
09:20:34 <gowtham_> logging implementation need your sugggestion for anmols comment
09:20:41 <gowtham_> https://github.com/Tendrl/specifications/pull/94
09:21:25 <gowtham_> i need quick review for logging implementation
09:21:33 <gowtham_> status
09:21:37 <gowtham_> status: good
09:21:49 <gowtham_> need quick suggestion for both task
09:22:31 <brainfunked> #info brainfunked is in the process of reviewing the network inventory (https://github.com/Tendrl/specifications/issues/41) and logging (https://github.com/Tendrl/specifications/issues/28) specifications
09:23:11 <brainfunked> #accept gowtham_ has updated the network inventory and logging specifications https://github.com/Tendrl/specifications/issues/41, https://github.com/Tendrl/specifications/issues/28 and is awaiting reviews
09:23:22 <brainfunked> #topic ltrilety's updates
09:24:46 <ltrilety> #info I am working on https://github.com/Tendrl/usmqe-tests/issues/10
09:25:37 <ltrilety> #action webstr framework is finished, now I will create some simple framework in usmqe-tests
09:26:06 <ltrilety> that's all
09:26:09 <brainfunked> simple framework?
09:26:28 <ltrilety> yeah some interface to work with webstr
09:26:49 <brainfunked> what is webstr?
09:27:52 <brainfunked> ltrilety, ^
09:28:44 <ltrilety> webstr is framework to work with GUI using selenium
09:28:50 <brainfunked> ok
09:29:21 <brainfunked> so when you say it is finished, what exactly was done?
09:30:49 <ltrilety> well we already used similar framework in our previous code, it was called raut in that time, and now we take it, simplified that and we prepared that to be open source and called it webstr
09:31:12 <brainfunked> ah ok
09:31:14 <ltrilety> plus some minor fixes and so
09:31:22 <brainfunked> thanks for clearing that up
09:32:42 <brainfunked> #info ltrilety has finished working on webstr, which is a framework to do GUI testing with selenium and is now working on interfacing with webstr via the usmqe-tests repository (https://github.com/Tendrl/usmqe-tests/issues/10)
09:32:53 <brainfunked> #topic mbukatov's updates
09:37:04 <ltrilety> we have some issues with connectivity
09:37:11 <mbukatov> hello
09:37:20 <ltrilety> mbukatov is connecting
09:37:25 <brainfunked> ack
09:37:25 <mbukatov> should I post my update now?
09:37:35 <brainfunked> mbukatov, yes, please
09:37:36 <mbukatov> #info worked on improvements of tox/travis CI setup (issue alerting#24)
09:37:42 <mbukatov> #link https://github.com/Tendrl/alerting/issues/24
09:37:56 <mbukatov> #action create pull request for alerting#24 with explanation/reasoning (the work is mostly done)
09:38:03 <mbukatov> #action file the rest of minor rpm packaging issues
09:38:09 <mbukatov> #action work on webstr (we have both legal and security approval, close to the opensourcing)
09:38:16 <mbukatov> that's all
09:38:57 <mbukatov> looking into alerting#24 took more time than I originaly anticipated
09:40:06 <brainfunked> ack, thanks
09:40:42 <brainfunked> #accept mbukatov working on the tox/travis CI setup for alerting (https://github.com/Tendrl/alerting/issues/24)
09:41:02 <brainfunked> #action mbukatov to file remaining rpm packaging related issues and work on webstr
09:41:08 <brainfunked> #topic mkudlej's updates
09:41:15 <mkudlej> brainfunked: I'm working on https://github.com/Tendrl/usmqe-tests/issues/9 and other tasks unrelated to Tendrl
09:42:07 <mkudlej> brainfunked: I'm waiting for Tim's comment in https://github.com/Tendrl/specifications/issues/53
09:43:01 <mkudlej> brainfunked: also i would like to ask you what are your plans with https://github.com/Tendrl/documentation/issues/70 and related issues in documentation
09:43:50 <brainfunked> #action noopq and brainfunked to comment upon the HTTP Verbs issue (https://github.com/Tendrl/documentation/issues/70)
09:44:20 <mkudlej> brainfunked: also will be great if local irc bot will expand github links to titles, so all know what people are talking about
09:44:42 <brainfunked> #action brainfunked and t1m1 to comment upon the CentOS CI setup discussion (https://github.com/Tendrl/specifications/issues/53)
09:45:00 <mkudlej> brainfunked: thank you, that's all from me
09:45:04 <brainfunked> #info mkudlej is working on testing the ceph cluster import (https://github.com/Tendrl/usmqe-tests/issues/9)
09:45:39 <brainfunked> mkudlej, ack, thanks, and the irc bot thingie would be quite useful. I don't know if the zodbot can do it however, but worth investigating
09:45:44 <brainfunked> #topic neha's updates
09:46:32 <neha> Completed - Issue - https://github.com/Tendrl/tendrl_frontend/issues/90, PR - https://github.com/Tendrl/tendrl_frontend/pull/91
09:46:49 <neha> Issue - https://github.com/Tendrl/tendrl_frontend/issues/88, PR - https://github.com/Tendrl/tendrl_frontend/pull/89
09:47:47 <neha> Need yours and nishanth comments on PR - https://github.com/Tendrl/specifications/pull/105
09:48:02 <neha> end
09:48:22 <brainfunked> ok
09:49:00 <brainfunked> #accept neha has pushed unit tests for the file share list view https://github.com/Tendrl/tendrl_frontend/pull/91
09:49:36 <brainfunked> #action brainfunked and nishanth need to review the import cluster UI specification https://github.com/Tendrl/specifications/pull/105
09:49:58 <brainfunked> neha, what will you be working on while the reviews are being done?
09:50:22 <neha> I am starting with import cluster unit tests
09:50:33 <neha> issue needs to be created for that
09:52:48 <brainfunked> ok
09:53:41 <brainfunked> neha, where's the implementation for the import cluster UI?
09:53:49 <brainfunked> neha, or are you writing the tests before the implementation?
09:54:19 <neha> its not yet committed yet in the repo as the format of response is nit yet received by us
09:55:21 <neha> we have completed it with assuming the response for all the API for import cluster
09:55:25 <Shu6h3ndu> neha, I feel brainfunked's spec https://github.com/Tendrl/specifications/pull/100/ talks about additional data to be available as part of node while import
09:55:41 <neha> for that I am writing unit tests
09:56:23 <neha> Shu6h3ndu, will look into it
09:56:49 <brainfunked> is noopq aware that you require some data from him?
09:57:17 <neha> yes. Kamlesh has asked him.
09:58:05 <brainfunked> #action noopq to provide the data necessary for neha to continue working on the import cluster UI implementation
09:58:37 <noopq> brainfunked, I am only aware about the cluster grouping needed for that UI
09:58:49 <noopq> That is already part of the PR
09:58:57 <brainfunked> neha, ^ ?
09:59:15 <brainfunked> neha, noopq do you guys document your conversations on some spec?
09:59:27 <noopq> brainfunked, No
09:59:35 <brainfunked> I keep seeing to-and-fro for API and UI integration
09:59:46 <brainfunked> this is precisely what the specifications are supposed to address
10:00:08 <brainfunked> if you're still missing data points after pushing a spec, the spec isn't good enough neha
10:00:58 <noopq> neha, can you point me to your import cluster spec?
10:01:19 <neha> noopq, you have already reviewed it and mentioned as looks good to me
10:01:20 <neha> https://github.com/Tendrl/specifications/pull/105/
10:01:35 <noopq> neha, yes I wanted the link
10:02:50 <neha> noopq, I will add your name in the spec where I needed your API response
10:03:27 <noopq> neha, Alright.
10:05:13 <brainfunked> #topic noopq's updates
10:05:43 <noopq> brainfunked, Finished this https://github.com/Tendrl/tendrl-api/pull/52
10:06:01 <brainfunked> #action brainfunked to review the API implementation for host list views with monitoring data (https://github.com/Tendrl/tendrl-api/pull/52)
10:06:18 <noopq> brainfunked, I will start working on fixing the API based on the changes by darshan on the cluster definitions
10:06:44 <brainfunked> noopq, this is based on the object specific flows?
10:06:51 <noopq> brainfunked, yes
10:07:32 <noopq> brainfunked, Apart from that, I am also waiting for the tagging based things we discussed to be implemented
10:07:40 <noopq> I am not sure how they are needed in import cluster
10:07:52 <brainfunked> #action noopq to work on the API changes induced by the object specific flows
10:08:14 <brainfunked> noopq, I think that'll become clear as rohan starts pushing the import cluster stuff
10:08:27 <brainfunked> #topic Shu6h3ndu's updates
10:08:41 <Shu6h3ndu> sure
10:08:51 <Shu6h3ndu> I was on PTO yesterday
10:08:51 <Shu6h3ndu> All re-factoring and guster get-state PRs merged.
10:08:51 <Shu6h3ndu> Today reviewed all the monitoring and alerting related PRs. Have some generic comments.
10:08:52 <Shu6h3ndu> Incorporated review comments for code PRs of https://github.com/Tendrl/specifications/pull/104
10:08:52 <Shu6h3ndu> Working on rework for https://github.com/Tendrl/gluster_integration/pull/62
10:09:01 <Shu6h3ndu> Summary:
10:09:11 <Shu6h3ndu> Rohan, Nishanth, Brainfunked to review spec PR https://github.com/Tendrl/specifications/pull/104
10:09:25 <Shu6h3ndu> Mrugesh to review and close https://github.com/Tendrl/specifications/pull/98
10:09:31 <Shu6h3ndu> Anup, Roahn and Nishanth to review the spec PR https://github.com/Tendrl/specifications/pull/93
10:09:39 <Shu6h3ndu> Rohan, nishanth to review code PRs https://github.com/Tendrl/commons/pull/99 and https://github.com/Tendrl/node-agent/pull/123
10:09:39 <Shu6h3ndu> Rohan to review https://github.com/Tendrl/gluster_integration/pull/63
10:09:51 <Shu6h3ndu> Next I would pick stuff from provisioing/create cluster flows based on discussion with Nishanth
10:09:52 <brainfunked> #info brainfunked is in the process of reviewing the multiple node ids spec https://github.com/Tendrl/specifications/pull/104
10:10:11 <Shu6h3ndu> thats all from my side
10:10:50 <brainfunked> Shu6h3ndu, I've made a comment to the multiple node ids issue
10:11:02 <brainfunked> havent finished reviewing the pull request yet, however
10:11:22 <Shu6h3ndu> brainfunked, I have done the changes as per latest comments and kept only required changes
10:11:50 <brainfunked> ok
10:11:53 <brainfunked> I'll check
10:12:04 <brainfunked> has noopq reviewed https://github.com/Tendrl/specifications/pull/98 ?
10:12:15 <Shu6h3ndu> brainfunked, you should review the code change PRs as well. They are small :)
10:12:28 <brainfunked> sure
10:13:33 <brainfunked> #action noopq to review the ceph pool utilisation data spec https://github.com/Tendrl/specifications/pull/98
10:16:51 <brainfunked> Shu6h3ndu, for now, check if you could contribute to the import cluster work
10:17:13 <brainfunked> Shu6h3ndu, I'm working on some details for the create cluster stuff, which will take a couple of days, post which, you could pick one of those up
10:18:32 <Shu6h3ndu> brainfunked, ok
10:18:55 <brainfunked> thanks
10:19:16 <brainfunked> #topic t1m1's updates
10:19:53 <t1m1> I am working on automated build for tendrl project thru fedora copr
10:20:51 <t1m1> exploring the possibilities thru fedora copr
10:20:55 <brainfunked> ok
10:21:00 <brainfunked> any progress on hwinfo?
10:21:08 <t1m1> also working on hwinfo
10:21:51 <brainfunked> #info t1m1 is working on build automation via copr and packaging hwinfo
10:21:55 <brainfunked> #endmeeting